Problema con dependencias Xubuntu 12.04

Dudas y comentarios relacionadas con paquetes o programas específicos (obtención, uso, actualizaciones, versiones, problemas de instalación, etc.)
Responder
realkraxy
Forista Nuevo
Forista Nuevo
Mensajes: 1
Registrado: Mar Jun 12, 2012 8:32 am

Problema con dependencias Xubuntu 12.04

Mensaje por realkraxy »

Que tal gente, de antemano muchas gracias por la ayuda que proveen dia a dia en el foro. Paso a explicar mi problema, utilizo Xubuntu 12.04 x64, y de la nada, actualizando lo mas bien, cada vez que realizo una actualizacion, borro paquetes, instalo, etc, me sale al final:

Código: Seleccionar todo

dpkg: error al procesar libgcrypt11 (--configure):
 libgcrypt11:amd64 1.5.0-3ubuntu0.1 cannot be configured because libgcrypt11:i386 is in a different version (1.5.0-3)
dpkg: error al procesar libkrb5support0 (--configure):
 libkrb5support0:amd64 1.10+dfsg~beta1-2ubuntu0.1 cannot be configured because libkrb5support0:i386 is in a different version (1.10+dfsg~beta1-2)
dpkg: error al procesar libk5crypto3 (--configure):
 libk5crypto3:amd64 1.10+dfsg~beta1-2ubuntu0.1 cannot be configured because libk5crypto3:i386 is in a different version (1.10+dfsg~beta1-2)
dpkg: error al procesar libkrb5-3 (--configure):
 libkrb5-3:amd64 1.10+dfsg~beta1-2ubuntu0.1 cannot be configured because libkrb5-3:i386 is in a different version (1.10+dfsg~beta1-2)
dpkg: error al procesar libgssapi-krb5-2 (--configure):
 libgssapi-krb5-2:amd64 1.10+dfsg~beta1-2ubuntu0.1 cannot be configured because libgssapi-krb5-2:i386 is in a different version (1.10+dfsg~beta1-2)
dpkg: error al procesar libcups2 (--configure):
 libcups2:amd64 1.5.3-0ubuntu1 cannot be configured because libcups2:i386 is in a different version (1.5.2-9ubuntu1)
dpkg: problemas de dependencias impiden la configuración de libcupsmime1:
 libcupsmime1 depende de libcups2 (>= 1.5~); sin embargo:
 El paquete `libcups2' no está configurado todavía.
dpkg: error al procesar libcupsmime1 (--configure):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de libcupscgi1:
 libcupscgi1 depende de libcups2 (>= 1.4.0); sin embargo:
 El paquete `libcups2' no está configurado todavía.
dpkg: error al procesar libcuNo se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
                                                  No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»



                                                  No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
   No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
                                                                                            No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
                        No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
                                                                                                                 No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
                                             pscgi1 (--configure):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de libcupsimage2:
 libcupsimage2 depende de libcups2 (>= 1.4.0); sin embargo:
 El paquete `libcups2' no está configurado todavía.
dpkg: error al procesar libcupsimage2 (--configure):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de libcupsppdc1:
 libcupsppdc1 depende de libcups2 (>= 1.4.0); sin embargo:
 El paquete `libcups2' no está configurado todavía.
dpkg: error al procesar libcupsppdc1 (--configure):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de cups-client:
 cups-client depende de libcups2 (>= 1.5.0); sin embargo:
 El paquete `libcups2' no está configurado todavía.
 cups-client depende de libcupsimage2 (>= 1.4.0); sin embargo:
 El paquete `libcupsimage2' no está configurado todavía.
dpkg: error al procesar cups-client (-No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
                                                                                                                               No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
                                                           No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
                                                                          


                                                                           No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
            No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
                                                                                                     No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
                                 No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
                                                                                                                          No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
                                                      -configure):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de cups-ppdc:
 cups-ppdc depende de libcups2 (>= 1.4.0); sin embargo:
 El paquete `libcups2' no está configurado todavía.
 cups-ppdc depende de libcupsppdc1 (>= 1.4.0); sin embargo:
 El paquete `libcupsppdc1' no está configurado todavía.
dpkg: error al procesar cups-ppdc (--configure):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de cups:
 cups depende de libcups2 (>= 1.5.0); sin embargo:
 El paquete `libcups2' no está configurado todavía.
 cups depende de libcupscgi1 (>= 1.4.2); sin embargo:
 El paquete `libcupscgi1' no está configurado todavía.
 cups depende de libcupsimage2 (>= 1.4.0); sin embargo:
 El paquete `libcupsimage2' no está configurado todavía.
 cups depende de libcupsmime1 (>= 1.5.0); sin embargo:
 El paquete `libcupsmime1' no está configurado todavía.
 cups depende de libcupsppdc1No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
                                                                                                                      No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
                                                  No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»



                                                   No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
   No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
                                                                                            No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
                        No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
                                                                                                                 No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
                                              (>= 1.4.0); sin embargo:
 El paquete `libcupsppdc1' no está configurado todavía.
 cups depende de libgssapi-krb5-2 (>= 1.8+dfsg); sin embargo:
 El paquete `libgssapi-krb5-2' no está configurado todavía.
 cups depende de libkrb5-3 (>= 1.6.dfsg.2); sin embargo:
 El paquete `libkrb5-3' no está configurado todavía.
 cups depende de cups-client (>= 1.5.3-0ubuntu1); sin embargo:
 El paquete `cups-client' no está configurado todavía.
 cups depende de cups-ppdc; sin embargo:
 El paquete `cups-ppdc' no está configurado todavía.
dpkg: error al procesar cups (--configure):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de libcupsdriver1:
 libcupsdriver1 depende de libcups2 (>= 1.4.0); sin embargo:
 El paquete `libcups2' no está configurado todavía.
dpkg: error al procesar libcupsdriver1 (--configure):
 problemas de dependencias - se deja sin configurar
dpkg: error al procesar libgl1-mesa-dri (--configure):
 libgl1-mesa-dri:amd6No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
                                                                                                              4 8.0.2-0ubuntu3.1 cannot be configured because libgl1-mesa-dri:i386 is in a different version (8.0.2-0ubuntu3)
dpkg: error al procesar libglapi-mesa (--configure):
 libglapi-mesa:amd64 8.0.2-0ubuntu3.1 cannot be configured because libglapi-mesa:i386 is in a different version (8.0.2-0ubuntu3)
dpkg: error al procesar libgl1-mesa-glx (--configure):
 libgl1-mesa-glx:amd64 8.0.2-0ubuntu3.1 cannot be configured because libgl1-mesa-glx:i386 is in a different version (8.0.2-0ubuntu3)
dpkg: problemas de dependencias impiden la configuración de libgssrpc4:
 libgssrpc4 depende de libgssapi-krb5-2 (>= 1.10+dfsg~); sin embargo:
 El paquete `libgssapi-krb5-2' no está configurado todavía.
dpkg: error al procesar libgssrpc4 (--configure):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de libkadm5clnt-mit8:
 libkadm5clnt-mit8 depende de libgssapi-krb5-2 (>= 1.10+dfsg~); sin embargo:
 El paquete `libgssapi-krb5-2' no está configurado todavía.
 libkadm5clnt-mit8 depende de libgssrpc4 (>= 1.6.dfsg.2); sin embargo:
 El paquete `libgssrpc4' no está configurado todavía.
 libkadm5clnt-mit8 depende de libk5crypto3 (>= 1.6.dfsg.2); sin embargo:
 El paquete `libk5crypto3' no está configurado todavía.
 libkadm5clnt-mit8 depende de libkrb5-3 (>= 1.8+dfsg); sin embargo:
 El paquete `libkrb5-3' no está configurado todavía.
 libkadm5clnt-mit8 depende de libkrb5support0 (>= 1.7dfsg~beta2); sin embargo:
 El paquete `libkrb5support0' no está configurado todavía.
dpkg: error al procesar libkadm5clnt-mit8 (--configure):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de libkdb5-6:
 libkdb5-6 depende de libgssrpc4 (>= 1.7dfsg~alpha1); sin embargo:
 El paquete `libgssrpc4' no está configurado todavía.
 libkdb5-6 depende de libk5crypto3 (>= 1.7+dfsg); sin embargo:
 El paquete `libk5crypto3' no está configurado todavía.
 libkdb5-6 depende de libkrb5-3 (>= 1.7dfsg); sin embargo:
 El paquete `libkrb5-3' no está configurado todavía.
 libkdb5-6 depende de libkrb5support0 (>= 1.7dfsg~beta2); sin embargo:
 El paquete `libkrb5support0' no está configurado todavía.
dpkg: error al procesar libkdb5-6 (--configure):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de libkadm5srv-mit8:
 libkadm5srv-mit8 depende de libgssapi-krb5-2 (>= 1.6.dfsg.2); sin embargo:
 El paquete `libgssapi-krb5-2' no está configurado todavía.
 libkadm5srv-mit8 depende de libgssrpc4 (>= 1.6.dfsg.2); sin embargo:
 El paquete `libgssrpc4' no está configurado todavía.
 libkadm5srv-mit8 depende de libk5crypto3 (>= 1.6.dfsg.2); sin embargo:
 El paquete `libk5crypto3' no está configurado todavía.
 libkadm5srv-mit8 depende de libkdb5-6; sin embargo:
 El paquete `libkdb5-6' no está configurado todavía.
 libkadm5srv-mit8 depende de libkrb5-3 (>= 1.9+dfsg~beta1); sin embargo:
 El paquete `libkrb5-3' no está configurado todavía.
 libkadm5srv-mit8 depende de libkrb5support0 (>= 1.7dfsg~beta2); sin embargo:
 El paquete `libkrb5support0' no está configurado todavía.
dpkg: error al procesar libkadm5srv-mit8 (--configure):
 problemas de dependencias - se deja sin configurar
dpkg: error al procesar libv4lconvert0 (--configure):
 libv4lconvert0:amd64 0.8.6-1ubuntu2 cannot be configured because libv4lconvert0:i386 is in a different version (0.8.6-1ubuntu1)
dpkg: error al procesar libv4l-0 (--configure):
 libv4l-0:amd64 0.8.6-1ubuntu2 cannot be configured because libv4l-0:i386 is in a different version (0.8.6-1ubuntu1)
dpkg: error al procesar libglu1-mesa (--configure):
 libglu1-mesa:amd64 8.0.2-0ubuntu3.1 cannot be configured because libglu1-mesa:i386 is in a different version (8.0.2-0ubuntu3)
dpkg: problemas de dependencias impiden la configuración de libdns81:
 libdns81 depende de libgssapi-krb5-2 (>= 1.10+dfsg~); sin embargo:
 El paquete `libgssapi-krb5-2' no está configurado todavía.
dpkg: error al procesar libdns81 (--configure):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de libisccfg82:
 libisccfg82 depende de libdns81; sin embargo:
 El paquete `libdns81' no está configurado todavía.
dpkg: error al procesar libisccfg82 (--configure):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de libbind9-80:
 libbind9-80 depende de libdns81; sin embargo:
 El paquete `libdns81' no está configurado todavía.
 libbind9-80 depende de libisccfg82; sin embargo:
 El paquete `libisccfg82' no está configurado todavía.
dpkg: error al procesar libbind9-80 (--configure):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de bind9-host:
 bind9-host depende de libbind9-80 (= 1:9.8.1.dfsg.P1-4ubuntu0.1); sin embargo:
 El paquete `libbind9-80' no está configurado todavía.
 bind9-host depende de libdns81 (= 1:9.8.1.dfsg.P1-4ubuntu0.1); sin embargo:
 El paquete `libdns81' no está configurado todavía.
 bind9-host depende de libisccfg82 (= 1:9.8.1.dfsg.P1-4ubuntu0.1); sin embargo:
 El paquete `libisccfg82' no está configurado todavía.
dpkg: error al procesar bind9-host (--configure):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de dnsutils:
 dnsutils depende de libbind9-80 (= 1:9.8.1.dfsg.P1-4ubuntu0.1); sin embargo:
 El paquete `libbind9-80' no está configurado todavía.
 dnsutils depende de libdns81 (= 1:9.8.1.dfsg.P1-4ubuntu0.1); sin embargo:
 El paquete `libdns81' no está configurado todavía.
 dnsutils depende de libisccfg82 (= 1:9.8.1.dfsg.P1-4ubuntu0.1); sin embargo:
 El paquete `libisccfg82' no está configurado todavía.
 dnsutils depende de libkrb5-3 (>= 1.6.dfsg.2); sin embargo:
 El paquete `libkrb5-3' no está configurado todavía.
 dnsutils depende de bind9-host | host; sin embargo:
 El paquete `bind9-host' no está configurado todavía.
  El paquete `host' no está instalado.
  El paquete `bind9-host' que provee `host' aún no está configurado.
dpkg: error al procesar dnsutils (--configure):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de krb5-multidev:
 krb5-multidev depende de libkrb5-3 (= 1.10+dfsg~beta1-2ubuntu0.1); sin embargo:
 El paquete `libkrb5-3' no está configurado todavía.
 krb5-multidev depende de libk5crypto3 (= 1.10+dfsg~beta1-2ubuntu0.1); sin embargo:
 El paquete `libk5crypto3' no está configurado todavía.
 krb5-multidev depende de libgssapi-krb5-2 (= 1.10+dfsg~beta1-2ubuntu0.1); sin embargo:
 El paquete `libgssapi-krb5-2' no está configurado todavía.
 krb5-multidev depende de libgssrpc4 (= 1.10+dfsg~beta1-2ubuntu0.1); sin embargo:
 El paquete `libgssrpc4' no está configurado todavía.
 krb5-multidev depende de libkadm5srv-mit8 (= 1.10+dfsg~beta1-2ubuntu0.1); sin embargo:
 El paquete `libkadm5srv-mit8' no está configurado todavía.
 krb5-multidev depende de libkadm5clnt-mit8 (= 1.10+dfsg~beta1-2ubuntu0.1); sin embargo:
 El paquete `libkadm5clnt-mit8' no está configurado todavía.
dpkg: error al procesar krb5-multidev (--configure):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de libgcrypt11-dev:
 libgcrypt11-dev depende de libgcrypt11 (= 1.5.0-3ubuntu0.1); sin embargo:
 El paquete `libgcrypt11' no está configurado todavía.
dpkg: error al procesar libgcrypt11-dev (--configure):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de libgl1-mesa-dev:
 libgl1-mesa-dev depende de libgl1-mesa-glx (= 8.0.2-0ubuntu3.1); sin embargo:
 El paquete `libgl1-mesa-glx' no está configurado todavía.
dpkg: error al procesar libgl1-mesa-dev (--configure):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de libglu1-mesa-dev:
 libglu1-mesa-dev depende de libglu1-mesa (= 8.0.2-0ubuntu3.1); sin embargo:
 El paquete `libglu1-mesa' no está configurado todavía.
 libglu1-mesa-dev depende de libgl1-mesa-dev | libgl-dev; sin embargo:
 El paquete `libgl1-mesa-dev' no está configurado todavía.
  El paquete `libgl-dev' no está instalado.
  El paquete `libgl1-mesa-dev' que provee `libgl-dev' aún no está configurado.
dpkg: error al procesar libglu1-mesa-dev (--configure):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de printer-driver-ptouch:
 printer-driver-ptouch depende de libcups2 (>= 1.4.0); sin embargo:
 El paquete `libcups2' no está configurado todavía.
 printer-driver-ptouch depende de libcupsimage2 (>= 1.4.0); sin embargo:
 El paquete `libcupsimage2' no está configurado todavía.
dpkg: error al procesar printer-driveNo se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
 No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
                                                          No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»



                                                          No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
           No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
                                                                                                    r-ptouch (--configure):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de system-config-printer-udev:
 system-config-printer-udev depende de libcups2 (>= 1.4.0); sin embargo:
 El paquete `libcups2' no está configurado todavía.
dpkg: error al procesar system-config-printer-udev (--configure):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de cups-bsd:
 cups-bsd depende de libcups2 (>= 1.4.0); sin embargo:
 El paquete `libcups2' no está configurado todavía.
 cups-bsd depende de cups-client (= 1.5.3-0ubuntu1); sin embargo:
 El paquete `cups-client' no está configurado todavía.
dpkg: error al procesar cups-bsd (--configure):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de libkrb5-dev:
 libkrb5-dev depende de krb5-multidev (= 1.10+dfsg~beta1-2ubuntu0.1); sin embargo:
 El paquete `krb5-multidev' no está configurado todavía.
dpkg: error al procesar libkrb5-dev (--configure):
 problemas de dependencias - se deja sin configurar
Configurando libboost-iostreams1.46.1 (1.46.1-7ubuntu3) ...
Configurando libcwidget3 (0.5.16-3.1ubuntu1) ...
Configurando aptitude (0.6.6-1ubuntu1) ...
update-alternatives: utilizando /usr/bin/aptitude-curses para proveer /usr/bin/aptitude (aptitude) en modo automático.
Configurando libsub-name-perl (0.05-1build2) ...
Configurando libclass-accessor-perl (0.34-1) ...
Configurando libio-string-perl (1.08-2) ...
Configurando libparse-debianchangelog-perl (1.2.0-1ubuntu1) ...
Procesando disparadores para libc-bin ...
ldconfig deferred processing now taking place
Procesando disparadores para menu ...
Se encontraron errores al procesar:
 libgcrypt11
 libkrb5support0
 libk5crypto3
 libkrb5-3
 libgssapi-krb5-2
 libcups2
 libcupsmime1
 libcupscgi1
 libcupsimage2
 libcupsppdc1
 cups-client
 cups-ppdc
 cups
 libcupsdriver1
 libgl1-mesa-dri
 libglapi-mesa
 libgl1-mesa-glx
 libgssrpc4
 libkadm5clnt-mit8
 libkdb5-6
 libkadm5srv-mit8
 libv4lconvert0
 libv4l-0
 libglu1-mesa
 libdns81
 libisccfg82
 libbind9-80
 bind9-host
 dnsutils
 krb5-multidev
 libgcrypt11-dev
 libgl1-mesa-dev
 libglu1-mesa-dev
 printer-driver-ptouch
 system-config-printer-udev
 cups-bsd
 libkrb5-dev
E: Sub-process /usr/bin/dpkg returned an error code (1)
Al parecer tengo un problema de paquetes tremendo, ya que uno depende del otro y se rompen, por lo tanto no pudiendo actualizarse. Ya probe los tipicos sudo apt-get -f install , sudo apt-get install --fix-missing y nada, sigue rompiendo. Alguna idea?. Muchas gracias por su ayuda.


Saludos.

Avatar de Usuario
doc
Forista Ancestral
Forista Ancestral
Mensajes: 3659
Registrado: Mié Ago 11, 2010 10:32 am
Ubicación: Oviedo-es_ES
Contactar:

Re: Problema con dependencias Xubuntu 12.04

Mensaje por doc »

pues, como me niego a leer de cabo a rabo el enorme reporte que pones, lo que se me ocurre es que uses 'aptitude', que por lo menos te irá informando de las posibles soluciones a los problemas de dependencias. O revisa cups, y eso de 'crypt...' que parece que tiene algo que ver.

Aunque el problema estará más bien en saber qué es lo que has hecho, y cómo, para llegar hasta ahí y eso es imposible que lo conozcamos así que, si no sabes salir del atolladero (o te puede resultar muy costoso) siempre te queda la opción, que no por tacharla de 'windowsera' es menos práctica, de reinstalar el Xubuntu, y partir de cero, vigilando lo que haces y, lo que sería mucho mejor, creándote 'escalones de restauración', con Clonezilla o similar, para dar el paso atrás cuando veas que algo que has hecho te vuelve a dar las inconsistencias que detectas.

Avatar de Usuario
enriquehh
Forista Distinguido
Forista Distinguido
Mensajes: 1337
Registrado: Sab Dic 08, 2007 8:00 am

Re: Problema con dependencias Xubuntu 12.04

Mensaje por enriquehh »

Hola como estas, al parecer tienes un problema en la configuración de los repositorios.

saludos

Responder
  • Temas similares
    Respuestas
    Vistas
    Último mensaje