No tengo apache y no me lo instala

Dudas y comentarios relacionadas con paquetes o programas específicos (obtención, uso, actualizaciones, versiones, problemas de instalación, etc.)
Responder
banderas20
Forista Menor
Forista Menor
Mensajes: 67
Registrado: Mar Jul 09, 2013 1:20 pm

No tengo apache y no me lo instala

Mensaje por banderas20 »

Hola.

En un debian, he mirado los scripts de inicio en /etc/init.d/ a ver si tenía apache. No me sale nada.

También hago

Código: Seleccionar todo

dpkg --get-selections apach*
Me devuelve

Código: Seleccionar todo

apache2.2-bin					install
Entiendo que no lo tengo instalado. Si es así, ¿por qué al hacerle

Código: Seleccionar todo

root@magus:/home/alberto# aptitude install apache2.2-bin
no hace nada?:

Código: Seleccionar todo

No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.
Gracias!!!

Avatar de Usuario
cuentos
Forista Distinguido
Forista Distinguido
Mensajes: 1088
Registrado: Mar May 03, 2011 7:09 am

Re: No tengo apache y no me lo instala

Mensaje por cuentos »

Prueba con:

Código: Seleccionar todo

aptitude install apache2
por ejemplo me da:
Se instalarán los siguiente paquetes NUEVOS:
apache2 apache2-bin{a} apache2-data{a} libapr1{a} libaprutil1{a} libaprutil1-dbd-sqlite3{a} libaprutil1-ldap{a}
0 paquetes actualizados, 7 nuevos instalados, 0 para eliminar y 0 sin actualizar.
Necesito descargar 1 548 kB de ficheros. Después de desempaquetar se usarán 5 285 kB.
¿Quiere continuar? [Y/n/?]
Cuando mi maestro me reprendió, me dijo: Alejandro Magno a los 20 años conquistaba el mundo, Yo le conteste "si pero tenia de maestro a Aristóteles".
Twitter: @mcuentos

banderas20
Forista Menor
Forista Menor
Mensajes: 67
Registrado: Mar Jul 09, 2013 1:20 pm

Re: No tengo apache y no me lo instala

Mensaje por banderas20 »

Hola cuentos,

eso que te da a ti es lo normal. Si lo pongo yo, me escupe esto:

Código: Seleccionar todo

# aptitude install apache2
No candidate version found for apache2   
No candidate version found for apache2
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.
Gracias.

Avatar de Usuario
cuentos
Forista Distinguido
Forista Distinguido
Mensajes: 1088
Registrado: Mar May 03, 2011 7:09 am

Re: No tengo apache y no me lo instala

Mensaje por cuentos »

como te comente tendríamos que ver tus repositorios, en la terminal:

Código: Seleccionar todo

cat /etc/apt/sources.list
y de una vez:

Código: Seleccionar todo

ls /etc/apt/sources.list.d
Cuando mi maestro me reprendió, me dijo: Alejandro Magno a los 20 años conquistaba el mundo, Yo le conteste "si pero tenia de maestro a Aristóteles".
Twitter: @mcuentos

banderas20
Forista Menor
Forista Menor
Mensajes: 67
Registrado: Mar Jul 09, 2013 1:20 pm

Re: No tengo apache y no me lo instala

Mensaje por banderas20 »

Buenas!

He actualizado el sources.list y ahora me sale apache2 como paquete disponible. Probaré y te cuento.

Muchas gracias por tu ayuda!

EDIT: he conseguido instalarlo después de agregar repositorios y hacer update (sin hacer upgrade).

Gracias y saludos!

Responder
  • Temas similares
    Respuestas
    Vistas
    Último mensaje