Re: Extraño inconveniente Audio Ubuntu Ubuntu 14.04 (SOLUCIONADO)

Las partes físicas de tu maquina funcionando bajo linux (Tarjeta de video, de sonido, modem, tarjeta de red, monitor, etc.)
Responder
pablomacri06
Forista Nuevo
Forista Nuevo
Mensajes: 31
Registrado: Jue Oct 17, 2013 5:47 pm

Re: Extraño inconveniente Audio Ubuntu Ubuntu 14.04 (SOLUCIONADO)

Mensaje por pablomacri06 »

Tengo un extraño inconveniente con el sonido en mi sistema.

Tengo un monitor Samsung T27A550 con parlantes incorporados que puede tomar el audio por 2 lados
1º por la placa de sonido de la PC mediante un cable del monitor a la placa de sonido (plug verde)
2º por el mismo HDMI de video.

Actualmente en UBUNTU el sonido que sale por el monitor lo tengo configurado que lo tome del HDMI porque por el Plug verde no me lo toma, Y aquí lo extraño Si le conecto auriculares al plug verde de la placa de sonido, el sonido SI SALE por auriculares, pero no por el monitor.

En WINDOWS el audio funciona perfectamente con el monitor sin realizar ningún cambio al monitor...... El mismo sale tanto por auricualres como por el monitor al mismo tiempo:S (Osea no es un problema del monitor)

Por lo tanto se me ocurrio hacer una prueba en Ubuntu. Puse un bifurcador a la salida del Plug verde de la placa de sonido y le conecte al mismo tiempo un par de auriculares y el cable de audio del monitor.. Y NO SE COMO! PERO EL SONIDO SALE POR MIS AURICUALRES Y POR EL MONITOR NO.
EN WINSHIT ESTO SI FUNCIAN... En Ubuntu no:S

Dejo mis datos del sistema:
UBUNTU 14.04.1

Código: Seleccionar todo

pablo@pablo-abajo:~$ lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Turks/Whistler HDMI Audio [Radeon HD 6000 Series]
pablo@pablo-abajo:~$  cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xfe720000 irq 50
 1 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xfe640000 irq 52
Editado -- Mié Sep 10, 2014 2:52 am --

Bueno ya voy encontrando el problema pero no se como resolverlo....

Hice otra prueba, agarre mi celular y le conecte el cable de audio de mi monitor al plug de sonido de mi celuar y le puse a reproducir algo. Antes de que cargue el Sistema Operativo Ubuntu, el sonido sale perfectamente por el monitor pero una vez que el sistema ingresa, el monitor se anula. Sospecho que la cuestion es porque el mismo esta conectado por HDMI y supongo que el sistema operativo de alguna manera esta anulando la otra entra del monitor, no se como pero asi parece.

Lo que quiero saber es como modificar manualmente ALSA o el sistema para QUITARLE la opción de que reproduzca audio por HDMI ya que si realizo el cambio desde la herramienta de sonido del mismo sistema, no me da resultado.
Última edición por pablomacri06 el Dom Sep 21, 2014 12:36 am, editado 1 vez en total.

Avatar de Usuario
cuentos
Forista Distinguido
Forista Distinguido
Mensajes: 1088
Registrado: Mar May 03, 2011 7:09 am

Re: Extraño inconveniente Audio Ubuntu Ubuntu 14.04

Mensaje por cuentos »

No se si te sirva, pero cuando tengo problemas al configurar las salidas de audio, instalo pavucontrol y desde esta configura los canales.
Cuando mi maestro me reprendió, me dijo: Alejandro Magno a los 20 años conquistaba el mundo, Yo le conteste "si pero tenia de maestro a Aristóteles".
Twitter: @mcuentos

pablomacri06
Forista Nuevo
Forista Nuevo
Mensajes: 31
Registrado: Jue Oct 17, 2013 5:47 pm

Re: Extraño inconveniente Audio Ubuntu Ubuntu 14.04

Mensaje por pablomacri06 »

Gracias! pero no es eso tampoco

De todas maneras creo que ya tengo a mi primer sospechoso!! 8-)

Analizando bien las cosas descubro que en windows el sonido sale unicamente por el Plug de audio porque windows NO TOMA la salida HDMI para audio, figura como NO Conectada, que no existe dicha salida....

Al parecer cuando el monitor detecta alguna especie de señal de audio proveniente del HDMI bloquea la otra entrada la del plug verde.
En windows el monitor no detecta en ningun momento el audio del HDMI porque windows no lo reconoce y por eso funciona por el Plug verde.
En Ubuntu el audio es enviado por el HDMI y por eso supongo que se bloquea, quizá sea el driver de Video que esta habilitando la salida de audio por HDMI y el monitor detecta eso suponog...

Probe lo siguiente: blacklist snd_hda_intel
El resultado es que me quedo totalmente sin audio pero el HDMI sigue bloqueando la otra entrada de audio, por eso deduzco que quiza el driver de Video me este bloqueando la otra entrada de audio porque si arranco UBUNTU en modo de recuperacion, osea en texto, el sonido es tomado perfectamente mediante un celular por ejemplo. Pero en cuanto carga el entorno gráfico deja de responderle al celular y pasa a prestarle atencion al auido del HDMI y por mas que este en blacklist el modulo anterior y sin sonido el sistema...

Espero no haberlos mareado y que puedan haberme comprendido jaja
Escucho ideas a ver si logramos dar con el responsable de mi problema
Gracias!!!!! :)

Editado -- Dom Sep 21, 2014 12:35 am --

LO RESOLVI!!!! 8-) 8-) 8-)

Era el driver de Video que estaba utilizando Ubuntu por defecto. Resultaba que estaba en uso el driver Radeaon, entonces me baje de la pagina de ATI el propio driver y ahora que está utilizando el otro driver, el sonido funciona desde el plug de la placa de sonido y ya no lo toma mas del HDMI porque basicamente el sonido ya no se envía mas por HDMI

Perfectoooooo caso cerraado 8)

Avatar de Usuario
doc
Forista Ancestral
Forista Ancestral
Mensajes: 3596
Registrado: Mié Ago 11, 2010 10:32 am
Ubicación: Oviedo-es_ES
Contactar:

Re: Re: Extraño inconveniente Audio Ubuntu Ubuntu 14.04 (SOLUCIONADO)

Mensaje por doc »

no se por qué pero el sonido por HDMI suele dar problemas. Yo hace tiempo que me harté del tema y lo que hice fue conectar la TV por cable HDMI y, para el sonido, un cable (con 'jacks' normales) de audio, estereo, de una salida del PC a una entrada de sonido de la tele... y santas pascuas.

pablomacri06
Forista Nuevo
Forista Nuevo
Mensajes: 31
Registrado: Jue Oct 17, 2013 5:47 pm

Re: Re: Extraño inconveniente Audio Ubuntu Ubuntu 14.04 (SOLUCIONADO)

Mensaje por pablomacri06 »

Si, obviamente si se consigue alguna solución sencilla Bienvenida!

Y aca estoy leyendo nuevamente mi propio mensaje porque lo tengo que volver a hacer, y no recordaba que era lo que había hecho para solucionarlo jajajajajaja ::lol:: ::lol:: Si ya se, no estoy bien :D

lamentealien
Forista Nuevo
Forista Nuevo
Mensajes: 1
Registrado: Mar Abr 05, 2016 8:19 pm

Re: Extraño inconveniente Audio Ubuntu Ubuntu 14.04 (SOLUCIONADO)

Mensaje por lamentealien »

pablomacri06 escribió:Si, obviamente si se consigue alguna solución sencilla Bienvenida!

Y aca estoy leyendo nuevamente mi propio mensaje porque lo tengo que volver a hacer, y no recordaba que era lo que había hecho para solucionarlo jajajajajaja :::lol::: :::lol::: Si ya se, no estoy bien :D
pablomacri06 creo que tengo el mismo problema que vos en mi ubuntu. Escuchaba bien el audio hasta que conecte el cable HDMI y seleccioné en configuraciones de sonido la salida HDMI. El audio sale bien si tengo la netbook conectada al televisor, pero sino, por los altavoces internos no sale nada. De hecho me desapareció el ícono de audio (el del altavoz) arriba a la derecha. Si reproduzco cualquier video de youtube por ejemplo y abro el PulseAudio, veo como el vúmetro muestra que está recibiendo señal, sin embargo por los altavoces (o conectando auriculares) no consigo que salga ningún sonido. Por más que en configuraciones de sonido cambie de "salida HDMI" a Altavoces internos, nada cambia.

Si entendí bien, tu tuviste el mismo problema y lo pudiste solucionar no?
podrías explicar bien cómo?

muchas gracias
saludos

Responder
  • Temas similares
    Respuestas
    Vistas
    Último mensaje