Problema con OpenGL [SOLUCIONADO]

Temas sobre el sistema X Window; problemas de configuración, xorg, xfree86, implementación de XGL, efectos, etc. En este foro no se tratara los problemas con las X durante o inmediatamente después de la instalación de las distribuciones.
Responder
Avatar de Usuario
cesarer
Forista Nuevo
Forista Nuevo
Mensajes: 14
Registrado: Mar Oct 26, 2010 7:29 am
Ubicación: San Salvador - El Salvador

Problema con OpenGL [SOLUCIONADO]

Mensaje por cesarer » Mar Oct 26, 2010 7:56 am

Saludos a todos, tengo un problema, hoy me doy cuenta que ningun juego que usa opengl me funciona, asi que coloqué en consola glxgears y me sale este error:

Código: Seleccionar todo

cesarer@debian:~$ glxgears
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  137 (NV-GLX)
  Minor opcode of failed request:  4 ()
  Resource id in failed request:  0x2a00002
  Serial number of failed request:  35
  Current serial number in output stream:  35
en efecto, no tengo opengl (que hace unos días funcionaba bien). Ya me puse a googlear el error pero no encuentro solución. No recuerdo haber instalado nada que pudiese haber estropeado algo (porque funcionaba de a 10).

Datos:
NVIDIA GeForce 8400 GS
(instalada con el driver propietario de Nvidia, antes tenía el driver libre nouveau, pero lo desinstalé)
Distribución: Debian Squeeze, con kernel: 2.6.32

¿Tienen alguna idea o sugerencia de como podría solucionarlo? Lo agradecería mucho.
Última edición por cesarer el Jue Oct 28, 2010 4:09 am, editado 1 vez en total.
“Proporciónale un pescado a un hombre y le alimentarás para un día. Enséñale cómo pescarlo y le alimentarás para toda la vida.” -- Lao Tzu
Avatar de Usuario
Sagman
Forista Mayor
Forista Mayor
Mensajes: 933
Registrado: Dom Jul 31, 2005 7:00 am
Ubicación: /world/europe/spain/catalonia/girona/figueres
Contactar:

Re: Problema con OpenGL

Mensaje por Sagman » Mar Oct 26, 2010 10:15 pm

Desinstalaste el driver nouveau después de instalar el driver oficial de Nvidia? Quizas al desinstalar el driver Nouveau se haya desinstalado otro paquete como por ejemplo libgl. Prueba a reinstalar el driver oficial de Nvidia
Avatar de Usuario
cesarer
Forista Nuevo
Forista Nuevo
Mensajes: 14
Registrado: Mar Oct 26, 2010 7:29 am
Ubicación: San Salvador - El Salvador

Re: Problema con OpenGL

Mensaje por cesarer » Mié Oct 27, 2010 4:39 am

Gracias por responder. El driver nouveau lo removí antes de instalar el driver de Nvidia.
Ayer, lo primero que intenté fue reinstalar el driver, pero nada pasó.
Pero hoy hice una actualización con: #aptitude update; aptitude upgrade
ya hace cierto rato que no actualizaba, y en esta ocasión se actualizaron varios paquetes, el xorg y el linux-header, entre otros... así que volví a intentar la re-instalación del driver y ahora ya funciona! La verdad no tengo idea de cual fue el problema :? me quedo con la duda 8O
Gracias de nuevo por responder, saludos.
“Proporciónale un pescado a un hombre y le alimentarás para un día. Enséñale cómo pescarlo y le alimentarás para toda la vida.” -- Lao Tzu
Responder
  • Similar Topics
    Respuestas
    Vistas
    Último mensaje