Reglamento general de los foros   •   FAQ   •   Buscar en el foro •  Registrarse | Iniciar sesión 



Portada » Foros Linux » Entorno gráfico » X Window


Nuevo tema Responder al tema
 [ 6 mensajes ] 
Patrocinadores

Autor
Buscar:
Mensaje

Desconectado
Forista Mayor
Forista Mayor
Avatar de Usuario

Registrado: Lun Sep 26, 2011 2:01 am
Mensajes: 691
Ubicación: Mexico, DF

Nota Publicado: Lun May 14, 2012 7:10 am 
Arriba  
¡Hola!, tal parece que tengo mala suerte.
Despues de poder instalar Debian, instale las Xorg, instale openbos y ¡pum! startx, inicia normalmente y se ve de la patada, al hacer tap derecho (no es mouse) sale el menu pero como que se clona a lo bestia por toda la pantalla, despues instale icewm y se ve un poco mas arriba de la pantalla, con fluxbox se combinan ambos errores.
Decidi revisar el xorg.conf para ver si habia algun problema y ¡OMG! no existe.
Asi que mate las X, y "cd /etc/X11" y "Xorg -configure". Aparecen fugazmente unas letras y queda una pantalla negra, eternamente.
Decidi reinstalar Debian de 0 y solo configurar el wireless y despues instale de nuevo las xorg. Exactamente lo mismo, decidi dejarla un rato a ver si era solo un traboncito. Desde hace una hora hasta el momento de escribir esto sigue en la pantalla negra.
La grafica es una SMI LynxEM+ y es una pantalla de 800x600 de 16 bits.
No he tenido ningun problema con la grafica en Puppy.
Saludos.
Charlie


Última edición por CharlieBros el Lun May 14, 2012 7:37 pm, editado 1 vez en total
 Perfil  

Desconectado
Forista Ancestral
Forista Ancestral
Avatar de Usuario

Registrado: Jue Abr 12, 2007 7:00 am
Mensajes: 9186
Ubicación: tras la pantalla (...)

Nota Publicado: Lun May 14, 2012 11:49 am 
Arriba  
a) seguro que no era Xorg --configure ?? (hace muchoq ue no lo hago, ya no lo recuerdo...) aka, con DOS giones? (que con el bold no se ve bien)

b) creo que era a partir de squeeze que hacia cosillas raras, pero en el fondo sigue funcionando. ya no vas a ver la pantalla gris con la X del raton en el medio. da igual, lo lanzas, esperas unos segundos por si acaso, matas las X (al gusto, prueba a ver que funciona: ctrl+alt+retroceso, ctrl+alt+f1 y ahi ves si el ctrl+c funciona, o un soft reset... aka, le das al boton, esperas que se apague (SOFT reset, aka, que el boton mande la senial de apagado. auqnue para esto necesitas tener el acpid instalado, creo recordar), y cuando arranques de nuevo sigues)

tras consguir matar a las X, tendras el nuevo xorg.conf en /root/xorg.conf.new . echale un ojo, y si ves que parece que esta bien, lo copias a su sitio, y ya sabes. startx y a ver que pasa.

por cierto, viendo que intentas tirar de startx te voy a dejar una guia que puede que te sea util.
http://man-linux.comli.com/?p=254 (se que s mucho mas completa, pero la parte del profile te puede ser MUY util. :wink: )

_________________
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]

 Perfil WWW  

Desconectado
Forista Legendario
Forista Legendario
Avatar de Usuario

Registrado: Dom Oct 10, 2004 7:00 am
Mensajes: 1790

Nota Publicado: Lun May 14, 2012 3:56 pm 
Arriba  
Es X -configure

 Perfil  

Desconectado
Forista Ancestral
Forista Ancestral
Avatar de Usuario

Registrado: Jue Abr 12, 2007 7:00 am
Mensajes: 9186
Ubicación: tras la pantalla (...)

Nota Publicado: Lun May 14, 2012 6:25 pm 
Arriba  
neurus escribió:
Es X -configure


:?

Código:
[18:24:36] - [root@ian:/usr/src/dwm-5.9]
802 >>> Xorg -configure

Fatal server error:
Server is already active for display 0
        If this server is no longer running, remove /tmp/.X0-lock
        and start again.

Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.


seh, las X estan corriendo ya, por eso da error, pero el comando lo reconoce sin problemas. :wink:

_________________
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]

 Perfil WWW  

Desconectado
Forista Legendario
Forista Legendario
Avatar de Usuario

Registrado: Dom Oct 10, 2004 7:00 am
Mensajes: 1790

Nota Publicado: Lun May 14, 2012 6:41 pm 
Arriba  
Bueno, sí. X es un enlace simbólico a Xorg. El hecho es que lleva un solo guión. Me llevó años memorizarlo. Seguramente lo olvidaré para la próxima vez que lo necesite y ejecutaré ordenadamente:
X --config
X -config
X --configure
y, por fin,
X -configure

 Perfil  

Desconectado
Forista Mayor
Forista Mayor
Avatar de Usuario

Registrado: Lun Sep 26, 2011 2:01 am
Mensajes: 691
Ubicación: Mexico, DF

Nota Publicado: Lun May 14, 2012 7:17 pm 
Arriba  
Niky, eres mi angel de la guarda Debianera. Efectivamente, se a creado el xorg.conf en la ruta que dijiste (/root/xorg.conf.new), ahora solo lo modifico para que me da la resolucion y listo.
Gracias y Saludos.
Charlie

 Perfil  
Mostrar mensajes previos:  Ordenar por  
 [ 6 mensajes ] 
Nuevo tema Responder al tema

Saltar a:  


 Temas relacionados   Autor   Respuestas   Vistas   Último mensaje 
(¿Solucionado?) Error al tratar de realizar NetInstall de Debian 6.0.4 con una Broadcom.

en Instalación de distribuciones

CharlieBros

13

2024

Vie Ago 07, 2015 6:39 pm

doc Ver último mensaje

Remover xserver-xorg en Debian squeeze (SOLUCIONADO)

en Instalación de distribuciones

pataro

13

3050

Dom Sep 04, 2011 7:17 pm

cronos Ver último mensaje

(SOLUCIONADO) GtkAda (Ada Gnat) problema con configure

[ Ir a página: 1, 2 ]

en Software

uma

17

3567

Sab Ago 25, 2012 4:45 pm

mcun Ver último mensaje

(xorg) Slackware64 13.1 GSB (Solucionado)

en GNOME

Treto

5

841

Sab Ago 14, 2010 9:57 am

Worthkunst Ver último mensaje

y mi xorg.conf?? (solucionado)

en X Window

niky45

12

8350

Jue Jul 30, 2009 10:44 am

tepes89 Ver último mensaje



¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado

No puede abrir nuevos temas en este Foro
No puede responder a temas en este Foro
No puede editar sus mensajes en este Foro
No puede borrar sus mensajes en este Foro
No puede enviar adjuntos en este Foro

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group :: Style based on FI Subice by phpBBservice.nl :: Todos los horarios son UTC + 1 hora [ DST ]
Traducción al español por Huan Manwë
phpBB SEO