Reglamento general de los foros   •   FAQ   •   Buscar en el foro •  Registrarse | Iniciar sesión 



Portada » Foros Linux » General » Instalación de distribuciones


Nuevo tema Responder al tema
 [ 55 mensajes ]  Ir a página 1, 2, 3, 4  Siguiente
Patrocinadores

Autor
Buscar:
Mensaje

Desconectado
Forista Legendario
Forista Legendario
Avatar de Usuario

Registrado: Mié Ago 11, 2010 10:32 am
Mensajes: 1852
Ubicación: Oviedo-es_ES

Nota Publicado: Jue Feb 23, 2012 2:51 pm 
Arriba  
a ver, no me refiero a hacer una instalación 'minimal', o montarte un Arch personalizado, y tal, sino a 'mejorar una situación actual'. Hace un par de meses me he pasado a la rama Sid, me funciona todo estupendamente, actualizo todos los días (con safe-upgrade) pero tengo la sensación de que mi Debian va algo lentorro: De hecho, me tarda casi minuto y medio en arrancar.

Cierto que ahora estoy usando gnome-shell, con varias extensiones, que en el arranque hago que se me abra Icedove, pero he anulado varias aplicaciones o demonios que se cargan al inicio (poca cosa, todo eso de compartir, y tal, la verdad en que no se muy bien qué se puede quitar y qué no) y no veo mejora. Creo que, cuando reinstalé, me cargaba todo más rápido.

En mis tiempos 'en el lado oscuro' recuerdo historias de optimizar registro, desfragmentar, y cosas así. Ya se que Linux no va de esto, pero mi pregunta es si aquí puede haber algunas teclas que tocar (y cuales) para mejorar, por ejemplo, el arranque.
Por cierto; cuando instalo de cero, me lo monto con mis aplicaciones 'habituales' y no suelo, normalmente, instalar nuevas cosas, solo actualizarlas. Y me suelo hacer (con Clonezilla) una imagen de mi partición Root, 'con el sistema 'nuevecito', que pesa unos 4 gigas. Pero las que hago ahora pesan más de 5 gigas. ¿tendrá algo que ver con la 'sensación' de lentitud? ¿Será por estar en Sid?

Bueno, pues eso: ¿alguna ideilla...?

 Perfil WWW  

Desconectado
Administrador
Administrador
Avatar de Usuario

Registrado: Lun Abr 19, 2010 12:30 am
Mensajes: 3847
Ubicación: En una de las nalgas del culo del mundo (según la Bersuit Vergarabat)

Nota Publicado: Jue Feb 23, 2012 2:53 pm 
Arriba  
revisa lo que se carga la arranque y elimina lo que no precises

_________________
Los programadores de verdad no documentan. La documentación es para los idiotas que no pueden leer un volcado de memoria.

Trusted Network and Developer | Lee el Reglamento !! |WIKI-EL | Twitter @mr_mcun
Debian + TTY | ArchLinux + awesome | openSUSE + Gnome-Shell | Linux User #508809

 Perfil WWW  

Desconectado
Moderador
Moderador
Avatar de Usuario

Registrado: Dom Abr 01, 2007 8:00 am
Mensajes: 3165
Ubicación: México, Estado de México

Nota Publicado: Jue Feb 23, 2012 5:03 pm 
Arriba  
que demonios te corren al inicio?.... podrías quitar los que no usas y poner en segundo plano a algunos otros...

_________________
Reglamento del Foro | Temas mas Preguntados | WikiEL | GitHub
Linux User #:406092
Manjaro | Asus P8z77-v | i5-2310 | Nvidia GeForce Gt 610 | Hp Ultrabook Folio 13

 Perfil  

Desconectado
Forista Legendario
Forista Legendario
Avatar de Usuario

Registrado: Mié Ago 11, 2010 10:32 am
Mensajes: 1852
Ubicación: Oviedo-es_ES

Nota Publicado: Jue Feb 23, 2012 7:44 pm 
Arriba  
veamos, supongo que eso es lo que sale en 'Aplicaciones al inicio' y, haciendo una captura (espero que se vea bien)...
Imagen

( no se si por algún lado habrá algún Log que las indique mejor. Como ves he desactivado algunas, pero del resto (salvo que tengo puesto que, al encenderlo por las mañanas, me ejecute el Icedove, y que, con AlarmClock, a las 5 de la tarde me vuelva a ejecutar el Icedove) no tengo ni idea de si sirven para algo importante, o se pueden desactivar.

(Tampoco tengo una idea clara de lo que es 'poner en segundo plano', y cómo hacerlo)

 Perfil WWW  

Desconectado
Moderador
Moderador
Avatar de Usuario

Registrado: Dom Abr 01, 2007 8:00 am
Mensajes: 3165
Ubicación: México, Estado de México

Nota Publicado: Jue Feb 23, 2012 7:56 pm 
Arriba  
pues poner un demonio en segundo plano es que el sistema no espere a que se termine de ejecutar antes de empezar a ejecutar al siguiente demonio...igual y no se como podrías ponerlos en segundo plano en debian....ya me mal acostumbre al rc.conf de arch :P

cuenta, necesitas tener activo la cola de impresion, el bluetooth, login sound y el notificador de actualizaciones?..si no podrias quitarlos....no creo que te solucione el problema pero algo es algo

_________________
Reglamento del Foro | Temas mas Preguntados | WikiEL | GitHub
Linux User #:406092
Manjaro | Asus P8z77-v | i5-2310 | Nvidia GeForce Gt 610 | Hp Ultrabook Folio 13

 Perfil  

Desconectado
Forista Distinguido
Forista Distinguido
Avatar de Usuario

Registrado: Dom Oct 10, 2004 7:00 am
Mensajes: 1456

Nota Publicado: Sab Feb 25, 2012 12:08 am 
Arriba  
Esa captura que muestras, ¿necesita permisos de root para ejecutarse? Con lo poco que pude leer con mi vista biónica (¿está caro el centímetro de pantalla?) parece algún tipo de manejador de aplicaciones de Gnome, no del sistema en sí. Por cierto: ¿servicio de almacenamiento de secretos? ¿WTF? ¿lo ejecutas y te sale un psicoanalista, un sacerdote, un chamán, o algo así? ¿Le cuentas que mataste a tu cuñada y pateaste al perro del vecino?.

En cuanto al inicio de Debian: si te atreves a instalar upstart, puede ayudarte. Pero yo me decantaría por mover momentáneamente todo script tuyo que tengas en /etc/init.d/ a otra ubicación, y actualizar entonces sysvinit. Luego puedes volver a ubicar tus scripts. Esto es porque, si hay algún script mal formado (sin las cabeceras correctas) Debian opta por no actualizar sysvinit, que resulta que lo han optimizado hace unos cuantos meses.

Hecho lo de arriba, instala bum. Luego lo ejecutas como root. Es una interfaz gráfica para habilitar/deshabilitar servicios al arranque del sistema. Demonios como saned, por ejemplo, sólo tienen sentido si tienes un scanner. Los demonios de red, dependerán de tu configuración que los necesites o no: avahi-daemon sólo tiene sentido si tu red cambia a menudo (se le agrega una impresora, tienes un dns en direcciones extrañas, agregas todo el tiempo directorios compartidos, etc; postfix inicia el servidor de correo que Debian instala siempre. Es muy bueno, pero no tiene sentido si tus cuentas de correo son de las gratuitas de algún webmail.

Y luego, ya no sé qué más puedas tener. En cualquier caso, mientras no deshabilites los demonios que comienzan con "depend", el sistema seguirá arrancando normalmente, y ya te enterarás si deshabilitaste lo justo o te pasaste tres pueblos.

Luego están los trucos. Un ejemplo: yo nunca enciendo la máquina para imprimir algo. Cuando imprimo algún documento, el equipo lleva minutos u horas encendido. Por lo tanto, no necesito ese servicio en el arranque. Ese y otros (no-ip, por ejemplo) los tengo en un script que se ejecuta al final, luego de levantar la interfaz gráfica, y con varios sleeps y pasos a segundo plano. Tres minutos después de estar usando la máquina, tal vez todavía se estén levantando demonios, pero yo ni me entero.

 Perfil  

Desconectado
Forista Legendario
Forista Legendario
Avatar de Usuario

Registrado: Mié Ago 11, 2010 10:32 am
Mensajes: 1852
Ubicación: Oviedo-es_ES

Nota Publicado: Sab Feb 25, 2012 3:02 am 
Arriba  
hombre, neurus, lo primero es el paquete 'Aplicaciones al Inicio' que se instala por defecto en Debian y no, no necesito abrirlo como root, esas cosas raras que salen no las he instalado yo, vienen así de la instalación 'por defecto'. Lo que me ha extrañado mucho es que, como también tengo instalado un Ubuntu ( en una partición adicional etiquetada como 'Pruebas'), y ese Ubuntu arranca muy rápido, solo tiene un par de cosillas en esa pantalla 'Aplicaciones al inicio'. Claro que también tengo un Ubuntu 'pelao'

Me parece interesantísimo eso del Boot Up Manager (BUM), ya me he informado con Google y 'fichado', en mis 'Apuntes Tácticos' la info que me pareció interesante, y lo iré estudiando con calma, que hay muchas cosas (runlevels y tal) que no domino. Entretanto haré algunas pruebitas, que después de todo, como yo suelo encender el PC 1 vez (o como mucho 2 o 3) al día, tampoco me urge. Además, me he dado cuenta de que, además de lo de bluetooth, saned, el correo icedove, el network, y tal me arrancan (porque así lo quiero) algunos servicios adicionales que quizás retarden ese arranque, como VirtualBox, Clamtk, MultiSystem, hddtemp y sensors, varias extensiones de gnome-shell, etc, etc.

Lo voy a mirar con lupa, a ver si voy profundizando en el tema. Gracias por la ayuda.

 Perfil WWW  

Desconectado
Forista Ancestral
Forista Ancestral
Avatar de Usuario

Registrado: Jue Abr 12, 2007 7:00 am
Mensajes: 9186
Ubicación: tras la pantalla (...)

Nota Publicado: Sab Feb 25, 2012 12:28 pm 
Arriba  
Citar:
Y me suelo hacer (con Clonezilla) una imagen de mi partición Root, 'con el sistema 'nuevecito', que pesa unos 4 gigas. Pero las que hago ahora pesan más de 5 gigas. ¿tendrá algo que ver con la 'sensación' de lentitud? ¿Será por estar en Sid?


sid no tiene la culpa. lo otro, no completamente, pero si.

respecto a lo que comenta neurus, es ideal.... PERO. la mayoria de esas cosas vienen por default, y raro es que un demonio haga retrasar el arranque esa diferencia de tiempo tan grande (mi debian wheezy ahora mismo esta en menos de 30 segundos, y la del portatil, en cosa de 15)

traduccion: eso es ideal para optimizar un sistema como tal, pero me parece raro que explique por que antes iba bien y ahora no.

como formas de acelerar el arranque en debian, el sysvinit tiene mucho que ver: antiguamente una debian no arrancaba en menos de ~90 segundos (a ojo), ahora la estoy viendo en menos de 30. queda tambien recompilar el kernel (puedes bajar a la mitad con relativa facilidad), y bueno, una limpiecita a fondo nunca viene mal:
http://man-linux.comli.com/?p=33

por cierto, creia que no funcionaba todo lo bien que se suponia, hasta que hace unos dias reinstale mi sistema, y me di cuenta de que si iba lento no era por la cantidad de polvo que tenia, sino por otra cosa (calidad de la conexion, fundamentalmente :cry: ). pero ojo: si te pasas, puedes acabar teniendo que reinstalar. :wink: (aka, si, es una guia bastante avanzada, y requiere que conozcas relativamente a ofndo tu sistema, y sobre todo, a apt/itutde )

PD: upstart, la ultima vez que lo probe, consiguio SUBIR el tiempo de arranque. :?

_________________
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]

 Perfil WWW  

Desconectado
Forista Distinguido
Forista Distinguido
Avatar de Usuario

Registrado: Dom Oct 10, 2004 7:00 am
Mensajes: 1456

Nota Publicado: Sab Feb 25, 2012 7:36 pm 
Arriba  
Citar:
pero me parece raro que explique por que antes iba bien y ahora no.


Es que me pareció descortés responderle que, para acelerar el sistema, debía cambiar el usuario.
Y, como todos saben, para mí, la cortesía ante todo.

PD: allí, las demoras más evidentes tienen que producirla los servidores de VirtualBox, o VMware, ya no recuerdo cuál menciona doc.

 Perfil  

Desconectado
Forista Legendario
Forista Legendario
Avatar de Usuario

Registrado: Mié Ago 11, 2010 10:32 am
Mensajes: 1852
Ubicación: Oviedo-es_ES

Nota Publicado: Sab Feb 25, 2012 9:51 pm 
Arriba  
pues esto no lo tengo yo muy claro: en realidad donde más rápido va es en la parte que entra el usuario, creo que es lento al principio, tras el grub (eso de que se van cargando cosas, y que en un momento 'cambia' el tipo de letra, y luego cuando entra el sistema gráfico (hasta que aparece la pantalla la pantalla de elegir usuario). Por cierto... ¿no hay un Log que registra lo que te está cargando durante el arranque? es que no me acuerdo cómo se llama. Estaría en /var/log ¿no?

 Perfil WWW  

Desconectado
Forista Ancestral
Forista Ancestral
Avatar de Usuario

Registrado: Jue Abr 12, 2007 7:00 am
Mensajes: 9186
Ubicación: tras la pantalla (...)

Nota Publicado: Sab Feb 25, 2012 10:24 pm 
Arriba  
/var/log/dmesg te muestra el log completo del kernel, desde el arranque. lo importante es buscar paradas.

y habia una herramienta que... servia para ver cuanto tardaba en cargar cada una de las cosas que tenia que cargar. cachis. no recuerdo como se llamaba. tal vez tirando del buscador del foro... (lo que no se es que buscar :P )

doc escribió:
creo que es lento al principio, tras el grub (eso de que se van cargando cosas, y que en un momento 'cambia' el tipo de letra, y luego cuando entra el sistema gráfico (hasta que aparece la pantalla la pantalla de elegir usuario


pasanos el dmesg via pastie.org. :wink: (dividelo en dos si hiciera falta, que suele ser largo)

:)

_________________
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]

 Perfil WWW  

Desconectado
Forista Legendario
Forista Legendario
Avatar de Usuario

Registrado: Mié Ago 11, 2010 10:32 am
Mensajes: 1852
Ubicación: Oviedo-es_ES

Nota Publicado: Sab Feb 25, 2012 10:59 pm 
Arriba  
pues a ver si se hacer lo de pastie.org
http://pastie.org/3458240

(porque entender lo que pone el dmesg ese... ya es demasié p'al body...)

 Perfil WWW  

Desconectado
Forista Ancestral
Forista Ancestral
Avatar de Usuario

Registrado: Jue Abr 12, 2007 7:00 am
Mensajes: 9186
Ubicación: tras la pantalla (...)

Nota Publicado: Dom Feb 26, 2012 11:12 pm 
Arriba  
la gracia del dmesg es que va "cronometrado", y es muy facil ver paradas y que las provoca.

dicho esto, preguntas:
Código:
[    3.837706] sd 6:0:0:1: [sdc] Attached SCSI removable disk
[    5.242672] udevd[302]: starting version 175


primera parada, apenas un par de segundos, la calificaria de irrelevante, pero, que es sdc??


Código:
[    7.435664] usbcore: registered new interface driver snd-usb-audio
[    8.344273] Did not find alt setting 1 for intf 0, config 1
[    8.530031] usblp0: USB Bidirectional printer dev 2 if 1 alt 0 proto 2 vid 0x03F0 pid 0x8711
[    8.530050] usbcore: registered new interface driver usblp
[   10.132003] hda-intel: azx_get_response timeout, switching to polling mode: last cmd=0x300f0000
[   11.136012] hda-intel: No response from codec, disabling MSI: last cmd=0x300f0000
[   12.140004] hda-intel: Codec #3 probe error; disabling it...
[   12.215544] hda_codec: ALC888: BIOS auto-probing.

toma ya frenazo. diria que el audio. que tarjeta tienes, que driver estas usando, y que serverde sonido?? pulseaudio, simple alsa,....??

y otra cosa. hay algun inconveniente en retrasar la carga del audio para evitarse esa parada (si no sabes lo que te pregunto, o por que, la respuesta es NO.)

Código:
[   14.882031] EXT4-fs (sda6): mounted filesystem with ordered data mode. Opts: (null)
[   15.619122] RPC: Registered named UNIX socket transport module.

casi un segundo para levantar la particion. habria que buscarle solucion, es muchisimo.
Código:
[   18.884531] ADDRCONF(NETDEV_UP): eth0: link is not ready
[   20.460865] e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: None
[   20.460870] e1000e 0000:00:19.0: eth0: 10/100 speed: disabling TSO
[   20.461308] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   21.305657] Bluetooth: Core ver 2.16

y red mas bluettoth (offtopic: necesitas bluetooth dsde el arranque?? no lo prefieres "ondemand"??), tres segundos. demasiado, de nuevo.

(EOF)
aun asi.....son 21 segundos. se puede bajar, pero no es taaanto.

para confirmar.... puedes pasar el /var/log/messages, de los dos o tres ultimos dias??
(va por fechas.... opia solo los ultimos dia si no quieres que nos mareemos entre tantas lineas. que ademas en pastie no te cabe mucho mas... :? )

esque en el dmesg me falta la parte de arranque de las X, y demas.... (suele mostrar una poarada caracteristica, y despues algun mensaje mas de muuuchos segundos despues. :? )

por cierto, juraria que el programa para monitorizar los tiempos de carga del arranque, se llamaba bootchart. te lo confirmaria, pero mi portatil no esta para esos trotes... (si con los codes ya casi me vuelvo loca :? )

_________________
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]

 Perfil WWW  

Desconectado
Forista Legendario
Forista Legendario
Avatar de Usuario

Registrado: Mié Ago 11, 2010 10:32 am
Mensajes: 1852
Ubicación: Oviedo-es_ES

Nota Publicado: Lun Feb 27, 2012 12:12 am 
Arriba  
ostras... o sea que esos números del dmesg son los segundos que están pasando... ¡lo que aprende uno, qué interesante...!

Ahora estoy liao para analizar lo que dices de esas paradas o tiempos excesivos que has detectado, a ver si lo miro con calma esta noche, entre tanto te paso el mesages que has comentado (he cogido desde el último apagado, hoy hacia las 17,55, y su posterior encendido, hacia las 19,50... y hasta ahora). Supongo que será suficiente, es un proceso completo.
http://pastie.org/3466937

bueno, añado esto otro (del mesages0), por si complementa algo
http://pastie.org/3467067

y gracias por abrirme los ojos (los tengo como platos, por la info que se puede obtener... y yo con estos pelos...)

 Perfil WWW  

Desconectado
Forista Ancestral
Forista Ancestral
Avatar de Usuario

Registrado: Jue Abr 12, 2007 7:00 am
Mensajes: 9186
Ubicación: tras la pantalla (...)

Nota Publicado: Lun Feb 27, 2012 1:16 pm 
Arriba  
doc escribió:
ostras... o sea que esos números del dmesg son los segundos que están pasando... ¡lo que aprende uno, qué interesante...!

Ahora estoy liao para analizar lo que dices de esas paradas o tiempos excesivos que has detectado, a ver si lo miro con calma esta noche, e


son los segundos desde el arranque. juraria que desde que grub le cede el control al sistema. vamos, eso creo. :? nunca me he parado a buscar la confirmacion, pero si, se corresponde con el resto de datos que tengo (aka, el cronometro :P)

y no le des vueltas a eso. tienes 22 segundos de arranque.... es MUY BUEN dato. debian lenny estaba en minuto y medio, optimizandola mucho (MUCHO. lo digo yo. :P )

aun asi, si lo quieres mirar, responde a las preguntas de mi post anterior, que sin saber esos detalles, es dificil. :wink:

Código:
Feb 26 19:51:17 debian kernel: [   22.689406] ppdev: user-space parallel port driver
Feb 26 19:51:25 debian kernel: [   30.522917] usblp0: removed


ajaja, ahi esta la parada que estaba buscando. efectivamente, y segun el init, tienes un arranque de 22 segundos. creeme, se puede optimizar, pero es muy buen dato.

luego quedan las X (en realidad el entorno grafico entero), que viendo eso, me imagino que es donde estara el problema.

eso no se puede ver directamente con los ficheros (o tal vez con el log de las X, pero.... ara mismo estoy en win, no te lo puedo confirmar :oops: ), asi que echale un ojo al bootchart: http://bytecoders.net/content/analizar- ... chart.html que ese muestra algo mas que el log del kernel.

PD: no obstante, esta tarde le echare un ojo al resto de logs, porque es imposible que no vengan los mensajes, tanto de las X como del entorno. tu ya sabes que yo no soy muy fan de los asistentes (y los datos del bootchart, para mi gusto, no son demasiado precisos. )

_________________
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]

 Perfil WWW  
Mostrar mensajes previos:  Ordenar por  
 [ 55 mensajes ]  Ir a página 1, 2, 3, 4  Siguiente
Nuevo tema Responder al tema

Saltar a:  


 Temas relacionados   Autor   Respuestas   Vistas   Último mensaje 
Se puede optimizar TODO Debian a mi arquitectura? (SOLUCIONADO)

en Software

ran8489

7

487

Lun Jun 28, 2010 9:00 am

ran8489 Ver último mensaje

Optimizar la PC

en Sistema

ilulaxi

8

1218

Lun Jul 17, 2006 4:26 am

Snaft_J1 Ver último mensaje

Distro basada en debian para usb

en Instalación de distribuciones

BadGenius

7

1124

Vie Oct 02, 2009 10:38 pm

niky45 Ver último mensaje

Distro Debian problemas configurando las X

en Instalación de distribuciones

Mainque

3

1426

Jue Ago 19, 2004 1:46 pm

Mainque Ver último mensaje

optimizar NVIDIA

en Hardware

vampir

3

861

Mié Jun 11, 2008 3:59 pm

haldrik Ver último mensaje



¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado

No puede abrir nuevos temas en este Foro
No puede responder a temas en este Foro
No puede editar sus mensajes en este Foro
No puede borrar sus mensajes en este Foro
No puede enviar adjuntos en este Foro

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group :: Style based on FI Subice by phpBBservice.nl :: Todos los horarios son UTC + 1 hora [ DST ]
Traducción al español por Huan Manwë
phpBB SEO