No puedo actualizar sistema

Comentarios sobre el buen funcionamiento del sistema y como personalizarlo a tus necesidades.

Moderadores: doc, mcun

Avatar de Usuario
clamide
Forista Medio
Forista Medio
Mensajes: 298
Registrado: Dom Mar 25, 2007 8:00 am

No puedo actualizar sistema

Mensaje por clamide » Vie Oct 14, 2011 6:58 pm

Hola a todos:
Hace unos días que no puedo actualizar mi linux mint katya. Me da el siguiente error:

Código: Seleccionar todo

E: Method  has died unexpectedly!
E: El subproceso  devolvió un código de error (100)
E: El método /usr/lib/apt/methods/ no se inició correctamente
E: No se ha podido bloquear el directorio de descargas
Mi sources list es el siguiente:

Código: Seleccionar todo

deb http://mirror.tuxis.nl/packages/ katya main upstream import universe multiverse
deb http://archive.ubuntu.com/ubuntu/ natty main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ natty-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ natty-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ natty partner
deb http://extras.ubuntu.com/ubuntu natty main
deb http://packages.medibuntu.org/ natty free non-free

# deb http://archive.getdeb.net/ubuntu natty-getdeb apps
# deb http://archive.getdeb.net/ubuntu natty-getdeb games
¿Alguién podría echarme una mano?
Gracias y un saludo.
Avatar de Usuario
Fanton
Forista Distinguido
Forista Distinguido
Mensajes: 1339
Registrado: Jue Ene 08, 2009 8:00 am
Ubicación: Magdalena [Argentina]
Contactar:

Re: No puedo actualizar sistema

Mensaje por Fanton » Vie Oct 14, 2011 7:10 pm

Hola clamide, ya trataste de marcar (#) todos los de natty, y tratar de hacer un (apt-get update), a ver que pasa, pueden estar jodiendo alguno de ellos, cualquier cosa, si funciona puedes ir agregando de a uno. Saludos
Diplomacia, es el arte de saber lo que no se debe decir...
_________________
Hardware: Intel i5-3570k | ASUS P8H77-M |HD [500GB] [1 TB] | Ram 8 GB | GPU: Nvidia GeForce 210/1 GB
S.O. Debian@testing x86_64 Openbox
Linux user #506272
Avatar de Usuario
clamide
Forista Medio
Forista Medio
Mensajes: 298
Registrado: Dom Mar 25, 2007 8:00 am

Re: No puedo actualizar sistema

Mensaje por clamide » Vie Oct 14, 2011 9:21 pm

Fanton escribió:Hola clamide, ya trataste de marcar (#) todos los de natty, y tratar de hacer un (apt-get update), a ver que pasa, pueden estar jodiendo alguno de ellos, cualquier cosa, si funciona puedes ir agregando de a uno. Saludos

Pues, tras hacer lo que me has dicho, la consola me devuelve el siguiente error:

Código: Seleccionar todo

Descargados 15,0 kB en 26min. 29seg. (9 B/s)
W: Error de GPG: http://ppa.launchpad.net natty InRelease: File /var/lib/apt/lists/partial/ppa.launchpad.net_transmissionbt_ppa_ubuntu_dists_natty_InRelease doesn't start with a clearsigned message
W: Error de GPG: http://ppa.launchpad.net natty InRelease: File /var/lib/apt/lists/partial/ppa.launchpad.net_webupd8team_y-ppa-manager_ubuntu_dists_natty_InRelease doesn't start with a clearsigned message
W: Imposible obtener http://ppa.launchpad.net/openshot.developers/ppa/ubuntu/dists/natty/Release.gpg  Mala línea de cabecera

W: Imposible obtener copy:/var/lib/apt/lists/partial/mirror.tuxis.nl_packages_dists_katya_import_binary-i386_Packages  La suma hash difiere

E: Algunos archivos de índice fallaron al descargar. Se han ignorado, o se han utilizado unos antiguos en su lugar

¿Qué he de hacer ahora?
Avatar de Usuario
doc
Forista Ancestral
Forista Ancestral
Mensajes: 3244
Registrado: Mié Ago 11, 2010 10:32 am
Ubicación: Oviedo-es_ES
Contactar:

Re: No puedo actualizar sistema

Mensaje por doc » Vie Oct 14, 2011 10:04 pm

pues espérate a mañana, a lo mejor es un bloqueo pasajero del servidor de Mint. (o busca un servidor alternativo, supongo que desde Synaptic lo podrás hacer)

PS: por lo que dices, no has hecho caso a lo que te comentaba Fanton de 'comentar' (poner delante el símbolo #) las líneas que correspondan a natty, y sigues teniendo activos algunos de sus repositorios...que en principio son del Ubuntu 11.04... y no tengo yo muy claro qué pintan en el LinuxMint que dices que tienes instalado.
Avatar de Usuario
clamide
Forista Medio
Forista Medio
Mensajes: 298
Registrado: Dom Mar 25, 2007 8:00 am

Re: No puedo actualizar sistema

Mensaje por clamide » Vie Oct 14, 2011 10:48 pm

doc escribió:pues espérate a mañana, a lo mejor es un bloqueo pasajero del servidor de Mint. (o busca un servidor alternativo, supongo que desde Synaptic lo podrás hacer)

PS: por lo que dices, no has hecho caso a lo que te comentaba Fanton de 'comentar' (poner delante el símbolo #) las líneas que correspondan a natty, y sigues teniendo activos algunos de sus repositorios...que en principio son del Ubuntu 11.04... y no tengo yo muy claro qué pintan en el LinuxMint que dices que tienes instalado.

Ya he cambiado de servidor varias veces y el resultado ha sido el mismo. No creo que se trate de eso.
Avatar de Usuario
Fanton
Forista Distinguido
Forista Distinguido
Mensajes: 1339
Registrado: Jue Ene 08, 2009 8:00 am
Ubicación: Magdalena [Argentina]
Contactar:

Re: No puedo actualizar sistema

Mensaje por Fanton » Sab Oct 15, 2011 3:35 am

mira googleando un poco creo que encontré la solución sera cuestión de probar

Primer método, por terminal:

Código: Seleccionar todo

    $ sudo -i

    # apt-get clean

    # cd /var/lib/apt

    # mv lists lists.old

    # mkdir -p lists/partial

    # apt-get clean

    # apt-get update
En caso de que el primero no funciones:

Código: Seleccionar todo

 sudo aptitude -o Acquire::http::No-Cache=True -o Acquire::BrokenProxy=true update

    sudo apt-get update
comenta a ver si alguno funciona, por lo que e visto Ubuntu 11.04 esta tirando mucho este error
Diplomacia, es el arte de saber lo que no se debe decir...
_________________
Hardware: Intel i5-3570k | ASUS P8H77-M |HD [500GB] [1 TB] | Ram 8 GB | GPU: Nvidia GeForce 210/1 GB
S.O. Debian@testing x86_64 Openbox
Linux user #506272
Avatar de Usuario
clamide
Forista Medio
Forista Medio
Mensajes: 298
Registrado: Dom Mar 25, 2007 8:00 am

Re: No puedo actualizar sistema

Mensaje por clamide » Sab Oct 15, 2011 1:48 pm

Fanton escribió:mira googleando un poco creo que encontré la solución sera cuestión de probar

Primer método, por terminal:

Código: Seleccionar todo

    $ sudo -i

    # apt-get clean

    # cd /var/lib/apt

    # mv lists lists.old

    # mkdir -p lists/partial

    # apt-get clean

    # apt-get update
En caso de que el primero no funciones:

Código: Seleccionar todo

 sudo aptitude -o Acquire::http::No-Cache=True -o Acquire::BrokenProxy=true update

    sudo apt-get update
comenta a ver si alguno funciona, por lo que e visto Ubuntu 11.04 esta tirando mucho este error

Bueno, pues siguiendo los dos métodos que dices, el resultado final ha sido este:

Código: Seleccionar todo

Error de GPG: http://ppa.launchpad.net natty InRelease: File /var/lib/apt/lists/partial/ppa.launchpad.net_transmissionbt_ppa_ubuntu_dists_natty_InRelease doesn't start with a clearsigned messageError de GPG: http://ppa.launchpad.net natty InRelease: File /var/lib/apt/lists/partial/ppa.launchpad.net_webupd8team_y-ppa-manager_ubuntu_dists_natty_InRelease doesn't start with a clearsigned messageError de GPG: http://ppa.launchpad.net natty InRelease: File /var/lib/apt/lists/partial/ppa.launchpad.net_yorba_ppa_ubuntu_dists_natty_InRelease doesn't start with a clearsigned messageImposible obtener copy:/var/lib/apt/lists/partial/mirror.tuxis.nl_packages_dists_katya_upstream_binary-i386_Packages  La suma hash difiere
Algunos archivos de índice fallaron al descargar. Se han ignorado, o se han utilizado unos antiguos en su lugar
Con lo cual sigo sin poder actualizar en condiciones.
Avatar de Usuario
niky45
Forista Ancestral
Forista Ancestral
Mensajes: 9186
Registrado: Jue Abr 12, 2007 7:00 am
Ubicación: tras la pantalla (...)
Contactar:

Re: No puedo actualizar sistema

Mensaje por niky45 » Sab Oct 15, 2011 2:03 pm

borra todo lo que haya de apt (rm /var/lib/apt/lists/ /var/cache/apt/archives), comenta los PPA, y prueba a hacer un apt-get update.

hay alguna clave publica que esta tocando las narices.

pregunta. tienes todas las claves instaladas?? (busca por keyring)

:)
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]
Avatar de Usuario
clamide
Forista Medio
Forista Medio
Mensajes: 298
Registrado: Dom Mar 25, 2007 8:00 am

Re: No puedo actualizar sistema

Mensaje por clamide » Sab Oct 15, 2011 2:51 pm

niky45 escribió:borra todo lo que haya de apt (rm /var/lib/apt/lists/ /var/cache/apt/archives), comenta los PPA, y prueba a hacer un apt-get update.

hay alguna clave publica que esta tocando las narices.

pregunta. tienes todas las claves instaladas?? (busca por keyring)

:)

A ver, podrías decirme cómo hacer todo eso como si se lo estuvieras explicando a un niño pequeño?
(No quiero meter la pata debido a mi ignorancia)
Gracias y un saludo.
Avatar de Usuario
niky45
Forista Ancestral
Forista Ancestral
Mensajes: 9186
Registrado: Jue Abr 12, 2007 7:00 am
Ubicación: tras la pantalla (...)
Contactar:

Re: No puedo actualizar sistema

Mensaje por niky45 » Sab Oct 15, 2011 3:47 pm

:? esque no hay mucho que explicar. metes lo que te he dicho ( rm /var/lib/apt/lists/* /var/cache/apt/archives/* # copia y pega ) en la consola, eso si, como root o con sudo, y le das a enter. despues, simplemente, sudo apt-get update, y ya.

lo de revisar los paquetes instalados...

Código: Seleccionar todo

apt-cache search keyring
y pasas (por aqui, usando la etiqueta [ code] ) la salida. (o via pastie.org si ves que es muy largo... )

comentar lineas, imagino que ya sabes (pero por si acaso: abre con tu editor favorito, y trabajando como root -o con sudo-, le metes un # delante)

una cosa: pierdele el miedo a meter la pata, que todo en esta vida se puede arreglar... eso si, con paciencia y suficiente buena voluntad. (bueno, y mientras no te quedes sin conexion y te lo podamos explicar :? )

:D
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]
Avatar de Usuario
clamide
Forista Medio
Forista Medio
Mensajes: 298
Registrado: Dom Mar 25, 2007 8:00 am

Re: No puedo actualizar sistema

Mensaje por clamide » Sab Oct 15, 2011 4:06 pm

niky45 escribió::? esque no hay mucho que explicar. metes lo que te he dicho ( rm /var/lib/apt/lists/* /var/cache/apt/archives/* # copia y pega ) en la consola, eso si, como root o con sudo, y le das a enter. despues, simplemente, sudo apt-get update, y ya.

lo de revisar los paquetes instalados...

Código: Seleccionar todo

apt-cache search keyring
y pasas (por aqui, usando la etiqueta [ code] ) la salida. (o via pastie.org si ves que es muy largo... )

comentar lineas, imagino que ya sabes (pero por si acaso: abre con tu editor favorito, y trabajando como root -o con sudo-, le metes un # delante)

una cosa: pierdele el miedo a meter la pata, que todo en esta vida se puede arreglar... eso si, con paciencia y suficiente buena voluntad. (bueno, y mientras no te quedes sin conexion y te lo podamos explicar :? )

:D
Mir lo que me devuelve la consolita:

Código: Seleccionar todo

sudo rm /var/lib/apt/lists/* /var/cache/apt/archives/*
[sudo] password for : 
rm: no se puede borrar «/var/lib/apt/lists/partial»: Es un directorio
rm: no se puede borrar «/var/cache/apt/archives/partial»: Es un directorio

Y en cuanto al keyring:

Código: Seleccionar todo

apt-cache search keyring
add-apt-key - Command line tool to add GPG keys to the APT keyring
ubuntu-extras-keyring - GnuPG keys of the Ubuntu extras archive
medibuntu-keyring - GnuPG key of the Medibuntu repository
linuxmint-keyring - GnuPG key of the Linux Mint repository
gnome-keyring - GNOME keyring services (daemon and tools)
python-keyring - store and access your passwords safely
libpam-gnome-keyring - PAM module to unlock the GNOME keyring upon login
libgnome-keyring1.0-cil - CLI library to access the GNOME Keyring daemon
python-gnomekeyring - Python bindings for the GNOME keyring library
apt-clone - Script to create state bundles
ubuntu-keyring - GnuPG keys of the Ubuntu archive
libgnome-keyring0 - GNOME keyring services library
network-manager-gnome - network management framework (GNOME frontend)
¡Desesperación gorda!
Avatar de Usuario
Yoyo
Administrador
Administrador
Mensajes: 3094
Registrado: Mar Jun 06, 2006 7:00 am
Ubicación: Andalucía/España
Contactar:

Re: No puedo actualizar sistema

Mensaje por Yoyo » Sab Oct 15, 2011 4:18 pm

Mmmmm, desde que salió Katya está dando muchos problemas, yo la tuve en mi época de Linux MinTero y la quité de nuevo por la anterior Julia

Quizás deberías pensar en eso o usar la nueva LMDE, osea, la Linux Mint Edición Debian http://blog.linuxmint.com/?p=1818
Reglamento del Foro

Informáticamente hablando...
Avatar de Usuario
niky45
Forista Ancestral
Forista Ancestral
Mensajes: 9186
Registrado: Jue Abr 12, 2007 7:00 am
Ubicación: tras la pantalla (...)
Contactar:

Re: No puedo actualizar sistema

Mensaje por niky45 » Sab Oct 15, 2011 7:31 pm

vale, por los errores no te preocupes porque es normal, y en este caso, deseable (creo que son cosas necesarias para funcionar). yo ya contaba con que esos directorios no se iban a borrar. de todas formas, si no ha chillado mas, es que ha borrado el resto, que era de lo que se trataba.

ahora haz un apt-get update a ver que nos dice, y intenta actualizar o instalar cosas de nuevo.

luego, para poder trabajar, voy a pedirte que instales aptitude, porque yo a apt-get no lo manejo con soltura, y lo de las keyrings, por ejemplo, esperaba que nos dijese que estaba instalado y que no, pero como ves, no ha sido asi. asi que instala aptitude, y dile esto:

Código: Seleccionar todo

aptitude search keyring
:)
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]
Avatar de Usuario
clamide
Forista Medio
Forista Medio
Mensajes: 298
Registrado: Dom Mar 25, 2007 8:00 am

Re: No puedo actualizar sistema

Mensaje por clamide » Sab Oct 15, 2011 8:57 pm

niky45 escribió:vale, por los errores no te preocupes porque es normal, y en este caso, deseable (creo que son cosas necesarias para funcionar). yo ya contaba con que esos directorios no se iban a borrar. de todas formas, si no ha chillado mas, es que ha borrado el resto, que era de lo que se trataba.

ahora haz un apt-get update a ver que nos dice, y intenta actualizar o instalar cosas de nuevo.

luego, para poder trabajar, voy a pedirte que instales aptitude, porque yo a apt-get no lo manejo con soltura, y lo de las keyrings, por ejemplo, esperaba que nos dijese que estaba instalado y que no, pero como ves, no ha sido asi. asi que instala aptitude, y dile esto:

Código: Seleccionar todo

aptitude search keyring
:)
Pues mira lo que medice con el aptitude (hay qué ver, pordiosssssssssssss1)

Código: Seleccionar todo

apt-get update
E: No se pudo abrir el fichero de bloqueo «/var/lib/apt/lists/lock» - open (13: Permiso denegado)
E: No se pudo bloquear el directorio /var/lib/apt/lists/
E: No se pudo abrir el fichero de bloqueo «/var/lib/dpkg/lock» - open (13: Permiso denegado)
E: No se encontró un archivo de réplica «/var/lib/dpkg/»

Y aquí va lo del keyring:

Código: Seleccionar todo

 aptitude search keyring
i   gnome-keyring                   - GNOME keyring services (daemon and tools) 
i   libgnome-keyring0               - GNOME keyring services library            
i   libgnome-keyring1.0-cil         - CLI library to access the GNOME Keyring da
i   libpam-gnome-keyring            - PAM module to unlock the GNOME keyring upo
v   libpam-keyring                  -                                           
i   linuxmint-keyring               - GnuPG key of the Linux Mint repository    
i   medibuntu-keyring               - GnuPG key of the Medibuntu repository     
i   python-gnomekeyring             - Python bindings for the GNOME keyring libr
i   python-keyring                  - store and access your passwords safely    
i   ubuntu-extras-keyring           - GnuPG keys of the Ubuntu extras archive   
i   ubuntu-keyring                  - GnuPG keys of the Ubuntu archive  
Avatar de Usuario
niky45
Forista Ancestral
Forista Ancestral
Mensajes: 9186
Registrado: Jue Abr 12, 2007 7:00 am
Ubicación: tras la pantalla (...)
Contactar:

Re: No puedo actualizar sistema

Mensaje por niky45 » Sab Oct 15, 2011 9:25 pm

:? euh. estooo... como root. (mea culpa, has dicho que quieres todo al detalle, y yo me suelo olvidar de ese tipo de detalles... :oops: )

en cuanto a las keyring, las tienes todas instaladas... incluyendo las de los PPA?? has comentado ya los PPA?? puedes hacer (ahora si, como root), el aptitude update (ya sabiendo que tiene aptitude me quedo mas tranquila... :D ), a ver que pasa??

:)
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]
Responder
  • Similar Topics
    Respuestas
    Vistas
    Último mensaje