No puedo actualizar sistema

Comentarios sobre el buen funcionamiento del sistema y como personalizarlo a tus necesidades.

Moderadores: doc, mcun

Avatar de Usuario
clamide
Forista Medio
Forista Medio
Mensajes: 298
Registrado: Dom Mar 25, 2007 8:00 am

Re: No puedo actualizar sistema

Mensaje por clamide » Sab Oct 15, 2011 10:02 pm

Como root ¿no es escribir "sudo" antes de la órden?

Editado -- Dom Oct 16, 2011 6:02 am --
niky45 escribió::? euh. estooo... como root. (mea culpa, has dicho que quieres todo al detalle, y yo me suelo olvidar de ese tipo de detalles... :oops: )

en cuanto a las keyring, las tienes todas instaladas... incluyendo las de los PPA?? has comentado ya los PPA?? puedes hacer (ahora si, como root), el aptitude update (ya sabiendo que tiene aptitude me quedo mas tranquila... :D ), a ver que pasa??

:)
¿Asíiii????

Código: Seleccionar todo

sudo apt-get update
[sudo] password for : 
E: No se pudo bloquear /var/lib/apt/lists/lock - open (11: Recurso no disponible temporalmente)
E: No se pudo bloquear el directorio /var/lib/apt/lists/

Y el sources list lo tengo así:

Código: Seleccionar todo

deb http://mirror.tuxis.nl/packages/ katya main upstream import universe multiverse
#deb http://archive.ubuntu.com/ubuntu/ natty main restricted universe multiverse
#deb http://archive.ubuntu.com/ubuntu/ natty-updates main restricted universe multiverse
#deb http://security.ubuntu.com/ubuntu/ natty-security main restricted universe multiverse
#deb http://archive.canonical.com/ubuntu/ natty partner
#deb http://extras.ubuntu.com/ubuntu natty main
#deb http://packages.medibuntu.org/ natty free non-free

# deb http://archive.getdeb.net/ubuntu natty-getdeb apps
# deb http://archive.getdeb.net/ubuntu natty-getdeb games
¿Está bien? :evil:

(Gracias por tu ayuda, de nuevo te lo digo :)
Avatar de Usuario
niky45
Forista Ancestral
Forista Ancestral
Mensajes: 9186
Registrado: Jue Abr 12, 2007 7:00 am
Ubicación: tras la pantalla (...)
Contactar:

Re: No puedo actualizar sistema

Mensaje por niky45 » Sab Oct 15, 2011 10:12 pm

:shock: que leches esta haciendo tu sistema?!?!

ehm... se que se pierden las palabras entre los posts, pero puedes hacer esto a ver que error da??

Código: Seleccionar todo

sudo aptitude update 
a aptitude lo conozco mas a fondo, y probablemente, pueda hacer una mejor diagnosis.

puedes mostrar tambien esto??

Código: Seleccionar todo

ls -la /var/lib/apt/lists
clamide escribió:Gracias por tu ayuda, de nuevo te lo digo
ya sabes que para eso estamos. :wink:
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]
Avatar de Usuario
clamide
Forista Medio
Forista Medio
Mensajes: 298
Registrado: Dom Mar 25, 2007 8:00 am

Re: No puedo actualizar sistema

Mensaje por clamide » Sab Oct 15, 2011 11:25 pm

niky45 escribió::shock: que leches esta haciendo tu sistema?!?!

ehm... se que se pierden las palabras entre los posts, pero puedes hacer esto a ver que error da??

Código: Seleccionar todo

sudo aptitude update 
a aptitude lo conozco mas a fondo, y probablemente, pueda hacer una mejor diagnosis.

puedes mostrar tambien esto??

Código: Seleccionar todo

ls -la /var/lib/apt/lists
clamide escribió:Gracias por tu ayuda, de nuevo te lo digo
ya sabes que para eso estamos. :wink:
A ver, el sudo aptitude update da esto (parece todo correcto):

Código: Seleccionar todo

sudo aptitude update 
[sudo] password for : 
Ign file: binary/ InRelease
Ign file: binary/ Release.gpg                                                   
Ign file: binary/ Release                                                       
Ign file: binary/ Translation-es_ES                                             
Ign file: binary/ Translation-es                                                
Ign file: binary/ Translation-en                                                
Ign http://dl.google.com stable InRelease                                       
Ign http://ppa.launchpad.net natty InRelease                                    
Ign http://ppa.launchpad.net natty InRelease           
Ign http://ppa.launchpad.net natty InRelease           
Ign http://ppa.launchpad.net natty InRelease           
Ign http://ppa.launchpad.net natty InRelease           
Ign http://ppa.launchpad.net natty InRelease                                    
Ign http://ppa.launchpad.net natty Release.gpg                                  
Err http://ppa.launchpad.net natty Release.gpg                                  
  Mala línea de cabecera
Ign http://ppa.launchpad.net natty Release.gpg                                  
Err http://ppa.launchpad.net natty Release.gpg                                  
  Mala línea de cabecera
Obj http://ppa.launchpad.net natty Release.gpg                                  
Obj http://ppa.launchpad.net natty Release.gpg                                  
Obj http://ppa.launchpad.net natty Release             
Obj http://ppa.launchpad.net natty Release             
Ign http://ppa.launchpad.net natty Release             
Ign http://ppa.launchpad.net natty Release             
Ign http://ppa.launchpad.net natty Release             
Ign http://mirror.tuxis.nl katya InRelease                                      
Obj http://mirror.tuxis.nl katya Release.gpg                                    
Obj http://mirror.tuxis.nl katya Release               
Obj http://mirror.tuxis.nl katya/main i386 Packages                         
Obj http://mirror.tuxis.nl katya/upstream i386 Packages
Obj http://mirror.tuxis.nl katya/import i386 Packages                           
Obj http://mirror.tuxis.nl katya/universe i386 Packages                         
Obj http://mirror.tuxis.nl katya/multiverse i386 Packages                       
Ign http://mirror.tuxis.nl katya/import TranslationIndex
Ign http://mirror.tuxis.nl katya/main TranslationIndex 
Obj http://ppa.launchpad.net natty Release                                      
Ign http://ppa.launchpad.net natty/main Sources/DiffIndex                       
Ign http://ppa.launchpad.net natty/main i386 Packages/DiffIndex                 
Ign http://ppa.launchpad.net natty/main TranslationIndex                        
Ign http://ppa.launchpad.net natty/main Sources/DiffIndex                       
Ign http://ppa.launchpad.net natty/main i386 Packages/DiffIndex                 
Ign http://ppa.launchpad.net natty/main TranslationIndex                        
Ign http://ppa.launchpad.net natty/main Sources/DiffIndex                       
Ign http://ppa.launchpad.net natty/main i386 Packages/DiffIndex                 
Ign http://ppa.launchpad.net natty/main TranslationIndex                        
Ign http://ppa.launchpad.net natty/main Sources/DiffIndex                       
Ign http://ppa.launchpad.net natty/main i386 Packages/DiffIndex                 
Ign http://ppa.launchpad.net natty/main TranslationIndex                        
Obj http://ppa.launchpad.net natty/main Sources                                 
Obj http://ppa.launchpad.net natty/main i386 Packages                           
Ign http://ppa.launchpad.net natty/main TranslationIndex                        
Obj http://ppa.launchpad.net natty/main Sources                                 
Obj http://ppa.launchpad.net natty/main i386 Packages                           
Obj http://ppa.launchpad.net natty/main Sources                                 
Obj http://ppa.launchpad.net natty/main i386 Packages                           
Obj http://ppa.launchpad.net natty/main Sources                                 
Obj http://ppa.launchpad.net natty/main i386 Packages                           
Obj http://ppa.launchpad.net natty/main Sources                                 
Obj http://ppa.launchpad.net natty/main i386 Packages                           
Ign http://ppa.launchpad.net natty/main Translation-es_ES                       
Ign http://ppa.launchpad.net natty/main Translation-es                          
Ign http://ppa.launchpad.net natty/main Translation-en 
Ign http://ppa.launchpad.net natty/main Translation-es_ES
Ign http://ppa.launchpad.net natty/main Translation-es 
Ign http://ppa.launchpad.net natty/main Translation-en 
Ign http://ppa.launchpad.net natty/main Translation-es_ES
Ign http://ppa.launchpad.net natty/main Translation-es 
Ign http://ppa.launchpad.net natty/main Translation-en 
Ign http://ppa.launchpad.net natty/main Translation-es_ES
Ign http://ppa.launchpad.net natty/main Translation-es 
Ign http://ppa.launchpad.net natty/main Translation-en 
Ign http://ppa.launchpad.net natty/main Translation-es_ES
Ign http://ppa.launchpad.net natty/main Translation-es 
Ign http://ppa.launchpad.net natty/main Translation-en 
Ign http://mirror.tuxis.nl katya/multiverse TranslationIndex
Ign http://mirror.tuxis.nl katya/universe TranslationIndex
Ign http://mirror.tuxis.nl katya/upstream TranslationIndex
Ign http://mirror.tuxis.nl katya/import Translation-es_ES
Ign http://mirror.tuxis.nl katya/import Translation-es 
Ign http://mirror.tuxis.nl katya/import Translation-en 
Ign http://mirror.tuxis.nl katya/main Translation-es_ES
Ign http://mirror.tuxis.nl katya/main Translation-es   
Ign http://mirror.tuxis.nl katya/main Translation-en   
Ign http://mirror.tuxis.nl katya/multiverse Translation-es_ES
Ign http://mirror.tuxis.nl katya/multiverse Translation-es
Ign http://mirror.tuxis.nl katya/multiverse Translation-en
Ign http://mirror.tuxis.nl katya/universe Translation-es_ES
Ign http://mirror.tuxis.nl katya/universe Translation-es
Ign http://mirror.tuxis.nl katya/universe Translation-en
Ign http://mirror.tuxis.nl katya/upstream Translation-es_ES
Ign http://mirror.tuxis.nl katya/upstream Translation-es
Ign http://mirror.tuxis.nl katya/upstream Translation-en
Des:1 http://dl.google.com stable Release.gpg [198 B]
Des:2 http://dl.google.com stable Release [1347 B]
Des:3 http://dl.google.com stable/main i386 Packages [1199 B]                   
Ign http://dl.google.com stable/main TranslationIndex                           
Ign http://dl.google.com stable/main Translation-es_ES                          
Ign http://dl.google.com stable/main Translation-es
Ign http://dl.google.com stable/main Translation-en
Descargados 2744 B en 30min. 39seg. (1 B/s).
                                
¡Mentira me parece!
Aunque, ahora que lo miro más detenidamente, al comienzo casi, dice :"mala línea de cabecera" ¿Lo ves?

Y el ls -la /var/lib/apt/lists:

Código: Seleccionar todo

ls -la /var/lib/apt/lists
total 368
drwxr-xr-x 3 root root  4096 2011-10-15 23:15 .
drwxr-xr-x 7 root root  4096 2011-10-15 20:52 ..
-rw-r--r-- 1 root root  4015 2011-10-13 00:12 dl.google.com_linux_chrome_deb_dists_stable_main_binary-i386_Packages
-rw-r--r-- 1 root root  1347 2011-10-13 00:12 dl.google.com_linux_chrome_deb_dists_stable_Release
-rw-r--r-- 1 root root   198 2011-10-13 00:12 dl.google.com_linux_chrome_deb_dists_stable_Release.gpg
-rw-r----- 1 root root     0 2011-10-15 16:10 lock
-rw-r--r-- 1 root root 15059 2011-10-06 14:28 mirror.tuxis.nl_packages_dists_katya_import_binary-i386_Packages
-rw-r--r-- 1 root root 28774 2011-10-06 14:28 mirror.tuxis.nl_packages_dists_katya_main_binary-i386_Packages
-rw-r--r-- 1 root root     0 2011-10-06 14:28 mirror.tuxis.nl_packages_dists_katya_multiverse_binary-i386_Packages
-rw-r--r-- 1 root root 16473 2011-10-06 14:28 mirror.tuxis.nl_packages_dists_katya_Release
-rw-r--r-- 1 root root   198 2011-10-06 14:28 mirror.tuxis.nl_packages_dists_katya_Release.gpg
-rw-r--r-- 1 root root     0 2011-10-06 14:28 mirror.tuxis.nl_packages_dists_katya_universe_binary-i386_Packages
-rw-r--r-- 1 root root 71264 2011-10-06 14:28 mirror.tuxis.nl_packages_dists_katya_upstream_binary-i386_Packages
drwxr-xr-x 2 root root  4096 2011-10-15 23:15 partial
-rw-r--r-- 1 root root 22335 2011-10-08 20:23 ppa.launchpad.net_alexx2000_doublecmd_ubuntu_dists_natty_main_binary-i386_Packages
-rw-r--r-- 1 root root  4193 2011-10-08 20:23 ppa.launchpad.net_alexx2000_doublecmd_ubuntu_dists_natty_main_source_Sources
-rw-r--r-- 1 root root  9744 2011-10-08 20:23 ppa.launchpad.net_alexx2000_doublecmd_ubuntu_dists_natty_Release
-rw-r--r-- 1 root root   939 2010-10-19 00:42 ppa.launchpad.net_jd-team_jdownloader_ubuntu_dists_natty_main_source_Sources
-rw-r--r-- 1 root root 39792 2010-10-19 00:42 ppa.launchpad.net_jd-team_jdownloader_ubuntu_dists_natty_Release
-rw-r--r-- 1 root root  1960 2011-09-23 10:37 ppa.launchpad.net_openshot.developers_ppa_ubuntu_dists_natty_main_binary-i386_Packages
-rw-r--r-- 1 root root  9749 2011-09-23 10:37 ppa.launchpad.net_openshot.developers_ppa_ubuntu_dists_natty_Release
-rw-r--r-- 1 root root 12925 2011-10-13 13:23 ppa.launchpad.net_transmissionbt_ppa_ubuntu_dists_natty_main_binary-i386_Packages
-rw-r--r-- 1 root root  2855 2011-10-13 13:23 ppa.launchpad.net_transmissionbt_ppa_ubuntu_dists_natty_main_source_Sources
-rw-r--r-- 1 root root  9736 2011-10-13 13:23 ppa.launchpad.net_transmissionbt_ppa_ubuntu_dists_natty_Release
-rw-r--r-- 1 root root  2586 2011-09-07 14:32 ppa.launchpad.net_webupd8team_y-ppa-manager_ubuntu_dists_natty_main_binary-i386_Packages
-rw-r--r-- 1 root root  2171 2011-09-07 14:32 ppa.launchpad.net_webupd8team_y-ppa-manager_ubuntu_dists_natty_main_source_Sources
-rw-r--r-- 1 root root  9747 2011-09-07 14:32 ppa.launchpad.net_webupd8team_y-ppa-manager_ubuntu_dists_natty_Release
-rw-r--r-- 1 root root  1533 2011-10-14 04:27 ppa.launchpad.net_yorba_ppa_ubuntu_dists_natty_main_binary-i386_Packages
-rw-r--r-- 1 root root  1154 2011-10-14 04:27 ppa.launchpad.net_yorba_ppa_ubuntu_dists_natty_main_source_Sources
-rw-r--r-- 1 root root  9719 2011-10-14 04:27 ppa.launchpad.net_yorba_ppa_ubuntu_dists_natty_Release
-rw-r--r-- 1 root root 22140 2011-05-05 01:18 _usr_share_local-repository_binary_Packages
¿Qué te parece?
Avatar de Usuario
niky45
Forista Ancestral
Forista Ancestral
Mensajes: 9186
Registrado: Jue Abr 12, 2007 7:00 am
Ubicación: tras la pantalla (...)
Contactar:

Re: No puedo actualizar sistema

Mensaje por niky45 » Dom Oct 16, 2011 4:25 pm

er.... tecnicamente, con ese sources, tu sistema no puede hacer lo que esta haciendo. asi que pasanos esto a ver que hay ahi:

Código: Seleccionar todo

ls /etc/apt/sources.list.d/
por cierto, como detalle aparte: evita citar el post entero. ya sabemos que respondes a el. :wink: (esque leer asi es un poco complicado....) si quieres citar una frase, te digo el truco: una vez en el editor completo, si bajas, veras los posts anteriores. si en uno de ellos seleciionas una frase, y en ese mismo post, le das a "citar", se cita solo esa frase. :wink:
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]
Avatar de Usuario
clamide
Forista Medio
Forista Medio
Mensajes: 298
Registrado: Dom Mar 25, 2007 8:00 am

Re: No puedo actualizar sistema

Mensaje por clamide » Dom Oct 16, 2011 6:31 pm

clamide escribió:evita citar el post entero
¡Uff, qué bien! Los post empezaban a parecerme ilegibles (gracias por el truqi-consejo).
Bueno, en cuanto al comando:

Código: Seleccionar todo

$ ls /etc/apt/sources.list.d/
alexx2000-doublecmd-natty.list
alexx2000-doublecmd-natty.list.save
getdeb.list
getdeb.list.save
google-chrome.list
google-chrome.list.save
jd-team-jdownloader-natty.list
jd-team-jdownloader-natty.list.save
local-repository.list
local-repository.list.save
medibuntu.list
openshot_developers-ppa-natty.list
openshot_developers-ppa-natty.list.save
sun-java-community-team-sun-java6-natty.list
sun-java-community-team-sun-java6-natty.list.save
transmissionbt-ppa-natty.list
transmissionbt-ppa-natty.list.save
tualatrix-ppa-natty.list
tualatrix-ppa-natty.list.save
ubuntu-x-swat-x-update-natty.list
ubuntu-x-swat-x-update-natty.list.save
virtualbox.list
virtualbox.list.save
webupd8team-y-ppa-manager-natty.list
webupd8team-y-ppa-manager-natty.list.save
yorba-ppa-natty.list
yorba-ppa-natty.list.save
Bonito ¿no? :wink:
Avatar de Usuario
niky45
Forista Ancestral
Forista Ancestral
Mensajes: 9186
Registrado: Jue Abr 12, 2007 7:00 am
Ubicación: tras la pantalla (...)
Contactar:

Re: No puedo actualizar sistema

Mensaje por niky45 » Dom Oct 16, 2011 7:13 pm

eso explica muuuchas cosas. :D

haz esto (como root):

Código: Seleccionar todo

mv /etc/apt/sources.list.d{,.bak}
luego pruebas otra vez.

y si funciona, habra que ver cual de esos repos (offtopic: quillo, que has hecho?? con lo grandes que son los repos de ubuntu, y vas tu y le metes tooodo eso?? :shock: no me quiero pensar la cantidad de paquetes que tienes. :D , aka, en serio. una cosa es meter un repo puntual (vbox, getdeb,..), pero creo que se te ha ido la mano... :? ), lo que decia, que habra que ver cual esta dando problemas. por ahora, los movemos todo, y santas pascuas.

:D
(completamente offtopic)
clamide escribió:¡Uff, qué bien! Los post empezaban a parecerme ilegibles (gracias por el truqi-consejo).
uf. menos mal que te lo he dicho antes de uno de mis megaposts. si no, me voy de cabeza al hospital por una fractura de dedo de tanto hacer scroll. :D (aka, de nada, hombre!!! y ademas, asi cuesta mucho menos leerte. :wink: )
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]
Avatar de Usuario
clamide
Forista Medio
Forista Medio
Mensajes: 298
Registrado: Dom Mar 25, 2007 8:00 am

Re: No puedo actualizar sistema

Mensaje por clamide » Dom Oct 16, 2011 8:43 pm

¿Te refieres a hacer esto? Pues mira lo que me dice:

Código: Seleccionar todo

sudo aptitude update 
E: No se pudo bloquear /var/lib/apt/lists/lock - open (11: Recurso no disponible temporalmente)
E: No se pudo bloquear el directorio de listas...¿es el administrador?
Creo que no he entendido bien lo que se trata de hacer...
Avatar de Usuario
niky45
Forista Ancestral
Forista Ancestral
Mensajes: 9186
Registrado: Jue Abr 12, 2007 7:00 am
Ubicación: tras la pantalla (...)
Contactar:

Re: No puedo actualizar sistema

Mensaje por niky45 » Dom Oct 16, 2011 9:51 pm

ehhhh..... no. ya se que el aptitude va a fallar... primero hay que quitar esos repos. me cito a mi misma :P
niky45 escribió:haz esto (como root):

Código: Seleccionar todo

mv /etc/apt/sources.list.d{,.bak}
en el resto del post, solo intentaba decirte que no abuses de los repos de terceros,. que luego pasan estas cosas. :wink: (a veces me lio yo sola.... :oops: )
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]
Avatar de Usuario
clamide
Forista Medio
Forista Medio
Mensajes: 298
Registrado: Dom Mar 25, 2007 8:00 am

Re: No puedo actualizar sistema

Mensaje por clamide » Dom Oct 16, 2011 10:52 pm

Pues lo curioso es que ahora el iconito de la barra de tareas me dice que el sistema está actualizado :!: ...y, cuando le he metido el comando a la consola, me ha respondido así, la muy contestona:

Código: Seleccionar todo

 sudo mv /etc/apt/sources.list.d{,.bak}
[sudo] password for alida: 
mv: no se puede efectuar `stat' sobre «/etc/apt/sources.list.d»: No existe el fichero o el directorio
(No entiendo nada :? )

P.S.: Soy mujer, por cierto (me atrevo a decirtelo ahora que sé que eres chica)
Avatar de Usuario
niky45
Forista Ancestral
Forista Ancestral
Mensajes: 9186
Registrado: Jue Abr 12, 2007 7:00 am
Ubicación: tras la pantalla (...)
Contactar:

Re: No puedo actualizar sistema

Mensaje por niky45 » Lun Oct 17, 2011 5:49 pm

er... escribo desde el movil asi que no me pidas milagros. pero lo que tienes que poner (que no se si se me fue la tecla o que ) es esto:

mv /etc/apt/sources.list.d{,.bak}

no lleva mas espacios que el que va detras de mv

digo, desde el movil, me hace cosas raras, y no se lo que he puesto yo, ni lo que has puesto tu, pero juraria que te sobra un espacio.

PD: que bien, una mas. ya no me siento tan solita :wink:

Editado -- hace menos de un minuto --

er... escribo desde el movil asi que no me pidas milagros. pero lo que tienes que poner (que no se si se me fue la tecla o que ) es esto:

mv /etc/apt/sources.list.d{,.bak}

no lleva mas espacios que el que va detras de mv

digo, desde el movil, me hace cosas raras, y no se lo que he puesto yo, ni lo que has puesto tu, pero juraria que te sobra un espacio.

PD: que bien, una mas. ya no me siento tan solita :wink:
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]
Avatar de Usuario
clamide
Forista Medio
Forista Medio
Mensajes: 298
Registrado: Dom Mar 25, 2007 8:00 am

Re: No puedo actualizar sistema

Mensaje por clamide » Lun Oct 17, 2011 9:47 pm

Pues mira lo que me da la consolita de marras:

Código: Seleccionar todo

$ mv /etc/apt/sources.list.d{,.bak} 
mv: no se puede efectuar `stat' sobre «/etc/apt/sources.list.d»: No existe el fichero o el directorio
(Debes de estar ya un poco harta del asunto :evil: , lo comprendo)
Avatar de Usuario
niky45
Forista Ancestral
Forista Ancestral
Mensajes: 9186
Registrado: Jue Abr 12, 2007 7:00 am
Ubicación: tras la pantalla (...)
Contactar:

Re: No puedo actualizar sistema

Mensaje por niky45 » Lun Oct 17, 2011 9:57 pm

culpa del movil. se me ha ido un signo:

Código: Seleccionar todo

mv /etc/apt/sources.list.d/  /etc/apt/sources.list.d.bak
en realidad la idea ponerlo de la otra manera, pero ya que haces copy-paste, copialo todo que asi segunro que se porta bien. :D
clamide escribió: (Debes de estar ya un poco harta del asunto :evil: , lo comprendo)
traaanqui. para una vez que alguien me hace caso, no me puedo quejar. :wink: (en serio, lo desesperante es cuando les digo "haz X", y veo que me ignoran. :cry: )
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]
Avatar de Usuario
clamide
Forista Medio
Forista Medio
Mensajes: 298
Registrado: Dom Mar 25, 2007 8:00 am

Re: No puedo actualizar sistema

Mensaje por clamide » Lun Oct 17, 2011 10:48 pm

Pues no, sigue dándome un mal resultado:

Código: Seleccionar todo

$ mv /etc/apt/sources.list.d/ /etc/apt/sources.list.d.bak
mv: no se puede efectuar `stat' sobre «/etc/apt/sources.list.d/»: No existe el fichero o el directorio
Tus buenas palabras alivian mi incomodidad... :wink:
Ya está mejor ¿no? :ugeek:
Última edición por clamide el Mié Oct 19, 2011 10:15 pm, editado 1 vez en total.
Avatar de Usuario
niky45
Forista Ancestral
Forista Ancestral
Mensajes: 9186
Registrado: Jue Abr 12, 2007 7:00 am
Ubicación: tras la pantalla (...)
Contactar:

Re: No puedo actualizar sistema

Mensaje por niky45 » Mié Oct 19, 2011 9:40 pm

perdon por tardar en venir. digamos que ando muy liada, y casi no tengo tiempo. (lo cierto es que me paso el dia fuera de casa.. y ya ves lo que pasa si intento escribir desde el movil :cry: )

veamos... ademas de pedirte que edites el post y corrijas ese code.... (por legibilidad, porque queda feo, y porque por pedir que no quede :P)

dejame adivinar... (esque no puede ser de otro sito, amos, el directorio ESTA ahi, el ls lo muestra. no tiene logica que cp te diga que no esta). se me ha vuelto a olvidar decirte que va como root, verdad?? :oops:

(traduccion: hazlo como root a ver que pasa :P. y de ahora en adelante, lo que nos quede de post, aviso: todo lo que sea administracion del sistema, trabaja siempre como root. ya ves por que :wink: )

*nota; insisto. trabaja como root si administras el sistema. si solo eres un user que quiere navegar por internet (y yo que se que mas cosas), pero NO administrar el sistema (aka, tocar algo de paqueteria, incluyendo el sistema de paquetes, o cualqueir cosa, digamoslos rapido y mal, de fuera de tu home).

:D
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]
Avatar de Usuario
clamide
Forista Medio
Forista Medio
Mensajes: 298
Registrado: Dom Mar 25, 2007 8:00 am

Re: No puedo actualizar sistema

Mensaje por clamide » Mié Oct 19, 2011 10:27 pm

Nada, tranquila; he decirte que con sudo (supongo que es a eso a lo que te refieres cuando dices que he de trabajar como root) me pasa lo mismito:

Código: Seleccionar todo

$ sudo mv /etc/apt/sources.list.d/  /etc/apt/sources.list.d.bak[sudo] password for : 
mv: no se puede efectuar `stat' sobre «/etc/apt/sources.list.d/»: No existe el fichero o el directorio
:twisted:

Y, tras hacer un update

Código: Seleccionar todo

$ sudo apt-get update
[sudo] password for : 
Leyendo lista de paquetes... Hecho
W: No pude leer /etc/apt/sources.list.d/ - DirectoryExists (2: No existe el fichero o el directorio)
W: No pude leer /etc/apt/sources.list - RealFileExists (2: No existe el fichero o el directorio)
, la cosa sigue igual...
Última edición por clamide el Jue Oct 20, 2011 7:39 pm, editado 1 vez en total.
Responder
  • Similar Topics
    Respuestas
    Vistas
    Último mensaje