Reglamento general de los foros   •   FAQ   •   Buscar en el foro •  Registrarse | Iniciar sesión 



Portada » Foros Linux » General » Software


Nuevo tema Responder al tema
 [ 8 mensajes ] 
Patrocinadores
  •  Deb Linux  •  Su enlace aquí...

Autor
Buscar:
Mensaje

Desconectado
Forista Nuevo
Forista Nuevo

Registrado: Sab Oct 30, 2010 12:14 am
Mensajes: 6

Nota Publicado: Sab Dic 18, 2010 12:01 am 
Arriba  
Hola amigos, les comento que estoy teniendo un gran problema luego de actualizar Archlinux, sucede que tanto compiz , como los complementos de l Rhythmbox me han dejado de funcionar. Por lo que estuve investigando, (sin dar con ninguna solución) el problema parece estar vinculado a Python.

Al ejecutar por ejemplo fusion-icon para dar arranque a compiz me arroja:
Código:
 * Detected Session: gnome
 * Searching for installed applications...
Backend     : ini
Integration : true
Profile     : default
Traceback (most recent call last):
  File "/usr/bin/fusion-icon", line 57, in <module>
    from FusionIcon.interface import choose_interface
  File "/usr/lib/python2.7/site-packages/FusionIcon/interface.py", line 22, in <module>
    from util import env
  File "/usr/lib/python2.7/site-packages/FusionIcon/util.py", line 421, in <module>
    decorators = CompizDecorators(_installed)
  File "/usr/lib/python2.7/site-packages/FusionIcon/util.py", line 228, in __init__
    self.command = context.Plugins['decoration'].Display['command']
KeyError: 'decoration'


y al abrir Rhythmbox e intentar activar un complemento me arroja:
Código:
Traceback (most recent call last):
  File "/home/hermess2/.gnome2/rhythmbox/plugins/alarm-clock/__init__.py", line 24, in <module>
    import gtk, gtk.glade, gconf
ImportError: No module named gconf

(rhythmbox:6554): Rhythmbox-WARNING **: Could not load plugin alarm-clock


(rhythmbox:6554): Rhythmbox-WARNING **: Error, impossible to activate plugin 'Alarm Clock'


Espero que sepan ayudarme! Desde ya muchas gracias!

 Perfil  

Desconectado
Forista Medio
Forista Medio
Avatar de Usuario

Registrado: Lun Sep 06, 2010 4:30 am
Mensajes: 398

Nota Publicado: Sab Dic 18, 2010 12:07 am 
Arriba  
Bienvenido a las Rolling Release...

Desde la actualización de Python3 han aparecido bastantes problemas de ese tipo.
Así que si quieres evitarte problemas, haz un downgrade a Python2.

A veces basta solo con referenciasr a "python2" en vez de "python" en el shebang.

_________________
scrotwm@FreeBSD
pekwm@Sabayon
::vim::zsh::urxvtd|blog::dotfiles::last.fm

 Perfil  

Desconectado
Forista Nuevo
Forista Nuevo

Registrado: Sab Oct 30, 2010 12:14 am
Mensajes: 6

Nota Publicado: Sab Dic 18, 2010 1:13 am 
Arriba  
ramonoid escribió:
Bienvenido a las Rolling Release...

Desde la actualización de Python3 han aparecido bastantes problemas de ese tipo.
Así que si quieres evitarte problemas, haz un downgrade a Python2.

A veces basta solo con referenciasr a "python2" en vez de "python" en el shebang.


Hola amigo, gracias por tu pronta respuesta! podrías indicarme la manera de volver a la versión anterior?

te agradezco desde ya!

 Perfil  

Desconectado
Administrador
Administrador
Avatar de Usuario

Registrado: Lun Abr 19, 2010 12:30 am
Mensajes: 3847
Ubicación: En una de las nalgas del culo del mundo (según la Bersuit Vergarabat)

Nota Publicado: Sab Dic 18, 2010 1:38 am 
Arriba  
si te refieres a la versión de la distribución no hay versión anterior... si te refieres a la versión anterior de los paquetes es como te explica ramonoid ... las distribuciones rolling realse se debe instalar con cuidado para evitar esas cuestiones... una buena practica es hacer un dd de la partición en que tienes el sistema para volcarlo en caso de apuros...

_________________
Los programadores de verdad no documentan. La documentación es para los idiotas que no pueden leer un volcado de memoria.

Trusted Network and Developer | Lee el Reglamento !! |WIKI-EL | Twitter @mr_mcun
Debian + TTY | ArchLinux + awesome | openSUSE + Gnome-Shell | Linux User #508809

 Perfil WWW  

Desconectado
Forista Nuevo
Forista Nuevo

Registrado: Sab Oct 30, 2010 12:14 am
Mensajes: 6

Nota Publicado: Sab Dic 18, 2010 2:12 am 
Arriba  
No claro, entiendo que es una distribución sin versiones.... lo que buscaba era lograr volver al paquete anterior de python pero parece no funcionar!

Lo que hice fue ejecutar: "pacman -Rd python" para eliminarlo y después "pacman -S python2", pero esto no soluciono el problema...

Acaso estoy errado en mi manera de hacer el downgrade?

Disculpen si hago este tipo de preguntas, pero soy nuevo en archlinux, y vengo de fedora y ubuntu, un poco mal acostumbrado tambien...

Desde ya gracias por su ayuda!

 Perfil  

Desconectado
Administrador
Administrador
Avatar de Usuario

Registrado: Lun Abr 19, 2010 12:30 am
Mensajes: 3847
Ubicación: En una de las nalgas del culo del mundo (según la Bersuit Vergarabat)

Nota Publicado: Sab Dic 18, 2010 2:20 am 
Arriba  
La documentación de arch debe ser una de las mejores fijate si esto te sirve

_________________
Los programadores de verdad no documentan. La documentación es para los idiotas que no pueden leer un volcado de memoria.

Trusted Network and Developer | Lee el Reglamento !! |WIKI-EL | Twitter @mr_mcun
Debian + TTY | ArchLinux + awesome | openSUSE + Gnome-Shell | Linux User #508809

 Perfil WWW  

Desconectado
Forista Legendario
Forista Legendario
Avatar de Usuario

Registrado: Vie Abr 27, 2007 7:00 am
Mensajes: 1789

Nota Publicado: Sab Dic 18, 2010 5:09 am 
Arriba  
Aca, en la wiki de arch esta como downgradear paquetes, pero no es una tarea fácil.
Con respecto al fallo de Rhythmbox proba reistalando gconf.

ramonoid escribió:
Desde la actualización de Python3 han aparecido bastantes problemas de ese tipo.
Así que si quieres evitarte problemas, haz un downgrade a Python2.


Solo comentar que la principal razón por la que el uso de Python 3 todavía no era masivo era debido a que muchas de las principales librerías que hoy por hoy se usan en Python 2, como: PyGTK, PIL, PyOpenGL, PyOpenCV, y otras mas, todas ellas dependen de una librería sumamente importante: numpy.
Por suerte numpy en su versión 1.5.1, ya es totalmente compatible con python 3.1 o superior así que es de esperar que poco a poco muchas las aplicaciones y módulos que dependen de numpy, comiencen a migrar hacia el nuevo standard, aunque todavía va a tardar un tiempo en suceder.
Ademas hay que tener en cuenta que no va a haber python 2.8, ya que python 2 esta oficialmente discontinuado.
Así que en conclusión la la gente de Arch a tomado el mejor camino posible, a diferencia de otras distros mas rezagadas.

_________________
Desarrollo en Qt: Codigo::Qt() | Qt Developer Network
Mis proyectos: github | SourceForge.net

 Perfil WWW  

Desconectado
Forista Nuevo
Forista Nuevo

Registrado: Sab Oct 30, 2010 12:14 am
Mensajes: 6

Nota Publicado: Mar Dic 21, 2010 7:20 pm 
Arriba  
Hola! Gracias por sus respuestas! Les comento que aun no lo pude solucionar, pues no tengo los archivos en "/var/cache/pacman/pkg" lo he borrado anteriormente... y no se soluciono lo de Rhythmbox reinstalando gconf....

Hay alguna otra manera? para me me funcione por ejemplo con la versión actual de python?

Editado -- Mar Dic 21, 2010 11:19 am --

Amigos aun no puedo solucionarlo pese a que ya intente hacer el downgradear, por favor necesito de su ayuda!! Puedo darles los logs o la información que sea necesaria, y me sirve cualquier idea o sugerencia que tengan! por otro lado eh notado que este problema o similares es bastante comun y nunca se da con una solución especifica!

pd: descubri que las extensiones de emesene tampoco funcionan, cuando lo abro y termina de cargar los contactos me arroja:

Código:
Exception
You are using emesene 1.6.3 - "Uberlândia" so you're free to complain here:
http://forum.emesene.org/index.php/board,19.0.html
Check already existing tickets for duplicates first, please.
Traceback (most recent call last):

  File "/usr/share/emesene/emesenelib/soap/manager.py", line 139, in process
    return process()

  File "/usr/share/emesene/emesenelib/soap/manager.py", line 76, in process
    response.callback(response, *response.args)

  File "/usr/share/emesene/emesenelib/ProfileManager.py", line 155, in onGetProfile
    photo = response.body.split('</Photo>')[0].split('<Photo>')[1]

IndexError: list index out of range


Suerte!!

 Perfil  
Mostrar mensajes previos:  Ordenar por  
 [ 8 mensajes ] 
Nuevo tema Responder al tema

Saltar a:  


 Temas relacionados   Autor   Respuestas   Vistas   Último mensaje 
systemd actualización y error en Archlinux

en Sistema

jvrcorti

3

1368

Jue Nov 29, 2012 1:28 am

jvrcorti Ver último mensaje

Problemas de actualización con apt-get

en Software

Sevilla

3

1248

Jue Sep 22, 2005 2:53 pm

bastard0s Ver último mensaje

Problemas de actualización

en Sistema

luis5636

2

81

Dom Sep 09, 2012 12:59 am

Fedoriano Ver último mensaje

Problemas con Broadcom 4312 en archlinux (Solucionado)

[ Ir a página: 1, 2 ]

en Hardware

cooper1589

17

292

Vie Dic 21, 2012 10:28 pm

cooper1589 Ver último mensaje

ArchBang, problemas actualizacion.

[ Ir a página: 1, 2 ]

en Software

Zamana

17

294

Lun Sep 09, 2013 7:01 am

Zamana Ver último mensaje



¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado

No puede abrir nuevos temas en este Foro
No puede responder a temas en este Foro
No puede editar sus mensajes en este Foro
No puede borrar sus mensajes en este Foro
No puede enviar adjuntos en este Foro

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group :: Style based on FI Subice by phpBBservice.nl :: Todos los horarios son UTC + 1 hora [ DST ]
Traducción al español por Huan Manwë
phpBB SEO