Problemas con nvidia gforce 7300

Temas sobre el sistema X Window; problemas de configuración, xorg, xfree86, implementación de XGL, efectos, etc. En este foro no se tratara los problemas con las X durante o inmediatamente después de la instalación de las distribuciones.
Responder
Avatar de Usuario
rockcabilla
Forista Nuevo
Forista Nuevo
Mensajes: 17
Registrado: Jue Mar 12, 2009 8:00 am

Problemas con nvidia gforce 7300

Mensaje por rockcabilla » Vie May 14, 2010 1:55 am

Estoy ya lo postie en el foro de archlinux y nadien me ha podido ayudar. Instale arch con gnome, drivers privativos del paquete "nvidia" y pues tengo el problema que no puedo aumentar la resolucion, incluso configure mi xorg nada, cuando arranco sin xorg, la pc se queda en negro, que puedo hacer para solucionar el problema?

Código: Seleccionar todo

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder75)  Fri Mar 12 01:44:55 PST 2010

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder75)  Fri Mar 12 01:42:27 PST 2010

Section "Module"
    Load "glx"
EndSection

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "CRT-1"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 7300 SE/7200 GS"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "AddARGBGLXVisuals" "True"
    Option         "TwinView" "0"
    Option         "metamodes" "nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
        Modes      "1024x600" "1440x900" "1280x1024" "1024x768"
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Enable"
EndSection


Código: Seleccionar todo

root@sala luis]# lsmod | grep nvidia
nvidia               9803096  28
i2c_core               14791  9 tuner_simple,tea5767,tuner,saa7134,v4l2_common,videodev,tveeprom,nvidia,i2c_i801
agpgart                23119  2 nvidia,intel_agp


Código: Seleccionar todo

[root@sala luis]# pacman -Qs nvidia
local/nvidia 195.36.15-2
    NVIDIA drivers for kernel26.
local/nvidia-utils 195.36.15-1
    NVIDIA drivers utilities and libraries.


Código: Seleccionar todo

[root@sala luis]# glxinfo | grep direct
direct rendering: Yes
    GL_EXT_direct_state_access, GL_EXT_draw_range_elements, GL_EXT_fog_coord,


Código: Seleccionar todo

[root@sala luis]# uname -a
Linux sala 2.6.33-ARCH #1 SMP PREEMPT Sun May 2 08:21:02 UTC 2010 i686 Intel(R) Core(TM)2 Duo CPU E4600 @ 2.40GHz GenuineIntel GNU/Linux



Genere un xorg con "hwd -x" y la session inicio con resolucion "1024x600" pero no podia mover ni el raton ni usar el teclado, tuve que eliminar el xorg por el cd de archlinux...

Código: Seleccionar todo

Section "ServerLayout"
   Identifier     "Xorg Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Keyboard0" "CoreKeyboard"
   InputDevice    "PS/2 Mouse" "CorePointer"
# Serial Mouse not detected
# USB Mouse not detected
EndSection

Section "ServerFlags"
   Option "AllowMouseOpenFail"  "true"
   Option "AutoAddDevices" "False"
   
EndSection

Section "Files"
   ModulePath   "/usr/lib/xorg/modules"
   FontPath     "/usr/share/fonts/misc:unscaled"
   FontPath     "/usr/share/fonts/misc"
   FontPath     "/usr/share/fonts/75dpi:unscaled"
   FontPath     "/usr/share/fonts/75dpi"
   FontPath     "/usr/share/fonts/100dpi:unscaled"
   FontPath     "/usr/share/fonts/100dpi"
   FontPath     "/usr/share/fonts/PEX"
# Additional fonts: Locale, Gimp, TTF...
   FontPath     "/usr/share/fonts/cyrillic"
#   FontPath     "/usr/share/lib/X11/fonts/latin2/75dpi"
#   FontPath     "/usr/share/lib/X11/fonts/latin2/100dpi"
# True type and type1 fonts are also handled via xftlib, see /etc/X11/XftConfig!
   FontPath     "/usr/share/fonts/Type1"
   FontPath     "/usr/share/fonts/ttf/western"
   FontPath     "/usr/share/fonts/ttf/decoratives"
   FontPath     "/usr/share/fonts/truetype"
   FontPath     "/usr/share/fonts/truetype/openoffice"
   FontPath     "/usr/share/fonts/truetype/ttf-bitstream-vera"
   FontPath     "/usr/share/fonts/latex-ttf-fonts"
   FontPath     "/usr/share/fonts/defoma/CID"
   FontPath     "/usr/share/fonts/defoma/TrueType"
EndSection

Section "Module"
        Load  "ddc"  # ddc probing of monitor
   Load  "dbe"
   Load  "dri"
   Load  "extmod"
   Load  "glx"
        Load  "bitmap" # bitmap-fonts
   Load  "type1"
   Load  "freetype"
   Load  "record"
   #   Load  "synaptics"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "keyboard"
        Option      "CoreKeyboard"
   Option "XkbRules" "xorg"
   Option "XkbModel" "pc105"
   Option "XkbLayout" "es-cp850"
   Option "XkbVariant" ""
EndSection

Section "InputDevice"
   Identifier  "Serial Mouse"
   Driver      "mouse"
   Option      "Protocol" "Microsoft"
   Option      "Device" "/dev/ttyS0"
   Option      "Emulate3Buttons" "true"
   Option      "Emulate3Timeout" "70"
   Option       "SendCoreEvents"  "true"
EndSection

Section "InputDevice"
   Identifier  "PS/2 Mouse"
   Driver      "mouse"
   Option      "Protocol" "auto"
   Option          "ZAxisMapping"          "4 5"
   Option      "Device" "/dev/psaux"
   Option      "Emulate3Buttons" "true"
   Option      "Emulate3Timeout" "70"
   Option       "SendCoreEvents"  "true"
EndSection

Section "InputDevice"
        Identifier      "USB Mouse"
        Driver          "mouse"
        Option          "Device"                "/dev/input/mice"
   Option      "SendCoreEvents"   "true"
        Option          "Protocol"              "IMPS/2"
        Option          "ZAxisMapping"          "4 5"
        Option          "Buttons"               "5"
EndSection

# Auto-generated by Archie mkxcfg

Section "Monitor"
   Identifier "Monitor0"
      Option "DPMS" "true"
#   HorizSync    28.0 - 78.0 # Warning: This may fry very old Monitors
   HorizSync    28.0 - 96.0 # Warning: This may fry old Monitors
   VertRefresh  50.0 - 75.0 # Very conservative. May flicker.
#   VertRefresh  50.0 - 62.0 # Extreme conservative. Will flicker. TFT default.
   #  Default modes distilled from
   #      "VESA and Industry Standards and Guide for Computer Display Monitor
   #       Timing", version 1.0, revision 0.8, adopted September 17, 1998.
   #  $XFree86: xc/programs/Xserver/hw/xfree86/etc/vesamodes,v 1.4 1999/11/18 16:52:17 tsi Exp $
   # 640x350 @ 85Hz (VESA) hsync: 37.9kHz
   ModeLine "640x350"    31.5  640  672  736  832    350  382  385  445 +hsync -vsync
   # 640x400 @ 85Hz (VESA) hsync: 37.9kHz
   ModeLine "640x400"    31.5  640  672  736  832    400  401  404  445 -hsync +vsync
   # 720x400 @ 85Hz (VESA) hsync: 37.9kHz
   ModeLine "720x400"    35.5  720  756  828  936    400  401  404  446 -hsync +vsync
   # 640x480 @ 60Hz (Industry standard) hsync: 31.5kHz
   ModeLine "640x480"    25.2  640  656  752  800    480  490  492  525 -hsync -vsync
   # 640x480 @ 72Hz (VESA) hsync: 37.9kHz
   ModeLine "640x480"    31.5  640  664  704  832    480  489  491  520 -hsync -vsync
   # 640x480 @ 75Hz (VESA) hsync: 37.5kHz
   ModeLine "640x480"    31.5  640  656  720  840    480  481  484  500 -hsync -vsync
   # 640x480 @ 85Hz (VESA) hsync: 43.3kHz
   ModeLine "640x480"    36.0  640  696  752  832    480  481  484  509 -hsync -vsync
   # 800x600 @ 56Hz (VESA) hsync: 35.2kHz
   ModeLine "800x600"    36.0  800  824  896 1024    600  601  603  625 +hsync +vsync
   # 800x600 @ 60Hz (VESA) hsync: 37.9kHz
   ModeLine "800x600"    40.0  800  840  968 1056    600  601  605  628 +hsync +vsync
   # 800x600 @ 72Hz (VESA) hsync: 48.1kHz
   ModeLine "800x600"    50.0  800  856  976 1040    600  637  643  666 +hsync +vsync
   # 800x600 @ 75Hz (VESA) hsync: 46.9kHz
   ModeLine "800x600"    49.5  800  816  896 1056    600  601  604  625 +hsync +vsync
   # 800x600 @ 85Hz (VESA) hsync: 53.7kHz
   ModeLine "800x600"    56.3  800  832  896 1048    600  601  604  631 +hsync +vsync
   # 1024x768i @ 43Hz (industry standard) hsync: 35.5kHz
   ModeLine "1024x768"   44.9 1024 1032 1208 1264    768  768  776  817 +hsync +vsync Interlace
   # 1024x768 @ 60Hz (VESA) hsync: 48.4kHz
   ModeLine "1024x768"   65.0 1024 1048 1184 1344    768  771  777  806 -hsync -vsync
   # 1024x768 @ 70Hz (VESA) hsync: 56.5kHz
   ModeLine "1024x768"   75.0 1024 1048 1184 1328    768  771  777  806 -hsync -vsync
   # 1024x768 @ 75Hz (VESA) hsync: 60.0kHz
   ModeLine "1024x768"   78.8 1024 1040 1136 1312    768  769  772  800 +hsync +vsync
   # 1024x768 @ 85Hz (VESA) hsync: 68.7kHz
   ModeLine "1024x768"   94.5 1024 1072 1168 1376    768  769  772  808 +hsync +vsync
   # 1152x864 @ 75Hz (VESA) hsync: 67.5kHz
   ModeLine "1152x864"  108.0 1152 1216 1344 1600    864  865  868  900 +hsync +vsync
   # 1280x960 @ 60Hz (VESA) hsync: 60.0kHz
   ModeLine "1280x960"  108.0 1280 1376 1488 1800    960  961  964 1000 +hsync +vsync
   # 1280x960 @ 85Hz (VESA) hsync: 85.9kHz
   ModeLine "1280x960"  148.5 1280 1344 1504 1728    960  961  964 1011 +hsync +vsync
   # 1280x1024 @ 60Hz (VESA) hsync: 64.0kHz
   ModeLine "1280x1024" 108.0 1280 1328 1440 1688   1024 1025 1028 1066 +hsync +vsync
   # 1280x1024 @ 75Hz (VESA) hsync: 80.0kHz
   ModeLine "1280x1024" 135.0 1280 1296 1440 1688   1024 1025 1028 1066 +hsync +vsync
   # 1280x1024 @ 85Hz (VESA) hsync: 91.1kHz
   ModeLine "1280x1024" 157.5 1280 1344 1504 1728   1024 1025 1028 1072 +hsync +vsync
   # 1600x1200 @ 60Hz (VESA) hsync: 75.0kHz
   ModeLine "1600x1200" 162.0 1600 1664 1856 2160   1200 1201 1204 1250 +hsync +vsync
   # 1600x1200 @ 65Hz (VESA) hsync: 81.3kHz
   ModeLine "1600x1200" 175.5 1600 1664 1856 2160   1200 1201 1204 1250 +hsync +vsync
   # 1600x1200 @ 70Hz (VESA) hsync: 87.5kHz
   ModeLine "1600x1200" 189.0 1600 1664 1856 2160   1200 1201 1204 1250 +hsync +vsync
   # 1600x1200 @ 75Hz (VESA) hsync: 93.8kHz
   ModeLine "1600x1200" 202.5 1600 1664 1856 2160   1200 1201 1204 1250 +hsync +vsync
   # 1600x1200 @ 85Hz (VESA) hsync: 106.3kHz
   ModeLine "1600x1200" 229.5 1600 1664 1856 2160   1200 1201 1204 1250 +hsync +vsync
   # 1792x1344 @ 60Hz (VESA) hsync: 83.6kHz
   ModeLine "1792x1344" 204.8 1792 1920 2120 2448   1344 1345 1348 1394 -hsync +vsync
   # 1792x1344 @ 75Hz (VESA) hsync: 106.3kHz
   ModeLine "1792x1344" 261.0 1792 1888 2104 2456   1344 1345 1348 1417 -hsync +vsync
   # 1856x1392 @ 60Hz (VESA) hsync: 86.3kHz
   ModeLine "1856x1392" 218.3 1856 1952 2176 2528   1392 1393 1396 1439 -hsync +vsync
   # 1856x1392 @ 75Hz (VESA) hsync: 112.5kHz
   ModeLine "1856x1392" 288.0 1856 1984 2208 2560   1392 1393 1396 1500 -hsync +vsync
   # 1920x1440 @ 60Hz (VESA) hsync: 90.0kHz
   ModeLine "1920x1440" 234.0 1920 2048 2256 2600   1440 1441 1444 1500 -hsync +vsync
   # 1920x1440 @ 75Hz (VESA) hsync: 112.5kHz
   ModeLine "1920x1440" 297.0 1920 2064 2288 2640   1440 1441 1444 1500 -hsync +vsync
   # Additional modelines
   ModeLine "1800x1440"  230    1800 1896 2088 2392  1440 1441 1444 1490 +HSync +VSync
   ModeLine "1800x1440"  250    1800 1896 2088 2392  1440 1441 1444 1490 +HSync +VSync
   # Extended modelines with GTF timings
   # 640x480 @ 100.00 Hz (GTF) hsync: 50.90 kHz; pclk: 43.16 MHz
   ModeLine "640x480"  43.16  640 680 744 848  480 481 484 509  -HSync +Vsync
   # 768x576 @ 60.00 Hz (GTF) hsync: 35.82 kHz; pclk: 34.96 MHz
   ModeLine "768x576"  34.96  768 792 872 976  576 577 580 597  -HSync +Vsync
   # 768x576 @ 72.00 Hz (GTF) hsync: 43.27 kHz; pclk: 42.93 MHz
   ModeLine "768x576"  42.93  768 800 880 992  576 577 580 601  -HSync +Vsync
   # 768x576 @ 75.00 Hz (GTF) hsync: 45.15 kHz; pclk: 45.51 MHz
   ModeLine "768x576"  45.51  768 808 888 1008  576 577 580 602  -HSync +Vsync
   # 768x576 @ 85.00 Hz (GTF) hsync: 51.42 kHz; pclk: 51.84 MHz
   ModeLine "768x576"  51.84  768 808 888 1008  576 577 580 605  -HSync +Vsync
   # 768x576 @ 100.00 Hz (GTF) hsync: 61.10 kHz; pclk: 62.57 MHz
   ModeLine "768x576"  62.57  768 816 896 1024  576 577 580 611  -HSync +Vsync
   # 800x600 @ 100.00 Hz (GTF) hsync: 63.60 kHz; pclk: 68.18 MHz
   ModeLine "800x600"  68.18  800 848 936 1072  600 601 604 636  -HSync +Vsync
   # 1024x768 @ 100.00 Hz (GTF) hsync: 81.40 kHz; pclk: 113.31 MHz
   ModeLine "1024x768"  113.31  1024 1096 1208 1392  768 769 772 814  -HSync +Vsync
   # 1152x864 @ 60.00 Hz (GTF) hsync: 53.70 kHz; pclk: 81.62 MHz
   ModeLine "1152x864"  81.62  1152 1216 1336 1520  864 865 868 895  -HSync +Vsync
   # 1152x864 @ 85.00 Hz (GTF) hsync: 77.10 kHz; pclk: 119.65 MHz
   ModeLine "1152x864"  119.65  1152 1224 1352 1552  864 865 868 907  -HSync +Vsync
   # 1152x864 @ 100.00 Hz (GTF) hsync: 91.50 kHz; pclk: 143.47 MHz
   ModeLine "1152x864"  143.47  1152 1232 1360 1568  864 865 868 915  -HSync +Vsync
   # 1280x960 @ 72.00 Hz (GTF) hsync: 72.07 kHz; pclk: 124.54 MHz
   ModeLine "1280x960"  124.54  1280 1368 1504 1728  960 961 964 1001  -HSync +Vsync
   # 1280x960 @ 75.00 Hz (GTF) hsync: 75.15 kHz; pclk: 129.86 MHz
   ModeLine "1280x960"  129.86  1280 1368 1504 1728  960 961 964 1002  -HSync +Vsync
   # 1280x960 @ 100.00 Hz (GTF) hsync: 101.70 kHz; pclk: 178.99 MHz
   ModeLine "1280x960"  178.99  1280 1376 1520 1760  960 961 964 1017  -HSync +Vsync
   # 1280x1024 @ 100.00 Hz (GTF) hsync: 108.50 kHz; pclk: 190.96 MHz
   ModeLine "1280x1024"  190.96  1280 1376 1520 1760  1024 1025 1028 1085  -HSync +Vsync
   # 1400x1050 @ 60.00 Hz (GTF) hsync: 65.22 kHz; pclk: 122.61 MHz
   ModeLine "1400x1050"  122.61  1400 1488 1640 1880  1050 1051 1054 1087  -HSync +Vsync
   # 1400x1050 @ 72.00 Hz (GTF) hsync: 78.77 kHz; pclk: 149.34 MHz
   ModeLine "1400x1050"  149.34  1400 1496 1648 1896  1050 1051 1054 1094  -HSync +Vsync
   # 1400x1050 @ 75.00 Hz (GTF) hsync: 82.20 kHz; pclk: 155.85 MHz
   ModeLine "1400x1050"  155.85  1400 1496 1648 1896  1050 1051 1054 1096  -HSync +Vsync
   # 1400x1050 @ 85.00 Hz (GTF) hsync: 93.76 kHz; pclk: 179.26 MHz
   ModeLine "1400x1050"  179.26  1400 1504 1656 1912  1050 1051 1054 1103  -HSync +Vsync
   # 1400x1050 @ 100.00 Hz (GTF) hsync: 111.20 kHz; pclk: 214.39 MHz
   ModeLine "1400x1050"  214.39  1400 1512 1664 1928  1050 1051 1054 1112  -HSync +Vsync
   # 1600x1200 @ 100.00 Hz (GTF) hsync: 127.10 kHz; pclk: 280.64 MHz
   ModeLine "1600x1200"  280.64  1600 1728 1904 2208  1200 1201 1204 1271  -HSync +Vsync
EndSection

# Auto-generated by Archie mkxcfg


Section "Device"
   Identifier  "Card0"
   Driver      "vesa"
   VendorName  "All"
   BoardName   "All"
EndSection


Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   DefaultColorDepth 16
   SubSection "Display"
      Depth     1
      Modes "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     4
      Modes "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     8
      Modes "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     15
      Modes "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     16
      Modes "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     24
      Modes "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     32
      Modes "1024x768" "800x600" "640x480"
   EndSubSection
EndSection

Section "DRI"
   Mode 0666
EndSection


Espero sus respuestas, Saludos!
Avatar de Usuario
hipersayan_x
Forista Legendario
Forista Legendario
Mensajes: 1905
Registrado: Vie Abr 27, 2007 7:00 am
Contactar:

Re: Problemas con nvidia gforce 7300

Mensaje por hipersayan_x » Vie May 14, 2010 3:01 am

Probaste haciendo la configuracion desde el panel de control de nVidia?
Desarrollo en Qt: Qt Developer Network
Mis proyectos: github | SourceForge.net
Avatar de Usuario
rockcabilla
Forista Nuevo
Forista Nuevo
Mensajes: 17
Registrado: Jue Mar 12, 2009 8:00 am

Re: Problemas con nvidia gforce 7300

Mensaje por rockcabilla » Vie May 14, 2010 3:46 am

tambien, solo me sale 640xXX como maximo, y si le doy a avanzado no me aplica la configuracion, lo hiso solo una sola vez con 1024xXXX y quedo larga la pantalla...
Avatar de Usuario
hipersayan_x
Forista Legendario
Forista Legendario
Mensajes: 1905
Registrado: Vie Abr 27, 2007 7:00 am
Contactar:

Re: Problemas con nvidia gforce 7300

Mensaje por hipersayan_x » Vie May 14, 2010 4:29 am

Fijate acá

Código: Seleccionar todo

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "AddARGBGLXVisuals" "True"
    Option         "TwinView" "0"
    Option         "metamodes" "nvidia-auto-select +0+0" #<-- Acá tenes que especificar la resolucion exacta, mirá el link.
    SubSection     "Display"
        Depth       24
        Modes      "1024x600" "1440x900" "1280x1024" "1024x768"
    EndSubSection
EndSection
Desarrollo en Qt: Qt Developer Network
Mis proyectos: github | SourceForge.net
Avatar de Usuario
rockcabilla
Forista Nuevo
Forista Nuevo
Mensajes: 17
Registrado: Jue Mar 12, 2009 8:00 am

Re: Problemas con nvidia gforce 7300

Mensaje por rockcabilla » Vie May 14, 2010 11:45 pm

hipersayan_x escribió:Fijate acá

Código: Seleccionar todo

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "AddARGBGLXVisuals" "True"
    Option         "TwinView" "0"
    Option         "metamodes" "nvidia-auto-select +0+0" #<-- Acá tenes que especificar la resolucion exacta, mirá el link.
    SubSection     "Display"
        Depth       24
        Modes      "1024x600" "1440x900" "1280x1024" "1024x768"
    EndSubSection
EndSection


man sigo con el problema, el xorg quedo asi...

Código: Seleccionar todo

Section "ServerFlags"
      Option   "DontZap" "off"
EndSection

Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
   ModulePath   "/usr/lib/xorg/modules"
   FontPath     "/usr/share/fonts/misc"
   FontPath     "/usr/share/fonts/100dpi:unscaled"
   FontPath     "/usr/share/fonts/75dpi:unscaled"
   FontPath     "/usr/share/fonts/TTF"
   FontPath     "/usr/share/fonts/Type1"
EndSection

Section "Module"
#   Load  "dri"
   Load  "glx"
   Load  "dri2"
   Load  "record"
   Load  "dbe"
   Load  "extmod"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/input/mice"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
        Option       "ModeValidation" "NoEdidModes"
        Option        "UseEdid" "false"
        Modeline     "1024x768_60.00"  64.11  1024 1080 1184 1344  768 769 772 795  -HSync +Vsync
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "SWcursor"              # [<bool>]
        #Option     "HWcursor"              # [<bool>]
        #Option     "NoAccel"               # [<bool>]
        #Option     "ShadowFB"              # [<bool>]
        #Option     "UseFBDev"              # [<bool>]
        #Option     "Rotate"                # [<str>]
        #Option     "VideoKey"              # <i>
        #Option     "FlatPanel"             # [<bool>]
        #Option     "FPDither"              # [<bool>]
        #Option     "CrtcNumber"            # <i>
        #Option     "FPScale"               # [<bool>]
        #Option     "FPTweak"               # <i>
        #Option     "DualHead"              # [<bool>]
   Identifier  "Card0"
   Driver      "nvidia"
   VendorName  "nVidia Corporation"
   BoardName   "G72 [GeForce 7300 SE/7200 GS]"
   BusID       "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "1024x768_60 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection


Editado -- Sab May 15, 2010 7:45 am --

LISTO!!! ya solucion el problema, lo que intente despues fue, desistalar los paquetes "nvidia-173xx-utils" y "nvidia-173xx" "con las X abajo claro" que eran los que esta usando en ese momento, lanse un pacman -Rc nvidia-173xx nvidia-173xx-utils , luego pacman -Sy xorg mesa, y despues pacman -S nvidia, instalo los drivers 195.36.15-2, cuando inicie las x no funciono, asi que genere un xorg con X -configure y luego como quedo en negro cuando inicie las X reinicie la pc, luego inicio con una resolucion de 800x600 "raro por que en el xorg que genere puse 1024x786" cuando inicie el nvidia-settings me daba error y me recomndo hacer un nvidia-xconfig, luego genero un xorg con la linea "metamodes" incluida, perfecto!, de una vez sin pensarlo reinicie la pc y pues calidad! inicio a la perfeccion con resolcion 1024x786!, gracias por la ayuda hipersayan_x. Aqui les dejo mi xorg, saludos!

Código: Seleccionar todo

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder75)  Fri Mar 12 01:42:27 PST 2010

Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    ModulePath      "/usr/lib/xorg/modules"
    FontPath        "/usr/share/fonts/misc"
    FontPath        "/usr/share/fonts/100dpi:unscaled"
    FontPath        "/usr/share/fonts/75dpi:unscaled"
    FontPath        "/usr/share/fonts/TTF"
    FontPath        "/usr/share/fonts/Type1"
EndSection

Section "Module"
    Load           "glx"
    Load           "dri2"
    Load           "record"
    Load           "dbe"
    Load           "extmod"
EndSection

Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Monitor Vendor"
    ModelName      "Monitor Model"
EndSection

Section "Device"

        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "SWcursor"              # [<bool>]
        #Option     "HWcursor"              # [<bool>]
        #Option     "NoAccel"               # [<bool>]
        #Option     "ShadowFB"              # [<bool>]
        #Option     "UseFBDev"              # [<bool>]
        #Option     "Rotate"                # [<str>]
        #Option     "VideoKey"              # <i>
        #Option     "FlatPanel"             # [<bool>]
        #Option     "FPDither"              # [<bool>]
        #Option     "CrtcNumber"            # <i>
        #Option     "FPScale"               # [<bool>]
        #Option     "FPTweak"               # <i>
        #Option     "DualHead"              # [<bool>]
    Identifier     "Card0"
    Driver         "nvidia"
    VendorName     "nVidia Corporation"
    BoardName      "G72 [GeForce 7300 SE/7200 GS]"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Card0"
    Monitor        "Monitor0"
    Option         "metamodes" "1024x768_60 +0+0"
    SubSection     "Display"
        Viewport    0 0
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       4
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       8
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       15
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       16
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       24
    EndSubSection
EndSection
Responder
  • Similar Topics
    Respuestas
    Vistas
    Último mensaje