Luego del inicio de Sesion, Pantalla en Negro

Temas sobre el sistema X Window; problemas de configuración, xorg, xfree86, implementación de XGL, efectos, etc. En este foro no se tratara los problemas con las X durante o inmediatamente después de la instalación de las distribuciones.
Responder
Avatar de Usuario
JD
Forista Nuevo
Forista Nuevo
Mensajes: 28
Registrado: Sab Mar 11, 2006 8:00 am
Ubicación: Venezuela

Luego del inicio de Sesion, Pantalla en Negro

Mensaje por JD » Sab Sep 05, 2009 2:59 am

Saludos, buenas noches.

Tengo una laptop ASUS M51A series, y la tengo una particion con ubuntu 9.04.

El problema radica en que al iniciar el equipo, llegar a la sesion de usuario, indicar mi cuenta luego, el escritorio no carga, o mejor dicho, si carga pero no se ve, se pone la pantalla en negro. Hay algo que no me deja ver el escritorio, y en vista e eso, debo estar reiniciando el equipo varias veces hasta que en una de varias logra entrar.

Pregunto, que debo correr, archivo ver o algun proceso para saber que puede ser y como podria solventarlo, puesto que no puedo trabajar con el sistema operativo asi.
Avatar de Usuario
niky45
Forista Ancestral
Forista Ancestral
Mensajes: 9186
Registrado: Jue Abr 12, 2007 7:00 am
Ubicación: tras la pantalla (...)
Contactar:

Re: Luego del inicio de Sesion, Pantalla en Negro

Mensaje por niky45 » Sab Sep 05, 2009 1:41 pm

osea que de vez en cuando le da por ahi, y funciona... .cosa mas rara, oye. lo logico es que funcione siempre o no funcione nunca. :roll:

a mi me da que pueda ser algo de hardware o del driver. por tanto:

a) si se te ocurre alguna forma de testear que no sea de hardware, hazla. yo que se.... lives, otras distros.... cualquier cosa para descartar la grafica.

b) prueba con otro driver (?? que grafica tienes?? te iba a dar ideas, pero... ), a ver si se soluciona. sobre todo, vesa. *

si es cosa de la grafica, mal vamos. pero si es cosa del driver, y aunque necesites usar l que tienes ahora mismo, creo que podremos solucionarlo.

*info sobre reconfigurar las X para poder elegir driver: http://man-linux.comli.com/?p=24

:D
Última edición por niky45 el Mar Dic 08, 2009 7:04 pm, editado 1 vez en total.
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]
Avatar de Usuario
JD
Forista Nuevo
Forista Nuevo
Mensajes: 28
Registrado: Sab Mar 11, 2006 8:00 am
Ubicación: Venezuela

Mensaje por JD » Sab Sep 05, 2009 5:56 pm

volvi a instalar Ubuntu 9.04
Tengo una laptop ASUS M51A series

Ubuntu toma mi tarjeta de video pero es inestable, lo se, porque cuando ingreso al sistema, el brillo de la pantalla no es del 100%, al rato es que ubuntu me la ajusta (la incrementa). Tambien se observa que de vez en cuando se observa un pantallazo, el brillo baja, es leve, pero se nota.

No tengo compiz, solo instale el Theme Ultimate Edition, el cual tampoco es problema a mi parecer.

En los manuales de la laptop no se me indica nada de la tarjeta de video, yo supongo que es una NVIDIA.

Necesito que ubuntu me tome bien el video o ponerle alguno que sea estable, para no tener que encontrarme otra vez con la pantalla en negro.

La resolucion me la toma de 14, le indique que ra de 15, le indique que me la detectara.
Sistema > Preferencias > Pantalla
boton: Detectar pantalla
Ubuntu me detectaba como maxima resolucion:
1024x768 (4:3)

Despues de pulsar: Detectar pantalla
es que me muestra la de:
1280x800 (16:10)

Realmente me preocupa esto, solo deseo tener una interfaz X window estable.

Seguire buscando sobre que video tiene mi laptop y ver que existe en linux para ello.
Avatar de Usuario
Navi
Forista Medio
Forista Medio
Mensajes: 152
Registrado: Lun Dic 24, 2007 8:00 am
Ubicación: Mexico/Coahuila
Contactar:

Re: Luego del inicio de Sesion, Pantalla en Negro

Mensaje por Navi » Sab Sep 05, 2009 6:11 pm

hola

trata de entar con entorno de texto a ubuntu, en el gestor de arranque, despues teclea startx, te pasa lo mismo?
Avatar de Usuario
JD
Forista Nuevo
Forista Nuevo
Mensajes: 28
Registrado: Sab Mar 11, 2006 8:00 am
Ubicación: Venezuela

Mensaje por JD » Sab Sep 05, 2009 6:58 pm

si, pasa lo mismo.
Avatar de Usuario
Navi
Forista Medio
Forista Medio
Mensajes: 152
Registrado: Lun Dic 24, 2007 8:00 am
Ubicación: Mexico/Coahuila
Contactar:

Mensaje por Navi » Sab Sep 05, 2009 7:22 pm

desactiva todos los efectos deja gnome lo mas austero que puedas, haber si sigue lo mismo?
Avatar de Usuario
JD
Forista Nuevo
Forista Nuevo
Mensajes: 28
Registrado: Sab Mar 11, 2006 8:00 am
Ubicación: Venezuela

Mensaje por JD » Sab Sep 05, 2009 8:14 pm

no tengo efectos, incluso con ubuntu instalado tan basicamente como viene sucede, esto es porque el driver que ubuntu me ha indicado para mi hardware de video no le es tan estable, por como se observa.
Avatar de Usuario
JD
Forista Nuevo
Forista Nuevo
Mensajes: 28
Registrado: Sab Mar 11, 2006 8:00 am
Ubicación: Venezuela

Mensaje por JD » Vie Sep 11, 2009 9:24 pm

Ok, creo que el problema es la resolucion, cuando reinicio Ubuntu me baja la resolucion.

Yo dispongo y ajusto de 1280x800 (16:10)
Pero al reiniciar Ubuntu me carga a 1024x768 (4:3)

En ocasiones en Sistema > Preferencias > Pantalla
No me muestra en la lista la resolucion de 1280x800, debo pulsar el boton: Detectar monitores
para que me lo detecte y aparezca en la lista (los Herz me lo tiene fijo a 60 Hz)

Cuando lo paso de 1024x768 a 1280x800 me baja el brillo, y al poco tiempo o al rato es que me pone el brillo como estaba, algo mas elevado, al mover el mouse.

Porque a Ubuntu 9.04 le cuesta mantener la resolucion de 1280x800 (16:10)?
Avatar de Usuario
Navi
Forista Medio
Forista Medio
Mensajes: 152
Registrado: Lun Dic 24, 2007 8:00 am
Ubicación: Mexico/Coahuila
Contactar:

Re: Luego del inicio de Sesion, Pantalla en Negro

Mensaje por Navi » Sab Sep 12, 2009 2:37 am

no creo que sea ubunto, alomejor es tu hadware, deberias de leer el manual de tu monitor y tableta grafica y asi buscar una alternativa
Solo lo hago por que me divierte!!!
Realiza tus sueños por que es lo mas divertido.
SLACKWARE OK!!!
probando getoo
Avatar de Usuario
yayopoint
Forista Medio
Forista Medio
Mensajes: 150
Registrado: Lun Jul 20, 2009 7:00 am
Ubicación: Viña del Mar Chile

Re: Luego del inicio de Sesion, Pantalla en Negro

Mensaje por yayopoint » Mié Sep 16, 2009 1:39 am

prueba con el driver vesa. Desde un editor abre el archivo xorg.conf:

sudo gedit /etc/X11/xorg.conf

Busca la línea que dice

Código: Seleccionar todo

Section "Device"
        Identifier      "Configured Video Device"
        Driver          "intel"
EndSection
y cambias la línea Driver por Vesa:

Código: Seleccionar todo

Section "Device"
        Identifier      "Configured Video Device"
        Driver          "vesa"
EndSection
Esta solución es infalible pero bajará considerablemente la calidad del video, incluso puede que algunos juegos o videos se vean lentos o sin sincronía entre audio y video. Te servirá, por lo menos, para no tener que reiniciar tanto...

Pruébala y dinos si te fue bien, y ahí tratamos de probar otra solución que aproveche el rendimiento de tu tarjeta gráfica (que no es sano que se desperdicie)

Si no tienes xorg.conf, tendrás que crearlo (hay muchas distros que han eliminado este archivo de configuración confiando en la autodetección). Aquí te dejo un link a un xorg.conf genérico

http://casatux.blogspot.com/2009/07/sup ... erico.html

Espero te sirva.
"Tengo una soledad tan concurrida que puedo organizarla como una procesión"
Mario Benedetti, Rostro de vos

"El silencio no puede seguir siendo mi lenguaje"
Jorge Teillier, La última isla
Responder
  • Similar Topics
    Respuestas
    Vistas
    Último mensaje