Problema con paquete 'adobe-flashplugin'

Dudas y comentarios relacionadas con paquetes o programas específicos (obtención, uso, actualizaciones, versiones, problemas de instalación, etc.)

Moderadores: doc, Deckon

Avatar de Usuario
Matu_07
Forista Nuevo
Forista Nuevo
Mensajes: 42
Registrado: Jue Abr 19, 2007 7:00 am

Problema con paquete 'adobe-flashplugin'

Mensaje por Matu_07 » Mié Jun 17, 2009 8:28 pm

Buenas a todos, les comento mi problema, uso Debian Squeeze (testing), y un dia se me dio por actualizar el flash player plugin desde la pagina de adobe, para lo cual me baje el deb (install_flash_player_10_linux.deb) y procedi a instalarlo con dpkg (dpkg -i install_flash_player_10_linux.deb). Al hacerlo, salieron errores de que no se pudo instalar correctamente, por lo cual procedo a instalarlo desde el comun (install_flash_player_10_linux.tar.gz) y santo remedio, flash plug instalado.
Ahora este es el problema, intento actualizar mi Debian y sale:
kron0@Krypto:~$ sudo apt-get upgrade
[sudo] password for kron0:
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
E: El paquete adobe-flashplugin necesita ser reinstalado, pero no se encuentra un archivo para éste.
kron0@Krypto:~$[/u]
Con aptitude:
kron0@Krypto:~$ sudo aptitude upgrade
W: The "upgrade" command is deprecated; use "safe-upgrade" instead.
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Leyendo la información de estado extendido
Inicializando el estado de los paquetes... Hecho
Escribiendo información de estado extendido... Hecho
Leyendo las descripciones de las tareas... Hecho
Resolviendo las dependencias...
Se instalarán los siguiente paquetes NUEVOS:
libcurl3{a} libssh2-1{a} twolame{a}
Se ELIMINARÁN los siguientes paquetes:
toolame{u}
Se actualizarán los siguientes paquetes:
avidemux avidemux-common libfaac0 libmjpegtools-1.9 mjpegtools
Se configurarán los siguientes paquetes que están ahora parcialmente instalados:
adobe-flashplugin
5 paquetes actualizados, 3 nuevos instalados, 1 para eliminar y 0 sin actualizar.
Necesito descargar 297kB de ficheros. Después de desempaquetar se usarán 463kB.
¿Quiere continuar? [Y/n/?] Y
E: No se pudo localizar un archivo para el paquete adobe-flashplugin. Esto puede significar que necesita arreglar manualmente este paquete.
Escribiendo información de estado extendido... Hecho
E: No se pudo localizar un archivo para el paquete adobe-flashplugin. Esto puede significar que necesita arreglar manualmente este paquete.
E: Error interno: no se pudo generar la lista de paquetes a descargar
kron0@Krypto:~$
Intento borrar el paquete que me provoca los problemas:
kron0@Krypto:~$ sudo aptitude remove adobe-flashplugin
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Leyendo la información de estado extendido
Inicializando el estado de los paquetes... Hecho
Escribiendo información de estado extendido... Hecho
Leyendo las descripciones de las tareas... Hecho
Se ELIMINARÁN los siguientes paquetes:
adobe-flashplugin
0 paquetes actualizados, 0 nuevos instalados, 1 para eliminar y 5 sin actualizar.
Necesito descargar 0B de ficheros. Después de desempaquetar se liberarán 10,2MB.
Escribiendo información de estado extendido... Hecho
dpkg: error al procesar adobe-flashplugin (--remove):
El paquete está en un estado muy malo e inconsistente - debe reinstalarlo
antes de intentar desinstalarlo.
Se encontraron errores al procesar:
adobe-flashplugin
E: Sub-process /usr/bin/dpkg returned an error code (1)
Un paquete no se pudo instalar. Intentado recuperarse:
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Leyendo la información de estado extendido
Inicializando el estado de los paquetes... Hecho
Escribiendo información de estado extendido... Hecho
Leyendo las descripciones de las tareas... Hecho

kron0@Krypto:~$

Debo reinstalarlo, por lo tanto:

kron0@Krypto:~$ sudo aptitude reinstall adobe-flashplugin
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Leyendo la información de estado extendido
Inicializando el estado de los paquetes... Hecho
Leyendo las descripciones de las tareas... Hecho
Los siguientes paquetes están ROTOS:
adobe-flashplugin
0 paquetes actualizados, 0 nuevos instalados, 1 reinstalados, 0 para eliminar y 5 sin actualizar.
Necesito descargar 0B de ficheros. Después de desempaquetar se usarán 0B.
No se satisfacen las dependencias de los siguientes paquetes:
adobe-flashplugin: Depende: libcurl3 pero no es instalable
E: No se pudo localizar un archivo para el paquete adobe-flashplugin. Esto puede significar que necesita arreglar manualmente este paquete.
Las acciones siguientes resolverán estas dependencias

Eliminar los paquetes siguientes:
adobe-flashplugin

La puntuación es 119

¿Acepta esta solución? [Y/n/q/?]Y
Se ELIMINARÁN los siguientes paquetes:
adobe-flashplugin{a}
0 paquetes actualizados, 0 nuevos instalados, 1 para eliminar y 5 sin actualizar.
Necesito descargar 0B de ficheros. Después de desempaquetar se liberarán 10,2MB.
¿Quiere continuar? [Y/n/?] Y
Escribiendo información de estado extendido... Hecho
dpkg: error al procesar adobe-flashplugin (--remove):
El paquete está en un estado muy malo e inconsistente - debe reinstalarlo
antes de intentar desinstalarlo.
Se encontraron errores al procesar:
adobe-flashplugin
E: Sub-process /usr/bin/dpkg returned an error code (1)
Un paquete no se pudo instalar. Intentado recuperarse:
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Leyendo la información de estado extendido
Inicializando el estado de los paquetes... Hecho
Leyendo las descripciones de las tareas... Hecho

kron0@Krypto:~$
No funciona, intento reinstalarlo desde el deb:
kron0@Krypto:~$ sudo dpkg -i install_flash_player_10_linux.deb
Seleccionando el paquete adobe-flashplugin previamente no seleccionado.
(Leyendo la base de datos ... 00%
118156 ficheros y directorios instalados actualmente.)
Preparando para reemplazar adobe-flashplugin 10.0.22.87-1 (usando install_flash_player_10_linux.deb) ...
update-alternatives: error: no alternatives for iceape-flashplugin.
update-alternatives: error: no alternatives for iceape-flashplugin.
dpkg: warning: script de `pre-removal' antiguo returned error exit status 2
dpkg - probando el script del nuevo paquete en su lugar...
update-alternatives: error: no alternatives for iceape-flashplugin.
update-alternatives: error: no alternatives for iceape-flashplugin.
dpkg: error al procesar install_flash_player_10_linux.deb (--install):
el subproceso script pre-removal nuevo devolvió el código de salida de error 2
postinst called with argument `abort-upgrade'
dpkg: error al reorganizar:
el subproceso installed post-installation script devolvió el código de salida de error 1
Se encontraron errores al procesar:
install_flash_player_10_linux.deb
kron0@Krypto:~$
Nada...como veran parece un bucle infinito, y no puedo solucionar el problema del paquete, por lo tanto no puedo actualizar los demas :(


Alguna solucion?


Mil gracias !!
Avatar de Usuario
niky45
Forista Ancestral
Forista Ancestral
Mensajes: 9186
Registrado: Jue Abr 12, 2007 7:00 am
Ubicación: tras la pantalla (...)
Contactar:

Re: Problema con paquete 'adobe-flashplugin'

Mensaje por niky45 » Mié Jun 17, 2009 10:46 pm

Código: Seleccionar todo

aptitude install -f 
(dile que si a casi todo, salvo que haga alguna tonteria, tipo intentar desinstalarlte medio sistema)

Código: Seleccionar todo

nano /etc/apt/sources.list

##te tiene que quedar algo asi:
deb http://ftp.fr.debian.org/debian/ lenny [b]main contrib non-free[/b]

aptitude update

aptitude install flashplugin-nonfree  
o si necesitas la ultima version:

-bajate el SOURCE de la pagina oficial (por cierto... de donde leches has sacado un deb?? yo nunca lo he visto), descomprimes (cd /DIR ; tar xjvf o bien tar xzvf, esque nunca me acuerdo de cual es cual), y copias el archivo (libflashplayer.so), a /home/USER/.mozilla/plugins

luego reinicia el navegador y listos. :wink:
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]
Avatar de Usuario
Matu_07
Forista Nuevo
Forista Nuevo
Mensajes: 42
Registrado: Jue Abr 19, 2007 7:00 am

Re: Problema con paquete 'adobe-flashplugin'

Mensaje por Matu_07 » Jue Jun 18, 2009 12:14 am

niky45, primero mil gracias por acudir a mi pedido de ayuda. He hecho tal cual has dicho:
kron0@Krypto:~$ sudo aptitude install -f
[sudo] password for kron0:
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Leyendo la información de estado extendido
Inicializando el estado de los paquetes... Hecho
Escribiendo información de estado extendido... Hecho
Leyendo las descripciones de las tareas... Hecho
Se instalarán los siguiente paquetes NUEVOS:
libcurl3 libssh2-1 twolame
Se ELIMINARÁN los siguientes paquetes:
linux-image-2.6-686{p} linux-image-2.6.26-1-686{p}
Se configurarán los siguientes paquetes que están ahora parcialmente instalados:
adobe-flashplugin
0 paquetes actualizados, 3 nuevos instalados, 2 para eliminar y 5 sin actualizar.
Necesito descargar 297kB de ficheros. Después de desempaquetar se liberarán 58,9MB.
¿Quiere continuar? [Y/n/?] Y
E: No se pudo localizar un archivo para el paquete adobe-flashplugin. Esto puede significar que necesita arreglar manualmente este paquete.
Escribiendo información de estado extendido... Hecho
E: No se pudo localizar un archivo para el paquete adobe-flashplugin. Esto puede significar que necesita arreglar manualmente este paquete.
E: Error interno: no se pudo generar la lista de paquetes a descargar
kron0@Krypto:~$
Como ves, sigue sin poder configurarlo. Sin embargo, agrego los repositorios que me indicas al sources.list, actualizo y intento reinstalar:
Krypto:/home/kron0# sudo aptitude install flashplugin-nonfree
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Leyendo la información de estado extendido
Inicializando el estado de los paquetes... Hecho
Escribiendo información de estado extendido... Hecho
Leyendo las descripciones de las tareas... Hecho
Los siguientes paquetes están ROTOS:
adobe-flashplugin
Se instalarán los siguiente paquetes NUEVOS:
flashplugin-nonfree
0 paquetes actualizados, 1 nuevos instalados, 0 para eliminar y 5 sin actualizar.
Necesito descargar 0B de ficheros. Después de desempaquetar se usarán 131kB.
No se satisfacen las dependencias de los siguientes paquetes:
adobe-flashplugin: Depende: libcurl3 pero no es instalable
E: No se pudo localizar un archivo para el paquete adobe-flashplugin. Esto puede significar que necesita arreglar manualmente este paquete.
Las acciones siguientes resolverán estas dependencias

Eliminar los paquetes siguientes:
adobe-flashplugin

La puntuación es 119

¿Acepta esta solución? [Y/n/q/?]Y
Se instalarán los siguiente paquetes NUEVOS:
flashplugin-nonfree
Se ELIMINARÁN los siguientes paquetes:
adobe-flashplugin{a}
0 paquetes actualizados, 1 nuevos instalados, 1 para eliminar y 5 sin actualizar.
Necesito descargar 0B/16,7kB de ficheros. Después de desempaquetar se liberarán 10,1MB.
¿Quiere continuar? [Y/n/?] Y
Escribiendo información de estado extendido... Hecho
dpkg: error al procesar adobe-flashplugin (--remove):
El paquete está en un estado muy malo e inconsistente - debe reinstalarlo
antes de intentar desinstalarlo.
Se encontraron errores al procesar:
adobe-flashplugin
E: Sub-process /usr/bin/dpkg returned an error code (1)
Un paquete no se pudo instalar. Intentado recuperarse:
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Leyendo la información de estado extendido
Inicializando el estado de los paquetes... Hecho
Leyendo las descripciones de las tareas... Hecho

Krypto:/home/kron0#
Con otra solución que me ofrece, obtengo el mismo resultado:

Instalar los paquetes siguientes:
libcurl3 [7.18.2-8.1 (testing, now)]
libssh2-1 [1.1-1 (testing, now)]

La puntuación es 32

¿Acepta esta solución? [Y/n/q/?]Y
Se instalarán los siguiente paquetes NUEVOS:
flashplugin-nonfree libcurl3{a} libssh2-1{a}
Se configurarán los siguientes paquetes que están ahora parcialmente instalados:
adobe-flashplugin
0 paquetes actualizados, 3 nuevos instalados, 0 para eliminar y 5 sin actualizar.
Necesito descargar 297kB de ficheros. Después de desempaquetar se usarán 791kB.
¿Quiere continuar? [Y/n/?] Y
E: No se pudo localizar un archivo para el paquete adobe-flashplugin. Esto puede significar que necesita arreglar manualmente este paquete.
Escribiendo información de estado extendido... Hecho
E: No se pudo localizar un archivo para el paquete adobe-flashplugin. Esto puede significar que necesita arreglar manualmente este paquete.
E: Error interno: no se pudo generar la lista de paquetes a descargar
Krypto:/home/kron0#
Como veras, no me deja borrar adobe-flashplugin ni instalar flashplugin-nonfree (lo cual no es un problema, yua lo tengo instalado por el tar.gz, pero si sigo con este error del adobe-flashplugin, no me deja actualizar el sistema)

Muchas gracias de nuevo!!

Saludos.
Avatar de Usuario
hmg79
Forista Legendario
Forista Legendario
Mensajes: 2211
Registrado: Lun Mar 31, 2008 8:00 am

Mensaje por hmg79 » Jue Jun 18, 2009 2:01 am

proba con synaptic, Filtros > roto y desinstalalo

El deb que hay en la pagina es para ubuntu.-
Avatar de Usuario
neurus
Forista Legendario
Forista Legendario
Mensajes: 1807
Registrado: Dom Oct 10, 2004 7:00 am

Mensaje por neurus » Jue Jun 18, 2009 2:07 am

La solución a lo bestia que le propuse a otro usuario:

sudo for i in `locate adobe-flashplugin`; do rm -rf $i; done
sudo apt-get remove adobe-flashplugin
sudo apt-get clean
sudo apt-get install adobe-flashplugin

Saludos.
Avatar de Usuario
leolin
Forista Medio
Forista Medio
Mensajes: 329
Registrado: Mié Abr 11, 2007 7:00 am
Ubicación: /home/LP/BsAs/Arg

Re: Problema con paquete 'adobe-flashplugin'

Mensaje por leolin » Jue Jun 18, 2009 2:36 am

Yo te diria que bajes de la pagina el source...

http://get.adobe.com/flashplayer/

y, descomprimas dentro de: /usr/lib/mozilla/plugins

Saludos...
### Tü×îtø ###

## Linux user: #456270 ##
Avatar de Usuario
Matu_07
Forista Nuevo
Forista Nuevo
Mensajes: 42
Registrado: Jue Abr 19, 2007 7:00 am

Re: Problema con paquete 'adobe-flashplugin'

Mensaje por Matu_07 » Jue Jun 18, 2009 3:05 am

Gracias a todos por las respuestas ofrecidas, de veras, son de gran ayuda :D.

neurus, probe lo que me dijiste:

sudo for i in `locate adobe-flashplugin`; do rm -rf $i; done me encontre dos carpetas las cuales suprimio:
/usr/lib/adobe-flashplugin
/usr/share/doc/adobe-flashplugin
Doy a sudo apt-get remove adobe-flashplugin y lo mismo de siempre:
Krypto:/home/kron0# apt-get remove adobe-flashplugin
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
E: El paquete adobe-flashplugin necesita ser reinstalado, pero no se encuentra un archivo para éste.
Con aptitude igual:
Krypto:/home/kron0# aptitude remove adobe-flashplugin
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Leyendo la información de estado extendido
Inicializando el estado de los paquetes... Hecho
Escribiendo información de estado extendido... Hecho
Leyendo las descripciones de las tareas... Hecho
Se ELIMINARÁN los siguientes paquetes:
adobe-flashplugin
0 paquetes actualizados, 0 nuevos instalados, 1 para eliminar y 5 sin actualizar.
Necesito descargar 0B de ficheros. Después de desempaquetar se liberarán 10,2MB.
Escribiendo información de estado extendido... Hecho
dpkg: error al procesar adobe-flashplugin (--remove):
El paquete está en un estado muy malo e inconsistente - debe reinstalarlo
antes de intentar desinstalarlo.
Se encontraron errores al procesar:
adobe-flashplugin
E: Sub-process /usr/bin/dpkg returned an error code (1)
Un paquete no se pudo instalar. Intentado recuperarse:
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Leyendo la información de estado extendido
Inicializando el estado de los paquetes... Hecho
Leyendo las descripciones de las tareas... Hecho

Krypto:/home/kron0#


Ni instalarlo me deja:
Krypto:/home/kron0# sudo apt-get install adobe-flashplugin
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
E: El paquete adobe-flashplugin necesita ser reinstalado, pero no se encuentra un archivo para éste.
Ni tampoco, con aptitude:
Krypto:/home/kron0# aptitude install adobe-flashplugin
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Leyendo la información de estado extendido
Inicializando el estado de los paquetes... Hecho
Leyendo las descripciones de las tareas... Hecho
Se instalarán los siguiente paquetes NUEVOS:
libcurl3{a} libssh2-1{a}
Se configurarán los siguientes paquetes que están ahora parcialmente instalados:
adobe-flashplugin
0 paquetes actualizados, 2 nuevos instalados, 0 para eliminar y 5 sin actualizar.
Necesito descargar 297kB de ficheros. Después de desempaquetar se usarán 659kB.
¿Quiere continuar? [Y/n/?] Y
E: No se pudo localizar un archivo para el paquete adobe-flashplugin. Esto puede significar que necesita arreglar manualmente este paquete.
Escribiendo información de estado extendido... Hecho
E: No se pudo localizar un archivo para el paquete adobe-flashplugin. Esto puede significar que necesita arreglar manualmente este paquete.
E: Error interno: no se pudo generar la lista de paquetes a descargar
Krypto:/home/kron0#

Parece una maldicion ya :(


Millones de gracias !!

Saludos.
Avatar de Usuario
enriquehh
Forista Distinguido
Forista Distinguido
Mensajes: 1337
Registrado: Sab Dic 08, 2007 8:00 am

Re: Problema con paquete 'adobe-flashplugin'

Mensaje por enriquehh » Jue Jun 18, 2009 3:32 am

Hola como estas, ese problema ya lo tube alguna vez, con otro paquete, no me dejaba ni borrar ni instalar el paquete, la solucion que me resulto fue la siguiente:

Abre terminal:

cd /var/lib/dpkg/info

ls | grep flash

seguramente encontraras archivos con extension .postinst y otros mas, cuando encuentres dichos archivos, logeate como root
y borralos uno por uno con el comando

rm -f nombredelosarchivosencontrados

echo esto, procede a borrarlos desde apt, aptitude o synaptic, el que mas gustes.

Te recomiendo que uses el archivo .tar.gz de flash que esta en la pagina de adobe.

saludos.
Avatar de Usuario
enriquehh
Forista Distinguido
Forista Distinguido
Mensajes: 1337
Registrado: Sab Dic 08, 2007 8:00 am

Re: Problema con paquete 'adobe-flashplugin'

Mensaje por enriquehh » Jue Jun 18, 2009 3:35 am

Para no causar confusion, cuando digo

echo esto, procede a borrarlos desde apt, aptitude o synaptic, el que mas gustes.

me refiero a borrar el paquete problematico en este caso el paquete flash plugin.

saludos
Avatar de Usuario
Matu_07
Forista Nuevo
Forista Nuevo
Mensajes: 42
Registrado: Jue Abr 19, 2007 7:00 am

Re: Problema con paquete 'adobe-flashplugin'

Mensaje por Matu_07 » Jue Jun 18, 2009 3:50 am

Gracias hermano, esto es lo que a pasado:
kron0@Krypto:~$ cd /var/lib/dpkg/info
kron0@Krypto:/var/lib/dpkg/info$ ls | grep flash
adobe-flashplugin.list
adobe-flashplugin.md5sums
adobe-flashplugin.postinst
adobe-flashplugin.prerm
Borro cada uno con rm -f nombredelosarchivosencontrados, no quedando ninguno de los archivos mencionados.

Hago un aptitude update por las dudas y procedo a borrar el maldito paquete:
Krypto:/var/lib/dpkg/info# aptitude update
Escribiendo información de estado extendido... Hecho
Obj http://www.debian-multimedia.org testing Release.gpg
Obj http://www.debian-multimedia.org testing/main Translation-es
Obj http://ftp.fr.debian.org ../project/experimental Release.gpg
Obj http://www.debian-multimedia.org testing Release
Obj http://www.debian-multimedia.org testing/main Packages/DiffIndex
Ign http://ftp.fr.debian.org ../project/experimental/main Translation-es
Ign http://ftp.fr.debian.org ../project/experimental/contrib Translation-es
Ign http://ftp.fr.debian.org ../project/experimental/non-free Translation-es
Obj http://ftp.fr.debian.org testing Release.gpg
Obj http://ftp.fr.debian.org testing/main Translation-es
Ign http://ftp.fr.debian.org testing/contrib Translation-es
Ign http://ftp.fr.debian.org testing/non-free Translation-es
Obj http://ftp.fr.debian.org ../project/experimental Release
Obj http://ftp.fr.debian.org testing Release
Obj http://ftp.fr.debian.org ../project/experimental/main Packages/DiffIndex
Obj http://ftp.fr.debian.org ../project/experimental/contrib Packages/DiffIndex
Obj http://ftp.fr.debian.org ../project/experimental/non-free Packages/DiffIndex
Obj http://ftp.fr.debian.org testing/main Packages/DiffIndex
Obj http://ftp.fr.debian.org testing/contrib Packages/DiffIndex
Obj http://ftp.fr.debian.org testing/non-free Packages/DiffIndex
Obj http://ftp.fr.debian.org testing/main Sources/DiffIndex
Obj http://ftp.fr.debian.org testing/contrib Sources/DiffIndex
Obj http://ftp.fr.debian.org testing/non-free Sources/DiffIndex
Leyendo lista de paquetes... Hecho

Krypto:/var/lib/dpkg/info# aptitude remove adobe-flashplugin
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Leyendo la información de estado extendido
Inicializando el estado de los paquetes... Hecho
Leyendo las descripciones de las tareas... Hecho
Se ELIMINARÁN los siguientes paquetes:
adobe-flashplugin
0 paquetes actualizados, 0 nuevos instalados, 1 para eliminar y 5 sin actualizar.
Necesito descargar 0B de ficheros. Después de desempaquetar se liberarán 10,2MB.
Escribiendo información de estado extendido... Hecho
dpkg: error al procesar adobe-flashplugin (--remove):
El paquete está en un estado muy malo e inconsistente - debe reinstalarlo
antes de intentar desinstalarlo.
Se encontraron errores al procesar:
adobe-flashplugin
E: Sub-process /usr/bin/dpkg returned an error code (1)
Un paquete no se pudo instalar. Intentado recuperarse:
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Leyendo la información de estado extendido
Inicializando el estado de los paquetes... Hecho
Leyendo las descripciones de las tareas... Hecho
Ni con apt-get, Ni con aptitude, ni con synaptic, tampoco reinstalarlos me deja :(

Estare malditoo ?? :( No lo elimina!


Gracias de enserio !!

Saludos.
Avatar de Usuario
enriquehh
Forista Distinguido
Forista Distinguido
Mensajes: 1337
Registrado: Sab Dic 08, 2007 8:00 am

Re: Problema con paquete 'adobe-flashplugin'

Mensaje por enriquehh » Jue Jun 18, 2009 3:56 am

Hola comoe stas, bueno intenta lo que te dije nuevamente, y antes de borrar el paquete desde synaptic, apt u otro, deshabilita tus repsositorios,
es decir, no hagas uso de repositorio alguno, luego

apt-get update, y si usas synaptic la opcion recargar.

echo esto recien procede a borrar el paquete problematico.

saludos
Avatar de Usuario
Matu_07
Forista Nuevo
Forista Nuevo
Mensajes: 42
Registrado: Jue Abr 19, 2007 7:00 am

Re: Problema con paquete 'adobe-flashplugin'

Mensaje por Matu_07 » Jue Jun 18, 2009 4:16 am

De donde deshabilito los repositorios ?, he marcado con # todo en el sources.list y nada, sigue con lo mismo :( o hay alguna otra forma mas "formal" de deshabilitarlos?

Por cierto, no puedo acceder a synaptic, aparece:

Imagen

Apreto "cerrar" y se cierra synaptic :(


Gracias !!!! de enseriooo!!!


Saludos.
Avatar de Usuario
enriquehh
Forista Distinguido
Forista Distinguido
Mensajes: 1337
Registrado: Sab Dic 08, 2007 8:00 am

Re: Problema con paquete 'adobe-flashplugin'

Mensaje por enriquehh » Jue Jun 18, 2009 4:21 am

Hola como estas, bueno la forma en que deshabilitaste tus repositorios es la unica, bueno parece que tu caso es diferente al mio, creo que por alli no va el asunto.

intenta con las opciones de eliminacion de paquetes de dpkg.


saludos.
Avatar de Usuario
enriquehh
Forista Distinguido
Forista Distinguido
Mensajes: 1337
Registrado: Sab Dic 08, 2007 8:00 am

Re: Problema con paquete 'adobe-flashplugin'

Mensaje por enriquehh » Jue Jun 18, 2009 4:24 am

Hola no habia visto la imagen, pero eso se soluciona, habilitando nuevamente tus repositorios.

saludos
Avatar de Usuario
neurus
Forista Legendario
Forista Legendario
Mensajes: 1807
Registrado: Dom Oct 10, 2004 7:00 am

Mensaje por neurus » Jue Jun 18, 2009 5:19 am

Bueno, segunda y última opción a lo bestia.
Habilita los repositorios. Los necesitas.

Haz una copia del archivo que controla el estado de los paquetes:

sudo cp /var/lib/dpkg/status ~/status.bak
ahora, lo editas:

sudo gedit /var/lib/dpkg/status

Cada paquete instalado en el sistema tiene su estado indicado en ese archivo. Así que ve con cuidado.

La manera en que se listan allí los paquetes es esta:

nombre del paquete

información varia.
bla bla bla

nombre de otro paquete
Información.
etc.

Por lo tanto, busca la línea

Package: adobe-flashplugin

borra desde ahí hasta la línea anterior a la siguiente vez que aparece

Package:algo.

Guardas, apt-get update.

Y vuelve a intentar.

Saludos.
Responder
  • Similar Topics
    Respuestas
    Vistas
    Último mensaje