[Solucionado] Permisos? de copia en unidades automontadas por el sistema

Dudas y comentarios relacionadas con paquetes o programas específicos (obtención, uso, actualizaciones, versiones, problemas de instalación, etc.)

Moderadores: doc, Deckon

Responder
ElLoco
Forista Nuevo
Forista Nuevo
Mensajes: 25
Registrado: Vie May 01, 2020 5:58 pm

[Solucionado] Permisos? de copia en unidades automontadas por el sistema

Mensaje por ElLoco »

Vamos a ver si alguien me puede echar un cable. Acabo de realizar mi copia de seguridad del usuario con BackinTime (un gestor de rsync) en un disco duro externo formateado en NTFS. Antes de actualizar a Ubuntu 20.04 he realizado mis copias así desde hace meses. La diferencia que he encontrado es que ahora los archivos con caracteres 'raros' por ejemplo 'Microsoft Corp.' (acaba en punto una carpeta de fuentes) y situaciones similares (carpeta Wine) ahora me dan error y no los puede copiar. Me huelo que tiene que ver con como lee el sistema el dispositivo NTFS y como lo maneja
He conseguido que las carpetas creadas en mi disco duro externo NTFS montado manualmente (enchufo el disco al sistema, lo detecta, lo desmonto, y lo monto a mano) no me de ese problema, así que el asunto esta en como las monta el sistema automáticamente. Cuando lo monto manualmente solo indico sudo mount /dev/sdc1 /media/usuario/disco sin opción alguna, no le pongo nada especial.
¿Alguna sugerencia de porque ha podido cambiar el comportamiento del disco externo tras actualizar el sistema?

PD: Lo tengo en NTFS para poder llevar información a equipos con guin2
Última edición por ElLoco el Vie Sep 11, 2020 8:02 pm, editado 1 vez en total.

Avatar de Usuario
neurus
Forista Legendario
Forista Legendario
Mensajes: 1837
Registrado: Dom Oct 10, 2004 7:00 am

Re: Permisos? de copia en unidades automontadas por el sistema

Mensaje por neurus »

Te dejo dos enlaces para que leas sobre ntfs-3g:

http://www.vicente-navarro.com/blog/200 ... con-samba/

https://wiki.archlinux.org/index.php/NT ... a%C3%B1ol)

Cuando lo montas manualmente, el sistema usa el LOCALE por defecto del sistema (y lo que tengas en /etc/fstab).
Si el problema es el montaje automático, caben dos opciones:
1- Debes corregir el archivo de configuración de ntfs-3g.
2- No tienes una entrada en fstab para montar ese disco.

Una tercera alternativa para solucionar el problema está en cambiar el juego de caracteres para el sistema Linux, pero entonces vas a tener problemas en tu Linux sólo para leer una partición ntfs.

ElLoco
Forista Nuevo
Forista Nuevo
Mensajes: 25
Registrado: Vie May 01, 2020 5:58 pm

Re: Permisos? de copia en unidades automontadas por el sistema

Mensaje por ElLoco »

Una pregunta que ignoro: ¿en fstab pueden estar discos que no se montan en el arranque, como un disco externo USB? Es que no lo se.
Tengo más datos que no se si aclaran más el tema o ya son distracción.
Diferencias que he encontrado al montar el disco:

Código: Seleccionar todo

'mount | grep /dev/sdc2'
muestra:

Código: Seleccionar todo

/dev/sdc2 on /media/nani/Disco_Externo type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,def ault_permissions,allow_other,blksize=4096,uhelper= udisks2)
Si lo monto manualmente desde la terminal:

Código: Seleccionar todo

/dev/sdc2 on /media/nani/DE type fuseblk (rw,relatime,user_id=0,group_id=0,allow_other,blks ize=4096)

ElLoco
Forista Nuevo
Forista Nuevo
Mensajes: 25
Registrado: Vie May 01, 2020 5:58 pm

Re: Permisos? de copia en unidades automontadas por el sistema [solucionado]

Mensaje por ElLoco »

Ya encontré la solución. Creo un punto de montaje en /media/(usuario)/Disco y añado en fstab lo siguiente:

/dev/sdc2 /media/nani/Disco_Externo ntfs-3g users,noauto,uid=1000,user,umask=0022 0 0

Entiendo que el valor umask=0022 me da permiso de lectura y escritura como usuario, y ahora si no tengo problemas con las copias de rsync. Podía haber puesto rw como permisos directamente que también funciona.

Responder
  • Temas similares
    Respuestas
    Vistas
    Último mensaje