Python y Puppy Linux 5.1.1

Dudas y comentarios relacionadas con paquetes o programas específicos (obtención, uso, actualizaciones, versiones, problemas de instalación, etc.)

Moderadores: doc, Deckon

Responder
Avatar de Usuario
SGAN
Forista Menor
Forista Menor
Mensajes: 80
Registrado: Jue Mar 19, 2009 8:00 am

Python y Puppy Linux 5.1.1

Mensaje por SGAN »

Buenas, acabo de instalar un Linux en una máquina sin mucha RAM, y he optado por Puppy Linux 5.1.1... pues probe con diversas distros con escritorios LXDE y con 256MB de RAM y un PIV 1700Mhz no acaba de ir como debiera... sobre todo con los vídeos Flash, que todos sabemos que el plugin de Flash para Linux es una castaña en cuanto a optimización.

Lubuntu y WattOS fueron mis primeras opciones, y tras instalar Lubuntu, me desanimé de probar WattOS, pues el rendimiento lo supuse similar.

Puppy Linux 5.1.1 es más o menos compatible con los repositorios de Debian/Ubuntu, concretamente de forma "pseudo-oficial" con los de Ubuntu (que se pueden agregar de forma automatica a base de clicks de raton). El gestor de paquetes de Puppy es lo que no me acaba de convencer, no está mal, y resuelve muchas dependencias, pero creo que no resuelve todo como es debido.

Concretamente con Python estoy ya aburrido de probar... Python 2.6 viene incluido de forma oficial desde los repositorios de Puppy, y se puede instalar otros paquetes relacionados con Python desde los repositorios de Ubuntu si se desea... en principio la instalación y resolucion de dependencias parece existosa, pero tras mucho probar, no he conseguido hacer funcionar ni Tucan Manager, ni Emesene (si no me equivoco, ambos dependientes de Python), instalandolos desde los repositorios de Ubuntu.

Pensé que podía ser un problema de usar los repositorios de Ubuntu, pero lo acabe descartando, pues instalando por ejemplo el aMSN desde dichos repositorios si funciona perfectamente... además me descargué tambien un paquete ".pet" de Tucan y da exactamente el mismo error que instalandolo desde los repositorios de Ubuntu.

También probé a instalar Python (y demás paquetes) con unos paquetes precompilados ".pet" obtenidos de un foro de Puppy (inglés o americano), y sigue sin funcionarme ninguna aplicación Python. Del mismo foro también me baje un precompilado para Tucan... y seguía haciendo lo mismo...

Alguien que use Puppy sabe como puedo instalar Python y demás paquetes (como python-cairo, python-gtk2, python-gobject, etc) en Puppy Linux 5? algún manual?

PD: Eso si, por lo demás la distro me parece muy bien hecha, es increíble lo fluida que va con un aspecto no demasiado tosco, e incluso los vídeos en flash van de forma aceptable (por ejemplo MegaVideo a pantalla completa con Chromium o con Opera... con FireFox la cosa empeora de forma más o menos notable)

EDITO: En caso de que nadie use Puppy sabéis donde puedo mirar TODAS las dependencias y subdependencias (dependencias de las dependencias) necesarias para hacer funciona Python y Python GTK de forma correcta?... puesto que Puppy 5.1.1 usa IceWM, igual tiene algun problema por falta de dependencias relacionadas con GTK, o el apartado gráfico... yo que se xD...

Avatar de Usuario
mcun
Administrador
Administrador
Mensajes: 3888
Registrado: Lun Abr 19, 2010 12:30 am
Ubicación: En una de las nalgas del culo del mundo (según la Bersuit Vergarabat)
Contactar:

Re: Python y Puppy Linux 5.1.1

Mensaje por mcun »

mm es muy extraño que python no venga instalado en puppy pon en la terminal python para asegurarnos de si esta o no python instalado....
Los programadores de verdad no documentan. La documentación es para los idiotas que no pueden leer un volcado de memoria.

Trusted Network and Developer | Lee el Reglamento !! |WIKI-EL | Twitter @mr_mcun
Debian + TTY | ArchLinux + awesome | openSUSE + Gnome-Shell | Linux User #508809

Avatar de Usuario
hipersayan_x
Forista Legendario
Forista Legendario
Mensajes: 1905
Registrado: Vie Abr 27, 2007 7:00 am
Contactar:

Re: Python y Puppy Linux 5.1.1

Mensaje por hipersayan_x »

Cuales son los errores exactos que te tiran tucan y amsn?
Para esa maquina hubiera sido mejor Debian.
Desarrollo en Qt: Qt Developer Network
Mis proyectos: github | SourceForge.net

Responder
  • Temas similares
    Respuestas
    Vistas
    Último mensaje