Instalar build-essential en Debian 10

Dudas y comentarios relacionadas con paquetes o programas específicos (obtención, uso, actualizaciones, versiones, problemas de instalación, etc.)

Moderadores: doc, Deckon

Responder
Avatar de Usuario
pamda_86
Forista Nuevo
Forista Nuevo
Mensajes: 3
Registrado: Jue Oct 14, 2004 7:00 am

Instalar build-essential en Debian 10

Mensaje por pamda_86 »

Buenas colegas!

estoy con un problemilla que me tiene dando vueltas dentro de un bucle, les comento lo siguiente...

deseo instalar el paquete "build-essential" pero me arroja lo siguiente:

Código: Seleccionar todo

apt install build-essential
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
 build-essential : Depende: g++ (>= 4:8.3) pero no va a instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.
-> Luego procedo a descargar :
https://debian.pkgs.org/10/debian-main- ... 4.deb.html

que es lo que me solicita, para instalarlo manualmente...
siguiendo la sugerencia de (software/solucionado-problemas-al-reins ... ml#p281534)

luego sigo con el siguiente error:

Código: Seleccionar todo

#dpkg -i ./g++_8.3.0-1_amd64.deb
Seleccionando el paquete g++ previamente no seleccionado.
(Leyendo la base de datos ... 134595 ficheros o directorios instalados actualmente.)
Preparando para desempaquetar ./g++_8.3.0-1_amd64.deb ...
Desempaquetando g++ (4:8.3.0-1) ...
dpkg: problemas de dependencias impiden la configuración de g++:
 g++ depende de cpp (= 4:8.3.0-1); sin embargo:
  La versión de `cpp' en el sistema es 4:9.2.1-3.1.
 g++ depende de gcc (= 4:8.3.0-1); sin embargo:
  La versión de `gcc' en el sistema es 4:9.2.1-3.1.
 g++ depende de g++-8 (>= 8.3.0-1~); sin embargo:
  El paquete `g++-8' no está instalado.

dpkg: error al procesar el paquete g++ (--install):
 problemas de dependencias - se deja sin configurar
Se encontraron errores al procesar:
 g++
entonces paso a ejecutar: apt install build-essential

pero creo que empeoro el tema; obtengo lo siguiente...

Código: Seleccionar todo

#apt install build-essential
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Tal vez quiera ejecutar «apt --fix-broken install» para corregirlo.
Los siguientes paquetes tienen dependencias incumplidas:
 build-essential : Depende: dpkg-dev (>= 1.17.11) pero no va a instalarse
 g++ : Depende: cpp (= 4:8.3.0-1) pero 4:9.2.1-3.1 va a ser instalado
       Depende: gcc (= 4:8.3.0-1) pero 4:9.2.1-3.1 va a ser instalado
       Depende: g++-8 (>= 8.3.0-1~) pero no va a instalarse
E: Dependencias incumplidas. Intente «apt --fix-broken install» sin paquetes (o especifique una solución).
luego:

Código: Seleccionar todo

#apt --fix-broken install
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Corrigiendo dependencias... Listo
Los siguientes paquetes se ELIMINARÁN:
  g++
0 actualizados, 0 nuevos se instalarán, 1 para eliminar y 1 no actualizados.
1 no instalados del todo o eliminados.
Se liberarán 15,4 kB después de esta operación.
¿Desea continuar? [S/n] s
(Leyendo la base de datos ... 134599 ficheros o directorios instalados actualmente.)
Desinstalando g++ (4:8.3.0-1) ...

luego, sigo:

Código: Seleccionar todo

#apt install build-essential
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
 build-essential : Depende: g++ (>= 4:8.3) pero no va a instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

es aquí donde llego a la conclusión de que estoy dentro de un bucle por alguna inconsistencia que no logro detectarla (se las pongo dificil parece), pero cualquier sugerencia sera bienvenida.

Dejo los siguiente datos del sistema donde me encuentro trabajando.

Código: Seleccionar todo

#neofetch
       _,met$$$$$gg.          root@DebianSys 
    ,g$$$$$$$$$$$$$$$P.       --------------- 
  ,g$$P"     """Y$$.".        OS: Debian GNU/Linux bullseye/sid x86_64 
 ,$$P'              `$$$.     Host: LocalNet 
',$$P       ,ggs.     `$$b:   Kernel: 4.19.0-6-amd64 
`d$$'     ,$P"'   .    $$$    Uptime: 1024 hours, 2 mins 
 $$P      d$'     ,    $$P    Packages: 1657 (dpkg) 
 $$:      $$.   -    ,d$$'    Shell: bash 5.0.11 
 $$;      Y$b._   _,d$P'      Terminal: xfce4-terminal 
 Y$$.    `.`"Y$$$$P"'         Terminal Font: Monospace 12 
 `$$b      "-.__              CPU: Genuine Intel 575 (1) @ 1.995GHz 
  `Y$$                        GPU: Intel Mobile 4 Series Chipset 
   `Y$$.                      Memory: 1994MiB / 2932MiB 
     `$$b.
       `Y$$b.                                         
          `"Y$b._
              `"""

recuerdo que el "OS" en un principio era "Buster", supongo que algo tiene que ver la rama (bullseye/sid).

He querido realizar un downgrade del OS, para volver a stable.. cambiando el "sourcelist", pero sin resultados positivos.

desde ya, les agradezco por vuestro tiempo!

Avatar de Usuario
doc
Forista Ancestral
Forista Ancestral
Mensajes: 3548
Registrado: Mié Ago 11, 2010 10:32 am
Ubicación: Oviedo-es_ES
Contactar:

Re: Instalar build-essential en Debian 10

Mensaje por doc »

Si, supongo que el problema reside en que estás en la rama Sid ('unstable') de Debian, y hay alguna inconsistencia, aún no solucionada por el equipo de desarrolladores de Debian, con ese paquete, y/o sus dependencias.

Al parecer, has hecho una migración completa a Sid. Eso suele ser muy poco recomendable, hombre, normalmente, si queremos usar un paquete de la rama Sid, se instala forzando su instalación expresa, con
sudo aptitude -t sid install nombre_paquete
así que (como yo no se cómo se puede hacer un downgrade total) mi consejo es que lo más sencillo es retomar el Debian Buster 'stable' (o, como mucho, el 'testing') reinstalando de nuevo, porque me temo que debes tener un buen barullo de paquetes de todas las ramas, y un sistema bastante inestable.

Avatar de Usuario
neurus
Forista Legendario
Forista Legendario
Mensajes: 1837
Registrado: Dom Oct 10, 2004 7:00 am

Re: Instalar build-essential en Debian 10

Mensaje por neurus »

Prueba primero usando aptitude (en lugar de apt). Va a ofrecerte varias soluciones. El paquete que estás intentando instalar no es algo esotérico. Con la guía del propio sistema se tiene que poder instalar de forma relativamente simple.

Los downgrades suelen salir mal. Aptitude, en última instancia, puede proponerte desactualizar algunos paquetes como parte de la solución, pero no todo el sistema.

Y si, finalmente, quieres volver a testing, cambia sid por testing en la sources.list y déjalo así. En un par de meses de actualizaciones, tendrás otra vez toda la paquetería en testing.

Avatar de Usuario
Califasuseso
Forista Nuevo
Forista Nuevo
Mensajes: 3
Registrado: Lun Oct 01, 2007 7:00 am

Re: Instalar build-essential en Debian 10

Mensaje por Califasuseso »

Despues de un dpkg -i que no se ha completado porque faltan dependencias, el paso siguiente es:
apt -f install

Es decir, instalar las dependencias pendientes. Esta orden instala las dependencias pendientes y configura el paquete cuyo dpkg quedó interrumpido por fallos en las dependencias.7
El -f es lo mismo que --fix de "reparar las denpendencias.

Avatar de Usuario
pamda_86
Forista Nuevo
Forista Nuevo
Mensajes: 3
Registrado: Jue Oct 14, 2004 7:00 am

Re: Instalar build-essential en Debian 10

Mensaje por pamda_86 »

doc escribió:
Mar Ago 04, 2020 11:10 am
Si, supongo que el problema reside en que estás en la rama Sid...
desde un principio supuse que venia por ahí la mano, de la rama que tenia.. alguna magia rara ha ocurrido con mi source.list; ya que en ningún momento edite la misma luego de haber instalado el sistema desde cero "Buster" siempre he mantenido en "stable"... pero me queda la duda que ha sucedido, ya que soy el único que manipula este ordenador.. Gracias @doc
neurus escribió:
Mar Ago 04, 2020 12:47 pm
Prueba primero usando aptitude (en lugar de apt). ...
Sí, esta fue una opcion que puse en consideración desde un principio, me toco instalar.. pero sin resultados positivos, por ahí estuve viendo que ha algunos si les funcionaba y a otros (mi caso) no :( cosa rara.
Califasuseso escribió:
Mar Ago 04, 2020 3:43 pm
...
Intentando arreglar las dependencias, cada vez parece ser que era más profundo el hoyo XD

todo esto fue a causa que tenia que instalar el programa / paquete "Dia" para hacer algunos diagramas; primero me salto que el mismo no estaba disponible.. que, etc.. entonces fui hasta https://github.com/GNOME/dia y aquí empieza mi odisea, instalando meson, etc..

La solución que encontré a todo este desmadre!! Fue modificar el source.list a la rama "testing" y luego ya saben, update.. upgrade, y voila

Desde ya, muchas gracias a todos vosotros.

Responder
  • Temas similares
    Respuestas
    Vistas
    Último mensaje