Impresion CUPS - Lentitud al start del servicio

Dudas y comentarios relacionadas con paquetes o programas específicos (obtención, uso, actualizaciones, versiones, problemas de instalación, etc.)
Responder
deadrising1980
Forista Nuevo
Forista Nuevo
Mensajes: 1
Registrado: Jue Sep 07, 2017 4:14 pm

Impresion CUPS - Lentitud al start del servicio

Mensaje por deadrising1980 »

Buenas, espero no haber pasado por alto si es que hubo una respuesta anterior.

Les comento el escenario que tengo con mi servidor CUPS, actualmente tengo mas de +5000 impresoras dadas de alta en printers.conf y hace unos dias sumamos la configuracion de Clases Implicitas para poder hacer balanceo de impresion.
Realmente el servicio no tiene problemas cuando esta en ejecucion, las impresiones salen bien y no hay temas de lentitud. El problema radica cuando reinicio el servicio de CUPS, este tarda mas de 1hr en iniciar.
Configure dentro de cupsd.conf el modo debug, y dentro de los logs no veo errores, si me muestra cuando inicia las impresoras, lee los PPD y a su vez la Clase en la que esta configurada. Pense que era un problema en el cache que genera CUPS, borre los archivos .data, pero lo que hace es generarlos nuevamente.

El hardware que tengo para CUPS es una VM con lo siguiente:
8 nucleos
8gb ram
30gb espacio en disco

Entiendo que este escenario no es el mas comun dentro de CUPS, pero queria saber si habia alguna manera de realizar el start de una manera mas rapida o si ustedes sugieren alguna configuracion diferente para esta cantidad de impresoras y clases que se configuraron en el servicio.

Una de las pruebas que hice, fue parsear el archivo printers.conf, y solamente hasta 250 impresoras configuradas aproximadamente, inicia rapido el servicio.

Saludos

Responder
  • Temas similares
    Respuestas
    Vistas
    Último mensaje