Cómo actualizar controladores en Ubuntu ?

Dudas y comentarios relacionadas con paquetes o programas específicos (obtención, uso, actualizaciones, versiones, problemas de instalación, etc.)
Responder
clau1708
Forista Nuevo
Forista Nuevo
Mensajes: 8
Registrado: Mar Ago 17, 2021 12:15 pm

Cómo actualizar controladores en Ubuntu ?

Mensaje por clau1708 »

Buenos días,

Hasta ahora, he estado utilizando Zoom para reuniones con normalidad, sin ningún problema.

Hoy, he entrado y, de pronto, el Zoom me pide que debo actualizar la nueva versión para poder acceder a la reunión.

He actualizado y no he podido. Imposible.

Al final, he llegado a la conclusión que debe ser problema de controladores.

Cómo puedo actualizar controladores en Ubuntu para que me deje instalar esta nueva versión de Zoom ?

No domino mucho estos temas, y tengo miedo de no causar un mayor problema, si toco algo sin saber.

Gracias por avanzado.

Saludos

Avatar de Usuario
doc
Forista Ancestral
Forista Ancestral
Mensajes: 3721
Registrado: Mié Ago 11, 2010 10:32 am
Ubicación: Oviedo-es_ES
Contactar:

Re: Cómo actualizar controladores en Ubuntu ?

Mensaje por doc »

normalmente, Ubuntu te avisa cuando hay una versión nueva de un paquete, para que lo actualices. Quizás tendrías que empezar diciendo qué has hecho para actualizar Zoom (y, si acaso... qué es Zoom, y cómo lo has instalado en tu Ubuntu). También sería bueno que explicases por qué has llegado a la conclusión de que es un problema de controladores... y a qué controladores, exactamente, te refieres

(Consejo general: si, si no sabes qué hacer, lo mejor es no tocar nada. Pero si te puede la ansiedad de hacer algo, preocúpate antes de 'cubrirte las espaldas, o sea poder dar 'el paso a atrás' y volver a la situación inicial, sin necesidad de tener que volver a reinstalar, a través de alguna de las herramientas de las que se puede disponer, como puede ser crearte una imagen de tu sistema con Clonezilla Live (para poder restaurarla con el mismo Clonezilla) o un 'punto de restauración, por ejemplo con TimeShift. No se si, incluso, Ubuntu ofrece algún sistema propio para ello).

Venga, suerte...

clau1708
Forista Nuevo
Forista Nuevo
Mensajes: 8
Registrado: Mar Ago 17, 2021 12:15 pm

Re: Cómo actualizar controladores en Ubuntu ?

Mensaje por clau1708 »

doc escribió:
Jue Nov 10, 2022 1:26 pm
normalmente, Ubuntu te avisa cuando hay una versión nueva de un paquete, para que lo actualices. Quizás tendrías que empezar diciendo qué has hecho para actualizar Zoom (y, si acaso... qué es Zoom, y cómo lo has instalado en tu Ubuntu). También sería bueno que explicases por qué has llegado a la conclusión de que es un problema de controladores... y a qué controladores, exactamente, te refieres

(Consejo general: si, si no sabes qué hacer, lo mejor es no tocar nada. Pero si te puede la ansiedad de hacer algo, preocúpate antes de 'cubrirte las espaldas, o sea poder dar 'el paso a atrás' y volver a la situación inicial, sin necesidad de tener que volver a reinstalar, a través de alguna de las herramientas de las que se puede disponer, como puede ser crearte una imagen de tu sistema con Clonezilla Live (para poder restaurarla con el mismo Clonezilla) o un 'punto de restauración, por ejemplo con TimeShift. No se si, incluso, Ubuntu ofrece algún sistema propio para ello).

Venga, suerte...
Hola, disculpa que no haya dicho nada antes. He estado con trabajo, estos días.

- No recuerdo que me haya avisado de ningún paquete de controladores.
Sí que, de vez en cuando, me sale una ventana para instalar actualizaciones.
Pero, le he dado a "más tarde" porque me interrumpía la tarea que estaba haciendo.
Pero, cuando al final le dí a actualizar me salió que "no podía por fallo al repositorio"

He mirado a "Más controladores disponibles", y me dice que no está usando el "Realtek Semiconductor co, un código muy largo + Wireless. Pero, este no puede ser sobre el problema. Debe ser otra cosa.

- El Zoom que tenía instalado no recuerdo cómo lo instalé.
El que me pide para instalar, le doy a ACTUALIZAR a la ventanilla que me sale cuando intento acceder a zoom (si no instalo esta nueva versión, no me deja). Y, luego, DESCARGAR y INSTALAR.

SIGO LOS PASOS QUE ME PIDE QUE HAGA EL MISMO PROGRAMA.

Pero, una vez instalado, cuando vuelvo a acceder a Zoom, me vuelve a salir de nuevo, la ventana que me pide actualizar la nueva versión.

- He llegado a la conclusión que debe ser el controlador porque me lo dijo el coordinador de la reunión, que debía ser un Driver.
Pero, ya se desentendió.

Y, el Zoom, hasta que no me ha pedido que instale una nueva versión, no me ha dado nunca ningún problema.


- No sé qué controlador... no entiendo... he buscado en controladores del ordenador, y sólo he visto lo que te he comentado más arriba

- Del último párrafo que comentas, no entiendo nada... tendría que llevarlo a un técnico. Y, ahora, me va bastante mal de dinero.

Gracias

Avatar de Usuario
vitouXY
Forista Menor
Forista Menor
Mensajes: 70
Registrado: Vie Mar 12, 2021 4:53 pm
Ubicación:   LATAM
Contactar:

Re: Cómo actualizar controladores en Ubuntu ?

Mensaje por vitouXY »

Comparte algo más que solo palabras... Capturas/Videos... algo más... cómo pa' creerte.

--

Código: Seleccionar todo

sudo apt update
sudo apt upgrade
apt search zoom
ZOOM escribió:https://support.zoom.us/hc/es/articles/ ... m-en-Linux

# Remover

Código: Seleccionar todo

apt-cache policy zoom
sudo apt remove zoom
#sudo apt purge --autoremove zoom
#sudo dpkg --remove zoom
#sudo snap remove zoom-client

sudo reboot
# Instalar desde SNAP

Código: Seleccionar todo

sudo snap install zoom-client
# Instalar desde paquete Deb (Versión 5.12.6(173) para Ubuntu 16.04+ 64bits)

Código: Seleccionar todo

sudo apt update
# Dependencias
sudo apt install libglib2.0-0 libgstreamer-plugins-base0.10-0 libxcb-shape0 libxcb-shm0 libxcb-xfixes0 libxcb-randr0 libxcb-image0 libfontconfig1 libgl1-mesa-glx libxi6 libsm6 libxrender1 libpulse0 libxcomposite1 libxslt1.1 libsqlite3-0 libxcb-keysyms1 libxcb-xtest0 ibus

wget 'https://zoom.us/client/5.12.6.173/zoom_amd64.deb'
sudo apt install ./zoom_amd64.deb
# Script - Actualizar desde paquete Deb (Última versión para Debian/Ubuntu)

Código: Seleccionar todo

#!/bin/sh
# Zoom (.Deb) Update - by Hamletmun

echo Installed: $(cat /opt/zoom/version.txt)
echo Available: $(wget --spider https://zoom.us/client/latest/zoom_amd64.deb 2>&1 | grep Location | sed -e 's/.*prod\/\(.*\)\/.*/\1/')

REPLY=n
echo -n "Download and install? "
read REPLY
if [ $REPLY = y ] ; then
  wget -c https://zoom.us/client/latest/zoom_amd64.deb
  sudo apt install ./zoom_amd64.deb
  rm zoom_amd64.deb
fi
https://askubuntu.com/questions/1271154 ... e-terminal
Quizás sea el momento de decirle adiós a GNU/Linux... y darle la bienvenida a pinGüindows o MacacOS.
Última edición por vitouXY el 31 Dic 1969, 23:59, editado 65355 veces en total.



Editado: DESCARGO DE RESPONSABILIDAD
No somos responsables de nada que pueda sucederle a su dispositivo y/o sistema operativo. ¡Investigue un poco si tiene alguna inquietud! USTED está eligiendo seguir este comentario. Lo hace bajo su propio riesgo y asume la responsabilidad sobre sí mismo y no debe culparnos a nosotros ni a EspacioLiñux ni a sus desaparecidos desarrolladores.

Responder
  • Temas similares
    Respuestas
    Vistas
    Último mensaje