[SOLUCIONADO] no funcionan algunos programas

Dudas y comentarios relacionadas con paquetes o programas específicos (obtención, uso, actualizaciones, versiones, problemas de instalación, etc.)

Moderadores: doc, Deckon

Responder
lukeovalle
Forista Nuevo
Forista Nuevo
Mensajes: 4
Registrado: Sab Abr 17, 2010 7:41 pm
Contactar:

[SOLUCIONADO] no funcionan algunos programas

Mensaje por lukeovalle » Sab May 01, 2010 12:54 am

hola, yo tenia opensuse 11.1 y actualize a la version 11.2, pero ahora tengo una lista de programas que no me andan, quedan cargando pero en lugar de abrir se cierran, por ejemplo el firefox desde la consola devuelve este error:

/usr/lib/firefox/firefox: symbol lookup error: /usr/lib/libgdk-x11-2.0.so.0: undefined symbol: XRRGetScreenResourcesCurrent
, asi tambien el pidgin, el gimp, y los entornos xfce, gnome, etc
:o
Última edición por lukeovalle el Dom May 16, 2010 10:31 pm, editado 1 vez en total.
Avatar de Usuario
tuxman
Forista Distinguido
Forista Distinguido
Mensajes: 1026
Registrado: Lun Feb 26, 2007 8:00 am
Ubicación: Guadalajara, Jalisco. Mexico
Contactar:

Re: no funcionan algunos programas

Mensaje por tuxman » Dom May 02, 2010 12:49 am

He escuchado algo hacerca de problemas con GTK y sus bibliotecas, con respecto a que las nuevas versiones suelen eliminar o cambiar ciertos elementos, por lo que se presenta tu situacion.

En este caso, yo recomendaria que probaras a actualizar tambien los programas o entornos que no funcionan. Probablemente pueda solucionar tu problema. Si no funciona o ya lo hiciste.... pues... mi unica solucion que te puedo plantear seria que desinstalaras alguna aplicacion y la volvieras a instalar (ya con version nueva). Y ver si eso funciona, quizas la version vieja dejo algun remanente.
Edita los nombres de tus post con "[SOLUCIONADO]" cuando encuentres una solución a tu problema.

Lenovo G470
Intel Core i3 2.1 GHz (2310M)
Chakra Linux.
lukeovalle
Forista Nuevo
Forista Nuevo
Mensajes: 4
Registrado: Sab Abr 17, 2010 7:41 pm
Contactar:

Re: no funcionan algunos programas

Mensaje por lukeovalle » Dom May 09, 2010 5:22 am

no funciono :cry:
Avatar de Usuario
shicefgo
Forista Menor
Forista Menor
Mensajes: 53
Registrado: Lun May 10, 2010 1:00 am
Ubicación: Andalucía

Re: no funcionan algunos programas

Mensaje por shicefgo » Lun May 10, 2010 11:59 am

Hola.
En los foros de Suse he encontrado esto, que lo mismo te vale de algo.

Saludos.
lukeovalle
Forista Nuevo
Forista Nuevo
Mensajes: 4
Registrado: Sab Abr 17, 2010 7:41 pm
Contactar:

Re: no funcionan algunos programas

Mensaje por lukeovalle » Mié May 12, 2010 5:05 pm

gracias

Editado -- Mié May 12, 2010 9:05 am --

eso lo escribio mi papa!

gracias
Avatar de Usuario
Deckon
Moderador
Moderador
Mensajes: 3273
Registrado: Dom Abr 01, 2007 8:00 am
Ubicación: México, Estado de México

Re: no funcionan algunos programas

Mensaje por Deckon » Mié May 12, 2010 8:03 pm

lukeovalle por favor si consideras que tu duda a sido solucionada coloca la etiqueta [solucionado] en el titulo de tu post. saludos
Reglamento del Foro | Temas mas Preguntados | WikiEL | GitHub
Linux User #:406092
Manjaro | Asus P8z77-v | i5-2310 | Nvidia GeForce Gt 610 | Hp Ultrabook Folio 13
lukeovalle
Forista Nuevo
Forista Nuevo
Mensajes: 4
Registrado: Sab Abr 17, 2010 7:41 pm
Contactar:

Re: no funcionan algunos programas

Mensaje por lukeovalle » Vie May 14, 2010 10:05 pm

continuo con el problema, estoy usando opera (no pude instalar el plugin flash) y las paginas no andan tan bien como en firefox, mi pagina tiene contenido desactualizado y no me anda el filezilla
Avatar de Usuario
manualinux
Forista Menor
Forista Menor
Mensajes: 57
Registrado: Lun Feb 12, 2007 8:00 am

Re: no funcionan algunos programas

Mensaje por manualinux » Sab May 15, 2010 10:05 pm

Código: Seleccionar todo

/usr/lib/firefox/firefox: symbol lookup error: /usr/lib/libgdk-x11-2.0.so.0: undefined symbol: XRRGetScreenResourcesCurrent
El mensaje de error tiene que ver con libXrandr que forma parte del paquete xorg-x11-libs de openSUSE. O una de dos, o no se ha actualizado el paquete gtk2 y sigues utilizando el de la versión anterior o no se ha actualizado el paquete xorg-x11-libs y sigues utilizando el de la versión anterior. Para comprobarlo abres una terminal y escribes lo siguiente:

Código: Seleccionar todo

$ rpm -q xorg-x11-libs gtk2
Las versiones que te tienen que salir son éstas que son las que tengo yo instaladas en mi partición de openSUSE y que son las de la versión 11.2 actualizadas a fecha de hoy.

Código: Seleccionar todo

jose@linux-cn48:~> rpm -q xorg-x11-libs gtk2
xorg-x11-libs-7.4-25.1.i586
gtk2-2.18.6-0.1.3.i586
Si no son éstas, tendrás que actualizar una de las dos y sus correspondientes dependencias, esto es lo peor.

Te las puedes bajar de este enlace:

ftp://ftp.gui.uva.es/sites/opensuse.org ... 3.i586.rpm
ftp://ftp.gui.uva.es/sites/opensuse.org ... 1.i586.rpm

Y para buscar dependencias que te pueda pedir (no sé cómo tendrás configurado los repositorios en Yast):

ftp://ftp.gui.uva.es/sites/opensuse.org ... 2/rpm/i586
ftp://ftp.gui.uva.es/sites/opensuse.org ... /suse/i586

Y para instalarlas, en el caso de que no funcione Yast, desde una terminal como root ejecutas el siguiente comando:

Código: Seleccionar todo

$ su
# rpm -Uvh xorg-x11-libs-7.4-25.1.i586.rpm
# rpm -Uvh gtk2-2.18.6-0.1.3.i586.prm
Desconozco cómo has realizado la actualización de openSUSE de la versión 11.1 a la 11.2, pero supongo que lo habrás hecho desde un CD/DVD. Si el sistema se ha actualizado a medias lo mejor es hacer una copia de seguridad de tu directorio home, formatear e instalar desde cero, si sigues teniendo problemas graves de compatibilidad de librerías.

Un cordial saludo.

P.D: Si se te hace muy cuesta arriba el tema, corta por lo sano y reinstala desde cero, te ahorrarás mucho tiempo, ahora bien, la mejor manera de aprender a usar GNU/Linux es ésta, cuanto más liada esté la cosa más aprenderá uno. Te lo digo por experiencia.
Avatar de Usuario
hormiga
Forista Nuevo
Forista Nuevo
Mensajes: 1
Registrado: Jue May 06, 2010 6:09 am

Re: no funcionan algunos programas

Mensaje por hormiga » Dom May 16, 2010 8:18 pm

ahi anduvo, al menos el firefox, pidgin, gimp, en fin, le (des)actualizo la libreria gtk a la gtk2 2.14.4.8.1
ya le voy a decir que lo ponga solucionado...
mientras el gnome se bloquea al iniciar y el xfce se me perdieron los paneles. pero esa es otra historia
Responder
  • Similar Topics
    Respuestas
    Vistas
    Último mensaje