Problema en configuracion de sonido de wine en Fedora 12

Dudas y comentarios relacionadas con paquetes o programas específicos (obtención, uso, actualizaciones, versiones, problemas de instalación, etc.)

Moderadores: doc, Deckon

Responder
infisk
Forista Nuevo
Forista Nuevo
Mensajes: 2
Registrado: Sab Mar 20, 2010 3:56 am

Problema en configuracion de sonido de wine en Fedora 12

Mensaje por infisk » Sab Mar 20, 2010 4:14 am

Buenas. Tengo dos problemas: 1. wine no deja instalar programas (se cae) 2. wine no deja configurar sonido (se cae).

Me interesa más poder instalar programas que escuchar música en wine. Sin embargo imagino de que el sonido provoca algún conflicto en la configuración al instalar

Las versiones de wine que he probado son la 1.1.29 y la 1.1.38. Ambas en Fedora 12.
He instalado y desinstalado wine, le hecho downgrade, lo he vuelto a actualizar, etc, pensando que por ahí iba el problema, pero no.
He instalado desde linea de comandos y desde interfaz gráfica.

Mi equipo es un Notebook Compaq T610 Core 2 Duo con 2 Gb. de RAM.

Anteriormente estube trabajando con Ubuntu en este equipo y wine funcionaba bien. sin embargo por incompatibilidades de drivers de sonido, me tuve que cambiar a fedora. De todos modos me gusta más que ubuntu.

Si alguien sabe la solución, o puede dar pistas acerca de ella, le estaría muy agradecido.

Saludos,
Gabo.
Avatar de Usuario
tuxman
Forista Distinguido
Forista Distinguido
Mensajes: 1026
Registrado: Lun Feb 26, 2007 8:00 am
Ubicación: Guadalajara, Jalisco. Mexico
Contactar:

Re: Problema en configuracion de sonido de wine en Fedora 12

Mensaje por tuxman » Dom Mar 21, 2010 7:49 am

Saludos.

Bien, tu problema es un poco mas sencillo de atacar que otros con los que me he encontrado, te haré algunos cuestionamientos que quizá puedan darnos mas información con la cual poder trabajar en una solución.

1.- Se que es una pregunta absurda, pero es evidente: ¿En el sistema tienes sonido? Es decir, en el propio Fedora, sin necesidad de Wine, tienes sonido? Quizás es algo tonta la pregunta, pero es necesaria. Si tu sistema no puede reproducir sonido desde hay estamos mal.

2.- ¿Tu sistema reconoce BIEN tu tarjeta de audio? Es decir, quizá tenga sonido, pero se escucha bien? He leído por hay de que a veces a una distro le falla ese aspecto.

3.- ¿Has probado a configurar Wine? Otra pregunta tonta, pero evidente. Si no vez algún menú con la opción para configurar Wine, ejecuta esto desde consola (como usuario normal):

Código: Seleccionar todo

winecfg
Debería de abrirte una ventana de configuración de Wine, puedes seleccionar el Windows a emular (3.1, 95, 98, 2000, NT, Millenium, XP y en versiones nuevas, hasta Vista). También tiene un apartado de audio. Al menos en mi Debian, tarda en mostrar su contenido, pues se configura y tiene que revisar que sistemas de audio hay en tu sistema.

En este apartado de audio, te debe de mostrar todos los sistemas de audio con que dispone tu Fedora. Con esto no me refiero al Hardware, si no a los manejadores del mismo, como ALSA, OSS, Jack, etc. Si sabes cual es el que usa tu sistema, fíjate que Wine, en primera instancia esta reconociendo que existe y que lo esta usando, ya que es probable que tu sistema (por ejemplo) este usando ALSA y Wine esta intentando usar OSS. Creo que este aspecto no debe de tener problemas, pero no esta de mas que esten haciendo lo mismo Wine y el sistema.

Ahora bien, otra pregunta un tanto tonta: ¿Que programa estas intentando instalar? ¿Porque no usas algún equivalente ya existente en Linux? Ciertamente no digo que no debas de usar el reproductor de tu preferencia, pero ten en mente que hay otras alternativas.
Edita los nombres de tus post con "[SOLUCIONADO]" cuando encuentres una solución a tu problema.

Lenovo G470
Intel Core i3 2.1 GHz (2310M)
Chakra Linux.
infisk
Forista Nuevo
Forista Nuevo
Mensajes: 2
Registrado: Sab Mar 20, 2010 3:56 am

Re: Problema en configuracion de sonido de wine en Fedora 12

Mensaje por infisk » Dom Mar 21, 2010 4:13 pm

Saludos.
Muchas gracias por responder y ayudarme con el problema. =)
Por cierto, tus preguntas no son tontas, yo debí haber entregado más información y haberlas específicado.

1.- ¿En el sistema tienes sonido?
R: Sí. De hecho me cambié a Fedora por el tema del sonido. Con Ubuntu el sonido nunca me funcionó bien, tenía que estar instalando desde las fuentes la snapshot de alsa a cada rato. Y luego de la actualización a 9.10, murió (ni siquiera iniciaba...). Leyendo en foros, alguien puso que en el modelo de notebook compaq T610 sólo funcionaba bien sonido con la distribución Fedora. Tenía razón. Supongo que este equipo es "complicadito" en ese aspecto. De todos modos estoy contentísimo con Fedora. El equipo anda bien y rápido.

2.- ¿Tu sistema reconoce BIEN tu tarjeta de audio? Es decir, quizá tenga sonido, pero se escucha bien? He leído por hay de que a veces a una distro le falla ese aspecto.
R: Interesante. No me había puesto a pensar en ello. En general, sí, en el sistema se oye bien el sonido. Quizá podría quejarme de que a veces está muy bajo, pero en realidad eso depende muchas veces de los archivos... Sobre mi tarjeta de audio... La verdad no sé cuál es. Ahora mismo estoy buscando algún comando que me permita conocer los dispositivos del equipo. Mientras, te doy algunas capturas de pantalla de la configuración de audio, específicamente hardware (http://portrait.cl/winecfg/1-Pantallazo ... arware.png), entrada (http://portrait.cl/winecfg/2-Pantallazo ... ntrada.png) y salida (http://portrait.cl/winecfg/3-Pantallazo ... salida.png).
Editado -- Dom Mar 21, 2010 8:10 am --

Gracias al comando lspci he podido saber el modelo de dispositivo de audio de mi equipo:

Código: Seleccionar todo

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
3.- ¿Has probado a configurar Wine?
R: Efectivamente, lo he hecho. Navego por todas las pestañas y todo bien, pero es en la pestaña de sonido donde muestra un mensaje de autoconfiguración (http://portrait.cl/winecfg/1_Pantallazo ... e-Wine.png) y luego se cae (http://portrait.cl/winecfg/2_Pantallazo ... ograma.png), literalmente. Cuando ejecuto el comando winecfg, aparecen unos mensajes en la línea de comandos. Los copiado y pegado, por si algo puede servir de allí (http://portrait.cl/winecfg/salida_winecfg_210301.txt). Lo interesante es que sé que el equipo puede tener wine, porque en Ubuntu 9.04 funcionaba a la perfección.

4.- ¿Que programa estas intentando instalar? ¿Porque no usas algún equivalente ya existente en Linux?
R: Macromedia Flash MX 2004 (me he quedado en el pasado!). Desafortunadamente (y me apena decirlo), no me la puedo aún con Synfig al nivel que con Flash(http://synfig.org/) - (http://es.wikipedia.org/wiki/Synfig). A pesar de que, por las capacidades del equipo, puedo ejecutar una máquina virtual con Windows (de hecho, es lo que hago acutalmente con VirtualBox(http://es.wikipedia.org/wiki/VirtualBox)), no es lo que había pensado.
En reproducción de audio, estoy contento con audacious2 y en video con VLC. =)
A propósito de instalación, wine me entrega este mensaje: http://portrait.cl/winecfg/3_Pantallazo ... taller.png. Sucede con cualquier instalador de Windows 32b. Sé que funcionan porque los he instalado en la máquina virtual, así que tiene que ser un problema de Wine.

Gracias nuevamente Tuxman.
Espero que con la información entregada, pueda ayudar a dilucidar el problema.

Saludos,
Gabo.
Avatar de Usuario
tuxman
Forista Distinguido
Forista Distinguido
Mensajes: 1026
Registrado: Lun Feb 26, 2007 8:00 am
Ubicación: Guadalajara, Jalisco. Mexico
Contactar:

Re: Problema en configuracion de sonido de wine en Fedora 12

Mensaje por tuxman » Dom Mar 21, 2010 7:03 pm

Tu problema parece especial.

Lo que comentas sobre el desinstalador de Wine, con respecto a que se muere, es bastante peculiar tu problema. Al igual que con la configuración de audio. En el paso en que te indica que esta haciendo auto configuración, considero que es normal, a mi también me muestra ese mensaje la primera vez que lo ejecuto en el sistema. Este aspecto, considero, es normal.

Dado que al parecer Wine en su salida te indica que hay problemas con el registro, te recomendaría estos pasos para que pruebes a ver si te funcionan:

1.- Desinstala Wine. Si usas un gestor de paquetes como Synaptic, procura seleccionar la opción "Desinstalar completamente". De esta manera, en teoría, debería de eliminar toda evidencia de la previa existencia de Wine en tu sistema (archivos de configuración y eso).

2.- Ve a tu Home, y con tu manejador de archivos favorito (Konqueror, Dolphin, Nautilus, etc. El que sea que uses) muestra los archivos ocultos (generalmente es en el menú Ver).

3.- Inspecciona en búsqueda de alguna carpeta llamada ".wine". Si existe, eliminala completamente.

4.- Consigue la versión estable de Wine, si no mal recuerdo o si no estoy muy desactualizado ya, era la versión 1.0.0.

5.- Instala esta versión en tu sistema. Procura cumplir perfectamente las dependencias.

6.- Ya instalado, ejecuta una sola vez el comando "winecfg". En cuanto se abra, ciérralo.

7.- Ve a una terminal cualquiera (Gnome Terminal, por ejemplo), y ejecuta este comando como usuario normal:

Código: Seleccionar todo

cd
8.- Después, ejecuta este comando:

Código: Seleccionar todo

chmod -R 777 .wine/
9.- Esto debería de tener ya listo y a punto la carpeta de configuración de Wine. Intenta abrir nuevamente el configurador del mismo:

Código: Seleccionar todo

winecfg
10.- Intenta irte directamente al aspecto de la configuración de audio. Me supondría que te mostraría nuevamente el mensaje de auto configuración y DEBERÍA de poder ya mostrarte la lista de los sistemas de audio que pudieras seleccionar para usar (ALSA, OSS y eso).

Este plan es con el fin de eliminar y restaurar el, probablemente, dañado archivo de registro de Wine. La idea es que quizás al desinstalarlo, no se elimina ese archivo, y cuando reinstalas o vuelves a ejecutar Wine, vuelve a usar esos archivos dañados. Prueba si funciona. Aquí estaré ayudándote en lo posible, aunque se me acaban las ideas :S.
Edita los nombres de tus post con "[SOLUCIONADO]" cuando encuentres una solución a tu problema.

Lenovo G470
Intel Core i3 2.1 GHz (2310M)
Chakra Linux.
Responder
  • Similar Topics
    Respuestas
    Vistas
    Último mensaje