problema al correr sqliv en kali linux

Dudas y comentarios relacionadas con paquetes o programas específicos (obtención, uso, actualizaciones, versiones, problemas de instalación, etc.)

Moderadores: doc, Deckon

Responder
democan
Forista Nuevo
Forista Nuevo
Mensajes: 2
Registrado: Mié Oct 02, 2019 2:13 am

problema al correr sqliv en kali linux

Mensaje por democan » Mié Oct 02, 2019 3:19 am

hola, tengo un problema al ejecutar sqliv (https://github.com/the-robot/sqliv) en kali, sigo todas las instrcciones y siempre es el mismo error, escribo el comando:

sudo python2 setup.py -i y me devuelve este error:

Traceback (most recent call last):
File "setup.py", line 4, in <module>
import pip
ImportError: No module named pip

despues pienso que el problema es que no esta instalado los requirements.txt y ejecuto este comando:

pip install -r requirements.txt y me devuelve este error:

bash: pip: orden no encontrada


no se que hago mal, si alguien puede ayudarme se lo agradeceria mucho
Avatar de Usuario
davidochobits
Forista Nuevo
Forista Nuevo
Mensajes: 27
Registrado: Jue Sep 05, 2019 5:00 pm
Ubicación: Barcelona
Contactar:

Re: problema al correr sqliv en kali linux

Mensaje por davidochobits » Mié Oct 02, 2019 12:42 pm

Hola,

A ver, ya te lo dice claramente el mensaje, tienes que instalar el paquete "pip"

https://www.ochobitshacenunbyte.com/201 ... n-con-pip/

Saludos
democan
Forista Nuevo
Forista Nuevo
Mensajes: 2
Registrado: Mié Oct 02, 2019 2:13 am

Re: problema al correr sqliv en kali linux

Mensaje por democan » Mié Oct 02, 2019 11:43 pm

hola amigo, ya installe el pip como dijiste pero sigo teniendo el mismo problema

root@ron:~/sqliv# sudo apt install python-pip ==ejecuto el comando y me dice que no se a encontrado el paquete==
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
E: No se ha podido localizar el paquete python-pip

root@ron:~/sqliv# sudo apt install python3-pip ==ejecuto el mismo comando pero con python3 y me dice que ya esta instalado==
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
python3-pip ya está en su versión más reciente (18.1-5).
0 actualizados, 0 nuevos se instalarán, 0 para eliminar y 0 no actualizados.

root@ron:~/sqliv# pip3 install -r requirements.txt ==ejecuto este comando con pip3 porque si escribo solo pip me dice orden no encontrada==
Requirement already satisfied: bs4 in /usr/local/lib/python3.7/dist-packages (from -r requirements.txt (line 1)) (0.0.1)
Requirement already satisfied: termcolor in /usr/lib/python3/dist-packages (from -r requirements.txt (line 2)) (1.1.0)
Requirement already satisfied: terminaltables in /usr/local/lib/python3.7/dist-packages (from -r requirements.txt (line 3)) (3.1.0)
Requirement already satisfied: nyawc in /usr/local/lib/python3.7/dist-packages (from -r requirements.txt (line 4)) (1.8.2)
Requirement already satisfied: beautifulsoup4 in /usr/lib/python3/dist-packages (from bs4->-r requirements.txt (line 1)) (4.8.0)
Requirement already satisfied: sphinxcontrib-napoleon==0.7 in /usr/local/lib/python3.7/dist-packages (from nyawc->-r requirements.txt (line 4)) (0.7)
Requirement already satisfied: requests==2.21.0 in /usr/lib/python3/dist-packages (from nyawc->-r requirements.txt (line 4)) (2.21.0)
Requirement already satisfied: lxml==4.3.0 in /usr/local/lib/python3.7/dist-packages (from nyawc->-r requirements.txt (line 4)) (4.3.0)
Requirement already satisfied: sphinx==1.8.3 in /usr/local/lib/python3.7/dist-packages (from nyawc->-r requirements.txt (line 4)) (1.8.3)
Requirement already satisfied: sphinx-better-theme==0.1.5 in /usr/local/lib/python3.7/dist-packages (from nyawc->-r requirements.txt (line 4)) (0.1.5)
Requirement already satisfied: requests-toolbelt==0.9.1 in /usr/local/lib/python3.7/dist-packages (from nyawc->-r requirements.txt (line 4)) (0.9.1)
Requirement already satisfied: six>=1.5.2 in /usr/lib/python3/dist-packages (from sphinxcontrib-napoleon==0.7->nyawc->-r requirements.txt (line 4)) (1.12.0)
Requirement already satisfied: pockets>=0.3 in /usr/local/lib/python3.7/dist-packages (from sphinxcontrib-napoleon==0.7->nyawc->-r requirements.txt (line 4)) (0.7.2)
Requirement already satisfied: sphinxcontrib-websupport in /usr/local/lib/python3.7/dist-packages (from sphinx==1.8.3->nyawc->-r requirements.txt (line 4)) (1.1.2)
Requirement already satisfied: babel!=2.0,>=1.3 in /usr/local/lib/python3.7/dist-packages (from sphinx==1.8.3->nyawc->-r requirements.txt (line 4)) (2.7.0)
Requirement already satisfied: Pygments>=2.0 in /usr/lib/python3/dist-packages (from sphinx==1.8.3->nyawc->-r requirements.txt (line 4)) (2.3.1)
Requirement already satisfied: packaging in /usr/lib/python3/dist-packages (from sphinx==1.8.3->nyawc->-r requirements.txt (line 4)) (19.0)
Requirement already satisfied: docutils>=0.11 in /usr/local/lib/python3.7/dist-packages (from sphinx==1.8.3->nyawc->-r requirements.txt (line 4)) (0.15.2)
Requirement already satisfied: snowballstemmer>=1.1 in /usr/local/lib/python3.7/dist-packages (from sphinx==1.8.3->nyawc->-r requirements.txt (line 4)) (1.9.1)
Requirement already satisfied: setuptools in /usr/lib/python3/dist-packages (from sphinx==1.8.3->nyawc->-r requirements.txt (line 4)) (41.0.1)
Requirement already satisfied: Jinja2>=2.3 in /usr/lib/python3/dist-packages (from sphinx==1.8.3->nyawc->-r requirements.txt (line 4)) (2.10.1)
Requirement already satisfied: alabaster<0.8,>=0.7 in /usr/local/lib/python3.7/dist-packages (from sphinx==1.8.3->nyawc->-r requirements.txt (line 4)) (0.7.12)
Requirement already satisfied: imagesize in /usr/local/lib/python3.7/dist-packages (from sphinx==1.8.3->nyawc->-r requirements.txt (line 4)) (1.1.0)
Requirement already satisfied: pytz>=2015.7 in /usr/lib/python3/dist-packages (from babel!=2.0,>=1.3->sphinx==1.8.3->nyawc->-r requirements.txt (line 4)) (2019.2)

root@ron:~/sqliv# sudo python setup.py -i ==ya descargado los requirements.txt ejecuto este comando que es el que lo instala y devuelve este error==
Traceback (most recent call last):
File "setup.py", line 4, in <module>
import pip
ImportError: No module named pip

root@ron:~/sqliv# sudo python3 setup.py -i ==entonces como instale pip3 ejecuto el mismo comando pero con python3 y otra vez error==
File "setup.py", line 25
print "SQLiv (2.0) by {}".format(__author__)
^
SyntaxError: invalid syntax
root@ron:~/sqliv#

NO SE CUAL ES EL ERROR, NO PENSE QUE FUERA TAN DIFICIL :(

davidochobits escribió:
Mié Oct 02, 2019 12:42 pm
Hola,

A ver, ya te lo dice claramente el mensaje, tienes que instalar el paquete "pip"

https://www.ochobitshacenunbyte.com/201 ... n-con-pip/

Saludos
Avatar de Usuario
davidochobits
Forista Nuevo
Forista Nuevo
Mensajes: 27
Registrado: Jue Sep 05, 2019 5:00 pm
Ubicación: Barcelona
Contactar:

Re: problema al correr sqliv en kali linux

Mensaje por davidochobits » Jue Oct 03, 2019 8:34 am

Hola,

Mira a ver donde tienes el binario de "pip":

whereis pip / whereis pip3
#o
which pip / which pip3

Ya me dices.

Saludos
Responder
  • Similar Topics
    Respuestas
    Vistas
    Último mensaje