Gestor actualizaciones Linux Mint 16 roto

Dudas y comentarios relacionadas con paquetes o programas específicos (obtención, uso, actualizaciones, versiones, problemas de instalación, etc.)

Moderadores: doc, Deckon

trocotroco
Forista Nuevo
Forista Nuevo
Mensajes: 11
Registrado: Dom Mar 09, 2014 5:44 pm

Gestor actualizaciones Linux Mint 16 roto

Mensaje por trocotroco » Dom Mar 09, 2014 8:53 pm

Hola a todos. Tengo Linux Mint (16) instalado y todo iba perfectamente hasta hace un par de días. Estuve instalando unos cuantos programas de manejo de Cad como DraftSight y en el siguiente inicio veo que el gestor de actualizaciones pone el aspa roja. Clico en Recargar y me descarga la actualización de paquetes. Pero finalmente me aparece una ventana emergente que dice:

No se pudieron descargar todos los índices de los repositorios

El repositorio quizá no esté disponible o no se pudo contactar con él por problemas en la red. Si hay disponible una versión más antigua del índice que falló, se usará esa versión. En caso contrario el repositorio se ignorará. Compruebe su conexión de red y que la dirección del repositorio esté escrita correctamente en las preferencias.

Imposible obtener http://archive.canonical.com/dists/petr ... 4/Packages 404 Not Found [IP: 91.189.92.150 80]
Imposible obtener http://archive.canonical.com/dists/petr ... 6/Packages 404 Not Found [IP: 91.189.92.150 80]
Algunos archivos de índice fallaron al descargar. Se han ignorado, o se han utilizado unos antiguos en su lugar


Busqué por internet e hice unas cuantas cosas:

Borré todo de /var/lib/apt/lists/ * y también dentro de /partial/

sudo dpkg --configure -a
sudo apt-get -f install
sudo apt-get autoclean


Pues na, sigo exactamente igual. Me sigue apareciendo ese mensaje. Alguien sabe como solucionarlo??

Gracias.
Avatar de Usuario
doc
Forista Ancestral
Forista Ancestral
Mensajes: 3305
Registrado: Mié Ago 11, 2010 10:32 am
Ubicación: Oviedo-es_ES
Contactar:

Re: Gestor actualizaciones Linux Mint 16 roto

Mensaje por doc » Dom Mar 09, 2014 9:36 pm

de momento, supongo que copiándonos aquí tu /etc/sources.list, a ver qué repositorios tienes ahí. O mira, más sencillo, te buscas por Google cuales son los repositorios que tienes que tener para tu Mint 16 Petra, y pones esos, y no otros.
trocotroco
Forista Nuevo
Forista Nuevo
Mensajes: 11
Registrado: Dom Mar 09, 2014 5:44 pm

Re: Gestor actualizaciones Linux Mint 16 roto

Mensaje por trocotroco » Dom Mar 09, 2014 10:04 pm

Hola. Esto es lo que tengo en /etc/apt/sources.list:

#deb cdrom:[Linux Mint 16 _petra_ - Release amd64 20131126]/ saucy contrib main non-free
deb http://packages.linuxmint.com/ petra main upstream import
deb http://archive.ubuntu.com/ubuntu/ saucy main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ saucy-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ saucy-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ saucy partner

Ya las había buscado por internet.. pero sigo con el mismo problema.
Avatar de Usuario
doc
Forista Ancestral
Forista Ancestral
Mensajes: 3305
Registrado: Mié Ago 11, 2010 10:32 am
Ubicación: Oviedo-es_ES
Contactar:

Re: Gestor actualizaciones Linux Mint 16 roto

Mensaje por doc » Dom Mar 09, 2014 10:30 pm

entonces... ¿de donde sale esto que dices?
Imposible obtener http://archive.canonical.com/dists/petr ... 4/Packages 404 Not Found [IP: 91.189.92.150 80]
Imposible obtener http://archive.canonical.com/dists/petr ... 6/Packages 404 Not Found [IP: 91.189.92.150 80]
Algunos archivos de índice fallaron al descargar. Se han ignorado, o se han utilizado unos antiguos en su lugar
trocotroco
Forista Nuevo
Forista Nuevo
Mensajes: 11
Registrado: Dom Mar 09, 2014 5:44 pm

Re: Gestor actualizaciones Linux Mint 16 roto

Mensaje por trocotroco » Lun Mar 10, 2014 12:24 am

Tengo un applet del gestor de actualizaciones cerca del reloj. Cuando clico, me pide contraseña, se la meto y actualiza la lista de paquetes. Pues justo después aparece la pantalla emergente diciendo lo que puse al principio y obviamente no hace nada.
El tema es que no encuentro en ningún sitio, en ninguno (ni etc ni var) donde pone esas url. Si supiera donde está las eliminaba a ver si desaparece el problema.

Editado -- Lun Mar 10, 2014 12:24 am --

Sigo dandole vueltas y veo tanto en interfaz gráfica como en terminal que el dpkg no funciona. Se congela y no hace nada.
Imagen
Avatar de Usuario
cuentos
Forista Distinguido
Forista Distinguido
Mensajes: 1088
Registrado: Mar May 03, 2011 7:09 am

Re: Gestor actualizaciones Linux Mint 16 roto

Mensaje por cuentos » Lun Mar 10, 2014 6:46 am

Ok, desactiva el repositorio que te da error. Si no sabes para ver cual es ejecuta esto en la terminal:

Código: Seleccionar todo

cat /etc/apt/sources.list
y este otro

Código: Seleccionar todo

ls -la  /etc/apt/sources.list.d
Y pon lo que te sale aquí para ver.
Por ultimo que editor tienes en mint, peta, pluma u otro.
Cuando mi maestro me reprendió, me dijo: Alejandro Magno a los 20 años conquistaba el mundo, Yo le conteste "si pero tenia de maestro a Aristóteles".
Twitter: @mcuentos
trocotroco
Forista Nuevo
Forista Nuevo
Mensajes: 11
Registrado: Dom Mar 09, 2014 5:44 pm

Re: Gestor actualizaciones Linux Mint 16 roto

Mensaje por trocotroco » Lun Mar 10, 2014 1:02 pm

pablo@fijo ~ $ cat /etc/apt/sources.list
# deb cdrom:[Linux Mint 16 _petra_ - Release amd64 20131126]/ saucy contrib main non-free



pablo@fijo ~ $ ls -la /etc/apt/sources.list.d
total 32
drwxr-xr-x 2 root root 4096 mar 9 22:59 .
drwxr-xr-x 6 root root 4096 mar 9 22:59 ..
-rw-r--r-- 1 root root 50 mar 9 21:58 additional-repositories.list
-rw-r--r-- 1 root root 58 mar 9 21:58 getdeb.list
-rw-r--r-- 1 root root 176 mar 9 22:00 google-chrome.list
-rw-r--r-- 1 root root 175 mar 9 22:00 google-earth.list
-rw-r--r-- 1 root root 180 mar 9 22:00 google-talkplugin.list
-rw-r--r-- 1 root root 418 mar 9 22:59 official-package-repositories.list
pablo@fijo ~ $


Esto es lo que me aparece, por qué? Porque ayer yo mismo borré la lista de /etc/apt/sources.list.

Por qué, te preguntarás? Pues tengo un pc fijo donde todo va mal. Y tengo un portátil con el mismo Mint que va de fábula. Vi los .list del portátil y los puse igual en el fijo. Ahora el gestor de actualizaciones no me da ningún error pero el gestor de software va mal. Entro, intento instalar algo y no me deja, cuando se ejecuta el dpkg queda "colgado".
Si pongo líneas de repostiorios en /etc/apt/sources.list me salen errores por todos lados.

Para cosillas pequeñas uso gedit. Para ofimática LibreOffice.

Estoy en un bucle. :(
Avatar de Usuario
cuentos
Forista Distinguido
Forista Distinguido
Mensajes: 1088
Registrado: Mar May 03, 2011 7:09 am

Re: Gestor actualizaciones Linux Mint 16 roto

Mensaje por cuentos » Lun Mar 10, 2014 5:38 pm

Ok, en tu sources.list no tienes nada.
Entonces toca ver que tienes en los otros repositorios, de uno :

Código: Seleccionar todo

cat /etc/apt/sources.list.d/dditional-repositories.list
y en este otro

Código: Seleccionar todo

cat /etc/apt/sources.list.d/official-package-repositories.list
Para ir viendo donde esta el problema, es mejo poner todos los demás:

cat /etc/apt/sources.list.d/getdeb.list
cat /etc/apt/sources.list.d/google-chrome.list
cat /etc/apt/sources.list.d/google-earth.list
cat /etc/apt/sources.list.d/ google-talkplugin.list
Cuando mi maestro me reprendió, me dijo: Alejandro Magno a los 20 años conquistaba el mundo, Yo le conteste "si pero tenia de maestro a Aristóteles".
Twitter: @mcuentos
trocotroco
Forista Nuevo
Forista Nuevo
Mensajes: 11
Registrado: Dom Mar 09, 2014 5:44 pm

Re: Gestor actualizaciones Linux Mint 16 roto

Mensaje por trocotroco » Mar Mar 11, 2014 11:27 pm

Hola, te pego las salidas de todos los comandos:

pablo@fijo ~ $ cat /etc/apt/sources.list.d/additional-repositories.list
# deb http://archive.canonical.com/ petra partner

pablo@fijo ~ $ cat /etc/apt/sources.list.d/official-package-repositories.list
deb http://packages.linuxmint.com petra main upstream import
deb http://extra.linuxmint.com petra main
deb http://archive.ubuntu.com/ubuntu saucy main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu saucy-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ saucy-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ saucy partner

pablo@fijo ~ $ cat /etc/apt/sources.list.d/getdeb.list
# deb http://archive.getdeb.net/ubuntu saucy-getdeb apps

pablo@fijo ~ $ cat /etc/apt/sources.list.d/google-chrome.list
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb http://dl.google.com/linux/chrome/deb/ stable main

pablo@fijo ~ $ cat /etc/apt/sources.list.d/google-earth.list
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb http://dl.google.com/linux/earth/deb/ stable main

pablo@fijo ~ $ cat /etc/apt/sources.list.d/google-talkplugin.list
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb http://dl.google.com/linux/talkplugin/deb/ stable main

Editado -- Mar Mar 11, 2014 11:26 pm --

Ahora mismo tengo el siguiente problema:

Clico en el gestor de actualizaciones (en modo gráfico) → meto la contraseña → descarga información de paquetes (lo hace bien) → clico en instalar actualizaciones → se pone a descargar paquetes (lo hace bien) → se pone a instalar el software y sale el siguientes pantallazo diciendo que la instalación no va:




Imagen

Imagen


Me pasa con el gestor de actualizaciones y también me pasa con el gestor de software. Busco un paquete --> lo descarga bien pero no lo instala. Es como si el dpkg se "corrompiera" y no tira.

Editado -- Mar Mar 11, 2014 11:27 pm --

También probé esto pero nada:

pablo@fijo ~ $ sudo dpkg --configure -a
[sudo] password for pablo:
Configurando man-db (2.6.5-2) ...
Can't exec "/var/lib/dpkg/info/man-db.config": Permiso denegado at /usr/share/perl/5.14/IPC/Open3.pm line 186.
open2: exec of /var/lib/dpkg/info/man-db.config configure 2.6.5-2 failed at /usr/share/perl5/Debconf/ConfModule.pm line 59
dpkg: error al procesar man-db (--configure):
el subproceso instalado el script post-installation devolvió el código de salida de error 13
Se encontraron errores al procesar:
man-db



Al final siempre sale el mismo error con man-db y no tengo ni idea de por donde tirar, alguna pista?

Cenkiu!!
Avatar de Usuario
cuentos
Forista Distinguido
Forista Distinguido
Mensajes: 1088
Registrado: Mar May 03, 2011 7:09 am

Re: Gestor actualizaciones Linux Mint 16 roto

Mensaje por cuentos » Mié Mar 12, 2014 8:43 am

Ok en primer lugar tienes repos repetidos, que no debería de darte problemas, pero como sea mejor de una vez corriges esto.
En primer hay que editar los repositorios, yo suelo usar la terminal con nano, pero no se si conozcas este editor, pero en mint dices que tienes gedit, lo puedes hacer con este. (no es recomendable los de libre-office).
En la terminal ejecutas:

Código: Seleccionar todo

gksudo gedit  /etc/apt/sources.list
Y te pide tu contraseña, la pones, y en este agregas el simbolo de numero al principio de todas las lineas quedando de esta manera:
#deb cdrom:[Linux Mint 16 _petra_ - Release amd64 20131126]/ saucy contrib main non-free
#deb http://packages.linuxmint.com/ petra main upstream import
#deb http://archive.ubuntu.com/ubuntu/ saucy main restricted universe multiverse
#deb http://archive.ubuntu.com/ubuntu/ saucy-updates main restricted universe multiverse
#deb http://security.ubuntu.com/ubuntu/ saucy-security main restricted universe multiverse
#deb http://archive.canonical.com/ubuntu/ saucy partner
Guardas y sales.
Poner el simbolo # al princio se le nombra comentar, y esto hace que el sistema no tome en cuenta la linea, solo sirve como "comentario" para que uno de usuario recuerde algo cuando edita el archivo.
Y para por el momento dejar el sistema bien, de una buena vez comentas estos archivos

Código: Seleccionar todo

gksudo gedit /etc/apt/sources.list.d/google-chrome.list
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
#deb http://dl.google.com/linux/chrome/deb/ stable main
Y este otro:

Código: Seleccionar todo

 gksudo gedit /etc/apt/sources.list.d/google-earth.list
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
#deb http://dl.google.com/linux/earth/deb/ stable main
Y por ultimo:

Código: Seleccionar todo

 gksudo gedit  /etc/apt/sources.list.d/google-talkplugin.list
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
#deb http://dl.google.com/linux/talkplugin/deb/ stable main
Y ya que editaste y guardaste los archivos ejecuta en la terminal estos dos comandos:
El primero para actualizar la lista de programas:

Código: Seleccionar todo

sudo apt-get update
Y al final no te debe de dar error, y luego actualizas el sistema con:

Código: Seleccionar todo

sudo apt-get upgrade 
Igual no te debe de dar error, ya que este el sistema bien puedes "des-comentar" (quitar #) de uno en uno los extras que agregaste:
Los tres de google.
/etc/apt/sources.list.d/google-chrome.list
/etc/apt/sources.list.d/google-earth.list
/etc/apt/sources.list.d/google-talkplugin.list
Pero no primero o sea el de: etc/apt/sources.list
Cuando mi maestro me reprendió, me dijo: Alejandro Magno a los 20 años conquistaba el mundo, Yo le conteste "si pero tenia de maestro a Aristóteles".
Twitter: @mcuentos
trocotroco
Forista Nuevo
Forista Nuevo
Mensajes: 11
Registrado: Dom Mar 09, 2014 5:44 pm

Re: Gestor actualizaciones Linux Mint 16 roto

Mensaje por trocotroco » Mié Mar 12, 2014 12:35 pm

Hola cuentos.

En /etc/apt/sources.list no puedo comentar nada porque el archivo ya no contenía ningún repositorio. Estaba vacío, solo tenía una línea comentada. He hecho todo lo que me has dicho y el apt-get update fue bien, pero el apt-get upgrade sigue dando el mismo error. Te pego las últimas líneas que devuelve la terminal:

Desempaquetando el reemplazo de xserver-xorg-video-intel ...
Configurando man-db (2.6.5-2) ...
Can't exec "/var/lib/dpkg/info/man-db.config": Permiso denegado at /usr/share/perl/5.14/IPC/Open3.pm line 186.
open2: exec of /var/lib/dpkg/info/man-db.config configure 2.6.5-2 failed at /usr/share/perl5/Debconf/ConfModule.pm line 59
dpkg: error al procesar man-db (--configure):
el subproceso instalado el script post-installation devolvió el código de salida de error 13
dpkg: error al procesar python-gst0.10 (--configure):
el paquete python-gst0.10 no está listo para configurarse
no se puede configurar (estado actual `half-installed')
Configurando libdbusmenu-glib4:amd64 (12.10.3+13.10.20131104-0ubuntu1) ...
Configurando gir1.2-dbusmenu-glib-0.4 (12.10.3+13.10.20131104-0ubuntu1) ...
Configurando libdbusmenu-gtk3-4:amd64 (12.10.3+13.10.20131104-0ubuntu1) ...
Configurando libdbusmenu-gtk4:amd64 (12.10.3+13.10.20131104-0ubuntu1) ...
Configurando linux-firmware (1.116.2) ...
Configurando linux-libc-dev:amd64 (3.11.0-18.32) ...
Configurando xserver-xorg-core (2:1.14.5-1ubuntu2~saucy1) ...
Configurando xserver-xorg-glamoregl:amd64 (0.5.1-0ubuntu4.2) ...
Configurando xserver-xorg-video-intel (2:2.99.904-0ubuntu2.1) ...
Procesando disparadores para libc-bin ...
Se encontraron errores al procesar:
man-db
python-gst0.10
E: Sub-process /usr/bin/dpkg returned an error code (1)


Parece que el gestor de actualizaciones y repositorios están bien pero man-db (que no sé qué es) y dpkg no van bien. Fallan.
Avatar de Usuario
doc
Forista Ancestral
Forista Ancestral
Mensajes: 3305
Registrado: Mié Ago 11, 2010 10:32 am
Ubicación: Oviedo-es_ES
Contactar:

Re: Gestor actualizaciones Linux Mint 16 roto

Mensaje por doc » Mié Mar 12, 2014 12:47 pm

¿etc/apt/sources.list sin repositorios....? yo creo que tenías que pararte a asentar un poco los 'fundamentos' de Linux, en general, y de LinuxMint, en particular
trocotroco
Forista Nuevo
Forista Nuevo
Mensajes: 11
Registrado: Dom Mar 09, 2014 5:44 pm

Re: Gestor actualizaciones Linux Mint 16 roto

Mensaje por trocotroco » Mié Mar 12, 2014 3:48 pm

Gracias doc, eres toda una fuente de inspiración...

Por eso estoy preguntando. Si tú tienes esos fundamentos, los podrías compartir y ayudarme a arreglar el problema en vez de poner un comentario que no lleva a nada.
Avatar de Usuario
doc
Forista Ancestral
Forista Ancestral
Mensajes: 3305
Registrado: Mié Ago 11, 2010 10:32 am
Ubicación: Oviedo-es_ES
Contactar:

Re: Gestor actualizaciones Linux Mint 16 roto

Mensaje por doc » Mié Mar 12, 2014 9:12 pm

los fundamentos no se comparten: se aprenden. Y hay que aprenderlos antes de empezar a hacer cosas.

Y además, mientras no falte al respeto, puedo opinar (o más bien aconsejar) lo que me parezca conveniente. Y que estudies un poco, y no venir aquí exigiendo que alguien te solucione los problemas... es conveniente decirlo.

Porque yo creo que este foro ni pretende convertirse en un parvulario... ni, como es gratuito y libre, admite exigencias (que es una de las prmeras reglas de la 'nettiquette' de los foros).
trocotroco
Forista Nuevo
Forista Nuevo
Mensajes: 11
Registrado: Dom Mar 09, 2014 5:44 pm

Re: Gestor actualizaciones Linux Mint 16 roto

Mensaje por trocotroco » Jue Mar 13, 2014 12:15 am

Por supuesto que puedes opinar sobre lo que quieras, faltaría más!

Dicho esto, me gustaría decirte que yo no he exigido nada en ningún momento, simplemente he pedido ayuda. Ayuda a gente que quizá en algún momento se topó con un problema igual o similar al que yo tengo ahora mismo. Te animo a leer todo el hilo y decirme dónde he exigido yo algo.

Desde mi punto de vista doc, un foro es para compartir información, experiencias, casos, vivencias, etc. y enriquecer en la medida de lo posible una afición. Pero si las respuestas son para mandar a alguien a Google o para llamarle ignorante, pues... no sé, tenemos un punto de vista diferente.

Y ahora hablemos un poco de Mint. Para tu información el archivo /etc/apt/sources.list está vacío, sólo contiene una línea y está comentada. Te animo a instalar Mint en un equipo y recién instalado ver el archivo.
La lista de repositorios está en /etc/apt/sources.list.d/official-package-repositories.list

Yo lo único que pretendo es arreglar un problema que tengo en un ordenador, no discutir con nadie. Sinceramente no sé qué hice para que repliques así. De todos modos, si sabes cómo arreglar el problema me encantaría que me lo dijeses y si no sabes o no quieres decirlo pues no pasa nada. Tú a lo tuyo, yo a lo mío y dios a la de todos.

Un saludo y muchas gracias a cuentos.
Responder
  • Similar Topics
    Respuestas
    Vistas
    Último mensaje