Error con VirtualBox Fedora18 x64 [CERRAR]

Dudas y comentarios relacionadas con paquetes o programas específicos (obtención, uso, actualizaciones, versiones, problemas de instalación, etc.)

Moderadores: doc, Deckon

MDM_ThuG
Forista Nuevo
Forista Nuevo
Mensajes: 41
Registrado: Mié Jun 25, 2008 7:00 am

Error con VirtualBox Fedora18 x64 [CERRAR]

Mensaje por MDM_ThuG » Vie Jun 28, 2013 6:25 pm

Hola , Espero que todos estén bien.

Les comento que actualmente estoy con Fedora 18 de 64bits y tengo problemas para utilizar VirtualBox, logre instalar VirtualBox 4.2.14 r86644, he leído varios foros, varios post y todo sale muy fácil pero a mi no me resulta, tambien en este foro hay un problema igual al mio, pero la solución dada para el en mi caso no corrió.
Topic del que hago mención software/error-ejecutar-virtualbox-t44914.html
Los errores al tratar de iniciar la maquina son:

ImagenImagen

Al ejecutar /etc/init.d/vboxdrv setup

Código: Seleccionar todo

[root@MDM Escritorio]# /etc/init.d/vboxdrv setup
Stopping VirtualBox kernel modules                         [  OK  ]
Uninstalling old VirtualBox DKMS kernel modules            [  OK  ]

Trying to register the VirtualBox kernel modules using DKMSError! echo
Your kernel headers for kernel 3.9.5-201.fc18.x86_64 cannot be found at
/lib/modules/3.9.5-201.fc18.x86_64/build or /lib/modules/3.9.5-201.fc18.x86_64/source.
                                                           [FALLÓ]
  (Failed, trying without DKMS)
Recompiling VirtualBox kernel modules                      [FALLÓ]
  (Look at /var/log/vbox-install.log to find out what went wrong)
Al revisar el log
more /var/log/vbox-install.log

Código: Seleccionar todo

Uninstalling modules from DKMS
  removing old DKMS module vboxhost version  4.2.14

------------------------------
Deleting module version: 4.2.14
completely from the DKMS tree.
------------------------------
Done.
Attempting to install using DKMS

Creating symlink /var/lib/dkms/vboxhost/4.2.14/source ->
                 /usr/src/vboxhost-4.2.14

DKMS: add completed.
Failed to install using DKMS, attempting to install without
Makefile:181: *** Error: unable to find the sources of your current Linux kernel. Specify KERN_DIR=<directory> and run Make again.  Alto.
Ahora he seguido todas las indicaciones que dan en foros, incluso he desinstalado e instalado nuevamente, instale primero las dependencias, pero aqui hay algo raro
cuando estaba probando dependencias 1 x 1 al momento de tratar con gcc

Código: Seleccionar todo

[root@MDM Escritorio]# yum install gcc
Complementos cargados:langpacks, presto, priorities, refresh-packagekit
13888 packages excluded due to repository priority protections
Resolviendo dependencias
--> Ejecutando prueba de transacción
---> Paquete gcc.x86_64 0:4.7.2-8.fc18 debe ser instalado
--> Procesando dependencias: cpp = 4.7.2-8.fc18 para el paquete: gcc-4.7.2-8.fc18.x86_64
--> Procesando dependencias: glibc-devel >= 2.2.90-12 para el paquete: gcc-4.7.2-8.fc18.x86_64
--> Procesando dependencias: cloog-ppl >= 0.15 para el paquete: gcc-4.7.2-8.fc18.x86_64
--> Procesando dependencias: libmpc.so.2()(64bit) para el paquete: gcc-4.7.2-8.fc18.x86_64
--> Ejecutando prueba de transacción
---> Paquete cloog-ppl.x86_64 0:0.15.11-4.fc18.1 debe ser instalado
--> Procesando dependencias: libppl_c.so.4()(64bit) para el paquete: cloog-ppl-0.15.11-4.fc18.1.x86_64
--> Procesando dependencias: libppl.so.9()(64bit) para el paquete: cloog-ppl-0.15.11-4.fc18.1.x86_64
---> Paquete cpp.x86_64 0:4.7.2-8.fc18 debe ser instalado
---> Paquete glibc-devel.x86_64 0:2.16-24.fc18 debe ser instalado
--> Procesando dependencias: glibc-headers = 2.16-24.fc18 para el paquete: glibc-devel-2.16-24.fc18.x86_64
--> Procesando dependencias: glibc = 2.16-24.fc18 para el paquete: glibc-devel-2.16-24.fc18.x86_64
--> Procesando dependencias: glibc-headers para el paquete: glibc-devel-2.16-24.fc18.x86_64
---> Paquete libmpc.x86_64 0:0.9-3.fc18.2 debe ser instalado
--> Ejecutando prueba de transacción
---> Paquete glibc.i686 0:2.16-24.fc18 debe ser instalado
--> Procesando dependencias: glibc-common = 2.16-24.fc18 para el paquete: glibc-2.16-24.fc18.i686
--> Procesando dependencias: libfreebl3.so(NSSRAWHASH_3.12.3) para el paquete: glibc-2.16-24.fc18.i686
--> Procesando dependencias: libfreebl3.so para el paquete: glibc-2.16-24.fc18.i686
---> Paquete glibc-headers.x86_64 0:2.16-24.fc18 debe ser instalado
---> Paquete ppl.x86_64 0:0.11.2-10.fc18 debe ser instalado
--> Procesando dependencias: libpwl.so.5()(64bit) para el paquete: ppl-0.11.2-10.fc18.x86_64
--> Ejecutando prueba de transacción
---> Paquete glibc.i686 0:2.16-24.fc18 debe ser instalado
--> Procesando dependencias: glibc-common = 2.16-24.fc18 para el paquete: glibc-2.16-24.fc18.i686
---> Paquete nss-softokn-freebl.i686 0:3.14-5.fc18 debe ser instalado
---> Paquete ppl-pwl.x86_64 0:0.11.2-10.fc18 debe ser instalado
--> Resolución de dependencias finalizada
[color=#FF0000]Error: Paquete: glibc-2.16-24.fc18.i686 (fedora)
           Necesita: glibc-common = 2.16-24.fc18
           Instalado: glibc-common-2.16-31.fc18.x86_64 (installed)
               glibc-common = 2.16-31.fc18
           Disponible: glibc-common-2.16-24.fc18.x86_64 (fedora)
               glibc-common = 2.16-24.fc18
 Podría intentar utilizar el comando --skip-broken para sortear el problema
Podría intentar ejecutar: rpm- Va --nofiles --nodigest[/color]
Tambien intento con #yum install gcc --skip-broken pero sale

Código: Seleccionar todo

Resolviendo dependencias
--> Ejecutando prueba de transacción
---> Paquete gcc.x86_64 0:4.7.2-8.fc18 debe ser instalado
--> Procesando dependencias: cpp = 4.7.2-8.fc18 para el paquete: gcc-4.7.2-8.fc18.x86_64
--> Procesando dependencias: glibc-devel >= 2.2.90-12 para el paquete: gcc-4.7.2-8.fc18.x86_64
--> Procesando dependencias: cloog-ppl >= 0.15 para el paquete: gcc-4.7.2-8.fc18.x86_64
--> Procesando dependencias: libmpc.so.2()(64bit) para el paquete: gcc-4.7.2-8.fc18.x86_64
--> Ejecutando prueba de transacción
---> Paquete cloog-ppl.x86_64 0:0.15.11-4.fc18.1 debe ser instalado
--> Procesando dependencias: libppl_c.so.4()(64bit) para el paquete: cloog-ppl-0.15.11-4.fc18.1.x86_64
--> Procesando dependencias: libppl.so.9()(64bit) para el paquete: cloog-ppl-0.15.11-4.fc18.1.x86_64
---> Paquete cpp.x86_64 0:4.7.2-8.fc18 debe ser instalado
---> Paquete glibc-devel.x86_64 0:2.16-24.fc18 debe ser instalado
--> Procesando dependencias: glibc-headers = 2.16-24.fc18 para el paquete: glibc-devel-2.16-24.fc18.x86_64
--> Procesando dependencias: glibc = 2.16-24.fc18 para el paquete: glibc-devel-2.16-24.fc18.x86_64
--> Procesando dependencias: glibc-headers para el paquete: glibc-devel-2.16-24.fc18.x86_64
---> Paquete libmpc.x86_64 0:0.9-3.fc18.2 debe ser instalado
--> Ejecutando prueba de transacción
---> Paquete glibc.i686 0:2.16-24.fc18 debe ser instalado
--> Procesando dependencias: glibc-common = 2.16-24.fc18 para el paquete: glibc-2.16-24.fc18.i686
--> Procesando dependencias: libfreebl3.so(NSSRAWHASH_3.12.3) para el paquete: glibc-2.16-24.fc18.i686
--> Procesando dependencias: libfreebl3.so para el paquete: glibc-2.16-24.fc18.i686
---> Paquete glibc-headers.x86_64 0:2.16-24.fc18 debe ser instalado
---> Paquete ppl.x86_64 0:0.11.2-10.fc18 debe ser instalado
--> Procesando dependencias: libpwl.so.5()(64bit) para el paquete: ppl-0.11.2-10.fc18.x86_64
--> Ejecutando prueba de transacción
---> Paquete glibc.i686 0:2.16-24.fc18 debe ser instalado
--> Procesando dependencias: glibc-common = 2.16-24.fc18 para el paquete: glibc-2.16-24.fc18.i686
---> Paquete nss-softokn-freebl.i686 0:3.14-5.fc18 debe ser instalado
---> Paquete ppl-pwl.x86_64 0:0.11.2-10.fc18 debe ser instalado
--> Ejecutando prueba de transacción
---> Paquete cloog-ppl.x86_64 0:0.15.11-4.fc18.1 debe ser instalado
--> Procesando dependencias: libppl_c.so.4()(64bit) para el paquete: cloog-ppl-0.15.11-4.fc18.1.x86_64
--> Procesando dependencias: libppl.so.9()(64bit) para el paquete: cloog-ppl-0.15.11-4.fc18.1.x86_64
---> Paquete cpp.x86_64 0:4.7.2-8.fc18 debe ser instalado
--> Procesando dependencias: libmpc.so.2()(64bit) para el paquete: cpp-4.7.2-8.fc18.x86_64
---> Paquete gcc.x86_64 0:4.7.2-8.fc18 debe ser instalado
--> Procesando dependencias: glibc-devel >= 2.2.90-12 para el paquete: gcc-4.7.2-8.fc18.x86_64
--> Procesando dependencias: libmpc.so.2()(64bit) para el paquete: gcc-4.7.2-8.fc18.x86_64

Paquetes ignorados por problemas de dependencias:
    cloog-ppl-0.15.11-4.fc18.1.x86_64 de fedora
    cpp-4.7.2-8.fc18.x86_64 de fedora
    gcc-4.7.2-8.fc18.x86_64 de fedora
    glibc-2.16-24.fc18.i686 de fedora
    glibc-devel-2.16-24.fc18.x86_64 de fedora
    glibc-headers-2.16-24.fc18.x86_64 de fedora
    libmpc-0.9-3.fc18.2.x86_64 de fedora
    nss-softokn-freebl-3.14-5.fc18.i686 de fedora
    ppl-0.11.2-10.fc18.x86_64 de fedora
    ppl-pwl-0.11.2-10.fc18.x86_64 de fedora
Tambien trate de desinstalar e instalar el paquete en cuestion, pero despues de un buen rato tratando de ver las dependencias tengo lo siguiente

Código: Seleccionar todo

.
.
.
Salteando el kernel en ejecución: kernel-3.9.5-201.fc18.x86_64
--> Reiniciando la resolución de las dependencias con las nuevas modificaciones.
--> Ejecutando prueba de transacción
--> Resolución de dependencias finalizada
Error: Intentando eliminar "systemd", que está protegido
Error: Intentando eliminar "yum", que está protegido
Estaría agradecido si me pueden ayudar.
Gracias totales xD
Última edición por MDM_ThuG el Jue Ago 08, 2013 2:50 am, editado 1 vez en total.
Avatar de Usuario
maiku
Moderador
Moderador
Mensajes: 1521
Registrado: Jue Abr 19, 2007 7:00 am
Ubicación: Cojutepeque, El Salvador C. A.
Contactar:

Re: Error con VirtualBox Fedora18 x64

Mensaje por maiku » Vie Jun 28, 2013 6:40 pm

instala esto:

Código: Seleccionar todo

yum -y install kernel-devel kernel-headers
nos cuentas cómo te fue.

Saludos
Grüße...
Maiku

Full linux alchemist!!!
MDM_ThuG
Forista Nuevo
Forista Nuevo
Mensajes: 41
Registrado: Mié Jun 25, 2008 7:00 am

Re: Error con VirtualBox Fedora18 x64

Mensaje por MDM_ThuG » Vie Jun 28, 2013 6:41 pm

Si ya estan instalados, instale todas las dependencias que indican.

El paquete kernel-devel-3.6.10-4.fc18.x86_64 ya se encuentra instalado con su versión más reciente
El paquete kernel-headers-3.6.10-4.fc18.x86_64 ya se encuentra instalado con su versión más reciente
Avatar de Usuario
maiku
Moderador
Moderador
Mensajes: 1521
Registrado: Jue Abr 19, 2007 7:00 am
Ubicación: Cojutepeque, El Salvador C. A.
Contactar:

Re: Error con VirtualBox Fedora18 x64

Mensaje por maiku » Vie Jun 28, 2013 6:50 pm

instala los correspondientes lanza uname -a y mira la versión de tu kernel y compáralo con el que tienes

Según leo tienes 3.9.5-201.fc18.x86_64 y el que tienes instalado es kernel-devel-3.6.10-4.fc18.x86_64 que no coinciden.

Para encontrarlos más fácilmente usa yum search e instala los correspondientes.

Saludos
Grüße...
Maiku

Full linux alchemist!!!
Avatar de Usuario
cuentos
Forista Distinguido
Forista Distinguido
Mensajes: 1088
Registrado: Mar May 03, 2011 7:09 am

Re: Error con VirtualBox Fedora18 x64

Mensaje por cuentos » Vie Jun 28, 2013 7:21 pm

También instalar DKMS, en la segunda imagen te lo esta pidiendo.
Cuando mi maestro me reprendió, me dijo: Alejandro Magno a los 20 años conquistaba el mundo, Yo le conteste "si pero tenia de maestro a Aristóteles".
Twitter: @mcuentos
MDM_ThuG
Forista Nuevo
Forista Nuevo
Mensajes: 41
Registrado: Mié Jun 25, 2008 7:00 am

Re: Error con VirtualBox Fedora18 x64

Mensaje por MDM_ThuG » Vie Jun 28, 2013 7:59 pm

Maiku efectivamente tengo instalado ese kernel devel, pero no hay otra versión

Código: Seleccionar todo

El paquete kernel-devel-3.6.10-4.fc18.x86_64 ya se encuentra instalado con su versión más reciente
Nada para hacer
Tambien busque en http://rpmfind.net/linux/rpm2html/searc ... vel-x86_64 y la ultima version disponible es la que tengo.

Ahora que sucede quienes usan la ultima version del kernel? no están usando VirtualBox??es raro.

_-----

cuentos.
SI la imagen lo dice, pero DKMS tengo instalado
El paquete dkms-2.2.0.3-4.fc18.noarch ya se encuentra instalado con su versión más reciente
Nada para hacer
Avatar de Usuario
cuentos
Forista Distinguido
Forista Distinguido
Mensajes: 1088
Registrado: Mar May 03, 2011 7:09 am

Re: Error con VirtualBox Fedora18 x64

Mensaje por cuentos » Vie Jun 28, 2013 8:09 pm

Ok. en Fedora casi no lo conozco, pero mira esta guía espero y te sirva.
http://tuxapuntes.com/instalar-virtualb ... dora-1718/
Cuando mi maestro me reprendió, me dijo: Alejandro Magno a los 20 años conquistaba el mundo, Yo le conteste "si pero tenia de maestro a Aristóteles".
Twitter: @mcuentos
MDM_ThuG
Forista Nuevo
Forista Nuevo
Mensajes: 41
Registrado: Mié Jun 25, 2008 7:00 am

Re: Error con VirtualBox Fedora18 x64

Mensaje por MDM_ThuG » Vie Jun 28, 2013 9:08 pm

cuentos escribió:Ok. en Fedora casi no lo conozco, pero mira esta guía espero y te sirva.
http://tuxapuntes.com/instalar-virtualb ... dora-1718/
Gracias cuentos pero ya lo había hecho asi, pero no ayuda a mi problema, es mas otros link tmb son los mismos pasos, la unica diferencia es que en este tu haces el repo a mano.
Avatar de Usuario
maiku
Moderador
Moderador
Mensajes: 1521
Registrado: Jue Abr 19, 2007 7:00 am
Ubicación: Cojutepeque, El Salvador C. A.
Contactar:

Re: Error con VirtualBox Fedora18 x64

Mensaje por maiku » Vie Jun 28, 2013 10:52 pm

Has actualizado tu kernel?

y si es ése el caso esa versión del kernel la bajaste de los repos de fedora?


Por otra parte si puedes bootear con tu versión previa de kernel e intentar los pasos deberías ser capaz de iniciar Virtual Box
Grüße...
Maiku

Full linux alchemist!!!
MDM_ThuG
Forista Nuevo
Forista Nuevo
Mensajes: 41
Registrado: Mié Jun 25, 2008 7:00 am

Re: Error con VirtualBox Fedora18 x64

Mensaje por MDM_ThuG » Sab Jun 29, 2013 2:31 am

el kernel lo tengo actualizado desde repos de fedora, revisare el antiguo kernel, pero si mal n recuerdo tenia un problema con el xD otra cosa
Avatar de Usuario
Fanton
Forista Distinguido
Forista Distinguido
Mensajes: 1339
Registrado: Jue Ene 08, 2009 8:00 am
Ubicación: Magdalena [Argentina]
Contactar:

Re: Error con VirtualBox Fedora18 x64

Mensaje por Fanton » Sab Jun 29, 2013 6:10 am

Hola MDM_ThuG, te comento que en esta imagen esta la solución y es correr en una terminal la linea de comando que esta en azul
Imagen

sudo /etc/init.d/vboxdrv setup

si ya tienes instalados el kernel-devel y gcc, con este simple comando se compila al kernel y listo
Diplomacia, es el arte de saber lo que no se debe decir...
_________________
Hardware: Intel i5-3570k | ASUS P8H77-M |HD [500GB] [1 TB] | Ram 8 GB | GPU: Nvidia GeForce 210/1 GB
S.O. Debian@testing x86_64 Openbox
Linux user #506272
Avatar de Usuario
maiku
Moderador
Moderador
Mensajes: 1521
Registrado: Jue Abr 19, 2007 7:00 am
Ubicación: Cojutepeque, El Salvador C. A.
Contactar:

Re: Error con VirtualBox Fedora18 x64

Mensaje por maiku » Sab Jun 29, 2013 6:16 am

Fanton escribió:Hola MDM_ThuG, te comento que en esta imagen esta la solución y es correr en una terminal la linea de comando que esta en azul
Imagen

sudo /etc/init.d/vboxdrv setup

si ya tienes instalados el kernel-devel y gcc, con este simple comando se compila al kernel y listo
Desde el comienzo del post estamos con el problema del kernel-devel y kernel-source que están al día según los repos de MDM_ThuG pero no coincide con el kernel en uso.

Por otra parte @MDM_ThuG: Puedes pegar por acá el resultado del yum search, consideremos que el gestor de paquetes está al día pero puede que te ofrezca instalar otras versiones de ellos.
Grüße...
Maiku

Full linux alchemist!!!
MDM_ThuG
Forista Nuevo
Forista Nuevo
Mensajes: 41
Registrado: Mié Jun 25, 2008 7:00 am

Re: Error con VirtualBox Fedora18 x64

Mensaje por MDM_ThuG » Dom Jun 30, 2013 9:46 pm

maiku escribió:
Desde el comienzo del post estamos con el problema del kernel-devel y kernel-source que están al día según los repos de MDM_ThuG pero no coincide con el kernel en uso.

Por otra parte @MDM_ThuG: Puedes pegar por acá el resultado del yum search, consideremos que el gestor de paquetes está al día pero puede que te ofrezca instalar otras versiones de ellos.

Código: Seleccionar todo

[root@MDM]# yum search kernel-devel
Complementos cargados:langpacks, presto, priorities, refresh-packagekit
13888 packages excluded due to repository priority protections
================ Nombre/Resumen que coinciden con: kernel-devel ================
buildsys-build-rpmfusion-kerneldevpkgs-current.x86_64 : Meta-package to get all
     ...: current kernel-devel packages into the buildroot
kernel-devel.x86_64 : Development package for building kernel modules to match
                    : the kernel

  Nombre y resumen que coinciden con  y sólo , use "buscar todo" para todo.
[root@MDM]# yum install kernel-devel.x86_64
Complementos cargados:langpacks, presto, priorities, refresh-packagekit
13888 packages excluded due to repository priority protections
El paquete kernel-devel-3.6.10-4.fc18.x86_64 ya se encuentra instalado con su versión más reciente
Nada para hacer
[root@MDM]# 

Avatar de Usuario
maiku
Moderador
Moderador
Mensajes: 1521
Registrado: Jue Abr 19, 2007 7:00 am
Ubicación: Cojutepeque, El Salvador C. A.
Contactar:

Re: Error con VirtualBox Fedora18 x64

Mensaje por maiku » Dom Jun 30, 2013 11:48 pm

Intenta con un yum search 3.9.5-201.fc18

veamos si tenemos resultados.
Grüße...
Maiku

Full linux alchemist!!!
Avatar de Usuario
Fanton
Forista Distinguido
Forista Distinguido
Mensajes: 1339
Registrado: Jue Ene 08, 2009 8:00 am
Ubicación: Magdalena [Argentina]
Contactar:

Re: Error con VirtualBox Fedora18 x64

Mensaje por Fanton » Lun Jul 01, 2013 1:19 am

Hola MDM_ThuG, no me has contestado si has ejecutado en una terminal "sudo /etc/init.d/vboxdrv setup", yo use casi un año o mas fedora, y cada vez que se actualizaba el kernel, era el comando que habia que ejecutar para que carge el VirtualBox.
Diplomacia, es el arte de saber lo que no se debe decir...
_________________
Hardware: Intel i5-3570k | ASUS P8H77-M |HD [500GB] [1 TB] | Ram 8 GB | GPU: Nvidia GeForce 210/1 GB
S.O. Debian@testing x86_64 Openbox
Linux user #506272
Responder
  • Similar Topics
    Respuestas
    Vistas
    Último mensaje