Error al tratar de instalar pdfedit en debian 9

Dudas y comentarios relacionadas con paquetes o programas específicos (obtención, uso, actualizaciones, versiones, problemas de instalación, etc.)

Moderadores: doc, Deckon

Responder
vra
Forista Nuevo
Forista Nuevo
Mensajes: 6
Registrado: Sab Oct 14, 2017 5:44 pm

Error al tratar de instalar pdfedit en debian 9

Mensaje por vra »

Hola a todos, espero hayan recibido una muy feliz navidad. Tengo un problema cuando trato de instalar pdfedit en debian9, después de descomprimirlo en una carpeta dentro de la carpeta de descargas con el comando

Código: Seleccionar todo

tar -jxvf ......
y hacer un make, entonces tengo los siguientes mensajes de error:

Código: Seleccionar todo

make[3]: se sale del directorio '/media/valery/Users/valery/Downloads/pdfedit-0.4.5/src/xpdf/xpdf'
Makefile:26: fallo en las instrucciones para el objetivo 'libxpdf'
make[2]: *** [libxpdf] Error 2
make[2]: se sale del directorio '/media/valery/Users/valery/Downloads/pdfedit-0.4.5/src/xpdf'
Makefile:16: fallo en las instrucciones para el objetivo 'xpdf'
make[1]: *** [xpdf] Error 2
make[1]: se sale del directorio '/media/valery/Users/valery/Downloads/pdfedit-0.4.5/src'
Makefile:91: fallo en las instrucciones para el objetivo 'source'
make: *** [source] Error 2
además de un montón de mensajes de advertencia como y/o parecidos al siguiente:

Código: Seleccionar todo

BuiltinFontTables.cc:4244:1: warning: deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
Cómo puedo resolver el problema?

Gracias de antemano por la ayuda brindada.

Avatar de Usuario
doc
Forista Ancestral
Forista Ancestral
Mensajes: 3502
Registrado: Mié Ago 11, 2010 10:32 am
Ubicación: Oviedo-es_ES
Contactar:

Re: Error al tratar de instalar pdfedit en debian 9

Mensaje por doc »

ni idea de cómo poder compilar los binarios de la aplicación PDFEdit que has descargado, y si siquiera tienes instalados los paquetes necesarios para ello (los headers, el built-essentials, etc.) ¿Que te dice el archivo 'LEAME' que seguramente incluirá el TAR?...
Pero permíteme unas pequeñas reflexiones
a) ¿Por qué 'pdfedit'? es una aplicación bastante antigua, que ya ha sido abandonada por Debian (creo que en Debian 6, o 7, aún andaba por los repositorios oficiales) Y, la verdad, hay muchos editores de PDFs, en Linux, que se pueden instalar en Debian sin complicarse la vida compilando. Incluso debe de haber alguno como AppImage.
b) Al parecer PDFEdit está basado en librerías Qt3... y en Debian ya se usan, hace tiempo, las Qt4. A lo mejor el problema surge de esto...
c) Por cierto ¿Y por qué Debian 9... si la versión 'oficial' de Debian ya es Debian 10?

Responder
  • Temas similares
    Respuestas
    Vistas
    Último mensaje