No arranca Linux Mint 13 tarjeta Nvidia

Comentarios sobre el buen funcionamiento del sistema y como personalizarlo a tus necesidades.

Moderadores: doc, mcun

Responder
wichortiz
Forista Nuevo
Forista Nuevo
Mensajes: 5
Registrado: Sab Jul 28, 2012 8:35 pm

No arranca Linux Mint 13 tarjeta Nvidia

Mensaje por wichortiz »

Buenas tardes señores... este es mi primer post y espero que me puedan dar una mano con el siguiente problema:
Instale Linux Mint Maya junto a mi Win XP desde hacer un par de meses... todo caminaba correctamente, pero un par de dias atras, se me ocurrio actualizar los controladores de mi tarjeta grafica Nvidia GeForce 8400 GS, por lo que me descargue de la pagina del proveedor, un archivo ".run" y luego lo ejecute para instalar las actualizaciones..... pues resulta que luego de varios intentos, al reiniciar, el entorno de Linux me decia que habia un problema con el SERVIDOR X (Entorno grafico) y que no podia iniciar... desde entonces no puedo entrar a Linux con mi tarjeta grafica.... puedo entrar a Win XP sin ningun problema, pero para entrar a Linux, tengo que quitar mi tarjeta grafica..... precisamente hoy, luego de hacer eso y querer ingresar, ya ni de esa manera podia, por lo que ingrese en modo reparacion y despues pude ingresar....

Que me sugieren que puede ser y como reparar esto ???

Agradezco mucho su ayuda.

Avatar de Usuario
doc
Forista Ancestral
Forista Ancestral
Mensajes: 3508
Registrado: Mié Ago 11, 2010 10:32 am
Ubicación: Oviedo-es_ES
Contactar:

Re: No arranca Linux Mint 13 tarjeta Nvidia

Mensaje por doc »

pues habrás creado algún cristo. Yo no tengo ni idea de cómo puedes dar el paso atrás pero si te sirve de guía (y porque Mint procede también de Debian) yo siempre he instalado los drivers de nVidia, sin mayores problemas, como digo aquí:
http://comoserdebianitaynomorirenelinte ... vidia.html

Así que, si nadie te dice algo más específico para resolver tu problema, podrías intentarlo.

wichortiz
Forista Nuevo
Forista Nuevo
Mensajes: 5
Registrado: Sab Jul 28, 2012 8:35 pm

Re: No arranca Linux Mint 13 tarjeta Nvidia

Mensaje por wichortiz »

Gracias Doc.... ahorita pruebo tu recomendacion y estare posteando si me ha resultado....

Saludos

Avatar de Usuario
niky45
Forista Ancestral
Forista Ancestral
Mensajes: 9186
Registrado: Jue Abr 12, 2007 7:00 am
Ubicación: tras la pantalla (...)
Contactar:

Re: No arranca Linux Mint 13 tarjeta Nvidia

Mensaje por niky45 »

busca por aqui la guia de yoyo sobre el driver nvidia. ;)
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]

Avatar de Usuario
Yoyo
Administrador
Administrador
Mensajes: 3156
Registrado: Mar Jun 06, 2006 7:00 am
Ubicación: España
Contactar:

Re: No arranca Linux Mint 13 tarjeta Nvidia

Mensaje por Yoyo »

niky45 escribió:busca por aqui la guia de yoyo sobre el driver nvidia. ;)
Hete aquí documentacion/instalar-driver-nvidia-lm ... 47700.html

Avatar de Usuario
niky45
Forista Ancestral
Forista Ancestral
Mensajes: 9186
Registrado: Jue Abr 12, 2007 7:00 am
Ubicación: tras la pantalla (...)
Contactar:

Re: No arranca Linux Mint 13 tarjeta Nvidia

Mensaje por niky45 »

Yoyo escribió:
niky45 escribió:busca por aqui la guia de yoyo sobre el driver nvidia. ;)
Hete aquí documentacion/instalar-driver-nvidia-lm ... 47700.html
yoyo, no los malacostumbres, que tienen que aprender a usar el buscador.... ::lol:: (mas de uno me agradecera esto.... espero. :jokingly: )

(offtopic)
y que yo se lo tenga que decir al staff. lo mio empieza a ser preocupante :cry:

:D
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]

wichortiz
Forista Nuevo
Forista Nuevo
Mensajes: 5
Registrado: Sab Jul 28, 2012 8:35 pm

Re: No arranca Linux Mint 13 tarjeta Nvidia

Mensaje por wichortiz »

Jajajajaj... Gracias Yoyo y Niki... y no se preocupen, ya antes habia buscado una solucion y habia encontrado lo que me mandan, pero no habia podido avanzar por diferentes problemas que les pongo a continuacion.

Lo primero que dice es hacer esto:
En una terminal nos logeamos como root y procedemos a instalarlos.
aptitude install build-essential linux-headers-`uname -r` gcc make libstdc++6 fakeroot

Aqui hace varias cosas y pareciera que todo bien.... las ultimas lineas son estas:
Procesando disparadores para man-db ...
Configurando libdpkg-perl (1.16.1.2ubuntu7) ...
Configurando dpkg-dev (1.16.1.2ubuntu7) ...
Configurando libalgorithm-diff-perl (1.19.02-2) ...
Configurando libalgorithm-diff-xs-perl (0.04-2build2) ...
Configurando libalgorithm-merge-perl (0.08-2) ...
Configurando libstdc++6-4.6-dev (4.6.3-1ubuntu5) ...
Configurando g++-4.6 (4.6.3-1ubuntu5) ...
Configurando g++ (4:4.6.3-1ubuntu5) ...
update-alternatives: utilizando /usr/bin/g++ para proveer /usr/bin/c++ (c++) en modo automático.
Configurando build-essential (11.5ubuntu2) ...

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Despues hacer lo siguiente:
Lo siguiente es desinstalar el driver libre nouveau pues crea conflictos con el de Nvidia y no nos dejaría instalarlo.

Como root en una terminal.

Y me da el siguiente error:
aptitude remove xserver-xorg-video-nouveau

No se pudo encontrar ningún paquete cuyo nombre o descripción coincida con «xserver-xorg-video-noveau»
No se pudo encontrar ningún paquete cuyo nombre o descripción coincida con «xserver-xorg-video-noveau»
No se instalará, actualizará o eliminará ningún paquete.
0 paquetes actualizados, 0 nuevos instalados, 0 para eliminar y 14 sin actualizar.
Necesito descargar 0 B de archivos. Después de desempaquetar se usarán 0 B.

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Despues pide hacer esto:
Ahora a pesar de haberlo desinstalado vamos a agregarlo a la blacklist en el /etc/modprobe.d/blacklist.conf pues a mí me seguía dando conflictos y no me dejaba instalar los Nvidia.

Como root en una terminal.

Al hacerlo me da este problema:
pechu-P4M900-M7-FE pechu # gedit /etc/modprobe.d/blacklist.conf

(gedit:2618): EggSMClient-WARNING **: Failed to connect to the session manager: None of the authentication protocols specified are supported


** (gedit:2618): WARNING **: Could not connect to session bus

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Como siguiente paso, hacer lo siguiente:
Guardamos cambios y cerramos.

Hecho todo esto reiniciamos y luego comenzaremos con la instalación

Una vez hayamos reiniciado, a mi se me cargó el entorno gráfico de nuevo, nos salimos del escritorio con Ctrl+Alt+F1

Ahora y estando en el prompt nos volvemos a logear con nuestro usuario y una vez logeados con nuestro usuario lo volvemos a hacer pero ahora como root.

Lo siguiente será detener el servidor X para poder instalar los drivers Nvidia, como ya estábamos como root tipeamos lo siguiente.

Para Gnome

Código:
# /etc/init.d/gdm3 stop


Si están en kde sería.

Código:
# /etc/init.d/kdm stop

Y aqui, el error es el siguiente:
bash: /etc/init.d/gdm3 stop: No existe el archivo o el directorio

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Total ya no segui haciendo nada, porque creo que no me esta funcionando lo que me dicen....

Lamento si estos errores son por cuestiones de novato, pero eso es precisamente lo que soy en cuanto a Linux.....

Gracias de nuevo por su valiosa ayuda y espero que me puedan dar otra manaita..

Avatar de Usuario
johpunk
Forista Ancestral
Forista Ancestral
Mensajes: 4530
Registrado: Mié Ago 09, 2006 7:00 am
Ubicación: Táchira - Venezuela

Re: No arranca Linux Mint 13 tarjeta Nvidia

Mensaje por johpunk »

No se pudo encontrar ningún paquete cuyo nombre o descripción coincida con «xserver-xorg-video-noveau»
ahi mismo te esta diciendo que no consigue un paquete con ese nombre, trata mejor haciendo primero
apt-cache search nouveau
y luego fíjate cual de los que te saldrán tienes instalado. y ahí si procedes a eliminarlos, esto también lo puedes hacer con el synaptic. aca de tejo un enlace por cierto en ese link salen las mismas capturas del how to de Yoyo. entonces quien se habra copiado de quien? :- ::lol::
Linux User #432922 ~ Linux Machine #390497
Gentoo 13.0 | ~amd64 | i3 improved | Github | dotfiles | Identi.ca | Twitter
irc.freenode.net | /join #gnu/linuxOS

Avatar de Usuario
Yoyo
Administrador
Administrador
Mensajes: 3156
Registrado: Mar Jun 06, 2006 7:00 am
Ubicación: España
Contactar:

Re: No arranca Linux Mint 13 tarjeta Nvidia

Mensaje por Yoyo »

Ese tutorial mío es para Debian y derivadas como LMDE y SolusOS. En Linux Mint así como en Ubuntu no funcionaria pues tienen configuraciones distintas

¿que hay con el instalador de drivers propietarios? (controladores adicionales) creo que se llama.

@johpunk, me han fusilado literalmente el tutto en el link ese que pones y no citan fuente . El mio es del 2010 y el de esos "prendas" del 2012 ¬__¬

Pero cualquiera le dice algo al autor del plagio teniendo de nick y avatar a Al Capone O_0

wichortiz
Forista Nuevo
Forista Nuevo
Mensajes: 5
Registrado: Sab Jul 28, 2012 8:35 pm

Re: No arranca Linux Mint 13 tarjeta Nvidia

Mensaje por wichortiz »

Gracias por la ayuda a todos...

Les comento que ahora si ya puedo entrar a Linux, el unico problema que tengo, es que la resolucion esta bastante desconfigurada, (todo se ve bastante grande !!!), lo que hice fue lo que les postee ayer, la apague y hoy que la encendi para seguir trabajando, me encuentro la grata sorpresa que pude entrar a mi entorno Linux....

Johpunk: al ejecutar el comando que me dijiste, me da la siguiente informacion que no se interpretar (mi sinceras disculpas por mi novatez).

pechu@pechu-P4M900-M7-FE ~ $ apt-cache search nouveau
libdrm-nouveau1a - Userspace interface to nouveau-specific kernel DRM services -- runtime
libdrm-nouveau1a-dbg - Userspace interface to nouveau-specific kernel DRM -- debugging symbols
xserver-xorg-video-nouveau - X.Org X server -- Nouveau display driver
xserver-xorg-video-nouveau-dbg - X.Org X server -- Nouveau display driver (debug symbols)
nouveau-firmware - Firmware para tarjetas gráficas nVidia
xfonts-jmk - James M. Knoble's character-cell fonts for X

Yoyo.... quiere decir que tu tutorial no me va a funcionar ???... mi Linux es Mint Maya (13)...

Gracias de nuevo y espero sus comentarios

Avatar de Usuario
niky45
Forista Ancestral
Forista Ancestral
Mensajes: 9186
Registrado: Jue Abr 12, 2007 7:00 am
Ubicación: tras la pantalla (...)
Contactar:

Re: No arranca Linux Mint 13 tarjeta Nvidia

Mensaje por niky45 »

wichortiz escribió:Yoyo.... quiere decir que tu tutorial no me va a funcionar ???... mi Linux es Maya (13)...
quiere decir que no lo puedes fusilar sin ams, sino que tendras que ir mirando que cosas se aplican directamente y en cuales tienes que modificar pequenios detalles... :? es cierto que eso requiere ciertos conocimientos sobre tu distro, PERO, mejor que te acostumbres ya: es algo que tendras que hacer el 99% de las veces. :wink:

lo de nouveau, creo que no lo tienes instalado. busca (apt-cache search) nvidia, a ver que dice.
-----------
guia para nvidia:
http://man-linux.comli.com/?p=36
varias cosas:
a) es antigua. te toca darte cuenta de que cosas han cambiado y cuales no. *
b) es para debian. tecnicamente en ubuntu funciona igual, pero nuevamente, habra cosas que no.... trabajo tuyo.
c) si bien creo que por ahi estaba el link de la fuente original, la guia no esta exactamente completa. te resumo aqui como va:
> instalar dependencias (es lo que mejor explicado esta)
> instalar module-assistant
> m-a a-i nvidia
*nota: si, es un RESUMEN. me he stalado la parte de salir de las X, etc, etc. todo eso esta por ahi explicado. es resumen va unicamente porque en la guia no se si esta toda la parte del m-a (aun asi, en la fuente original, creo recordar que SI)

* por ejemplo, la parte del xorg.conf.... (que no se diga que no aviso...)

*asi como nota al margen: yo se que ahora pensaras "dios, y para que me daran documentacion obsoleta y de otra distro...", pues bien, te dire: el 99% de lo que encuentres por internet, como minimo va a ser antiguo. todo es cuestion de ver que en realidad las cosas NO han cambiado TAAANTO. :wink:
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]

Avatar de Usuario
CharlieBros
Forista Mayor
Forista Mayor
Mensajes: 691
Registrado: Lun Sep 26, 2011 2:01 am
Ubicación: Mexico, DF

Re: No arranca Linux Mint 13 tarjeta Nvidia

Mensaje por CharlieBros »

Lo que sigo sin entender es, ¿como rayos se te ocurrio tratar de instalarlo asi?, en el menu de Mint te vas a (creo) Sistema, y hay uno que dice algo de privativo, tiene un icono que parece una tarjetita de hardware verde, de ahi instalas el driver, si quieres por el momento, configura el xorg para que use VESA, entras graficamente y haces lo que dije.
Saludos.
Ch

wichortiz
Forista Nuevo
Forista Nuevo
Mensajes: 5
Registrado: Sab Jul 28, 2012 8:35 pm

Re: No arranca Linux Mint 13 tarjeta Nvidia

Mensaje por wichortiz »

Creo que ya he resuelto mi problema......(Creo !!!!).
Con lo posteado anteriormente, sobre la resolución de mi pantalla... pues hice lo siguiente:

Fui a Sistema ---> Centro de Control ----> Controladores adicionales.... ahi me aparece: NVIDIA binary Xorg drive, kernel module and VDPAU library
le di "Activar"... hizo varios procesos, me pidio reiniciar y al hacerlo, tenia al centro de la pantalla, el mensaje: "Out of range"..
De nuevo fui a: Sistema ---> Centro de Control ---> Monitores... y ahi cambie la resolucion de mi pantalla por una mas agradable....

Es todo, ahora parece que todo esta bien..... habré solucionado mi problema ???.... creo que si...

Gracias miles por sus ayudas y si tengo problemas nuevos, los vuelvo a molestar,

Wichortiz

Avatar de Usuario
CharlieBros
Forista Mayor
Forista Mayor
Mensajes: 691
Registrado: Lun Sep 26, 2011 2:01 am
Ubicación: Mexico, DF

Re: No arranca Linux Mint 13 tarjeta Nvidia

Mensaje por CharlieBros »

wichortiz escribió:Creo que ya he resuelto mi problema......(Creo !!!!).
Con lo posteado anteriormente, sobre la resolución de mi pantalla... pues hice lo siguiente:

Fui a Sistema ---> Centro de Control ----> Controladores adicionales.... ahi me aparece: NVIDIA binary Xorg drive, kernel module and VDPAU library
le di "Activar"... hizo varios procesos, me pidio reiniciar y al hacerlo, tenia al centro de la pantalla, el mensaje: "Out of range"..
De nuevo fui a: Sistema ---> Centro de Control ---> Monitores... y ahi cambie la resolucion de mi pantalla por una mas agradable....

Es todo, ahora parece que todo esta bien..... habré solucionado mi problema ???.... creo que si...

Gracias miles por sus ayudas y si tengo problemas nuevos, los vuelvo a molestar,

Wichortiz
Si, lo has resuelto, de hecho eso es lo que te habia puesto, aunque recordaba que decia algo de privativos...
Saludos.
Ch

Responder
  • Temas similares
    Respuestas
    Vistas
    Último mensaje