linux mint no arranca despues de la instalacion

Comentarios sobre el buen funcionamiento del sistema y como personalizarlo a tus necesidades.

Moderadores: doc, mcun

Responder
rs1964
Forista Nuevo
Forista Nuevo
Mensajes: 5
Registrado: Jue Jul 04, 2013 9:30 pm

linux mint no arranca despues de la instalacion

Mensaje por rs1964 »

después de haber intentado reinstalar linux mint 15 cinnamon varias veces, no consigo que este arranque. cuando hago el restart después de finalizar la instalación se me queda la pantalla negra con el cursor parpadeando. no entiendo el problema, porque estuve trabajando con el mismo durante un mes sin ningún problema, hasta que desinstalle python 3.3. Desde entonces no he conseguido poder instalar linux. he formateado el disco varias veces. hay alguien que me puede ayudar a resolver el problema?

después de hacer: inxi -Fnc 0

System: Host: mint Kernel: 3.8.0-19-generic x86_64 (64 bit)
Desktop:Gnome Distro: Linux Mint 15 Olivia
Machine: Mobo: ASUSTeK model: P8P67 LE version: Rev X.0X Bios: American Megatrends version: 1017 date: 06/13/2011
CPU: Quad core Intel Core i7-2600 CPU (-HT-MCP-) cache: 8192 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) Clock Speeds: 1: 1600.00 MHz 2: 1600.00 MHz 3: 1600.00 MHz 4: 1600.00 MHz 5: 1600.00 MHz 6: 1600.00 MHz 7: 1600.00 MHz 8: 1600.00 MHz
Graphics: Card: Advanced Micro Devices [AMD] nee ATI Turks PRO [Radeon HD 6570] X.Org: 1.13.3 drivers: ati,radeon (unloaded: dev,vesa)
Resolution: 1920x1080@59.9hz GLX Renderer: Gallium 0.4 on AMD TURKS GLX Version: 3.0 Mesa 9.1.1
Audio: Card-1: Intel 6 Series/C200 Series Chipset Family High Definition Audio Controller driver: snd_hda_intel
Card-2: Advanced Micro Devices [AMD] nee ATI Turks/Whistler HDMI
Audio [Radeon HD 6000 Series] driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture ver: k3.8.0-19-generic Network: Card: Realtek RTL8111/8168 PCI Express Gigabit Ethernet controller driver: r8169
IF: eth0 state: up speed: 1000 Mbps duplex: full mac:
f4:6d:04:66:06:08
Drives: HDD Total Size: 503.5GB (0.9% used) 1: id: /dev/sda model:
My_Passport_070A size: 499.4GB 2: USB id: /dev/sdb model: USB_Flash_Memory size: 4.1GB
Partition: ID: / size: 3.9G used: 63M (2%) fs: overlayfs
RAID: No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors: System Temperatures: cpu: 39.0C mobo: N/A gpu: 66.5 Fan Speeds (in rpm): cpu: N/A
Info: Processes: 203 Uptime: 23 min Memory: 524.4/7967.5MB Client: Shell inxi: 1.8.4

Avatar de Usuario
doc
Forista Ancestral
Forista Ancestral
Mensajes: 3522
Registrado: Mié Ago 11, 2010 10:32 am
Ubicación: Oviedo-es_ES
Contactar:

Re: linux mint no arranca despues de la instalacion

Mensaje por doc »

pues si dices que has estado trabajando perfectamente con LinuxMint, y en una nueva reinstalación no te arranca, será que se te ha pasado algo por alto. Desde luego, si reinstalas (se supone que desde cero ¿no? ) nada tiene que ver eso que dices de haber desinstalado python en una anterior instalación.

Te sugiero...
a) que revises que la ISO que te habrás descargado es correcta, y la has quemado (o pasado a un pendrive) bien
b) que pruebes, antes de instalar, si te funciona todo bien en modo LiveCD
b) que, en extremo, pruebes con cualquier otra distribución

rs1964
Forista Nuevo
Forista Nuevo
Mensajes: 5
Registrado: Jue Jul 04, 2013 9:30 pm

Re: linux mint no arranca despues de la instalacion

Mensaje por rs1964 »

he bajado una nueva version de linux mint 15 cinnamon, he formateado el pen drive y la he vuelto a quemar la iso en el pen drive. despues he arrancado desde el pen drive (todo ok), he vuelto a instalr, y al final me dice que la instalacion ha ido bien y que tengo que reiniciar para poder utilizar la version instalada. despues de hacer restart tengo el mismo problema: dispaly negro con cursor que parpadea. alguien tieni idea de lo que me esta pasando?

un salutos a todos

Avatar de Usuario
hipersayan_x
Forista Legendario
Forista Legendario
Mensajes: 1905
Registrado: Vie Abr 27, 2007 7:00 am
Contactar:

Re: linux mint no arranca despues de la instalacion

Mensaje por hipersayan_x »

Estos enlaces te pueden ayudar:

En caso de que sea el GRUB:

https://help.ubuntu.com/community/Boot-Repair

En caso de que sea la gráfica:

http://askubuntu.com/questions/38780/ho ... stallation
http://ubuntuforums.org/showthread.php?t=1466952
http://phoronix.com/forums/showthread.p ... on-hd-6790

Y no, el problema no tiene nada que ver con Python sino con tu gráfica.
Desarrollo en Qt: Qt Developer Network
Mis proyectos: github | SourceForge.net

rs1964
Forista Nuevo
Forista Nuevo
Mensajes: 5
Registrado: Jue Jul 04, 2013 9:30 pm

Re: linux mint no arranca despues de la instalacion

Mensaje por rs1964 »

Voy a probar y luego te comento. Lo que me vuelve loco es que lo tuve un mes funcionando a la perfección.

Editado -- Sab Jul 06, 2013 1:44 am --

no lo consigo.
he probado con boot-repair, siguiendo las instrucciones, al final me dice que ha sido reparado, pero me sigue dando el mismo problema.

con sudo nano /etc/default/grub
he cambiado: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
pero cuando hago:
sudo update-grub
/usr/sbin/grub-probe: error: failed to get canonical path of /cow.

estoy por tirar la toalla, es una putada porque me gustaba mucho mint15.

que mas puedo probar?

Avatar de Usuario
enriquehh
Forista Distinguido
Forista Distinguido
Mensajes: 1337
Registrado: Sab Dic 08, 2007 8:00 am

Re: linux mint no arranca despues de la instalacion

Mensaje por enriquehh »

Hola, ¿linuxmint tiene alguna opción para entrar en modo texto o recovery mode?, esto te lo pregunto pare ver si se puede arrancar el sistema creando el archivo xorg.conf con el comando X -configure.

Saludos

Avatar de Usuario
hipersayan_x
Forista Legendario
Forista Legendario
Mensajes: 1905
Registrado: Vie Abr 27, 2007 7:00 am
Contactar:

Re: linux mint no arranca despues de la instalacion

Mensaje por hipersayan_x »

rs1964 escribió: he cambiado: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
pero cuando hago:
sudo update-grub
El update-grub se ejecuta siempre en un entorno chroot, de todas formas no es necesario ejecutarlo, buscá el archivo /boot/grub/grub.cfg (en tu partición de Mint) (creo que es igual para todas las distros, no estoy seguro :? ), busca las lineas que dicen:

Código: Seleccionar todo

menuentry ... {
        ...
	linux	...
        ...
}
y cambialas por:

Código: Seleccionar todo

menuentry ... {
        ...
	linux	... nomodeset
        ...
}
o

Código: Seleccionar todo

menuentry ... {
        ...
	linux	... radeon.nomodeset=0
        ...
}
guardá, ejecuta el comando sync, y probá bootear de vuelta.
Desarrollo en Qt: Qt Developer Network
Mis proyectos: github | SourceForge.net

rs1964
Forista Nuevo
Forista Nuevo
Mensajes: 5
Registrado: Jue Jul 04, 2013 9:30 pm

Re: linux mint no arranca despues de la instalacion

Mensaje por rs1964 »

esto es lo que he encontrado en grub.cfg por lo que se refiere a menuentry...{}

menuentry 'LinuxMint GNU/Linux' --class linuxmint --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-f2ec72a5-1b8c-4dc9-9e22-2aaa3173938a' {
recordfail
load_video
gfxmode $linux_gfx_mode
insmod gzio
insmod part_gpt
insmod ext2
set root='hd0,gpt2'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2 ed56c314-8833-4849-8d04-acbae917579c
else
search --no-floppy --fs-uuid --set=root ed56c314-8833-4849-8d04-acbae917579c
fi
linux /vmlinuz-3.8.0-26-generic root=/dev/mapper/mint--vg-root ro quiet splash $vt_handoff
initrd /initrd.img-3.8.0-26-generic
}
submenu 'Advanced options for LinuxMint GNU/Linux' $menuentry_id_option 'gnulinux-advanced-f2ec72a5-1b8c-4dc9-9e22-2aaa3173938a' {
menuentry 'LinuxMint GNU/Linux, with Linux 3.8.0-26-generic' --class linuxmint --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-3.8.0-26-generic-advanced-f2ec72a5-1b8c-4dc9-9e22-2aaa3173938a' {
recordfail
load_video
gfxmode $linux_gfx_mode
insmod gzio
insmod part_gpt
insmod ext2
set root='hd0,gpt2'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2 ed56c314-8833-4849-8d04-acbae917579c
else
search --no-floppy --fs-uuid --set=root ed56c314-8833-4849-8d04-acbae917579c
fi
echo 'Loading Linux 3.8.0-26-generic ...'
linux /vmlinuz-3.8.0-26-generic root=/dev/mapper/mint--vg-root ro quiet splash $vt_handoff
echo 'Loading initial ramdisk ...'
initrd /initrd.img-3.8.0-26-generic
}
menuentry 'LinuxMint GNU/Linux, with Linux 3.8.0-26-generic (recovery mode)' --class linuxmint --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-3.8.0-26-generic-recovery-f2ec72a5-1b8c-4dc9-9e22-2aaa3173938a' {
recordfail
load_video
insmod gzio
insmod part_gpt
insmod ext2
set root='hd0,gpt2'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2 ed56c314-8833-4849-8d04-acbae917579c
else
search --no-floppy --fs-uuid --set=root ed56c314-8833-4849-8d04-acbae917579c
fi
echo 'Loading Linux 3.8.0-26-generic ...'
linux /vmlinuz-3.8.0-26-generic root=/dev/mapper/mint--vg-root ro recovery nomodeset
echo 'Loading initial ramdisk ...'
initrd /initrd.img-3.8.0-26-generic
}
menuentry 'LinuxMint GNU/Linux, with Linux 3.8.0-19-generic' --class linuxmint --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-3.8.0-19-generic-advanced-f2ec72a5-1b8c-4dc9-9e22-2aaa3173938a' {
recordfail
load_video
gfxmode $linux_gfx_mode
insmod gzio
insmod part_gpt
insmod ext2
set root='hd0,gpt2'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2 ed56c314-8833-4849-8d04-acbae917579c
else
search --no-floppy --fs-uuid --set=root ed56c314-8833-4849-8d04-acbae917579c
fi
echo 'Loading Linux 3.8.0-19-generic ...'
linux /vmlinuz-3.8.0-19-generic root=/dev/mapper/mint--vg-root ro quiet splash $vt_handoff
echo 'Loading initial ramdisk ...'
initrd /initrd.img-3.8.0-19-generic
}
menuentry 'LinuxMint GNU/Linux, with Linux 3.8.0-19-generic (recovery mode)' --class linuxmint --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-3.8.0-19-generic-recovery-f2ec72a5-1b8c-4dc9-9e22-2aaa3173938a' {
recordfail
load_video
insmod gzio
insmod part_gpt
insmod ext2
set root='hd0,gpt2'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2 ed56c314-8833-4849-8d04-acbae917579c
else
search --no-floppy --fs-uuid --set=root ed56c314-8833-4849-8d04-acbae917579c
fi
echo 'Loading Linux 3.8.0-19-generic ...'
linux /vmlinuz-3.8.0-19-generic root=/dev/mapper/mint--vg-root ro recovery nomodeset
echo 'Loading initial ramdisk ...'
initrd /initrd.img-3.8.0-19-generic
}

me podrias decir lo que tengo que modificar?

gracias por tu ayuda.

Avatar de Usuario
hipersayan_x
Forista Legendario
Forista Legendario
Mensajes: 1905
Registrado: Vie Abr 27, 2007 7:00 am
Contactar:

Re: linux mint no arranca despues de la instalacion

Mensaje por hipersayan_x »

La primera opción es simpre (o casi siempre) la que está por defecto, así que esta entrada:

Código: Seleccionar todo

menuentry 'LinuxMint GNU/Linux' --class linuxmint --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-f2ec72a5-1b8c-4dc9-9e22-2aaa3173938a' {
recordfail
	load_video
	gfxmode $linux_gfx_mode
	insmod gzio
	insmod part_gpt
	insmod ext2
	set root='hd0,gpt2'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2  ed56c314-8833-4849-8d04-acbae917579c
	else
	  search --no-floppy --fs-uuid --set=root ed56c314-8833-4849-8d04-acbae917579c
	fi
	linux	/vmlinuz-3.8.0-26-generic root=/dev/mapper/mint--vg-root ro   quiet splash $vt_handoff
	initrd	/initrd.img-3.8.0-26-generic
}
la cambias por:

Código: Seleccionar todo

menuentry 'LinuxMint GNU/Linux' --class linuxmint --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-f2ec72a5-1b8c-4dc9-9e22-2aaa3173938a' {
recordfail
	load_video
	gfxmode $linux_gfx_mode
	insmod gzio
	insmod part_gpt
	insmod ext2
	set root='hd0,gpt2'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2  ed56c314-8833-4849-8d04-acbae917579c
	else
	  search --no-floppy --fs-uuid --set=root ed56c314-8833-4849-8d04-acbae917579c
	fi
	linux	/vmlinuz-3.8.0-26-generic root=/dev/mapper/mint--vg-root ro   quiet splash nomodeset $vt_handoff
	initrd	/initrd.img-3.8.0-26-generic
}
Desarrollo en Qt: Qt Developer Network
Mis proyectos: github | SourceForge.net

rs1964
Forista Nuevo
Forista Nuevo
Mensajes: 5
Registrado: Jue Jul 04, 2013 9:30 pm

Re: linux mint no arranca despues de la instalacion

Mensaje por rs1964 »

gracias por tu ayuda, pero tampoco esta vez he conseguido que me arranque. voy a probar con otra distribución para ver que pasa.

Editado -- Mar Jul 09, 2013 11:31 am --

finalmente he instalado mint 14 cinnamon y todo ok. un saludo y gracias.

Responder
  • Temas similares
    Respuestas
    Vistas
    Último mensaje