[SOLUCIONADO] Servidor pierde comunicación de forma intermitente

Comentarios sobre el buen funcionamiento del sistema y como personalizarlo a tus necesidades.

Moderadores: doc, mcun

Responder
HRN
Forista Nuevo
Forista Nuevo
Mensajes: 4
Registrado: Vie Ene 22, 2016 8:50 pm

[SOLUCIONADO] Servidor pierde comunicación de forma intermitente

Mensaje por HRN » Mié May 11, 2016 6:13 pm

Hola a todos, en esta ocacion acudo a ustedes para solicitar de su ayuda en algo que me tiene dando vueltas como loco y no puedo solucionar.
Miren, les platico que tengo un problema con un servidor el cual esta con Centos 7 minimal y se accede por SSH. Las cosas raras que presenta son:
1) Desconexiones de SSH de forma repentina:
Cuando estoy conectado por SSH suele pasar que se desconecta de forma intermintente, es decir puede estar funcionando correctamente 5-10 min y se desconecta, despues trato de conectarme de nuevo y tarda como 1 min en volverse a conectar (si hago un ping en ese intervalo el resultado aparcece como si el destino no esta al alcance), pero despues de ese 1min ya se conecta sin problema, y de nuevo puedo trabajar entre 10- 15 o hasta 20 min antes de la porxima desconexion.

2) Desconeccion de todos los servicios:
Aunado al punto anterior me he dado cuenta que no solo es el SSH sino al parecer se desconectan todos los servicios, como son SMB, HTTPD. Es decir que tampoco puedo acceder a mis carpetas compartidas por SMB en otro host, y si habia una descarga en curso o carga de documentos esta se pierde. En cuanto a HTTPD tengo un repositorio web, y tampoco es accesible.

Posible problema
Lo que he realizado para detectar el problema es delimitarlo en partes:
Capa física : He revisado las conexiones de los cables y no hay problemas en la conexión
Problemas de IP: El servidor tiene IP estática configurada, y no he encontrado equipos con IP duplicada

Esto me lleva a pensar que es posible que algo este mal en el propio sistema operativo específicamente estoy dudando si el problema esta en el systemd (que segun tengo entendido es el que administra los demonios del sistema). He consultado el archivo /var/log/messages encontrando algunas lineas raras o que desconozco como son, de todos modos adjunto mi archivo messages el cual es del dia 5 de mayo.

Apr 5 14:37:01 funkserver systemd: Removed slice user-0.slice.
Apr 5 14:37:01 funkserver systemd: Stopping user-0.slice.

Espero me puedan ayudar. Saludos
Adjuntos
messages20160505.txt
Archivo messages 05-05-2016
(7.58 KiB) Descargado 33 veces
Última edición por HRN el Mar May 17, 2016 7:58 pm, editado 1 vez en total.
Avatar de Usuario
neurus
Forista Legendario
Forista Legendario
Mensajes: 1807
Registrado: Dom Oct 10, 2004 7:00 am

Re: Servidor pierde comunicación de forma intermitente

Mensaje por neurus » Mié May 11, 2016 7:22 pm

Ahora no puedo revisar el log.
Sin embargo, lo que cuentas me suena mucho más a problemas con la capa física. Sé que afirmas haber controlado ese punto, pero no veo que menciones uno de los controles más básicos en estos casos: probar otra placa de red. Supongo que tienes o puedes adquirir una placa de red barata y probar si sigue ocurriendo. Las placas onboard (sobre todo las sis900, si es que todavía existen) suelen hacer exactamente lo que describes.
HRN
Forista Nuevo
Forista Nuevo
Mensajes: 4
Registrado: Vie Ene 22, 2016 8:50 pm

Re: Servidor pierde comunicación de forma intermitente

Mensaje por HRN » Mié May 11, 2016 8:03 pm

neurus escribió:Ahora no puedo revisar el log.
Sin embargo, lo que cuentas me suena mucho más a problemas con la capa física. Sé que afirmas haber controlado ese punto, pero no veo que menciones uno de los controles más básicos en estos casos: probar otra placa de red. Supongo que tienes o puedes adquirir una placa de red barata y probar si sigue ocurriendo. Las placas onboard (sobre todo las sis900, si es que todavía existen) suelen hacer exactamente lo que describes.
Hola neurus gracias por responder, buen punto eso de revisar la tarjeta de red, pase por alto ese punto y me limite a revisar los cables, voy a checar esta recomendación que me das, aprovechare que la tarjeta de red es de 2 puertos para ver si la otra salida funciona bien. Como comentario mi server es un HP Proliant Microserver Gen8 .

Pero si puedes darle una revisada al archivo log en algún tiempo libre que tengas te lo agradeceré mucho igual hay algo ahí, la verdad aun no interpretar mucho algunos logs, y por lo mismo quizá sospecho de algunos mensajes que aparecen ahí. Buen dia colega.
Responder
  • Similar Topics
    Respuestas
    Vistas
    Último mensaje