[SOLUCIONADO] Macros que desaparecen en LibreOffice

Comentarios sobre el buen funcionamiento del sistema y como personalizarlo a tus necesidades.

Moderadores: doc, mcun

Responder
Silo
Forista Nuevo
Forista Nuevo
Mensajes: 14
Registrado: Jue Ago 22, 2019 2:58 pm

[SOLUCIONADO] Macros que desaparecen en LibreOffice

Mensaje por Silo » Dom Nov 03, 2019 11:15 pm

Hola gente, mis saludos para todos.

Resulta que me está pasando algo muy raro con LibreOfficeCalc y es que me borra las macros que grabo, os explico...

Tengo una hoja de cálculos en la cual estoy usando una macro y ésta es activada por un botón de formulario.

Resulta que de repente, al hacer clic en el botón, me envía un error informando de que la macro no existe en la ubicación indicada, el caso es que voy a dicha ubicación y ciertamente la macro ha desaparecido, acto seguido, me pongo a buscarla a ver si se ha movido a otra rama pero no hay señales de ella.

Luego de esto, la vuelvo a grabarla (con la opción "Grabar Macro") y la guardo con el mismo nombre en la que le tengo asignado al botón y todo vuelve a la normalidad, funciona perfectamente, sin embargo cuando vuelvo a encender el ordenador o cuando vuelvo a cargar LibreOfficeCalc, la macro ha vuelto a desaparecer, el botón me vuelve a enviar el mismo mensaje de error.

La versión de mi SO es Linux Ming 19 y la versión de Libreoffice calces: 6.0.7.3

Lo raro es que antes todo iba bien y la macro estaba en su sitio cada vez que usaba la hoja de cálculos, pero ahora ha empezado a darme ese fallo y no tengo idea de por qué :shock:

¿Alguien me podría echar una mano a ver si detectamos el fallo?, desde ya muchas gracias de antemano.
Última edición por Silo el Jue Nov 07, 2019 3:55 pm, editado 1 vez en total.
Silo
Forista Nuevo
Forista Nuevo
Mensajes: 14
Registrado: Jue Ago 22, 2019 2:58 pm

Re: Macros que desaparecen en LibreOffice

Mensaje por Silo » Jue Nov 07, 2019 3:53 pm

Hola a todos.

Como nadie me respondió, lo hago yo y así me siento un poco mejor :) :) :) .

Bueno, fuera de broma, si a alguien le ha pasado lo mismo que a mí, ya he encontrado la solución y la describo a continuación.

Resulta que en mi Linux Mint 19 tengo instalado un programita que se llama BleachBit (para el que no lo conozca, éste se encarga de eliminar archivos obsoletos que encuentre en el equipo muy similar a Ccleaner en Windows), y lo ejecutaba en cada inicio y la macro volvía a desaparecer.

Lo que hice fue empezar a ver todos los archivos que borraba, encontré conque entre ellos borraba el historial y la caché de LibreOffice y cada vez que hacía limpieza, la macro desaparecía, así es que desactivé todo lo relacionado con LibreOffice en BleachBit y ahora ya no ha vuelto a suceder.

Espero que esto le sirva de ayuda a alguien.

Un saludo a todos.
Avatar de Usuario
amanecer
Forista Nuevo
Forista Nuevo
Mensajes: 47
Registrado: Sab Ago 31, 2019 12:36 pm

Re: [SOLUCIONADO] Macros que desaparecen en LibreOffice

Mensaje por amanecer » Jue Nov 07, 2019 4:30 pm

Interesante.
en otro tema había leído que hay que utilizar Bleachbit, ccleaner y similares con precaución.
Portátil Lenovo thinkpad T460, i5, 8GB Ram, gráfica intel HD 520 - Linux Mint 19.x Cinnamon
Responder
  • Similar Topics
    Respuestas
    Vistas
    Último mensaje