Paquetes rotos tras actualizar a Kali rolling

Comentarios sobre el buen funcionamiento del sistema y como personalizarlo a tus necesidades.

Moderadores: doc, mcun

Responder
ivanowski
Forista Nuevo
Forista Nuevo
Mensajes: 3
Registrado: Vie Sep 30, 2016 5:10 pm

Paquetes rotos tras actualizar a Kali rolling

Mensaje por ivanowski » Sab Oct 01, 2016 3:09 pm

Hola, hace una semana aproximadamente empecé a ver que tenía problemas a la hora de usar apt-get, intenté instalar gedit en mi Kali linux pero decía que el paquete no tenía candidato, después de rebuscar un poco me enteré de la nueva "versión" Kali rolling, en la que a parte de las mejoras correspondientes parecía que me iba a tener que olvidar un poco de actualizar continuamente.
Cambié el sources.list por "deb http://http.kali.org/kali kali-rolling main contrib non-free" y actualicé. Algo debí de hacer mal porque el entorno gráfico no iniciaba. Probando algunas cosas desde la consola (alt+f2) acabé haciendo "dpkg --configure -a" y para mi sorpresa el entorno gráfico inició (pensaba que iba a tener que sacar todos los datos y hacer una reinstalación completa). El caso es que ahora, aunque puedo entrar, hay muchas cosas que no funcionan (no aparecen los archivos en el escritorio, no puedo acceder a las configuraciones de pantalla, no funciona el "click" en el touchpad táctil...) y tengo lo que parece ser un grave problema de paquetes rotos.
Al intentar usar apt-get o incluso dpkg me salen muchos errores, los muestro a continuación.

apt-get upgrade

Código: Seleccionar todo

Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Tal vez quiera ejecutar «apt-get -f install» para corregirlo.
Los siguientes paquetes tienen dependencias incumplidas:
 amarok : Depende: amarok-common (= 2.8.0-2.1) pero 2.8.0-5 está instalado
 aptitude : Depende: libsigc++-2.0-0c2a (>= 2.2.0) pero no es instalable
            Recomienda: aptitude-doc-en pero no está instalado o
                        aptitude-doc
 gnome-contacts : Depende: libcheese-gtk25 (>= 3.18.0) pero no está instalado
                  Depende: libcheese8 (>= 3.18.0) pero no está instalado
 gnome-control-center : Depende: libcheese-gtk25 (>= 3.18.0) pero no está instalado
                        Depende: libcheese8 (>= 3.18.0) pero no está instalado
                        Depende: libclutter-1.0-0 (>= 1.23.4) pero 1.20.0-1 está instalado
                        Depende: libgoa-1.0-0b (>= 3.16.2) pero 3.14.2-1 está instalado
                        Depende: libgrilo-0.3-0 (>= 0.3.0) pero no está instalado
                        Depende: libnma0 (>= 1.1.90) pero no está instalado
                        Recomienda: rygel pero no está instalado o
                                    rygel-tracker pero no está instalado
                        Recomienda: system-config-printer-common (>= 1.4) pero no está instalado
                        Recomienda: libnss-myhostname pero no está instalado
                        Recomienda: cracklib-runtime
                        Recomienda: pulseaudio-module-bluetooth pero no está instalado
                        Recomienda: realmd pero no está instalado
 gnome-system-monitor : Depende: libglibmm-2.4-1c2a (>= 2.42.0) pero no es instalable
                        Depende: libgtkmm-3.0-1 (>= 3.14.0) pero no es instalable
                        Depende: libsigc++-2.0-0c2a (>= 2.2.0) pero no es instalable
 gparted : Depende: libatkmm-1.6-1 (>= 2.22.1) pero no es instalable
           Depende: libglibmm-2.4-1c2a (>= 2.42.0) pero no es instalable
           Depende: libpangomm-1.4-1 (>= 2.27.1) pero no es instalable
           Depende: libsigc++-2.0-0c2a (>= 2.2.0) pero no es instalable
 gstreamer1.0-plugins-bad : Depende: libgstreamer-plugins-bad1.0-0 (= 1.4.4-2.1+b1) pero 1.8.3-1+b2 está instalado
                            Depende: libopencv-calib3d2.4 pero no es instalable
                            Depende: libopencv-contrib2.4 pero no es instalable
                            Depende: libopencv-core2.4 pero no es instalable
                            Depende: libopencv-highgui2.4 pero no es instalable
                            Depende: libopencv-imgproc2.4 pero no es instalable
                            Depende: libopencv-legacy2.4 pero no es instalable
                            Depende: libopencv-objdetect2.4 pero no es instalable
                            Depende: libopencv-video2.4 pero no es instalable
 libcairo2-dev : Depende: libcairo2 (= 1.14.6-1+b1) pero 1.14.0-2.1 está instalado
                 Depende: libcairo-script-interpreter2 (= 1.14.6-1+b1) pero 1.14.0-2.1 está instalado
 libcwidget3 : Depende: libsigc++-2.0-0c2a (>= 2.2.0) pero no es instalable
 libgdk-pixbuf2.0-dev : Depende: libpng-dev (>= 1.6)
                        Depende: libpng-dev (< 1.7)
 libglademm-2.4-1c2a : Depende: libatkmm-1.6-1 (>= 2.22.1) pero no es instalable
                       Depende: libcairomm-1.0-1 (>= 1.6.4) pero no es instalable
                       Depende: libglibmm-2.4-1c2a (>= 2.40.0) pero no es instalable
                       Depende: libpangomm-1.4-1 (>= 2.27.1) pero no es instalable
                       Depende: libsigc++-2.0-0c2a (>= 2.2.0) pero no es instalable
 libgmp-dev : Depende: libgmpxx4ldbl (= 2:6.1.1+dfsg-1) pero 2:6.0.0+dfsg-6 está instalado
 libgstreamer-plugins-bad1.0-0 : Depende: libgstreamer-plugins-base1.0-0 (>= 1.8.0) pero 1.4.4-2 está instalado
                                 Depende: libgstreamer1.0-0 (>= 1.8.0) pero 1.4.4-2 está instalado
 libgtkmm-2.4-1c2a : Depende: libatkmm-1.6-1 (>= 2.22.1) pero no es instalable
                     Depende: libcairomm-1.0-1 (>= 1.6.4) pero no es instalable
                     Depende: libglibmm-2.4-1c2a (>= 2.40.0) pero no es instalable
                     Depende: libpangomm-1.4-1 (>= 2.27.1) pero no es instalable
                     Depende: libsigc++-2.0-0c2a (>= 2.2.0) pero no es instalable
 mysql-server-5.5 : Depende: mysql-client-5.5 (>= 5.5.50-0+deb8u1) pero no es instalable
                    Depende: mysql-server-core-5.5 (>= 5.5.50-0+deb8u1) pero no es instalable
 paman : Depende: libcairomm-1.0-1 (>= 1.4.0) pero no es instalable
         Depende: libglibmm-2.4-1c2a (>= 2.14.0) pero no es instalable
         Depende: libsigc++-2.0-0c2a (>= 2.0.2) pero no es instalable
 pavucontrol : Depende: libatkmm-1.6-1 (>= 2.22.1) pero no es instalable
               Depende: libcairomm-1.0-1 (>= 1.6.4) pero no es instalable
               Depende: libglibmm-2.4-1c2a (>= 2.42.0) pero no es instalable
               Depende: libgtkmm-3.0-1 (>= 3.14.0) pero no es instalable
               Depende: libpangomm-1.4-1 (>= 2.27.1) pero no es instalable
               Depende: libsigc++-2.0-0c2a (>= 2.2.0) pero no es instalable
 pavumeter : Depende: libatkmm-1.6-1 (>= 2.22.1) pero no es instalable
             Depende: libcairomm-1.0-1 (>= 1.6.4) pero no es instalable
             Depende: libglibmm-2.4-1c2a (>= 2.31.22) pero no es instalable
             Depende: libpangomm-1.4-1 (>= 2.27.1) pero no es instalable
             Depende: libsigc++-2.0-0c2a (>= 2.0.2) pero no es instalable
E: Dependencias incumplidas. Pruebe de nuevo utilizando -f.
Con apt-get -f upgrade ocurre lo mismo
Al principio dice "Tal vez quiera ejecutar «apt-get -f install» para corregirlo." Pero al usarlo sale ésto

Código: Seleccionar todo

Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Corrigiendo dependencias... falló.
Los siguientes paquetes tienen dependencias incumplidas:
 amarok : Depende: amarok-common (= 2.8.0-2.1) pero 2.8.0-5 está instalado
 aptitude : Depende: libsigc++-2.0-0c2a (>= 2.2.0) pero no es instalable
            Recomienda: aptitude-doc-en pero no está instalado o
                        aptitude-doc
 gnome-contacts : Depende: libcheese-gtk25 (>= 3.18.0) pero no está instalado
                  Depende: libcheese8 (>= 3.18.0) pero no está instalado
 gnome-control-center : Depende: libcheese-gtk25 (>= 3.18.0) pero no está instalado
                        Depende: libcheese8 (>= 3.18.0) pero no está instalado
                        Depende: libclutter-1.0-0 (>= 1.23.4) pero 1.20.0-1 está instalado
                        Depende: libgoa-1.0-0b (>= 3.16.2) pero 3.14.2-1 está instalado
                        Depende: libgrilo-0.3-0 (>= 0.3.0) pero no está instalado
                        Depende: libnma0 (>= 1.1.90) pero no está instalado
                        Recomienda: rygel pero no está instalado o
                                    rygel-tracker pero no está instalado
                        Recomienda: system-config-printer-common (>= 1.4) pero no está instalado
                        Recomienda: libnss-myhostname pero no está instalado
                        Recomienda: cracklib-runtime
                        Recomienda: pulseaudio-module-bluetooth pero no está instalado
                        Recomienda: realmd pero no está instalado
 gnome-system-monitor : Depende: libglibmm-2.4-1c2a (>= 2.42.0) pero no es instalable
                        Depende: libgtkmm-3.0-1 (>= 3.14.0) pero no es instalable
                        Depende: libsigc++-2.0-0c2a (>= 2.2.0) pero no es instalable
 gparted : Depende: libatkmm-1.6-1 (>= 2.22.1) pero no es instalable
           Depende: libglibmm-2.4-1c2a (>= 2.42.0) pero no es instalable
           Depende: libpangomm-1.4-1 (>= 2.27.1) pero no es instalable
           Depende: libsigc++-2.0-0c2a (>= 2.2.0) pero no es instalable
 gstreamer1.0-plugins-bad : Depende: libgstreamer-plugins-bad1.0-0 (= 1.4.4-2.1+b1) pero 1.8.3-1+b2 está instalado
                            Depende: libopencv-calib3d2.4 pero no es instalable
                            Depende: libopencv-contrib2.4 pero no es instalable
                            Depende: libopencv-core2.4 pero no es instalable
                            Depende: libopencv-highgui2.4 pero no es instalable
                            Depende: libopencv-imgproc2.4 pero no es instalable
                            Depende: libopencv-legacy2.4 pero no es instalable
                            Depende: libopencv-objdetect2.4 pero no es instalable
                            Depende: libopencv-video2.4 pero no es instalable
 libcairo2-dev : Depende: libcairo2 (= 1.14.6-1+b1) pero 1.14.0-2.1 está instalado
                 Depende: libcairo-script-interpreter2 (= 1.14.6-1+b1) pero 1.14.0-2.1 está instalado
 libcwidget3 : Depende: libsigc++-2.0-0c2a (>= 2.2.0) pero no es instalable
 libgdk-pixbuf2.0-dev : Depende: libpng-dev (>= 1.6)
                        Depende: libpng-dev (< 1.7)
 libglademm-2.4-1c2a : Depende: libatkmm-1.6-1 (>= 2.22.1) pero no es instalable
                       Depende: libcairomm-1.0-1 (>= 1.6.4) pero no es instalable
                       Depende: libglibmm-2.4-1c2a (>= 2.40.0) pero no es instalable
                       Depende: libpangomm-1.4-1 (>= 2.27.1) pero no es instalable
                       Depende: libsigc++-2.0-0c2a (>= 2.2.0) pero no es instalable
 libgmp-dev : Depende: libgmpxx4ldbl (= 2:6.1.1+dfsg-1) pero 2:6.0.0+dfsg-6 está instalado
 libgstreamer-plugins-bad1.0-0 : Depende: libgstreamer-plugins-base1.0-0 (>= 1.8.0) pero 1.4.4-2 está instalado
                                 Depende: libgstreamer1.0-0 (>= 1.8.0) pero 1.4.4-2 está instalado
 libgtkmm-2.4-1c2a : Depende: libatkmm-1.6-1 (>= 2.22.1) pero no es instalable
                     Depende: libcairomm-1.0-1 (>= 1.6.4) pero no es instalable
                     Depende: libglibmm-2.4-1c2a (>= 2.40.0) pero no es instalable
                     Depende: libpangomm-1.4-1 (>= 2.27.1) pero no es instalable
                     Depende: libsigc++-2.0-0c2a (>= 2.2.0) pero no es instalable
 mysql-server-5.5 : Depende: mysql-client-5.5 (>= 5.5.50-0+deb8u1) pero no es instalable
                    Depende: mysql-server-core-5.5 (>= 5.5.50-0+deb8u1) pero no es instalable
 paman : Depende: libcairomm-1.0-1 (>= 1.4.0) pero no es instalable
         Depende: libglibmm-2.4-1c2a (>= 2.14.0) pero no es instalable
         Depende: libsigc++-2.0-0c2a (>= 2.0.2) pero no es instalable
 pavucontrol : Depende: libatkmm-1.6-1 (>= 2.22.1) pero no es instalable
               Depende: libcairomm-1.0-1 (>= 1.6.4) pero no es instalable
               Depende: libglibmm-2.4-1c2a (>= 2.42.0) pero no es instalable
               Depende: libgtkmm-3.0-1 (>= 3.14.0) pero no es instalable
               Depende: libpangomm-1.4-1 (>= 2.27.1) pero no es instalable
               Depende: libsigc++-2.0-0c2a (>= 2.2.0) pero no es instalable
 pavumeter : Depende: libatkmm-1.6-1 (>= 2.22.1) pero no es instalable
             Depende: libcairomm-1.0-1 (>= 1.6.4) pero no es instalable
             Depende: libglibmm-2.4-1c2a (>= 2.31.22) pero no es instalable
             Depende: libpangomm-1.4-1 (>= 2.27.1) pero no es instalable
             Depende: libsigc++-2.0-0c2a (>= 2.0.2) pero no es instalable
E: Error, pkgProblemResolver::Resolve generó cortes, esto puede deberse a paquetes retenidos.
E: No se pueden corregir las dependencias
he probado también cosas como --fix-missing obteniendo resultados parecidos

dpkg --configure -a

Código: Seleccionar todo

dpkg: problemas de dependencias impiden la configuración de libgmp-dev:amd64:
 libgmp-dev:amd64 depende de libgmpxx4ldbl (= 2:6.1.1+dfsg-1); sin embargo:
  La versión de `libgmpxx4ldbl:amd64' en el sistema es 2:6.0.0+dfsg-6.

dpkg: error al procesar el paquete libgmp-dev:amd64 (--configure):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de libcairo2-dev:
 libcairo2-dev depende de libcairo2 (= 1.14.6-1+b1); sin embargo:
  La versión de `libcairo2:amd64' en el sistema es 1.14.0-2.1.
 libcairo2-dev depende de libcairo-script-interpreter2 (= 1.14.6-1+b1); sin embargo:
  La versión de `libcairo-script-interpreter2:amd64' en el sistema es 1.14.0-2.1.

dpkg: error al procesar el paquete libcairo2-dev (--configure):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de libgtk2.0-dev:
 libgtk2.0-dev depende de libcairo2-dev (>= 1.6.4-6.1); sin embargo:
 El paquete `libcairo2-dev' no está configurado todavía.

dpkg: error al procesar el paquete libgtk2.0-dev (--configure):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de gnome-control-center:
 gnome-control-center depende de libcheese-gtk25 (>= 3.18.0); sin embargo:
  El paquete `libcheese-gtk25' no está instalado.
 gnome-control-center depende de libcheese8 (>= 3.18.0); sin embargo:
  El paquete `libcheese8' no está instalado.
 gnome-control-center depende de libclutter-1.0-0 (>= 1.23.4); sin embargo:
  La versión de `libclutter-1.0-0:amd64' en el sistema es 1.20.0-1.
 gnome-control-center depende de libgoa-1.0-0b (>= 3.16.2); sin embargo:
  La versión de `libgoa-1.0-0b:amd64' en el sistema es 3.14.2-1.
 gnome-control-center depende de libgrilo-0.3-0 (>= 0.3.0); sin embargo:
  El paquete `libgrilo-0.3-0' no está instalado.
 gnome-control-center depende de libnma0 (>= 1.1.90); sin embargo:
  El paquete `libnma0' no está instalado.

dpkg: error al procesar el paquete gnome-control-center (--configure):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de gnome-contacts:
 gnome-contacts depende de libcheese-gtk25 (>= 3.18.0); sin embargo:
  El paquete `libcheese-gtk25' no está instalado.
 gnome-contacts depende de libcheese8 (>= 3.18.0); sin embargo:
  El paquete `libcheese8' no está instalado.

dpkg: error al procesar el paquete gnome-contacts (--configure):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de libgstreamer-plugins-bad1.0-0:amd64:
 libgstreamer-plugins-bad1.0-0:amd64 depende de libgstreamer-plugins-base1.0-0 (>= 1.8.0); sin embargo:
  La versión de `libgstreamer-plugins-base1.0-0:amd64' en el sistema es 1.4.4-2.
 libgstreamer-plugins-bad1.0-0:amd64 depende de libgstreamer1.0-0 (>= 1.8.0); sin embargo:
  La versión de `libgstreamer1.0-0:amd64' en el sistema es 1.4.4-2.

dpkg: error al procesar el paquete libgstreamer-plugins-bad1.0-0:amd64 (--configure):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de libgdk-pixbuf2.0-dev:
 libgdk-pixbuf2.0-dev depende de libpng-dev (>= 1.6); sin embargo:
  El paquete `libpng-dev' no está instalado.
  La versión de `libpng-dev' en el sistema, proveída por libpng12-dev:amd64, es <ninguna>.
 libgdk-pixbuf2.0-dev depende de libpng-dev (<< 1.7); sin embargo:
  El paquete `libpng-dev' no está instalado.
  La versión de `libpng-dev' en el sistema, proveída por libpng12-dev:amd64, es <ninguna>.

dpkg: error al procesar el paquete libgdk-pixbuf2.0-dev (--configure):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de libpango1.0-dev:
 libpango1.0-dev depende de libcairo2-dev (>= 1.12.10); sin embargo:
 El paquete `libcairo2-dev' no está configurado todavía.

dpkg: error al procesar el paquete libpango1.0-dev (--configure):
 problemas de dependencias - se deja sin configurar
Se encontraron errores al procesar:
 libgmp-dev:amd64
 libcairo2-dev
 libgtk2.0-dev
 gnome-control-center
 gnome-contacts
 libgstreamer-plugins-bad1.0-0:amd64
 libgdk-pixbuf2.0-dev
 libpango1.0-dev

Siempre intento solucionar mis errores yo solo para aprender, pero para el nivel que tengo en linux ahora mismo todo ésto me viene algo grande, por eso pido ayuda, a ver si alguien me puede orientar. He intentado algunas cosas más, sin resultado, incluso estoy leyendo sobre la reparación manual mediante aptitude o algo por el estilo.
Gracias por adelantado, un saludo!
Responder
  • Similar Topics
    Respuestas
    Vistas
    Último mensaje