Error en sinaptyc y gestor actualizaciones linux mint

Comentarios sobre el buen funcionamiento del sistema y como personalizarlo a tus necesidades.

Moderadores: doc, mcun

Responder
Avatar de Usuario
clamide
Forista Medio
Forista Medio
Mensajes: 298
Registrado: Dom Mar 25, 2007 8:00 am

Error en sinaptyc y gestor actualizaciones linux mint

Mensaje por clamide » Vie Ago 17, 2012 10:47 am

Hola a todos:
Tengo el siguiente mensaje de error con el sinaptyc y con el gestor de actualizaciones:

Código: Seleccionar todo

E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_precise-security_main_i18n_Translation-en
E: No se pudieron analizar o abrir las listas de paquetes o el archivo de estado.
E: _cache->open() failed, please report.
Hasta ahora había empleado los siguientes códigos para solucionarlo:

Código: Seleccionar todo

sudo rm /var/lib/apt/lists/* -vf
y

Código: Seleccionar todo

sudo rm /var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_oneiric-security_main_i18n_Translation-en
...pero esta vez no están surtiendo efecto.
¿Algún alma bondadosa puede echarme una mano?

Gracias y saludos.
Última edición por Yoyo el Vie Ago 17, 2012 10:47 am, editado 1 vez en total.
Razón: Tema movido al foro Sistema por pertenecer mejor a esta temática
Avatar de Usuario
Fanton
Forista Distinguido
Forista Distinguido
Mensajes: 1339
Registrado: Jue Ene 08, 2009 8:00 am
Ubicación: Magdalena [Argentina]
Contactar:

Re: Error en sinaptyc y gestor actualizaciones linux mint

Mensaje por Fanton » Vie Ago 17, 2012 11:41 am

probaste limpiando el cahe

sudo aptitude autoclean && sudo aptitude update
Diplomacia, es el arte de saber lo que no se debe decir...
_________________
Hardware: Intel i5-3570k | ASUS P8H77-M |HD [500GB] [1 TB] | Ram 8 GB | GPU: Nvidia GeForce 210/1 GB
S.O. Debian@testing x86_64 Openbox
Linux user #506272
Avatar de Usuario
niky45
Forista Ancestral
Forista Ancestral
Mensajes: 9186
Registrado: Jue Abr 12, 2007 7:00 am
Ubicación: tras la pantalla (...)
Contactar:

Re: Error en sinaptyc y gestor actualizaciones linux mint

Mensaje por niky45 » Vie Ago 17, 2012 3:02 pm

que tienes en el sources.list?? (via pastie.org, porfa, que el medico me ha dicho que no abuse del scroll. ;) )
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]
Avatar de Usuario
clamide
Forista Medio
Forista Medio
Mensajes: 298
Registrado: Dom Mar 25, 2007 8:00 am

Re: Error en sinaptyc y gestor actualizaciones linux mint

Mensaje por clamide » Vie Ago 17, 2012 6:52 pm

Esto es lo que tengo en mis sources list (no sé lo que es pasti-org, sorry):

Código: Seleccionar todo

deb http://linux-mint.froonix.org/ maya main upstream import
deb http://archive.ubuntu.com/ubuntu/ precise main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ precise-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ precise-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ precise partner
deb http://packages.medibuntu.org/ precise free non-free

deb http://archive.getdeb.net/ubuntu precise-getdeb apps
# deb http://archive.getdeb.net/ubuntu precise-getdeb games
deb http://ppa.launchpad.net/webupd8team/y-ppa-manager/ubuntu oneiric main
deb-src http://ppa.launchpad.net/webupd8team/y-ppa-manager/ubuntu oneiric main
deb http://archive.getdeb.net/ubuntu lucid-getdeb apps
deb http://archive.getdeb.net/ubuntu lucid-getdeb games

deb http://packages.unknown-horizons.org/lucid weekly main
Avatar de Usuario
Yoyo
Administrador
Administrador
Mensajes: 3125
Registrado: Mar Jun 06, 2006 7:00 am
Ubicación: España
Contactar:

Re: Error en sinaptyc y gestor actualizaciones linux mint

Mensaje por Yoyo » Vie Ago 17, 2012 7:36 pm

¿Por qué tienes repositorios de dos ubuntu distintos? precise que es el último y lucid que ya queda muy atrás...

Debería darte conflictos, sos dos versiones muy alejadas con distintas versiones de paquetes....

¿y que tienes en /etc/apt/sources.list.d/?
Avatar de Usuario
clamide
Forista Medio
Forista Medio
Mensajes: 298
Registrado: Dom Mar 25, 2007 8:00 am

Re: Error en sinaptyc y gestor actualizaciones linux mint

Mensaje por clamide » Vie Ago 17, 2012 9:20 pm

Esto es lo que tengo en el sources.list.d:
  • google-earth.list
    google-earth.list.save
    google-talkplugin.list
    google-talkplugin.list.save
    jd-team-jdownloader-precise.list
    jd-team-jdownloader-precise.list.save
    local-repository.list
    local-repository.list.save
    pj-assis-ppa-precise.list
    pj-assis-ppa-precise.list.save
    rvm-smplayer-precise.list
    rvm-smplayer-precise.list.save
    skype.list
    skype.list.save
    synapse-core-ppa-precise.list
    synapse-core-ppa-precise.list.save
    thebernmeister-indicator-ppa-download-statistics-precise.list.save
    videolan-stable-daily-precise.list
    videolan-stable-daily-precise.list.save
    webupd8team-y-ppa-manager-precise.list
    webupd8team-y-ppa-manager-precise.list.save
¿Para quitar lo de lucid, simplemente lo borro?
Avatar de Usuario
Yoyo
Administrador
Administrador
Mensajes: 3125
Registrado: Mar Jun 06, 2006 7:00 am
Ubicación: España
Contactar:

Re: Error en sinaptyc y gestor actualizaciones linux mint

Mensaje por Yoyo » Vie Ago 17, 2012 10:02 pm

clamide escribió:¿Para quitar lo de lucid, simplemente lo borro?
No lo borres, simplemente desactívalos.

Delante de cada repositorio que no vayas a utilizar, ejemplo los de lucid, le pones una almohadilla delante (#) lo que se llama comentar un repositorio

Ejemplo de como debes dejarlos:

Código: Seleccionar todo

#deb http://archive.getdeb.net/ubuntu lucid-getdeb apps
Con eso el sistema ya no los lee/usa

Ahora entra a Nautilus como root, vas a la ruta /etc/apt/sources.list.d/ y borra todos los archivos de repositorios .list que acaben en .save

Ojo!!! no te equivoques, solo los que acaban en .save como el google-earth.list.save, rvm-smplayer-precise.list.save etc etc...

Si borras alguno de los que no acaban en .save simplemente te quedarás sin repo y tendrías que volver a agregarlo, es solo eso.

Luego de esto vuelve a ejecutar

Código: Seleccionar todo

sudo apt-get update && sudo apt-get upgrade
Lo que no me explico es por que agregáis tantos repositorios de terceros, tienes una barbaridad. Si ubuntu y Mint con los suyos propios tienen de todo.

Como te vea niky45 con tantos repos de terceros es capaz de pegarte ;)

Un saludo
Avatar de Usuario
niky45
Forista Ancestral
Forista Ancestral
Mensajes: 9186
Registrado: Jue Abr 12, 2007 7:00 am
Ubicación: tras la pantalla (...)
Contactar:

Re: Error en sinaptyc y gestor actualizaciones linux mint

Mensaje por niky45 » Vie Ago 17, 2012 11:46 pm

(completamente offtopic)
Yoyo escribió:Como te vea niky45 con tantos repos de terceros es capaz de pegarte ;)
::lol:: no se que me han dado mas ganas, si de decirle "quillo que leches haces con tantos repos" (aka, ponerme a chillar yo sola al ver el... espectaculo :shock: ), o de mandarle esto ( http://lmgtfy.com/?q=pastie.org ), por aquello:
clamide escribió:(no sé lo que es pasti-org, sorry)
menos mal que no tenia el sources tipico de ubuntu.... que si no el medico se hubiera enfadado conmigo.

definitivamente, tengo un problema. :oops:

centrandome en el tema, y leyendo detenidamente.... lo que esta dando problemas es esto:

Código: Seleccionar todo

deb http://ppa.launchpad.net/webupd8team/y-ppa-manager/ubuntu oneiric main
deb-src http://ppa.launchpad.net/webupd8team/y-ppa-manager/ubuntu oneiric main
comentalos, y prueba otra vez. :wink:
por cierto, ya por curiosidad, de que son?? :shock:

(inevitable offtopic) sigo sin saber como la gente se aclara con tanto repo. si en los oficiales esta TOOODO lo imaginable!! por dios, ubuntu tiene oficialmente (universe y multiverse incluidos) 44850 paquetes!!

Código: Seleccionar todo

506 >>> wc -l allpackages\?format\=txt 
44856 allpackages?format=txt
# las primeras lineas son informativas, pero me dan igual 6 paquetes mas que 6 menos... 
(EDIT - aun mas offtopic) debian wheezy, sin contar contrib y non-free * (lo siento, me ha podido la curiosidad.... ):

Código: Seleccionar todo

509 >>> wc -l allpackages\?format\=txt 
49395 allpackages?format=txt
it's debian. 8-)

*parece que si... repos completos (mi sources )

Código: Seleccionar todo

513 >>> aptitude search ~T |wc -l
49691
PD: si, me aburro, no tengo nada mejor que hacer. :oops:
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]
Avatar de Usuario
Yoyo
Administrador
Administrador
Mensajes: 3125
Registrado: Mar Jun 06, 2006 7:00 am
Ubicación: España
Contactar:

Re: Error en sinaptyc y gestor actualizaciones linux mint

Mensaje por Yoyo » Sab Ago 18, 2012 12:09 am

No me había dado cuenta que también había repos de ubuntu oneiric, sigue siendo anterior, el actual es precise y linux mint maya se basa en precise, si no me equivoco.

Por cierto, niky45, clamide es chica y no chico ;)

clamide... no puedes mezclar repositorios de distintas ramas de ubuntu en tu linux mint maya que se basa en ubuntu 12.04 precise

El de webupd8 tiene repos ppa para precise así que no se por que usas los de oneiric

Juer con los nombrecitos de ubuntu, jolines....

Offtopiqueando:

niky45, ¿por que tus repos terminan en non-free contrib cuando de toda la vida ha sido contrib non-free? respetemos las costumbres por el bien de la Debienidad.
Avatar de Usuario
clamide
Forista Medio
Forista Medio
Mensajes: 298
Registrado: Dom Mar 25, 2007 8:00 am

Re: Error en sinaptyc y gestor actualizaciones linux mint

Mensaje por clamide » Sab Ago 18, 2012 11:50 am

Yoyo, Niky...he hecho lo que me habéis recomendado y parece que el sistema está actualizado correctamente ...aunque el terminal sigue diciéndome lo siguiente al final:

Código: Seleccionar todo

W: Error de GPG: http://ppa.launchpad.net precise Release: Las siguientes firms fueron inválidas: BADSIG E4010F076C2225A4 Launchpad PPA for Synapse core team
W: Imposible obtener http://download.skype.com/linux/repos/debian/dists/stable/Release.gpg  Mala línea de cabecera [IP: 195.57.81.57 80]

W: Imposible obtener http://security.ubuntu.com/ubuntu/dists/precise-security/multiverse/binary-i386/Packages  404  Not Found [IP: 91.189.92.190 80]

W: Imposible obtener http://download.skype.com/linux/repos/debian/dists/stable/non-free/binary-i386/Packages  0  Not Found [IP: 195.57.81.57 80]

W: Imposible obtener http://download.skype.com/linux/repos/debian/dists/stable/non-free/i18n/Translation-es  Mala línea de cabecera [IP: 195.57.81.57 80]

W: Imposible obtener http://archive.canonical.com/ubuntu/dists/precise/partner/i18n/Translation-es_ES  Mala línea de cabecera [IP: 91.189.92.150 80]

W: Imposible obtener http://archive.canonical.com/ubuntu/dists/precise/partner/i18n/Translation-es  Mala línea de cabecera [IP: 91.189.92.150 80]

W: Imposible obtener http://dl.google.com/linux/earth/deb/dists/stable/main/i18n/Translation-es_ES  Obtuve una sola línea de cabecera arriba de 360 caracteres [IP: 173.194.34.3 80]

W: Imposible obtener http://dl.google.com/linux/earth/deb/dists/stable/main/i18n/Translation-es  Obtuve una sola línea de cabecera arriba de 360 caracteres [IP: 173.194.34.3 80]

W: Imposible obtener gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_precise-updates_main_binary-i386_Packages  La suma hash difiere

W: Imposible obtener http://packages.unknown-horizons.org/lucid/dists/weekly/main/binary-i386/Packages  404  Not Found

W: Imposible obtener http://linux-mint.froonix.org/dists/maya/import/i18n/Translation-es_ES  Mala línea de cabecera

W: Imposible obtener http://linux-mint.froonix.org/dists/maya/import/i18n/Translation-es  Mala línea de cabecera

W: Imposible obtener http://linux-mint.froonix.org/dists/maya/import/i18n/Translation-en  Mala línea de cabecera

W: Imposible obtener http://linux-mint.froonix.org/dists/maya/main/i18n/Translation-es_ES  Mala línea de cabecera

W: Imposible obtener http://linux-mint.froonix.org/dists/maya/main/i18n/Translation-es  Mala línea de cabecera

W: Imposible obtener http://linux-mint.froonix.org/dists/maya/upstream/i18n/Translation-es  Mala línea de cabecera

E: Algunos archivos de índice fallaron al descargar. Se han ignorado, o se han utilizado unos antiguos en su lugar
Por lo que supongo que volveré a tener problemas :?

(Sois unos soles y unos panes benditos, dicho sin "acritú" ninguna =D>
Avatar de Usuario
niky45
Forista Ancestral
Forista Ancestral
Mensajes: 9186
Registrado: Jue Abr 12, 2007 7:00 am
Ubicación: tras la pantalla (...)
Contactar:

Re: Error en sinaptyc y gestor actualizaciones linux mint

Mensaje por niky45 » Sab Ago 18, 2012 5:51 pm

Yoyo escribió:Offtopiqueando:

niky45, ¿por que tus repos terminan en non-free contrib cuando de toda la vida ha sido contrib non-free? respetemos las costumbres por el bien de la Debienidad.
diselo al equipo de debian. es una expert, y active, desde la install, ambos. salio asi. :wink: parece que los que lo hemos heco MAL toda la vida, hemos sido los users... :D

@ clamide: bueno, pues parece que no soy la unica por aqui (desde que luli ha desaparecido, a veces me creo que si... :? )
centrandonos en el tema, aparte de una firma que no encuentra... te esta dando (leo directamente) errores con las cabeceras.
la segunda referencia que encuentro por google ( http://www.ubuntu-es.org/node/108008#.UC-44uovDRY ) dice esto:
Busca la linea a la que hace referencia este error, eso es una linea mal formado en el listado de repositorios.
leyendo un poco mas, parece que lo que quiere decir es que no esta ahi el repo, bien porque el sources esta mal escrito, bien porque el repo no existe.

haz una cosa: prueba con el sources que te pase yo en mi anterior post: http://pastie.org/4540020 , tras hacer una copia del actual, y vuelves a probar.
*nota: estan los de belgica. si no te gustan, editas, y en "be" pones el codigo del pais que suelas usar (por ejemplo "es" si te gustan los de espania. )

repito, que creo que no me he explicado bien: te bajas el fichero del link. copias tu sources actual a otro sitio. y despues, copias ese sources a su sitio (/etc/apt/sources.list). y despues, apt-get update. y a ver que dice.

:D
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]
Avatar de Usuario
clamide
Forista Medio
Forista Medio
Mensajes: 298
Registrado: Dom Mar 25, 2007 8:00 am

Re: Error en sinaptyc y gestor actualizaciones linux mint

Mensaje por clamide » Sab Ago 18, 2012 6:18 pm

¡Uy, "la vierge", Niky! Para hacer todo eso que dices me gustaría tener el médico al ladito, que me encuentro torpona para esas lides.. (No la vaya ciscar más.. :roll: )
Por cierto, ¡hay que ver lo bien que buscas tú en google! A mí me salen cosas que ni parecidas! (Lo que tiene saber buscar... :wink: )
Avatar de Usuario
niky45
Forista Ancestral
Forista Ancestral
Mensajes: 9186
Registrado: Jue Abr 12, 2007 7:00 am
Ubicación: tras la pantalla (...)
Contactar:

Re: Error en sinaptyc y gestor actualizaciones linux mint

Mensaje por niky45 » Dom Ago 19, 2012 2:35 pm

todo como root (o con sudo)

Código: Seleccionar todo

mv /etc/apt/sources.list{,.bak}
cd /etc/apt/
wget http://pastie.org/pastes/4540020/text 
mv text sources.list
apt-get update #blah, blah, blah
clamide escribió:Por cierto, ¡hay que ver lo bien que buscas tú en google! A mí me salen cosas que ni parecidas! (Lo que tiene saber buscar... :wink: )
cuestion de practica. y de paciencia, no siempre las cosas salen en los primeros resultados (si bine, si haces la busqueda correctamente, deberian). como pista: si te da algun error, copiaselo tal cual, excluyendo datos propios de tu maquina (ej: en este caso, solo "mala linea de cabecera", sin especificar el repo o la ip). si ademas le poners el nombre de tu distro, ayuda bastante. :wink:

:? un dia de estos me liare la manta a la cabeza y escribire una guia para google.... o completare una que habia por ahi. 8-)
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]
Avatar de Usuario
clamide
Forista Medio
Forista Medio
Mensajes: 298
Registrado: Dom Mar 25, 2007 8:00 am

Re: Error en sinaptyc y gestor actualizaciones linux mint

Mensaje por clamide » Dom Ago 19, 2012 7:11 pm

¡Anda! Pues fíjate que yo lo que había pensado hacer era simplemente borrar todo lo de sources list, copiar el de "la pastita esa", guardando primero a buen recaudo el mío, por si las moscas... y ver que pasaba. Pero, por lo que veo, la cosa es, digamos, menos sencilla ¿o más sencilla, si acaso, con los códigos que me envías? ¿Se trataría, pues, de copiar y pegar los códigos, con el sudo delante, y nada más?
Ah, y a lot of thanks por los consejos sobre búsquedas en google. ¡Una santa, eso es lo que eres, una santa! =P~
Avatar de Usuario
niky45
Forista Ancestral
Forista Ancestral
Mensajes: 9186
Registrado: Jue Abr 12, 2007 7:00 am
Ubicación: tras la pantalla (...)
Contactar:

Re: Error en sinaptyc y gestor actualizaciones linux mint

Mensaje por niky45 » Dom Ago 19, 2012 9:28 pm

:? la unica diferencia entre lo que tu propones y lo que yo te digo, es que yo lo hago a base de teclado y tu de raton. yo es que con el raton no me llevo bien, y como el teclado SE que va a funcionar, pues... ahi va. bueno, y te he "automatizado" la descarga .
clamide escribió:¿Se trataría, pues, de copiar y pegar los códigos, con el sudo delante, y nada más?
exacto. bueno, y despues, ver que todo funciona. :wink:

por cierto, habia olvidado los repos extras.... antes de aptitude apt-get update, haz esto:

Código: Seleccionar todo

(sudo) mv /etc/apt/sources.list.d{,.bak}
:)
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]
Responder
  • Similar Topics
    Respuestas
    Vistas
    Último mensaje