Wicd detecta redes pero no se conecta.

Todos los comentarios sobre redes y servidores en linux y su interacción con otros sistemas operativos.

Moderadores: doc, Kde_Tony, ps-ax

Responder
Avatar de Usuario
hemorroide
Forista Nuevo
Forista Nuevo
Mensajes: 7
Registrado: Dom May 20, 2007 7:00 am

Wicd detecta redes pero no se conecta.

Mensaje por hemorroide »

Pues es eso. Hasta ahora tenía debian 9 y al actualizar a debian 10 ya no se conecta. Antes funcionaba bien. Para conectarme uso esto.

https://www.amazon.es/NETVIP-Adaptador- ... B07CB8JG2V

Funciona porque en Windows sí va, y como dije antes en debian 9 también iba.

Tras actualizar no me reconocía el dispositivo, que ahora es la interfaz de red wlan0, así que de milagro instalé los drivers para que me saliera wlan0 al hacer un iwconfig.

Por lo tanto ahora al darle que conecte se queda un buen rato en "validatin autentication" y al final salta con un "contraseña errónea" y fin. Lo curioso es que si meto mi antiguo pincho usb el sistema me lo reconoce como wlan2, a continuación le doy a conectar a la misma red, y en ese caso sí que conecta. Así que la contraseña está bien.

Muchas gracias

Avatar de Usuario
doc
Forista Ancestral
Forista Ancestral
Mensajes: 3462
Registrado: Mié Ago 11, 2010 10:32 am
Ubicación: Oviedo-es_ES
Contactar:

Re: Wicd detecta redes pero no se conecta.

Mensaje por doc »

Si has actualizado por repositorios, o sea sin necesidad de reinstalar el nuevo Debian, es posible que también tengas que hacer es volver a instalar los controladores de ese 'nano USB adapter' . Yo tengo uno parecido, un TP-Link TL-WN725N, y es lo que tengo que hacer cuando cambia el kernel. Yo tengo anotado que hay que hacer esto
make clean
make
sudo make install
sudo modprobe -v 8188eu
y reiniciar, y enchufar el miniadaptador
(ese 8188eu es el controlador que usa mi miniUSB)

Por otro lado, no conozco WiCD, pero siempre me ha parecido bastante más complicado que el Network Manager que Debian instala por defecto. Mira a ver que no tengan conflicto, o reinícialo (o reinicia tu router)

Avatar de Usuario
hemorroide
Forista Nuevo
Forista Nuevo
Mensajes: 7
Registrado: Dom May 20, 2007 7:00 am

Re: Wicd detecta redes pero no se conecta.

Mensaje por hemorroide »

Pues por ahí va la cosa. Lo que he hecho es aprovechar que el grub guarda la opción de arrancar núcleos antiguos, así arranco uno de esos y ahora me conecto a internet. Si debian 10 te pone el núcleo 4.19 pues yo la uso con el 4.09. Es una chapuza pero funciona. De todos modos te agradecería que me dieras más detalles de eso que haces de

make clean
make
sudo make install
sudo modprobe -v ....

Para saber cómo haces cada vez que al actualizar se te cambia el núcleo.

Avatar de Usuario
doc
Forista Ancestral
Forista Ancestral
Mensajes: 3462
Registrado: Mié Ago 11, 2010 10:32 am
Ubicación: Oviedo-es_ES
Contactar:

Re: Wicd detecta redes pero no se conecta.

Mensaje por doc »

pues yo solo te lo puedo explicar (y con mi propio nano Adapter) a través de las experiencias que iba anotando en mi Blog, como...
https://comoserdebianitaynomorirenelint ... ipset.html
https://comoserdebianitaynomorirenelint ... nk-tl.html

Responder
  • Temas similares
    Respuestas
    Vistas
    Último mensaje