[DNS] Problema con cierta zona, se mezcla !

Todos los comentarios sobre redes y servidores en linux y su interacción con otros sistemas operativos.

Moderadores: doc, Kde_Tony, ps-ax

Responder
Avatar de Usuario
Diabliyo
Forista Medio
Forista Medio
Mensajes: 372
Registrado: Jue Abr 29, 2004 7:00 am
Contactar:

[DNS] Problema con cierta zona, se mezcla !

Mensaje por Diabliyo »

Buenas.

Tengo un servidor dedicado en la nube el cual le configure el Servidor DNS y no habia tenido ningun problema cuando lo usaba con otras redes, me resolvia bien todo. Aparte tambien monte Apache+MySQL+PHP y tengo espacios de hosting para algunas cosas, asi que tambien re-configure el DNS para que se pudiera acceder al hosting por su sub-sibdominio.

Me di cuenta del este problema porque quiero estandarizar todas mis plataformas webs, ya que actualmente para mis plataformas web y mis blogs utilizo una base de datos independiente, donde cada una tiene sus propias tablas TIPICAS, como: Usuarios. Y con la finalidad de estandarizar las cuentas de mis usuarios y que no tengan que registrarse en cada uno de mis portales, pense en mejor centralizar un sitio de logeo, de forma que, cada vez que alguien se registre en alguno de mis portales, el registro se realizo contra mi servidor deciado, al cual le abriria una sub-dominio denominado: http://login.miservidor.com.

Mi primer paso fue ir al Account Manager de GoDaddy, ya que mis Blogs los manejo con GoDaddy, y solo mis plataformas webs las manejo con mi Servidor Dedicado (por las limitaciones que ofrece GoDaddy), en fin, edite cada una de las Zonas de los dominos de mis Blogs y le agregue una nueva regla donde invico que el sub-domonio "login" lo lance a: http://login.miservidor.com, y ademas en la parte de DNSs agregue las IPs de mi dns del servidor.com.

Pero malas noticias :(.... Cuando hago esto: login.blogX.com me lanza a blog.miservidor.com, en vez de ir a login.miservidor.com, no entiendo la razon porque :S, si ya verifique y efectivamente estoy escribiendo bien en las Reglas de zonas del dominio (en GoDaddy Account Manager), el dominio: login.miservidor.com.

Hasta este punto mi servidor dedicado esta asi:

Servidor Dedicado
OJO: no uso las IPs reales, para proteger mi servidor de los bots y personas maliciosas.
dominio: miservidor.com
ip1: 10.10.10.5 (ip directa) --> miservidor.com
ip2: 10.10.10.6 (servidor de nombres 1) --> ns1.miservidor.com
ip3: 10.10.10.7 (servidor de nombres 2) --> ns2.miservidor.com

La configuracion del Servidor Dedicado tiene el hostname de: server, de modo que el servidor se llama (localmente): server.miservidor.com.

La configuracion de Zonas Externa:

Podran apreciar los sub-dominios de:

- ns1.miservidor.com
- ns2.miservidor.com
- server.miservidor.com
- http://www.miservidor.com
- mail.miservidor.com
- login.miservidor.com <-- el que me interesa
- blog.miservidor.com
- db.miservidor.com
- git.miservidor.com

# cat /var/named/external/db.miservidor.com

Código: Seleccionar todo

$TTL	604800
@	IN SOA	ns1.miservidor.com. server.miservidor.com. (
		2010080301	; serial
		604800		; refresh
		86400		; retry
		2419200		; expire
		604800 )	; negative cache ttl
;
@	IN NS	ns1
	IN MX	10 server
	IN A	10.10.10.5
ns1	IN A	10.10.10.6
ns2	IN A	10.10.10.7
mail	IN A	10.10.10.5
server	IN A	10.10.10.5
www	IN A	10.10.10.5
login	IN A	10.10.10.5 ; Login Sistema
blog	IN A	10.10.10.5 ; mi blog personal
git	IN A	10.10.10.5 ; Git Server
db	IN A	10.10.10.5 ; MySQL Databases
Las Reglas de Zonas Recursivas:

# cat /var/named/db.10.10.10.5

Código: Seleccionar todo

$TTL	604800
@	IN SOA	miservidor.com. server.miservidor.com. (
		1	; serial
		8H	; refresh
		2H	; retry
		4W	; expire
		1D )	; minimum ttl
;
@	IN NS	miservidor.com
5	IN PTR	miservidor.com
5	IN PTR	www
5	IN PTR	server
5	IN PTR	mail
6	IN PTR	ns1
7	IN PTR	ns2
5	IN PTR	login	; Login Registro de usuario
5	IN PTR	blog ; mi Blog
5	IN PTR	db	; MySQL
5	IN PTR	git	; MySQL
Si escribo directamente en el navegador la URL: http://login.miservidor.com sale perfectamente una pagina en Blanco (que hice de prueba) y dice: Pagina de LOGIN.

Pero cuando escribo en el navegador la URL: http://login.blogX.com que se supone me debe re-dirigir a http://login.miservidor.com, me envia a: http://blog.miservidor.com.

Espero puedan ayudarme !!

Saludos !

Editado -- Vie Feb 11, 2011 8:31 am --

Ya medio soluciones el problema, pero no entiendo porque sucede esta anomalia o probelma....

Mi solucion fue simple, edite mi configuracion de sub-dominios en apache (VirtualHost) y coloque el VirtualHost de login.miservidor.com al principio de todos, ya que todos mis VirtualHost los tengo dentro de un mismo archivo llamadao mis_subdominios.conf. Ya con eso ahora cuando hago: login.miblog.com o login.miplataforma.com, entra directo la pagina de login.miservidor.com.

Porque sera que, si la configuracion del VirtualHost login.miservidor.com esta en segunda posicion o mas abajo, entra directo siempre el primer VirtualHost... el que tenia al principio era blog.miservidor.com y pues, este era el que entraba.

Saludos !

Responder
  • Temas similares
    Respuestas
    Vistas
    Último mensaje