[Solucionado] Problema Ubuntu 9.1 Server y apt-get upgrade con slapd

Todos los comentarios sobre redes y servidores en linux y su interacción con otros sistemas operativos.

Moderadores: doc, Kde_Tony, ps-ax

Responder
carballinho
Forista Nuevo
Forista Nuevo
Mensajes: 4
Registrado: Vie Sep 10, 2010 9:31 am

[Solucionado] Problema Ubuntu 9.1 Server y apt-get upgrade con slapd

Mensaje por carballinho » Vie Sep 10, 2010 9:34 am

Buenas tardes a todos,

Comentaros antes de nada que soy nuevo por aquí. Tengo algunos conocimientos de linux pero no soy ningún "hacha", por lo que intentaré explicarme lo mejor posible.

He instalado un servidor Ubuntu, con Openldap. Todo funcionaba bien pero, después de una actualización, me empezó a salir esto cada vez que hago apt-get upgrade:

root@ubuntuserver:~# apt-get upgrade
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
0 actualizados, 0 se instalarán, 0 para eliminar y 0 no actualizados.
1 no instalados del todo o eliminados.
Se utilizarán 0B de espacio de disco adicional después de esta operación.
¿Desea continuar [S/n]? s
Configurando slapd (2.4.18-0ubuntu1.1) ...
Backing up /etc/ldap/slapd.conf in /var/backups/slapd-2.4.18-0ubuntu1... done.
chown: invalid argument: `'
dpkg: error al procesar slapd (--configure):
el subproceso installed post-installation script devolvió el código de salida de error 1
Se encontraron errores al procesar:
slapd
E: Sub-process /usr/bin/dpkg returned an error code (1)

No se qué pasó... pero me tiene mosqueado este error. El servidor openldap sigue funcionando sin problemas y el slapd también, pero me gustaría arreglar este problema. Da la sensación de que se actualizó mal el sldap o algo así...

Espero que podáis ayudarme.

Gracias. Un saludo.
Última edición por carballinho el Lun Sep 13, 2010 3:03 pm, editado 1 vez en total.
Avatar de Usuario
Fanton
Forista Distinguido
Forista Distinguido
Mensajes: 1339
Registrado: Jue Ene 08, 2009 8:00 am
Ubicación: Magdalena [Argentina]
Contactar:

Re: Problema Ubuntu 9.1 Server y apt-get upgrade con slapd

Mensaje por Fanton » Vie Sep 10, 2010 1:13 pm

Hola carballinho, bienvenido, prueba hacer un:

sudo aptitude clean

o

sudo aptitude autoclean

haber si te puede purgar ese proceso, y despues vuelves a actualizar a ver que pasa
Diplomacia, es el arte de saber lo que no se debe decir...
_________________
Hardware: Intel i5-3570k | ASUS P8H77-M |HD [500GB] [1 TB] | Ram 8 GB | GPU: Nvidia GeForce 210/1 GB
S.O. Debian@testing x86_64 Openbox
Linux user #506272
carballinho
Forista Nuevo
Forista Nuevo
Mensajes: 4
Registrado: Vie Sep 10, 2010 9:31 am

Re: Problema Ubuntu 9.1 Server y apt-get upgrade con slapd

Mensaje por carballinho » Vie Sep 10, 2010 1:27 pm

Sigue apareciendo lo mismo:


root@ubuntuserver:/etc/bind# sudo aptitude autoclean
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Reading extended state information
Initializing package states... Hecho
Freed 0B of disk space
root@ubuntuserver:/etc/bind# apt-get upgrade
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
0 actualizados, 0 se instalarán, 0 para eliminar y 0 no actualizados.
1 no instalados del todo o eliminados.
Se utilizarán 0B de espacio de disco adicional después de esta operación.
¿Desea continuar [S/n]? s
Configurando slapd (2.4.18-0ubuntu1.1) ...
Backing up /etc/ldap/slapd.conf in /var/backups/slapd-2.4.18-0ubuntu1... done.
chown: invalid argument: `'
dpkg: error al procesar slapd (--configure):
el subproceso installed post-installation script devolvió el código de salida de error 1
Se encontraron errores al procesar:
slapd
E: Sub-process /usr/bin/dpkg returned an error code (1)
Avatar de Usuario
Fanton
Forista Distinguido
Forista Distinguido
Mensajes: 1339
Registrado: Jue Ene 08, 2009 8:00 am
Ubicación: Magdalena [Argentina]
Contactar:

Re: Problema Ubuntu 9.1 Server y apt-get upgrade con slapd

Mensaje por Fanton » Vie Sep 10, 2010 2:13 pm

que raro que no mato ese paquete, a mi a principio de semana me paso lo mismo y con solo ejecutar el primer comando que te puse lo mato, y por las dudas le pase también el segundo comando y después de actualizar nuevamente se había arreglado, (el problema se me genero porque se me corto la luz y fue como que ese paquete quedo roto)
Diplomacia, es el arte de saber lo que no se debe decir...
_________________
Hardware: Intel i5-3570k | ASUS P8H77-M |HD [500GB] [1 TB] | Ram 8 GB | GPU: Nvidia GeForce 210/1 GB
S.O. Debian@testing x86_64 Openbox
Linux user #506272
Avatar de Usuario
Kde_Tony
Moderador
Moderador
Mensajes: 3866
Registrado: Mié Jul 20, 2005 7:00 am
Ubicación: /home/Peru/Lima/La Molina
Contactar:

Re: Problema Ubuntu 9.1 Server y apt-get upgrade con slapd

Mensaje por Kde_Tony » Sab Sep 11, 2010 10:18 pm

por eso nunca uso ubuntu en servidores en produccion.,..
prueba con aptitude clean ... asu vez revisa este directorio: /var/cache/apt/archives/
borra todo lo que haya alli
"Quiero cambiar al mundo pero no me dan los RPM"
----------------------------
Tony Blair
Linux User # 433253
Ubuntu User # 9562
-----------------------------
carballinho
Forista Nuevo
Forista Nuevo
Mensajes: 4
Registrado: Vie Sep 10, 2010 9:31 am

Re: Problema Ubuntu 9.1 Server y apt-get upgrade con slapd

Mensaje por carballinho » Lun Sep 13, 2010 8:36 am

He solucionado el problema comentado la linea SLAPD_CONF en /etc/default/slapd y corriendo 'aptitude -f install'. Una vez hecho esto, la he quitado los comentarios de nuevo y todo sigue funcionando bien.

Gracias por todo y un saludo.
Avatar de Usuario
Deckon
Moderador
Moderador
Mensajes: 3273
Registrado: Dom Abr 01, 2007 8:00 am
Ubicación: México, Estado de México

Re: Problema Ubuntu 9.1 Server y apt-get upgrade con slapd

Mensaje por Deckon » Lun Sep 13, 2010 2:27 pm

carballinho no se te olvide que si consideras que la duda se a resuelto el agregar [solucionado] al titulo de tu post. saludos
Reglamento del Foro | Temas mas Preguntados | WikiEL | GitHub
Linux User #:406092
Manjaro | Asus P8z77-v | i5-2310 | Nvidia GeForce Gt 610 | Hp Ultrabook Folio 13
carballinho
Forista Nuevo
Forista Nuevo
Mensajes: 4
Registrado: Vie Sep 10, 2010 9:31 am

Re: Problema Ubuntu 9.1 Server y apt-get upgrade con slapd

Mensaje por carballinho » Lun Sep 13, 2010 3:03 pm

Deckon escribió:carballinho no se te olvide que si consideras que la duda se a resuelto el agregar [solucionado] al titulo de tu post. saludos
Hecho.

Gracias por el aviso.
Responder
  • Similar Topics
    Respuestas
    Vistas
    Último mensaje