problema de logueo en opensuse con samba

Todos los comentarios sobre redes y servidores en linux y su interacción con otros sistemas operativos.

Moderadores: doc, Kde_Tony, ps-ax

Responder
gzamora
Forista Nuevo
Forista Nuevo
Mensajes: 6
Registrado: Mié Ago 04, 2010 5:52 pm

problema de logueo en opensuse con samba

Mensaje por gzamora » Mié Ago 04, 2010 6:03 pm

hola amigos les agradeceria inmensamente si me ayudan con esto tengo un pequeño problema al intentar loguearme al servidor desde mi maquina, tengo una red el so es opensuse 11.1 la cuestion es q quiero loguearme al servidor desde mi maquina ya que tenemos algunos usuarios creados y se supone q uno se loguea con su usuario y todo lo que haga quedara grabado en el servidor pero en la carpeta de cada usuario y eso lo tengo configurado con samba pero no me funciona el error es que al poner mi usuario y mi contraseña me sale sin autentificacion de usuario he revisado millon foros y hasta el momento no lo he podido solucionar esperando una pronta respuesto les reitero mis agradecimientos espero puedan ayudarme el smb.conf lo tengo de esta manera:

[global]

workgroup = ROBOTICA

netbios name = CVR01

domain logons = yes

domain master = yes

local master = yes

os level = 65

preferred master = yes

security = user

logon path =

logon drive = P:

passdb backend = smbpasswd

encrypt passwords = Yes

add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$

name resolve order = bcast host lmhost

server string = “opensuse”

printing = cups

printcap name = cups

printcap cache time = 750

cups options = raw

wins support = No



[homes]
comment = Home Directories
valid users = %S, %D%w%S
read only = No
inherit acls = Yes
browseable = No

[profiles]
comment = Network Profiles Service
path = %H
read only = No
create mask = 0600
directory mask = 0700
store dos attributes = Yes

[users]
comment = All users
path = /home
read only = No

[printers]
comment = All Printers
path = /var/tmp
create mask = 0600
printable = Yes
browseable = No

[print$]
comment = Printer Drivers
path = /var/lib/samba/drivers
write list = @ntadmin, root
force group = ntadmin
create mask = 0664
directory mask = 0775

[secreadm]
comment = Carpeta Secretarias
path = /recursos/secrecvr
write list = kcastro, scastro, dromero
read only = No
browseable = No

[proyectos]
comment = Carpeta Proyectos
path = /recursos/proyectos
write list = kcastro, scastro, dromero
read only = No

[varios]
comment = Carpeta Varios
path = /recursos/Varios
write list = kcastro, scastro, dromero
read only = No

[netlogon]
comment = Network Logon Service
path = /var/lib/samba/netlogon
write list = root
guest ok = Yes
browseable = No
no se si algo tengo mal o tengo q cambiar algo aqui o el problema es en otro lado o algo por el estilo gracias
Avatar de Usuario
Kde_Tony
Moderador
Moderador
Mensajes: 3866
Registrado: Mié Jul 20, 2005 7:00 am
Ubicación: /home/Peru/Lima/La Molina
Contactar:

Re: problema de logueo en opensuse con samba

Mensaje por Kde_Tony » Mié Ago 04, 2010 8:53 pm

1.- Cambia el PASSDB BACKEND... usa el que trae por defecto
2. Estas usando LDAP ??? ... de ser asi, en passdb backend debes de indicar que LDAP hara la autenticacion

Mas informacion: http://www.samba.org/samba/docs/man/Sam ... assdb.html

P.D Usa CentOS es mejor y hay mas documentacion sobre PDC .... OpenSuse etheeee... como desktop es bonito... nada mas!!!!!!!!!!
"Quiero cambiar al mundo pero no me dan los RPM"
----------------------------
Tony Blair
Linux User # 433253
Ubuntu User # 9562
-----------------------------
gzamora
Forista Nuevo
Forista Nuevo
Mensajes: 6
Registrado: Mié Ago 04, 2010 5:52 pm

Re: problema de logueo en opensuse con samba

Mensaje por gzamora » Jue Ago 05, 2010 5:27 am

muchas gracias lo intentare y estare escribiendo la verdad en esto soy nuevo recien estoy aprendiendo, el error q me sale al iniciar secion es algo sobre el pam q no encuentra el usuario
Avatar de Usuario
Kde_Tony
Moderador
Moderador
Mensajes: 3866
Registrado: Mié Jul 20, 2005 7:00 am
Ubicación: /home/Peru/Lima/La Molina
Contactar:

Re: problema de logueo en opensuse con samba

Mensaje por Kde_Tony » Jue Ago 05, 2010 8:43 pm

puede ser que la autenticacion la este cogiendo PAM, por es comento que cambies el passdb backend
Sls
"Quiero cambiar al mundo pero no me dan los RPM"
----------------------------
Tony Blair
Linux User # 433253
Ubuntu User # 9562
-----------------------------
gzamora
Forista Nuevo
Forista Nuevo
Mensajes: 6
Registrado: Mié Ago 04, 2010 5:52 pm

Re: problema de logueo en opensuse con samba

Mensaje por gzamora » Vie Ago 06, 2010 1:05 am

y que me recomiendas poner en el passdb backend?
Avatar de Usuario
Kde_Tony
Moderador
Moderador
Mensajes: 3866
Registrado: Mié Jul 20, 2005 7:00 am
Ubicación: /home/Peru/Lima/La Molina
Contactar:

Re: problema de logueo en opensuse con samba

Mensaje por Kde_Tony » Vie Ago 06, 2010 4:21 am

http://www.samba.org/samba/docs/man/Sam ... assdb.html

Saludos

P.D el passdb backend por default
"Quiero cambiar al mundo pero no me dan los RPM"
----------------------------
Tony Blair
Linux User # 433253
Ubuntu User # 9562
-----------------------------
gzamora
Forista Nuevo
Forista Nuevo
Mensajes: 6
Registrado: Mié Ago 04, 2010 5:52 pm

Re: problema de logueo en opensuse con samba

Mensaje por gzamora » Sab Ago 07, 2010 6:40 am

gracias amigo lo intentare
gzamora
Forista Nuevo
Forista Nuevo
Mensajes: 6
Registrado: Mié Ago 04, 2010 5:52 pm

sigo sin poder loguearme

Mensaje por gzamora » Lun Ago 16, 2010 5:17 pm

sigo sin poder loguearme espero me puedan ayudar a entender y a saber que puedo hacer ya reinstale el samba y nada aun esto es lo que me sale cuando intento loguearme esto sale en el yast system log:


Aug 9 10:49:15 cvrred gdm-session-worker[7327]: pam_winbind(gdm:auth): getting password (0x00000010)
Aug 9 10:49:15 cvrred gdm-session-worker[7327]: pam_winbind(gdm:auth): pam_get_item returned a password
Aug 9 10:49:15 cvrred gdm-session-worker[7327]: pam_winbind(gdm:auth): request failed: Access denied, PAM error was System error (4), NT error was NT_STATUS_ACCESS_DENIED
Aug 9 10:49:15 cvrred gdm-session-worker[7327]: pam_winbind(gdm:auth): internal module error (retval = 4, user = 'ROBOTICA\root')
Aug 9 10:49:15 cvrred winbindd[5475]: [2010/08/09 10:49:15, 0] rpc_client/cli_pipe.c:cli_rpc_pipe_open_ntlmssp_internal(2367)
Aug 9 10:49:15 cvrred winbindd[5475]: cli_rpc_pipe_open_ntlmssp_internal: cli_rpc_pipe_bind failed with error NT_STATUS_NETWORK_ACCESS_DENIED
Aug 9 10:49:15 cvrred winbindd[5475]: [2010/08/09 10:49:15, 0] rpc_client/cli_pipe.c:cli_rpc_pipe_open_ntlmssp_internal(2367)
Aug 9 10:49:15 cvrred winbindd[5475]: cli_rpc_pipe_open_ntlmssp_internal: cli_rpc_pipe_bind failed with error NT_STATUS_NETWORK_ACCESS_DENIED
Aug 9 10:49:15 cvrred gdm-session-worker[7327]: gkr-pam: error looking up user information for: ROBOTICA\root
Aug 9 10:49:15 cvrred gdm-session-worker[7327]: PAM pam_putenv: NULL pam handle passed
Aug 9 10:49:22 cvrred gdm-session-worker[7339]: PAM pam_putenv: NULL pam handle passed
Aug 9 10:49:23 cvrred gdm-simple-greeter[7326]: Gdk-WARNING: gdkdrawable-x11.c:878 drawable is not a pixmap or window
Aug 9 10:49:23 cvrred gdm-simple-greeter[7326]: Gdk-WARNING: gdkdrawable-x11.c:878 drawable is not a pixmap or window
Aug 9 10:49:23 cvrred gdm-simple-greeter[7326]: Gdk-WARNING: gdkdrawable-x11.c:878 drawable is not a pixmap or window
Aug 9 10:49:23 cvrred gdm-simple-greeter[7326]: Gdk-WARNING: gdkdrawable-x11.c:878 drawable is not a pixmap or window
Aug 9 10:49:23 cvrred gdm-simple-greeter[7326]: Gdk-WARNING: gdkdrawable-x11.c:878 drawable is not a pixmap or window
Avatar de Usuario
Deckon
Moderador
Moderador
Mensajes: 3273
Registrado: Dom Abr 01, 2007 8:00 am
Ubicación: México, Estado de México

Re: problema de logueo en opensuse con samba

Mensaje por Deckon » Lun Ago 16, 2010 7:04 pm

Hola gzamora e unido tus temas ya que tratan de la misma temática. Por favor no dupliques temas.
Reglamento del Foro | Temas mas Preguntados | WikiEL | GitHub
Linux User #:406092
Manjaro | Asus P8z77-v | i5-2310 | Nvidia GeForce Gt 610 | Hp Ultrabook Folio 13
gzamora
Forista Nuevo
Forista Nuevo
Mensajes: 6
Registrado: Mié Ago 04, 2010 5:52 pm

Re: problema de logueo en opensuse con samba

Mensaje por gzamora » Mar Ago 17, 2010 4:19 am

no duplico deckon el tema trato de encontrar una solucion ya que aun no la he podido encontrar si tienes una solucion para mi problema te lo agradeceria infinitamente ese es registro de error que no pude copiar en el tema anterior muchas gracias
Responder
  • Similar Topics
    Respuestas
    Vistas
    Último mensaje