Debian 9 sin monitor - Problema para utilizarlo

Todos los comentarios sobre redes y servidores en linux y su interacción con otros sistemas operativos.

Moderadores: doc, Kde_Tony, ps-ax

Responder
pablomacri06
Forista Nuevo
Forista Nuevo
Mensajes: 31
Registrado: Jue Oct 17, 2013 5:47 pm

Debian 9 sin monitor - Problema para utilizarlo

Mensaje por pablomacri06 » Dom Mar 24, 2019 10:45 pm

Hola gente les comento.

Tengo una PC que utilizo como servidor con Debian 9

La situacion es la siguiente. Cuando inicio el sistema con un monitor instalado, funciona correctamente todo.
Pero cuando le quito el monitor e inicio el sistema, sucede que no me carga el video. Osea arranca el sistema bien pero si LUEGO le conecto un monitor no me da absolutamente nada de imagen. Por lo tanto me conecto por SSH desde otro equipo y veo que xradn me dice que no ningun display.
Intente generar un Xorg -config y copiar el archivo a /etc/X11/xorg.conf pero no funciona.

Necesito que el equipo trabaje sin monitor pero en algun que otro momento necesito conectarle el monitor y es aqui lo que no logro solucionar.
Busque por internet y aparentemente le dicen debian 9 headless.
Tambien agregue al /etc/default/grub la opcion nomodeset y luego de un update-grub tampoco funciona.

Ya no se que intentar. Gracias
Dejo lo siguiente por si aporta
00:02.0 VGA compatible controller: Intel Corporation Device 3e91 (prog-if 00 [VGA controller])
Xradn con el monitor previamente conectado
xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 1920 x 1200, maximum 1920 x 1200
default connected 1920x1200+0+0 0mm x 0mm
1920x1200 0.00*
1600x1200 0.00
1280x1024 0.00
1024x768 0.00
800x600 0.00
640x480 0.00
Xorg -configure con el monitor previamente conectado
Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "built-ins"
EndSection

Section "Module"
Load "glx"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
### <percent>: "<f>%"
### [arg]: arg optional
#Option "Accel" # [<bool>]
#Option "AccelMethod" # <str>
#Option "Backlight" # <str>
#Option "CustomEDID" # <str>
#Option "DRI" # <str>
#Option "Present" # [<bool>]
#Option "ColorKey" # <i>
#Option "VideoKey" # <i>
#Option "Tiling" # [<bool>]
#Option "LinearFramebuffer" # [<bool>]
#Option "HWRotation" # [<bool>]
#Option "VSync" # [<bool>]
#Option "PageFlip" # [<bool>]
#Option "SwapbuffersWait" # [<bool>]
#Option "TripleBuffer" # [<bool>]
#Option "XvPreferOverlay" # [<bool>]
#Option "HotPlug" # [<bool>]
#Option "ReprobeOutputs" # [<bool>]
#Option "XvMC" # [<bool>]
#Option "ZaphodHeads" # <str>
#Option "VirtualHeads" # <i>
#Option "TearFree" # [<bool>]
#Option "PerCrtcPixmaps" # [<bool>]
#Option "FallbackDebug" # [<bool>]
#Option "DebugFlushBatches" # [<bool>]
#Option "DebugFlushCaches" # [<bool>]
#Option "DebugWait" # [<bool>]
#Option "BufferCache" # [<bool>]
Identifier "Card0"
Driver "intel"
BusID "PCI:0:2:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection
Avatar de Usuario
doc
Forista Ancestral
Forista Ancestral
Mensajes: 3303
Registrado: Mié Ago 11, 2010 10:32 am
Ubicación: Oviedo-es_ES
Contactar:

Re: Debian 9 sin monitor - Problema para utilizarlo

Mensaje por doc » Dom Mar 24, 2019 11:22 pm

ni idea, pero lo primero que deberías decir es cómo conectas el monitor, si por HDMI o por VGA. Lo digo porque el segundo caso no es plug and play... y por HDMI, a veces suele fallar.
En todo caso, yo bajaría la resolución, ese 1920x1200 puede ser excesivo.
pablomacri06
Forista Nuevo
Forista Nuevo
Mensajes: 31
Registrado: Jue Oct 17, 2013 5:47 pm

Re: Debian 9 sin monitor - Problema para utilizarlo

Mensaje por pablomacri06 » Lun Mar 25, 2019 2:17 am

Conecta por VGA
Por lo que estuve leyendo el problema aparece porque en las nuevas versiones del Kernel, los monitores lo configura directamente el Kernel, es por eso mismo que ya no existe el Xorg.conf en las nuevas versiones.

Por lo tanto una de las soluciones era modificar el Grub para decirle en el booteo que el Kernel no modifique el display pero a mi no me funciono nada, y por eso vengo por aqui.
Avatar de Usuario
doc
Forista Ancestral
Forista Ancestral
Mensajes: 3303
Registrado: Mié Ago 11, 2010 10:32 am
Ubicación: Oviedo-es_ES
Contactar:

Re: Debian 9 sin monitor - Problema para utilizarlo

Mensaje por doc » Lun Mar 25, 2019 11:34 am

si, es claro que ahora no hace falta el xorg.conf. De hecho, ni se crea. Pero sigo pensando que el problema es que la conexión VGA no es 'plug and play'. Yo, al menos, cuando hace unos años quería usar una TV como monitor de mi portátil, si los conectaba por VGA tenía que reiniciar el portátil.
pablomacri06
Forista Nuevo
Forista Nuevo
Mensajes: 31
Registrado: Jue Oct 17, 2013 5:47 pm

Re: Debian 9 sin monitor - Problema para utilizarlo

Mensaje por pablomacri06 » Lun Mar 25, 2019 4:13 pm

Claro, entiendo que no sea Plug & play entonces tengo que buscar la forma de que ya este seteada la configuracion del monitor vga.

Al no darle importancia al xorg, no se como ni donde especificar estos datos. Estuve leyendo instalar Xvfb para emular un monitor pero no se si funcionaria porque lo aplican para conexiones VNC no para conexiones de un monitor vga directo.
Avatar de Usuario
doc
Forista Ancestral
Forista Ancestral
Mensajes: 3303
Registrado: Mié Ago 11, 2010 10:32 am
Ubicación: Oviedo-es_ES
Contactar:

Re: Debian 9 sin monitor - Problema para utilizarlo

Mensaje por doc » Lun Mar 25, 2019 4:28 pm

a lo mejor la solución más fácil es probar conectando el ordenador al PC por HDMI, a ver si así funciona.
frayes
Forista Nuevo
Forista Nuevo
Mensajes: 1
Registrado: Mar Dic 20, 2016 4:48 pm

ayuda

Mensaje por frayes » Vie Abr 05, 2019 4:59 pm

Ante todo bien por las publicaciones, Pregunto si me pudieran ayudar con este escript, pues cuando lo pongo a correr en consola de ubuntu Ej. 3% y ocurre un fallo de red, empiesa desde el principio 0%,

# Arch= -a # Architecture. For Ubuntu can be i386, powerpc or amd64.
# sparc, only starts in dapper, it is only the later models of sparc.
#
/usr/bin/debmirror --nosource -m --passive --host=ve.archive.ubuntu.com \
--root=ubuntu --method=http --progress --rsync-options \
--dist=xenial,xenial-security,xenial-updates,xenial-proposed,xenial-backports \
--ignore-release-gpg --section=main,restricted,universe,multiverse \
--arch=i386,amd64 /home/todo/ubuntu/
#
si me pudieran ayudar
Responder
  • Similar Topics
    Respuestas
    Vistas
    Último mensaje