Algo le paso a mi Apache+PHP que no lee las paginas

Todos los comentarios sobre redes y servidores en linux y su interacción con otros sistemas operativos.

Moderadores: doc, Kde_Tony, ps-ax

Responder
Avatar de Usuario
Diabliyo
Forista Medio
Forista Medio
Mensajes: 372
Registrado: Jue Abr 29, 2004 7:00 am
Contactar:

Algo le paso a mi Apache+PHP que no lee las paginas

Mensaje por Diabliyo » Mié May 05, 2010 11:03 pm

Utilizo Ubuntu y el dia de ayer me llego la actualizacion de la distribucion 9.10 a 10.04 LTS, asi que la aplique y todo BIEN. Note que despues de actualizarla, no tenia audio ni reproduccion de video youtube, TODO eso se arreglo re-instalando los paquetes.

Despues el dia de HOY cuando me disponia a continuar mi proyecto de software en PHP, note que cuando accedia a mi servidor local, no se desplegaba la index.php, me envia directamente la descarga del archivo en formato PHTML :S.

Les dejo la screenshot: http://i44.tinypic.com/2vmbm9c.png.

Despues verifique la configuracion del apache y esta correcta :S, asi que des-instale apache y php, despues volvi a instalarlos y deje nuevamente las cosas como estaban, pero persiste :(.

Modulo PHP habilitado

Código: Seleccionar todo

shell# cd /etc/apache2/mods-enabled/
shell# ls -l |grep php
lrwxrwxrwx 1 root root 27 2010-05-05 10:48 php5.conf -> ../mods-available/php5.conf
lrwxrwxrwx 1 root root 27 2010-05-05 10:48 php5.load -> ../mods-available/php5.load
HAciendo CAT al modulo PHP

Código: Seleccionar todo

shell# cat /etc/apache2/mods-available/php5.conf 

<IfModule mod_php5.c>
    <FilesMatch "\.ph(p3?|tml)$">
	SetHandler application/x-httpd-php
    </FilesMatch>
    <FilesMatch "\.php$">
	SetHandler application/x-httpd-php
    </FilesMatch>
    <FilesMatch "\.phps$">
	SetHandler application/x-httpd-php-source
    </FilesMatch>
    # To re-enable php in user directories comment the following lines
    # (from <IfModule ...> to </IfModule>.) Do NOT set it to On as it
    # prevents .htaccess files from disabling it.
    #<IfModule mod_userdir.c>
     #   <Directory /home/*/public_html>
      #      php_admin_value engine Off
       # </Directory>
    #</IfModule>
</IfModule>
Reinicio y nada :(, el mismo problema...

Código: Seleccionar todo

shell# /etc/init.d/apache2 restart
Saludos !.

Editado -- Jue May 06, 2010 7:03 am --

Que curiosos.... Si pongo esto en el navegador: http://localhost/~diabliyo/index.php si se despliega la pagina, pero si omito escribir: index.php y escribo solamente: http://localhost/~diabliyo/ me lanza a descargar el archivo.

Alguna idea ?
Avatar de Usuario
Kde_Tony
Moderador
Moderador
Mensajes: 3866
Registrado: Mié Jul 20, 2005 7:00 am
Ubicación: /home/Peru/Lima/La Molina
Contactar:

Re: Algo le paso a mi Apache+PHP que no lee las paginas

Mensaje por Kde_Tony » Mié May 05, 2010 11:31 pm

Eso se debe a que te fala configurar la sentencia
Directory Index index.html index.php
No uso ubuntu con httpd, pero quizas en google te digan donde encontrar esa directiva.

Sls
"Quiero cambiar al mundo pero no me dan los RPM"
----------------------------
Tony Blair
Linux User # 433253
Ubuntu User # 9562
-----------------------------
Responder
  • Similar Topics
    Respuestas
    Vistas
    Último mensaje