[Espacio Linux] Instalación de Sound Blaster Audigy 2 SE

Foro para discutir sobre la documentación en linux (libros, ebooks, documentos, editoriales, autores, etc), así como temas publicados en el sitio.
Responder
Avatar de Usuario
Ayax
Administrador
Administrador
Mensajes: 3451
Registrado: Jue Ene 01, 1970 2:00 am
Ubicación: León, Guanajuato; México.
Contactar:

[Espacio Linux] Instalación de Sound Blaster Audigy 2 SE

Mensaje por Ayax »

Hola:

Se abre este tema para comentar, hacer observaciones o exponer dudas del documento publicado en el taller linux: "Instalación de Sound Blaster Audigy 2 SE".

Son bienvenidos todos sus mensajes al respecto.

Saludos.
No hay nada que agradecer. Hago, lo tengo que hacer.
Reglamento del foro | Temas más preguntados | Twitter: @pacorevilla

Avatar de Usuario
glups
Forista Nuevo
Forista Nuevo
Mensajes: 2
Registrado: Lun May 01, 2006 7:00 am

Re: [Espacio Linux] Instalación de Sound Blaster Audigy 2 SE

Mensaje por glups »

Hola!

Tengo una SoundBlaster Live 7.1 de 24 bits integrada en mi MSI Diamond Plus que compre hace poco. Tengo Kubuntu 5.10.

Ya hice todos los pasos, pero aún no tengo sonido... incluso después de haber reiniciado. Hice todos los test (cat /proc....) y la información que sale sobre los módulos de sonido esta perfecta..., por ejemplo:

root@kubuntu:/home/santiago# cat /proc/asound/cards
0 [CA0106 ]: CA0106 - CA0106
MSI K8N Diamond MB [SB0438] at 0xd880 irq 18

... como si sí hubiesen instalado bien... incluso puedo ajustar el volumen usando amixer alsamixer y los controles de kde... pero pongo todo en 100% y activado y nada...

La única diferencia durante la instalación fue que instale la version 15 y en la guía aparece la versión 11rc2 de los drivers de ALSA... por otra parte yo si instalé los lib y los utils... pero no creo que estas sean razones para que no funcione...

porfa ayúdenme,

Gracias de antemano

Santiago

Avatar de Usuario
ColdZero
Forista Legendario
Forista Legendario
Mensajes: 1704
Registrado: Vie Jun 03, 2005 7:00 am
Ubicación: San Diego, California

Mensaje por ColdZero »

Ejecuta alsaconf en consola y como root, puede que tu tarjeta ya tenga soporte pero no este detectada aun por los controladores, dejas que el alsaconf detecte tu tarjeta y la configure, despues ejecutas nuevamente el alsamixer, para que subas los volumenes, y para que tu configuracion se guarde ejecuta un alsactl store, saludos...
Genius by birth, Slacker by choice | Linux User #409793

Avatar de Usuario
glups
Forista Nuevo
Forista Nuevo
Mensajes: 2
Registrado: Lun May 01, 2006 7:00 am

Re: [Espacio Linux] Instalación de Sound Blaster Audigy 2 SE

Mensaje por glups »

Hola!

Lastimosamente no funcionó el alsaconf, alsamixer y alsactl store que me recomendaste...

A propósito, el alsaconf mostro que es una Audigy y no una Audigy 2.

Sigo sin sonido... será que me toca bajar de versión de alsa (tengo la v1.0.11.rc5)? Como lo hago? A qué versión bajo?

Mi versión de Kernel es Linux Kubuntu 2.6.12-10.386

En todo caso estoy seguro de que no se trata de nada relacionado con volúmen o de haber enchufado mal los altavoces, o de que la tarjeta esté dañada... ya lo comprobé pues en el otro disco tengo windows instalado para jugar unos jueguitos y el sonido funciona siempre bien.

Por otra parte, en system settings, el sonido esta habilitado y está con los valores por defecto.

No obstante, cuando ejecuto el KInfoCenter me muestra que los Audio devices, Synth devices, y Mixers están NOT ENABLED IN CONFIG. Curiosamente, hace unos días logré que Audio devices y Mixers quedaran activados pero de todas formas no hubo sonido.


Ok, en todo caso, muchas gracias por tu ayuda...

Avatar de Usuario
Joseluisar
Forista Nuevo
Forista Nuevo
Mensajes: 1
Registrado: Dom Jun 04, 2006 7:00 am

Mensaje por Joseluisar »

A mi no me deja acceder al Alsa Mixer, me pone:
alsamixer: function snd_ctl_open failed for default: No such device

Avatar de Usuario
Yoyo
Administrador
Administrador
Mensajes: 3156
Registrado: Mar Jun 06, 2006 7:00 am
Ubicación: España
Contactar:

Re: [Espacio Linux] Instalación de Sound Blaster Audigy 2 SE

Mensaje por Yoyo »

Hola acabo de registrarme para mostrar mi alegria, he seguido al pie de letra el documento y me a ido todo perfecto, tengo una SoundBlaster Live 24-bits y la tenia guardada en una caja de zapatos puesto que no podia usarla en mi querido ubuntu, uso ubuntu 6.06 lts dapper drake y la tarjeta de sonido integrada en mi placa base asus cuando no estoy reproduciendo nada hace como una especie de chisporroteo molesto, lo hacia antes en windows y en ubuntu tambien.
Así que solo me queda daros las gracias por esta excelente labor que haceis, soy lector y seguidor asiduo de esta pagina pero nunca me habia atrevido a registrarme...
Saludos

Avatar de Usuario
fr3e
Forista Medio
Forista Medio
Mensajes: 145
Registrado: Sab Ago 13, 2005 7:00 am

Re: [Espacio Linux] Instalación de Sound Blaster Audigy 2 SE

Mensaje por fr3e »

Bienvenido al foro. Me alegro que te haya servidor el pequeño manual.:wink: Lastima los problemas que dio a los demas. :cry:

Espero que alguien con mas conocimientos pueda ayudaros y se solucione.

Avatar de Usuario
don_buho19
Forista Medio
Forista Medio
Mensajes: 301
Registrado: Mar Ene 04, 2005 8:00 am
Ubicación: Tijuana B.C., Mexico
Contactar:

Mensaje por don_buho19 »

Joseluisar escribió:A mi no me deja acceder al Alsa Mixer, me pone:
alsamixer: function snd_ctl_open failed for default: No such device
yo lo arregle instlando udev o si ya lo tienes solo reinicialo.

Esta solucion me sirvio perfecto en Gentoo, no se si serviria para tu sistema...

Esta fue la nota que me ayudo:

Código: Seleccionar todo

Importante: Si experimenta problemas al iniciar alsamixer y obtiene errores como: alsamixer: function snd_ctl_open failed for default: No such file or directory, esto normalmente es un problema con udev al configurar los dispositivos. Se ejecuta killall udevd; udevstart para recargar las entradas en /dev y a continuación se inicia alsamixer. Con ello se debería haber resuelto el problema.
Th!nk Tank

Avatar de Usuario
luigisito
Forista Nuevo
Forista Nuevo
Mensajes: 2
Registrado: Mar Ago 29, 2006 7:00 am

Mensaje por luigisito »

Joseluisar escribió:A mi no me deja acceder al Alsa Mixer, me pone:
alsamixer: function snd_ctl_open failed for default: No such device
tengo un sound blaster audigy LS segun lspci
he seguido al pie de la laetra este tutorial y me pasa algo de lo mas estraño cuando inicio Ubuntu en la pantalla de seleccion de usuario me suena el sonido, al iniciar ya no tengo sonido, ejecuto alsa mixer (por cierto tengo Ubuntu 6.0.6) como root y tengo la tarjeta de sonido bien instalada pero en ventana el icono de ajustes de sonido sale inabilitado No se han encontrado complementos y/o dispositivos control de volumen de GStreamer, ya no se que hacer para poder oir algo,que alguien me ayude muchas gracias

Avatar de Usuario
cristafor
Forista Medio
Forista Medio
Mensajes: 413
Registrado: Lun Dic 19, 2005 8:00 am
Ubicación: Murcia (ESPAÑA)
Contactar:

Re: [Espacio Linux] Instalación de Sound Blaster Audigy 2 SE

Mensaje por cristafor »

Hóla yo tengo una sound blaster AWE 32. Pero, soy tan ignorante por no decir burraco de burro pero con ganas. Que a traves de la consóla no se como hacer la instalación en si de dicha tarjéta...
Eso sí, puedo escuchar y oir música a través de unos auriculares (no altavoces de equipos de alta fidelidad), y ejecutar kmixer y alsamixer, sin problémas de clase alguna.
Cristobal
http://forolinux.freelinuxforum.com/portal.htm
http://linuxmurcia.wordpress.com

Avatar de Usuario
perico
Forista Nuevo
Forista Nuevo
Mensajes: 1
Registrado: Vie Oct 20, 2006 7:00 am

Re: [Espacio Linux] Instalación de Sound Blaster Audigy 2 SE

Mensaje por perico »

muy buenas a todos, soyun recien iniciado en el ubuntu, y de momento, aunq a duras penas, estoy configurando todo de maravilla, lo unico que con mi sound blaster live 24 bit no me detecta los altavoces 5.1 y solo me suena en los frontales salvo el central. hay algun modo de que se pueda poner en 5.1? gracias por todo. por cierto, el howto estaba genial, paso a paso y facil de hacer

Avatar de Usuario
didacuz
Forista Menor
Forista Menor
Mensajes: 51
Registrado: Lun Oct 16, 2006 7:00 am

Re: [Espacio Linux] Instalación de Sound Blaster Audigy 2 SE

Mensaje por didacuz »

Hola! es la primera vez que escribo en este foro pero lo leo hace un tiempo y hace poco me propuse a aprnder a usar linux.
Uso el fedora core 4 2.6.11-1.1369_FC4 y tambien tengo la SB Live 7.1 24 bits, prove lo que dice el tutorial pero desde un comienzo me dice

"sudo: apt-get: command not found"

por adentro me dije, si empiezo asi...
en fin, fui directamente a ejecutar "./cvscompile" hasta ahi todo bien, despues puse:

"./configure --with-cards=ca0106 --with-sequencer=yes;make;make install"

y la primer linea dice:

"./configure: line 602: ==with-sequencer=yes: command not found"

despues todo bien hasta que en la parte final de "checking" dice esto:

checking for kernel linux/version.h... no
The file /lib/modules/2.6.11-1.1369_FC4/source/include/linux/version.h does not exist.
Please install the package with full kernel sources for your distribution
or use --with-kernel=dir option to specify another directory with kernel
sources (default is /lib/modules/2.6.11-1.1369_FC4/source).
make all-deps
make[1]: Entering directory `/usr/src/alsa/alsa-driver-1.0.13'
make[1]: No se hace nada para `all-deps'.
make[1]: Leaving directory `/usr/src/alsa/alsa-driver-1.0.13'

Please, run the configure script as first...

rm -f /snd*.*o /persist.o /isapnp.o
make[1]: Entering directory `/usr/src/alsa/alsa-driver-1.0.13/acore'
Makefile:6: /usr/src/alsa/alsa-driver-1.0.13/Makefile.conf: No existe el fichero o el directorio
/usr/src/alsa/alsa-driver-1.0.13/Rules.make:75: /Rules.make1: No existe el fichero o el directorio
make[1]: *** No hay ninguna regla para construir el objetivo `/Rules.make1'. Alto.
make[1]: Leaving directory `/usr/src/alsa/alsa-driver-1.0.13/acore'
make: *** [install-modules] Error 1

como no entendi nada de todo eso segui con lo demas del tutorial,probe sonido, seguia igual, solo se escucha por un solo canal, reinicie y lo mismo, sonido por un solo canal.
conocen alguna solucion? perdon por hacerlo tan largo :oops:
muchas gracias!

Avatar de Usuario
Yoyo
Administrador
Administrador
Mensajes: 3156
Registrado: Mar Jun 06, 2006 7:00 am
Ubicación: España
Contactar:

Re: [Espacio Linux] Instalación de Sound Blaster Audigy 2 SE

Mensaje por Yoyo »

Hola didacuz, yo no te puedo decir como hacerlo en Fedora que es la distro que dices que usas, lo que si te puedo decir es que ese tutorial esta hecho para ubuntu como bien pone en el encabezamiento.
(Este manual está realizado bajo la distribución Ubuntu 5.10, cuando se llevo a cabo la instalación era limpia en el PC, es decir, justo después de instalar Ubuntu)
Es logico que no te funcione el sudo apt-get, ya que esos son comandos para debian y derivados como ubuntu etc.. pero no para fedora que no está basada en debian.

Avatar de Usuario
didacuz
Forista Menor
Forista Menor
Mensajes: 51
Registrado: Lun Oct 16, 2006 7:00 am

Mensaje por didacuz »

gracias yoyofv!, no me habia percatado de ese detalle..., ogualmente voy a probar con Debian a ver que pasa, mas adelante les cuento como me fue, Gracias!

Avatar de Usuario
Cram
Forista Medio
Forista Medio
Mensajes: 181
Registrado: Lun May 21, 2007 7:00 am
Ubicación: /colomia/bogota
Contactar:

Mensaje por Cram »

tengo linux mandriva 2007 y no me funciona.....el paso 1 para instalar
b) gcc-3.4
c) build-essential
d) linux-headers-2.6.12-10-386

hu,mmmmquie me orienta!!!!
Por mas obstaculos que se encuentren a la solucion de un problema siempre hay un final

mario andres cortes romero
http://cram-cram.blogspot.com/

Responder
  • Temas similares
    Respuestas
    Vistas
    Último mensaje