Postfix envía hacia internet pero no recibe mails

Todos los comentarios sobre redes y servidores en linux y su interacción con otros sistemas operativos.

Moderadores: doc, Kde_Tony, ps-ax

Responder
Avatar de Usuario
erdosain9
Forista Nuevo
Forista Nuevo
Mensajes: 18
Registrado: Jue May 07, 2009 7:00 am

Postfix envía hacia internet pero no recibe mails

Mensaje por erdosain9 » Vie Nov 03, 2017 1:18 am

Hola a todos.
Espero puedan darme una mano, estoy bastante perdido, leí muchos tutoriales y documentación y no doy con qué estoy haciendo mal...

El escenario es este:
Queremos instalar un Servidor con Zimbra y otro servidor con Postfix (es decir, está cada uno en una máquina distinta). Sé que Zimbra trae su propio postfix pero me pidieron que lo haga de esta manera. La idea es generar los usuarios en Zimbra, y enviar y recibir los mails a través del servidor Postfix. (es Zimbra el que debería recibir los mails y postfix sólo entregárselos)

Seguí este tutorial https://www.jorgedelacruz.es/tag/zimbra-relay/
En el cual la configuración dada permite que Zimbra envie los mails a través de ese otro servidor Postfix. Hasta ahí todo bien, el tema es que si uno contesta a esos mails, pues no llegan a Zimbra.

Es decir, si escribo un mail en Zimbra del usuario, digamos, pablo@midominio.org.ar y lo envío a jose@gmail.com pues el mail llega a gmail, pero si intento contestar desde gmail, pues el mail no llega a la casilla de pablo.

Me encuentro con este error en los log.

Código: Seleccionar todo

Nov 1 12:50:52 postfix postfix/smtpd[6206]: connect from mail-pg0-f49.google.com[74.125.83.49]
Nov 1 12:50:53 postfix postfix/smtpd[6206]: 292EFAFC09:client=mail-pg0-f49.google.com[74.125.83.49]
Nov 1 12:50:53 postfix postfix/cleanup[6210]: 292EFAFC09:message-id=
Nov 1 12:50:53 postfix postfix/qmgr[6201]: 292EFAFC09:from=, size=2693, nrcpt=1 (queue active)
Nov 1 12:50:53 postfix postfix/smtpd[6206]: disconnect from mail-pg0-f49.google.com[74.125.83.49]
Nov 1 12:50:53 postfix postfix/smtpd[6206]: connect from unknown[172.16.0.1]
[b]Nov 1 12:50:53 postfix postfix/smtp[6211]: warning: host postfix.mydomain.org.ar[190.2.135.194]:25 greeted me with my own hostname postfix.mydomain.org.ar
Nov 1 12:50:53 postfix postfix/smtp[6211]: warning: host postfix.mydomain.org.ar[190.2.135.194]:25 replied to HELO/EHLO with my own hostname postfix.mydomain.org.ar
Nov 1 12:50:53 postfix postfix/smtp[6211]: 292EFAFC09:to=, relay=postfix.mydomain.org.ar[190.2.135.194]:25,delay=0.48, delays=0.19/0.01/0.28/0, dsn=5.4.6, status=bounced (mail for mydomain.org.ar loops back to myself)[/b]
Nov 1 12:50:53 postfix postfix/smtpd[6206]: disconnect from unknown[172.16.0.1]
Nov 1 12:50:53 postfix postfix/cleanup[6210]: 9F392AFC0B:message-id=
Nov 1 12:50:53 postfix postfix/qmgr[6201]: 9F392AFC0B: from=, size=4683,nrcpt=1 (queue active)
Nov 1 12:50:53 postfix postfix/bounce[6212]: 292EFAFC09: sender non-delivery notification: 9F392AFC0B
Nov 1 12:50:53 postfix postfix/qmgr[6201]: 292EFAFC09: removed
Nov 1 12:51:00 postfix postfix/smtp[6213]: 9F392AFC0B:
to=,
relay=gmail-smtp-in.l.google.com[64.233.190.26]:25, delay=6.8,
delays=0/0.01/5.6/1.1, dsn=2.0.0, status=sent (250 2.0.0 OK 1509551885
e64si537222qkc.73 – gsmtp)
Nov 1 12:51:00 postfix postfix/qmgr[6201]: 9F392AFC0B: removed

Estos son mis archivos de configuración del servidor Postfix donde imagino está el problema.

main.cf

Código: Seleccionar todo

command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/libexec/postfix
data_directory = /var/lib/postfix
debug_peer_level = 2
debugger_command = PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin ddd
$daemon_directory/$process_name $process_id & sleep 5
html_directory = no
inet_interfaces = all
inet_protocols = all
mail_owner = postfix
mailq_path = /usr/bin/mailq.postfix
manpage_directory = /usr/share/man
mydomain = mydomain.org.ar
myhostname = postfix.mydomain.org.ar
myorigin = $mydomain
relay_domains = mydomain.org.ar
newaliases_path = /usr/bin/newaliases.postfix
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/postfix-2.10.1/README_FILES
sample_directory = /usr/share/doc/postfix-2.10.1/samples
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop
smtpd_banner = $myhostname ESMTP $mail_name ($mail_version)
smtpd_recipient_restrictions =
permit_mynetworks,permit_sasl_authenticated,reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain = mydomain.org.ar
smtpd_sasl_path = /etc/sasl2/smtpd.conf
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
unknown_local_recipient_reject_code = 550
—————————————————————-

master.cf

Código: Seleccionar todo

smtp inet n – n – – smtpd
pickup unix n – n 60 1 pickup
cleanup unix n – n – 0 cleanup
qmgr unix n – n 300 1 qmgr
tlsmgr unix – – n 1000? 1 tlsmgr
rewrite unix – – n – – trivial-rewrite
bounce unix – – n – 0 bounce
defer unix – – n – 0 bounce
trace unix – – n – 0 bounce
verify unix – – n – 1 verify
flush unix n – n 1000? 0 flush
proxymap unix – – n – – proxymap
proxywrite unix – – n – 1 proxymap
smtp unix – – n – – smtp
relay unix – – n – – smtp
showq unix n – n – – showq
error unix – – n – – error
retry unix – – n – – error
discard unix – – n – – discard
local unix – n n – – local
virtual unix – n n – – virtual
lmtp unix – – n – – lmtp
anvil unix – – n – 1 anvil
scache unix – – n – 1 scache
Podrían darme una mano?? estoy bastante perdido.
Un saludo y muchas gracias
aismel
Forista Nuevo
Forista Nuevo
Mensajes: 2
Registrado: Jue Dic 07, 2017 7:35 pm

Re: Postfix envía hacia internet pero no recibe mails

Mensaje por aismel » Jue Dic 07, 2017 7:55 pm

Hola,

Compa yo tengo una configuración similar veras tengo 2 POSTFIX

NS1 RELAY con FETHMAIL (WAN) -- Este sale a buscar los correos y se los entrega a NS2
NS2 (LAN) -- Este se los entrega a los usuarios finales y se los pasa al NS1 cuando salen para la internet

Nose si es igual a tu escenario ¿?
Responder
  • Similar Topics
    Respuestas
    Vistas
    Último mensaje