Problemas con XFCE, Debian [solucionado]

Instalación, configuracion y manejo de escritorios y entornos gráficos como Xfce, Fluxbox, Enlightenment, Window Maker, etc..
Responder
Avatar de Usuario
Kenton
Forista Mayor
Forista Mayor
Mensajes: 548
Registrado: Sab Jun 21, 2014 1:54 pm

Problemas con XFCE, Debian [solucionado]

Mensaje por Kenton » Lun Dic 22, 2014 9:10 pm

Hola,

Parece que XFCE trabaja mejor con mi hardware, lo tengo en manjaro, es muy rapido y quisiera probarlo en Debian (cuentos tenias razón) pero tengo algunos problemas con este nuevo escritorio y me voy corriendo a la wiki de Debian: https://wiki.debian.org/es/Xfce ...

Lo primero es que no pude desinstalar gnome con el primer comando: aptitude purge `dpkg --get-selections | grep gnome | cut -f 1` -- seria porque no lo hice desde xfce?.

Lo segundo es que las terminales de sudo y root no escriben nada sobre ellas, ni siquiera aparecen el home usuario escrito $ o el de root # son solo una pantalla negra, no se puede hacer ninguna cosa -- y los emuladores que tiene, como Xterm, no admiten copy-paste, no se puede pegar nada, aunque si se pueden escribir.

Y también, por ultimo, me aparecen muchos iconos en este escritorio, ej: 'sistema de archivo de 180 GB' ... que ni siquiera puedo remover o quitar, o al menos redimencionarlos para empequeñecerlos lo suficiente como para que no me ocupen todo el espacio del escritorio.

Si alguien me puede dar una mano con este asunto ... muchas gracias.

Un saludo.

Editado -- Lun Dic 22, 2014 3:40 pm --

Olvide decir que instale la ultima opción de 'todos los paquetes de xfce': apt-get install `apt-cache search xfce | cut -d ' ' -f1`pensando que esto podría solucionar los problemas de las terminales y lo que consegui fue que se agrandara como hasta en 3GB mas el sistema, ahora tiene libreoffice, printer y no se cuantas cosas mas y no se como darle marcha atrás a esto.
Última edición por Kenton el Mar Dic 23, 2014 8:02 am, editado 1 vez en total.
"Me lo contaron y lo olvidé. Lo vi y lo entendí. Lo hice y lo aprendí." -- Confucio.

Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

Sistemas Operativos: PCLinux
Avatar de Usuario
enriquehh
Forista Distinguido
Forista Distinguido
Mensajes: 1337
Registrado: Sab Dic 08, 2007 8:00 am

Re: Problemas con XFCE, Debian

Mensaje por enriquehh » Mar Dic 23, 2014 3:09 am

Hola, en cuanto a xfce en Debian te doy unos cuantos consejos

a) Primero abre synaptic luego busca y elimina este paquete: libgtk-3-0, al eliminar este paquete se eliminaran varios paquetes relacionados a gnome 3.

b) Luego desde synaptic, busca e instala los paquetes xfce4 y lightdm

c) Reinicia la pc.


En cuanto al rendimiento que tienes en Debian 7.7 me parece que podria mejorar instalando el firmware no libre y un núcleo mas moderno (En Antergos los firmware no libres ya se instalan por defecto, al menos asi me paso a mi cuando probe esta distro, además el kernel en esta distro es mucho mas moderno que en Debian 7.7 ).

Finalmente mencionar que en Debian 7.7 para tener un kernel mas moderno y firmware no libres mas modernos se pude usar el repositorio Backports. Si estas interesado en este tema me avisas y te oriento al respecto (Yo estoy usando este repositorio en Debian 7.7 con gnome 3). Asimismo puedes mejorar el rendimiento de gnome 3 (version 3.4) desinstalando los paquetes: tracker y gnome-documents

Saludos
Última edición por enriquehh el Mar Dic 23, 2014 6:18 am, editado 1 vez en total.
Avatar de Usuario
Kenton
Forista Mayor
Forista Mayor
Mensajes: 548
Registrado: Sab Jun 21, 2014 1:54 pm

Re: Problemas con XFCE, Debian

Mensaje por Kenton » Mar Dic 23, 2014 5:19 am

Hola enriquehh,

Elimine desde el synaptic el paquete libgtk-3-0 y con el, efectivamente, se fueron muchísimas cosas de gnome,

después instale lightdm, pues xfce como dije antes ya estaba instalado,

reinicie la pc y las terminales están ahora muy bien (excepto las llamadas emuladores, no admiten copy-paste) pero,

no se puede abrir el synaptic ni el gparted, ni desde los iconos ni desde 'aplicaciones', por lo que supongo que se fue todo con gnome, lo reinstalarlo nuevamente desde la terminal, pero igual, no se abre desde aplicaciones ... -- solo abre cuando lo escribo en el terminal.

Se abrió también una opción en el gestor de inicio, donde se pone la clave y el usuario: Pekwm no hace nada, no va a ningún lugar, no abre ...

Saludos
"Me lo contaron y lo olvidé. Lo vi y lo entendí. Lo hice y lo aprendí." -- Confucio.

Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

Sistemas Operativos: PCLinux
Avatar de Usuario
enriquehh
Forista Distinguido
Forista Distinguido
Mensajes: 1337
Registrado: Sab Dic 08, 2007 8:00 am

Re: Problemas con XFCE, Debian

Mensaje por enriquehh » Mar Dic 23, 2014 6:28 am

Hola, para lo de gparted y synaptic (en cuanto a los lanzadores), prueba borrando los archivos ocultos de tu carpeta personal, para ello abre thunar y haz visible los archivos ocultos en tu carpeta personal y luego borra las carpetas llamadas: .local .config .gvfs .gconf .gnome2 .dbus (los archivos ocultos tienen un punto antes del nombre)
Cierra sesion o reinicia la computadora para comprobar si los lanzadores de las aplicaciones que mencionas se generaron correctamente.

En caso que lo anterior no solucione tu problema, instala alacarte y desde allí genera manualmente los lanzadores de los programas que mencionaste.

Saludos
Avatar de Usuario
Kenton
Forista Mayor
Forista Mayor
Mensajes: 548
Registrado: Sab Jun 21, 2014 1:54 pm

Re: Problemas con XFCE, Debian

Mensaje por Kenton » Dom Dic 28, 2014 1:03 am

Hola enriquehh,

Que extraño, no funciono eliminarlos desde archivos ocultos, el .local nunca lo pude borrar, pero con solo instalar alacarte todo cambio de súbito, no tuve que hacer nada mas, vinieron algunas cosas de gnome, y enseguida pude abrir synaptic y gparted como por arte de magia, quedo resuelto también lo de los iconos en el escritorio, pues encontré donde se ajustaba y configuraba todo.

En cuanto al consejo final sobre lo de instalar el firmware no libre y un kernel mas moderno ... la verdad que por el momento prefiero probar esta opción y ver como se sigue comportando ahora Debian con estos cambios, pero tendré siempre en cuenta vuestra proposición, muchas gracias.

Un saludo

Editado -- Mar Dic 23, 2014 12:21 pm --

hola enrriquehh, apenas me doy cuenta que me ha dejado sin sonido, fui al buscador de aplicaciones y lo que encuentro por audio es esa 'salida boba' sin opciones ...

Imagen

Editado -- Mar Dic 23, 2014 12:49 pm --

No parece tener nada que ver con los cambios que se hicieron pues regreso el sonido (pero bajo) después de ponerle el comando como root: alsa force-reload, parece otro tipo de fallo ya que hay que hacerlo con cierta frecuencia, aquí te dejo una captura de como esta ahora, no se cual marcar a la derecha ...


Imagen

Saludos.

Editado -- Sab Dic 27, 2014 7:27 pm --

Hola, solo para dejar constancia, olvide decir que ayer, después de este post decidí reinstalarlo, pero lo hice de una iso que ya venia con el escritorio xfce para evitarme el malabarismo ... (la iso, decía híbrido, no se porque) y aun así siguió teniendo problemas con el sonido hasta que aplique:

# alsactl store
# alsactl restore

Saludos
"Me lo contaron y lo olvidé. Lo vi y lo entendí. Lo hice y lo aprendí." -- Confucio.

Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

Sistemas Operativos: PCLinux
Avatar de Usuario
cargoan
Forista Medio
Forista Medio
Mensajes: 281
Registrado: Dom Oct 19, 2014 6:26 pm

Re: Problemas con XFCE, Debian [solucionado]

Mensaje por cargoan » Dom Dic 28, 2014 8:56 am

híbrido le suelen llamar cuando es para ambas arquitecturas (32 y 64 bits), también hay que se refieren a que la iso vale tanto para cd/dvd como para usb.
«La simplicidad es la máxima sofisticación» L. da Vinci
Arch Linux 64 (liquorix+BFS)
calipo
Forista Nuevo
Forista Nuevo
Mensajes: 4
Registrado: Sab May 28, 2016 4:55 am

Re: Problemas con XFCE, Debian [solucionado]

Mensaje por calipo » Sab May 28, 2016 5:12 pm

Hola amigos. Uso Xfce y veo que tengo instalado el paquete libgtk-3-0.
Por que lo tengo instalado si he realizado una instalación limpia con xfce?
Existe algún comando que me permita ver que programas usan un determinado paquete? Sería otro comando distinto del que dice las dependencias?
Muchas gracias por las respuestas
Responder
  • Similar Topics
    Respuestas
    Vistas
    Último mensaje