Problemas con el sources.list, Debian Jessie [solucionado]

Dudas y comentarios relacionadas con paquetes o programas específicos (obtención, uso, actualizaciones, versiones, problemas de instalación, etc.)

Moderadores: doc, Deckon

Responder
Avatar de Usuario
Kenton
Forista Mayor
Forista Mayor
Mensajes: 548
Registrado: Sab Jun 21, 2014 1:54 pm

Problemas con el sources.list, Debian Jessie [solucionado]

Mensaje por Kenton » Dom Nov 02, 2014 7:43 pm

Hola,

El sistema esta actualizado. No puedo ver vídeos. Recargo el synaptic y no aparece el flashplugin, y por la terminal no puedo instalarlo.
No se ahora que burrada estaré haciendo.

root@kaos:/home/keos# apt-get install flashplugin
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
E: No se ha podido localizar el paquete flashplugin
root@kaos:/home/keos#

Saludos

Olvido:

También trate esto, sin resultado:

root@kaos:/home/keos# apt-get install firmware-linux firmware-linux-free firmware-linux-nonfree firmware-realtek
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Package firmware-linux is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'firmware-linux' has no installation candidate
E: No se ha podido localizar el paquete firmware-linux-nonfree
E: No se ha podido localizar el paquete firmware-realtek
root@kaos:/home/keos#

En caso que ... el sources.list:

#

deb http://ftp.us.debian.org/debian/ jessie main
deb-src http://ftp.us.debian.org/debian/ jessie main

deb http://security.debian.org/ jessie/updates main contrib
deb-src http://security.debian.org/ jessie/updates main contrib

# jessie-updates, previously known as 'volatile'
deb http://ftp.us.debian.org/debian/ jessie-updates main contrib
deb-src http://ftp.us.debian.org/debian/ jessie-updates main contrib

# jessie-backports, previously on backports.debian.org
deb http://ftp.us.debian.org/debian/ jessie-backports main contrib
deb-src http://ftp.us.debian.org/debian/ jessie-backports main contrib
Última edición por Kenton el Lun Nov 03, 2014 1:30 am, editado 2 veces en total.
"Me lo contaron y lo olvidé. Lo vi y lo entendí. Lo hice y lo aprendí." -- Confucio.

Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

Sistemas Operativos: PCLinux
Avatar de Usuario
doc
Forista Ancestral
Forista Ancestral
Mensajes: 3304
Registrado: Mié Ago 11, 2010 10:32 am
Ubicación: Oviedo-es_ES
Contactar:

Re: No puedo instalar flashplugin, Debian Jessie

Mensaje por doc » Dom Nov 02, 2014 8:36 pm

es que el flashplugin-nonfree está en los repos 'contrib' y solo tienes activados los 'main'
https://packages.debian.org/search?keyw ... lla-search
Avatar de Usuario
Kenton
Forista Mayor
Forista Mayor
Mensajes: 548
Registrado: Sab Jun 21, 2014 1:54 pm

Re: No puedo instalar flashplugin, Debian Jessie

Mensaje por Kenton » Dom Nov 02, 2014 9:11 pm

hola, pues hago el download de [flashplugin-nonfree_3.6.tar.xz] lo extraigo, y no sucede nada, no aparece en el synaptic (?).
"Me lo contaron y lo olvidé. Lo vi y lo entendí. Lo hice y lo aprendí." -- Confucio.

Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

Sistemas Operativos: PCLinux
Avatar de Usuario
cuentos
Forista Distinguido
Forista Distinguido
Mensajes: 1088
Registrado: Mar May 03, 2011 7:09 am

Re: No puedo instalar flashplugin, Debian Jessie

Mensaje por cuentos » Dom Nov 02, 2014 10:08 pm

para flash desde la terminal como root prueba con:

Código: Seleccionar todo

apt-get install flashplugin-nonfree
Cuando mi maestro me reprendió, me dijo: Alejandro Magno a los 20 años conquistaba el mundo, Yo le conteste "si pero tenia de maestro a Aristóteles".
Twitter: @mcuentos
Avatar de Usuario
Kenton
Forista Mayor
Forista Mayor
Mensajes: 548
Registrado: Sab Jun 21, 2014 1:54 pm

Re: No puedo instalar flashplugin, Debian Jessie

Mensaje por Kenton » Dom Nov 02, 2014 10:24 pm

hola cuentos ya había hecho eso también, de cualquier manera aqui te dejo lo que me da:

root@kaos:/home/keos# apt-get install flashplugin-nonfree
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Package flashplugin-nonfree is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'flashplugin-nonfree' has no installation candidate
root@kaos:/home/keos#

Ahora bien, no se si doc se referirá a que tengo que comentar la linea de contrib que aparece descomentada en el sources.list, o sea estas dos:

deb http://security.debian.org/ jessie/updates main contrib
deb-src http://security.debian.org/ jessie/updates main contrib

saludos
"Me lo contaron y lo olvidé. Lo vi y lo entendí. Lo hice y lo aprendí." -- Confucio.

Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

Sistemas Operativos: PCLinux
Avatar de Usuario
cuentos
Forista Distinguido
Forista Distinguido
Mensajes: 1088
Registrado: Mar May 03, 2011 7:09 am

Re: No puedo instalar flashplugin, Debian Jessie

Mensaje por cuentos » Dom Nov 02, 2014 10:51 pm

ok, en mi pc con testing me da:

Código: Seleccionar todo

apt-get install flashplugin-nonfree
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
flashplugin-nonfree ya está en su versión más reciente.
en cuanto a mi sources.list, veo que te falta en las primeras lineas contrib, y si también non-free, tu pusiste (son las dos primeras lineas:

Código: Seleccionar todo

deb http://ftp.us.debian.org/debian/ jessie main
deb-src http://ftp.us.debian.org/debian/ jessie main

te pongo mi archivo

Código: Seleccionar todo

deb http://mmc.geofisica.unam.mx/debian/ testing main  contrib non-free
deb-src http://mmc.geofisica.unam.mx/debian/ testing  main  contrib non-free

deb http://security.debian.org/ testing/updates main  contrib non-free
deb-src http://security.debian.org/ testing/updates main  contrib non-free
En caso que agregues contrib y non-free, después de editar y guardar el archivo actualizas la lista con:

Código: Seleccionar todo

apt-get update
y luego procedes a instalar flash, y el firmware que nombras
Cuando mi maestro me reprendió, me dijo: Alejandro Magno a los 20 años conquistaba el mundo, Yo le conteste "si pero tenia de maestro a Aristóteles".
Twitter: @mcuentos
Avatar de Usuario
Kenton
Forista Mayor
Forista Mayor
Mensajes: 548
Registrado: Sab Jun 21, 2014 1:54 pm

Re: No puedo instalar flashplugin, Debian Jessie

Mensaje por Kenton » Lun Nov 03, 2014 12:20 am

Hola,

Si te fijas bien, mi sources.list original es muy diferente al tuyo, no hay testing en ninguna parte, de cualquier manera, le agregue estas dos lineas:

deb http://security.debian.org/ testing/updates main contrib non-free
deb-src http://security.debian.org/ testing/updates main contrib non-free

*Hice el update y reboot para regresar e instalar, pero:

root@kaos:/home/keos# apt-get install flashplugin-nonfree
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Package flashplugin-nonfree is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'flashplugin-nonfree' has no installation candidate
root@kaos:/home/keos#

Debo ahora quitarles estas lineas que agregue ...?

Saludos

Editado -- Dom Nov 02, 2014 6:48 pm --

Cada vez que el sistema arranca, en la pantalla negra aparece un comentario que dice algo sobre el kernel (es muy rápido) seguido de esto:

modensetting R600 require firmware-linux-nonfree

Pero tampoco lo puedo instalar
"Me lo contaron y lo olvidé. Lo vi y lo entendí. Lo hice y lo aprendí." -- Confucio.

Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

Sistemas Operativos: PCLinux
Avatar de Usuario
enriquehh
Forista Distinguido
Forista Distinguido
Mensajes: 1337
Registrado: Sab Dic 08, 2007 8:00 am

Re: No puedo instalar flashplugin, Debian Jessie

Mensaje por enriquehh » Lun Nov 03, 2014 12:46 am

Hola, en estas lineas de tu sources.list:

Código: Seleccionar todo

deb http://ftp.us.debian.org/debian/ jessie main
deb-src http://ftp.us.debian.org/debian/ jessie main
Agrega después de main las palabras contrib y non-free, cosa que te quede así

Código: Seleccionar todo

deb http://ftp.us.debian.org/debian/ jessie main contrib non-free
deb-src http://ftp.us.debian.org/debian/ jessie main contrib non-free
Luego lanza apt-get update y finalmente instala los paquetes que necesitas.


Saludos
Avatar de Usuario
Kenton
Forista Mayor
Forista Mayor
Mensajes: 548
Registrado: Sab Jun 21, 2014 1:54 pm

Re: No puedo instalar flashplugin, Debian Jessie

Mensaje por Kenton » Mar Nov 04, 2014 3:01 am

Hola enriquehh,

Que te puedo decir, como siempre, funciono, genial.

Mil gracias!!

Editado -- Lun Nov 03, 2014 7:30 pm --

Hola, estoy tratando de conseguir estos paquetes, que usualmente están siempre en el synaptic: unhide.rb harden anon-proxy y pero no aparecen ahí, voy por la terminal para instalarlos y no se pueden conseguir, pensé que quizás debía poner este comando para los firmwares:

apt-get install firmware-linux firmware-linux-free firmware-linux-nonfree

--pero tampoco funciono, entonces nuevamente los removí, pues no parecen servir de mucho.

Ya no se que hacer, no abrí otro hilo pensando que quizás tenga también que ver con el source.list (?).

Gracias por cualquier sugerencia.

Saludos.

Editado -- Lun Nov 03, 2014 9:31 pm --

root@kaos:/home/keos# apt-get install unhide.rb
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Package unhide.rb is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'unhide.rb' has no installation candidate
root@kaos:/home/keos# apt-get install harden
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
E: No se ha podido localizar el paquete harden
root@kaos:/home/keos# apt-get install anon-proxy
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
E: No se ha podido localizar el paquete anon-proxy
root@kaos:/home/keos#
"Me lo contaron y lo olvidé. Lo vi y lo entendí. Lo hice y lo aprendí." -- Confucio.

Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

Sistemas Operativos: PCLinux
Avatar de Usuario
enriquehh
Forista Distinguido
Forista Distinguido
Mensajes: 1337
Registrado: Sab Dic 08, 2007 8:00 am

Re: Problemas con el sources.list, Debian Jessie [solucionado]

Mensaje por enriquehh » Mar Nov 04, 2014 5:39 pm

Hola, los paquetes que mencionas están todavía en la rama inestable de debian. Si deses esos paquetes tienes dos caminos.
1) Esperar a que dichos paquetes entres a la rama testing.
2) Configurar tus repositorios para que apunten a la rama inestable de Debian e instalar dichos paquetes (Si eliges esta alternativa tienes que hacerlo con mucho cuidado)

Saludos
Avatar de Usuario
Kenton
Forista Mayor
Forista Mayor
Mensajes: 548
Registrado: Sab Jun 21, 2014 1:54 pm

Re: Problemas con el sources.list, Debian Jessie [solucionado]

Mensaje por Kenton » Mar Nov 04, 2014 6:41 pm

Hola enriquehh,

La verdad que no entiendo a que te refieres con 'testing', pues estos paquetes han estado anteriormente en el synaptic de debian/jessie, o quizás no me explico bien, lo que quiero decir es que ahora no están en lo absoluto en el synaptic y anteriormente, en la otra instalación que hice el mes pasado, si estaban ahí (?).

-- que no es este jessie el 'testing' ? De hecho tiene hasta el stockfish-5 ! ... no comprendo ... Gracias.

Un saludo.
"Me lo contaron y lo olvidé. Lo vi y lo entendí. Lo hice y lo aprendí." -- Confucio.

Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

Sistemas Operativos: PCLinux
Avatar de Usuario
enriquehh
Forista Distinguido
Forista Distinguido
Mensajes: 1337
Registrado: Sab Dic 08, 2007 8:00 am

Re: Problemas con el sources.list, Debian Jessie [solucionado]

Mensaje por enriquehh » Mar Nov 04, 2014 9:14 pm

Hola, Debian tiene tres ramas (si sumamos experimental serían cuatro). Estas son Debian Estable (actualmente wheezy), Debian Testing (Actualmente Jessie), Debian inestable (Sid) y Debian experimental. El flujo de los paquetes de una rama a otra es la siguiente (Para que te hagas una idea):

Los paquetes nuevos entran primero a la rama experimental luego cuando estos han sido probados y no causan muchos problemas pasan a debian inestable; para que esos mismos paquetes pasen a debian testing se realizan pruebas mas rigurosas. Ahora bien para que esos mismos paquetes formen parte de la versión estable de Debian (Debian Jessie esta entrando a una etapa de congelamiento, pues esta será la próxima versión estable de Debian) pasan por pruebas mas exigentes y los requisitos que ponen los desarrolladores de Debian a los paquetes que serán parte de la versión estable aumentan notablemente.

Dicho lo anterior los paquetes que llegan a Debian testing (actualmente Jessie) varían constantemente a lo largo del periodo de vida de la versión estable de Debian, pero este cambio continuo tiene un tope, pues cuanto mas se acerca el tiempo en el que Debian Jessie se convierta en la próxima versión estable, los desarrolladores de esta distro van seleccionando los paquetes que consideran que cumplen con los requisitos mínimos que ellos acordaron para ser parte de la próxima versión estable.

La razón por la que los paquetes que mencionas no estén actualmente en la rama testing es debido a que los desarrolladores no han dado el visto bueno para que estos paquetes formen parte de la futura estable.

Saludos
Avatar de Usuario
Kenton
Forista Mayor
Forista Mayor
Mensajes: 548
Registrado: Sab Jun 21, 2014 1:54 pm

Re: Problemas con el sources.list, Debian Jessie [solucionado]

Mensaje por Kenton » Mar Nov 04, 2014 9:58 pm

Hola, gracias por aclararme tan importante aspecto, ahora lo entiendo mejor.

Como puede uno saber cuando esos paquetes que actualmente están en Sic pasaran a Jessie?

-- pues creo es lo mejor que puedo hacer entonces, esperarlos, ya que eso de 'configurar los repositorios' para en definitiva tener después algo mas inestable ... en mi caso no vale la pena.

Un saludo.
"Me lo contaron y lo olvidé. Lo vi y lo entendí. Lo hice y lo aprendí." -- Confucio.

Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

Sistemas Operativos: PCLinux
Responder
  • Similar Topics
    Respuestas
    Vistas
    Último mensaje