[Solucionado][LDAP] error al poblar el directorio ldap

Todos los comentarios sobre redes y servidores en linux y su interacción con otros sistemas operativos.

Moderadores: doc, Kde_Tony, ps-ax

Responder
Avatar de Usuario
crakeador
Forista Nuevo
Forista Nuevo
Mensajes: 37
Registrado: Vie Oct 19, 2012 12:34 pm
Ubicación: Germany

[Solucionado][LDAP] error al poblar el directorio ldap

Mensaje por crakeador » Lun Dic 17, 2012 6:30 pm

Hola a todos, en una configuracion LDAP, a la hora de poblar la base con el comando smbldap-populate, me genera el siguiente error:

Código: Seleccionar todo

Populating LDAP directory for domain MIENTORNOVIRTUAL (S-1-5-21-2839187728-1443221184-85559460)
(using builtin directory structure)

entry dc=mientornovirtual,dc=org already exist. 
entry ou=people,dc=mientornovirtual,dc=org already exist. 
entry ou=group,dc=mientornovirtual,dc=org already exist. 
entry ou=computer,dc=mientornovirtual,dc=org already exist. 
entry ou=idmap,dc=mientornovirtual,dc=org already exist. 
adding new entry: uid=root,ou=people,dc=mientornovirtual,dc=org
failed to add entry: objectClass: value #4 invalid per syntax at /usr/sbin/smbldap-populate line 498, <GEN1> line 58.
adding new entry: uid=nobody,ou=people,dc=mientornovirtual,dc=org
failed to add entry: objectClass: value #4 invalid per syntax at /usr/sbin/smbldap-populate line 498, <GEN1> line 89.
adding new entry: cn=Domain Admins,ou=group,dc=mientornovirtual,dc=org
failed to add entry: objectClass: value #2 invalid per syntax at /usr/sbin/smbldap-populate line 498, <GEN1> line 101.
adding new entry: cn=Domain Users,ou=group,dc=mientornovirtual,dc=org
failed to add entry: objectClass: value #2 invalid per syntax at /usr/sbin/smbldap-populate line 498, <GEN1> line 112.
adding new entry: cn=Domain Guests,ou=group,dc=mientornovirtual,dc=org
failed to add entry: objectClass: value #2 invalid per syntax at /usr/sbin/smbldap-populate line 498, <GEN1> line 123.
adding new entry: cn=Domain Computers,ou=group,dc=mientornovirtual,dc=org
failed to add entry: objectClass: value #2 invalid per syntax at /usr/sbin/smbldap-populate line 498, <GEN1> line 134.
adding new entry: cn=Administrators,ou=group,dc=mientornovirtual,dc=org
failed to add entry: objectClass: value #2 invalid per syntax at /usr/sbin/smbldap-populate line 498, <GEN1> line 179.
adding new entry: cn=Account Operators,ou=group,dc=mientornovirtual,dc=org
failed to add entry: objectClass: value #2 invalid per syntax at /usr/sbin/smbldap-populate line 498, <GEN1> line 201.
adding new entry: cn=Print Operators,ou=group,dc=mientornovirtual,dc=org
failed to add entry: objectClass: value #2 invalid per syntax at /usr/sbin/smbldap-populate line 498, <GEN1> line 212.
adding new entry: cn=Backup Operators,ou=group,dc=mientornovirtual,dc=org
failed to add entry: objectClass: value #2 invalid per syntax at /usr/sbin/smbldap-populate line 498, <GEN1> line 223.
adding new entry: cn=Replicators,ou=group,dc=mientornovirtual,dc=org
failed to add entry: objectClass: value #2 invalid per syntax at /usr/sbin/smbldap-populate line 498, <GEN1> line 234.
adding new entry: sambaDomainName=MIENTORNOVIRTUAL,dc=mientornovirtual,dc=org
failed to add entry: invalid DN at /usr/sbin/smbldap-populate line 498, <GEN1> line 242.

Please provide a password for the domain root: 
/usr/sbin/smbldap-passwd: user root doesn't exist

Al revisar los logs, me da el siguiente error

Código: Seleccionar todo

Dec 13 13:10:06 SERVER-001 slapd[1722]: conn=1003 op=28 do_search: invalid dn: "sambaDomainName=MIENTORNOVIRTUAL,dc=mientornovirtual,dc=org"
Dec 13 13:10:06 SERVER-001 slapd[1722]: conn=1003 op=29 do_add: invalid dn (sambaDomainName=MIENTORNOVIRTUAL,dc=mientornovirtual,dc=org)
Dec 13 13:10:17 SERVER-001 AptDaemon: INFO: Quiting due to inactivity
Dec 13 13:10:17 SERVER-001 AptDaemon: INFO: Shutdown was requested
Dec 13 13:12:17 SERVER-001 slapd[1722]: conn=1014 op=27 do_search: invalid dn: "sambaDomainName=MIENTORNOVIRTUAL,dc=mientornovirtual,dc=org"
Dec 13 13:12:17 SERVER-001 slapd[1722]: conn=1014 op=28 do_add: invalid dn (sambaDomainName=MIENTORNOVIRTUAL,dc=mientornovirtual,dc=org)


Alguno ha tenido experiencia en LDAP y puede resultarle familiar el error?

PARA EVITAR ESTE ERROR SE DEBE ESPECIFICAR EN EL FICHERO /ETC/DEFAULT/SLAPD DONDE SE UBICA EL FICHERO SLAPD.CONF YA QUE POR DEFECTO, VIENE EN BLANCO
Responder
  • Similar Topics
    Respuestas
    Vistas
    Último mensaje