Reglamento general de los foros   •   FAQ   •   Buscar en el foro •  Registrarse | Iniciar sesión 



Portada » Foros Linux » Administración del sistema » Redes y Servidores


Nuevo tema Responder al tema
 [ 2 mensajes ] 
Patrocinadores

Autor
Buscar:
Mensaje

Desconectado
Forista Nuevo
Forista Nuevo
Avatar de Usuario

Registrado: Vie Dic 30, 2011 6:06 pm
Mensajes: 23
Ubicación: Tampico, México.

Nota Publicado: Vie Ago 17, 2012 8:04 pm 
Arriba  
Buenas tardes a todos, bueno, quiero contarles mi problema...

Tengo un Servidor con Ubuntu Server, donde tengo Squid corriendo sin problemas, también tengo Apache y Samba.
El detalle surge que en este servidor he subido un directorio de archivos visualizados de forma web (puerto 80) con Apache obviamente dentro de /var/www que de forma local (LAN) con http://laipdelserver/archivos, puedo verlos sin ningún problema.

Pues resulta que tenemos sucursales conectados a través de VPN's a la Organización principal. Es aquí en donde se supone que estas sucursales deben y puede entrar de la misma manera a http://laipdelserver/archivos, lo extraño es que no se hace. Se probó ping desde la sucursal a la Organización principal y Si respondeeeeen!!!

Entonces... que podría estar pasando ?

Este es la configuración de las interfaces de red y el ruteo dentro del archivo /etc/network/interfaces:

Código:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
        address 10.0.0.30
        netmask 255.255.255.0
        network 10.0.0.0
        broadcast 10.0.0.255
        gateway 10.0.0.135

auto eth1
iface eth1 inet static
        address 192.168.2.253
        netmask 255.255.255.0
        network 192.168.2.0
        broadcast 192.168.2.255
post-up route add -net 192.168.0.0 netmask 255.255.0.0 gw 192.168.2.210
pre-down route del -net 192.168.0.0 netmask 255.255.0.0 gw 192.168.2.210


Donde 192.168.2.210 es el Concentrador principal de VPN's

Estas la configuración de mis IPTABLES

Código:
# Generated by iptables-save v1.4.4 on Thu Dec  8 09:10:17 2011
*nat
:PREROUTING ACCEPT [2525:201500]
:POSTROUTING ACCEPT [47:4021]
:OUTPUT ACCEPT [97:11047]
-A PREROUTING -i eth1 -p tcp -m tcp --dport 80 -j DNAT --to-destination 10.0.0.30:3128
-A PREROUTING -i eth0 -p tcp -m tcp --dport 80 -j REDIRECT --to-ports 3128
-A POSTROUTING -j MASQUERADE
-A POSTROUTING -s 192.168.0.0/24 -o eth0 -j SNAT --to-source 10.0.0.30
-A POSTROUTING -s 192.168.0.0/24 -o eth1 -j SNAT --to-source 192.168.2.210
COMMIT
# Completed on Thu Dec  8 09:10:17 2011
# Generated by iptables-save v1.4.4 on Thu Dec  8 09:10:17 2011
*filter
:INPUT ACCEPT [5836:575599]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [1801:271331]
-A FORWARD -s 192.168.0.0/24 -i eth1 -o eth0 -m conntrack --ctstate NEW -j ACCEPT
-A FORWARD -m conntrack --ctstate RELATED,ESTABLISHED -j ACCEPT
COMMIT
# Completed on Thu Dec  8 09:10:17 2011


Espero haber sido claro en lo que hasta ahorita no he podido lograr y alguien caritativo me pueda ayudar, tengo varias noches sin poder dormir bien :o jajaja.

Un saludo a todos.

_________________
A quien va usted a creer, ¿A mi, o a sus propios ojos? Groucho Marx

 Perfil  

Desconectado
Moderador
Moderador
Avatar de Usuario

Registrado: Mié Jul 20, 2005 7:00 am
Mensajes: 3866
Ubicación: /home/Peru/Lima/La Molina

Nota Publicado: Lun Ago 20, 2012 10:31 pm 
Arriba  
asumo que los clientes no tienen configurado el proxy o si ?... bueno, de ser asi, prueba colocando las configuraciones de tu proxy en un browser y realiza las mismas pruebas

Sls

_________________
"Quiero cambiar al mundo pero no me dan los RPM"
----------------------------
Tony Blair
Linux User # 433253
Ubuntu User # 9562
-----------------------------

 Perfil WWW  
Mostrar mensajes previos:  Ordenar por  
 [ 2 mensajes ] 
Nuevo tema Responder al tema

Saltar a:  


 Temas relacionados   Autor   Respuestas   Vistas   Último mensaje 
Problemas Con Nat

en Redes y Servidores

ybarmax

12

1294

Dom Abr 04, 2010 12:33 am

ybarmax Ver último mensaje

Problemas con VLC

en Software

clamide

6

1155

Mié Ago 13, 2014 7:05 pm

clamide Ver último mensaje

Problemas con ssh

en Redes y Servidores

korex

2

685

Lun May 31, 2010 4:51 pm

mrvic Ver último mensaje

Problemas con sonido (again and again)

en Hardware

clamide

2

473

Mar Abr 22, 2014 3:30 pm

clamide Ver último mensaje

Problemas al descomprimir

en Software

antopv

3

523

Jue Ene 28, 2010 3:42 pm

antopv Ver último mensaje



¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 2 invitados

No puede abrir nuevos temas en este Foro
No puede responder a temas en este Foro
No puede editar sus mensajes en este Foro
No puede borrar sus mensajes en este Foro
No puede enviar adjuntos en este Foro

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group :: Style based on FI Subice by phpBBservice.nl :: Todos los horarios son UTC + 1 hora [ DST ]
Traducción al español por Huan Manwë
phpBB SEO