error al refrescar al lista de paquetes en debian

Dudas y comentarios relacionadas con paquetes o programas específicos (obtención, uso, actualizaciones, versiones, problemas de instalación, etc.)

Moderadores: doc, Deckon

Avatar de Usuario
hall9000
Forista Medio
Forista Medio
Mensajes: 186
Registrado: Jue Ene 07, 2010 1:06 am
Ubicación: en la orbita de jupiter
Contactar:

Re: error al refrescar al lista de paquetes en debian

Mensaje por hall9000 »

jony127 escribió:Todavía sigo obteniendo algún error, en este caso está relacionado con el repo multimedia:

E: Se produjo un fallo al descargar http://www.deb-multimedia.org/pool/main ... _amd64.deb: La suma hash difiere

¿a alguien más le pasa esto? porque al dar ese error no me actualiza otros paquetes de este repo, no se que problema puede haber con los repos.
a mi me esta pasando desde hace unos dias, algo parecido con el repo de multimedia.

Código: Seleccionar todo

root@debian:/home/pablo# aptitude safe-upgrade
Resolviendo las dependencias...                 
Se actualizarán los siguientes paquetes:
  libvlc5 libvlccore5 vlc vlc-data vlc-nox vlc-plugin-notify vlc-plugin-pulse
7 paquetes actualizados, 0 nuevos instalados, 0 para eliminar y 11 sin actualizar.
Necesito descargar 12,2 MB de ficheros. Después de desempaquetar se usarán 0 B.
¿Quiere continuar? [Y/n/?] y
Des: 1 http://www.deb-multimedia.org/ testing/main libvlccore5 amd64 1:2.0.1-dmo3 [414 kB]
Des: 2 http://www.deb-multimedia.org/ testing/main vlc-data all 1:2.0.1-dmo3 [7.367 kB]
Des: 3 http://www.deb-multimedia.org/ testing/main libvlc5 amd64 1:2.0.1-dmo3 [46,4 kB]                            
Des: 4 http://www.deb-multimedia.org/ testing/main vlc-plugin-notify amd64 1:2.0.1-dmo3 [6.588 B]                  
Des: 5 http://www.deb-multimedia.org/ testing/main vlc-plugin-pulse amd64 1:2.0.1-dmo3 [20,2 kB]                   
Des: 6 http://www.deb-multimedia.org/ testing/main vlc amd64 1:2.0.1-dmo3 [1.313 kB]                               
Des: 7 http://www.deb-multimedia.org/ testing/main vlc-nox amd64 1:2.0.1-dmo3 [3.064 kB]                           
Descargados 12,2 MB en 1min. 40seg. (121 kB/s)                                                                     
E: Se produjo un fallo al descargar http://www.deb-multimedia.org/pool/main/v/vlc-dmo/libvlccore5_2.0.1-dmo3... La suma hash difiere
                                                
E: Se produjo un fallo al descargar http://www.deb-multimedia.org/pool/main/v/vlc-dmo/libvlccore5_2.0.1-dmo3... La suma hash difiere
lo curioso que he descubierto, es que sin en vez de utilizar aptitude, uso apt-get si que me actualiza :? .
We were but stones, your light made us stars

Debian testing + Openbox --- Arch + Xfce4
http://linuxveredas.blogspot.com/ http://identi.ca/hall9000

Avatar de Usuario
CharlieBros
Forista Mayor
Forista Mayor
Mensajes: 691
Registrado: Lun Sep 26, 2011 2:01 am
Ubicación: Mexico, DF

Re: error al refrescar al lista de paquetes en debian

Mensaje por CharlieBros »

Pues hoy empece a tambien tener problemas con debmulti.
Asi que mejor me cambio de nuevo a Arch, que esa si es full rolling :).
Saludos.
Charlie

Avatar de Usuario
jony127
Forista Mayor
Forista Mayor
Mensajes: 605
Registrado: Jue Ago 24, 2006 7:00 am

Re: error al refrescar al lista de paquetes en debian

Mensaje por jony127 »

CharlieBros escribió:Pues hoy empece a tambien tener problemas con debmulti.
Asi que mejor me cambio de nuevo a Arch, que esa si es full rolling :).
Saludos.
Charlie
No sé de donde sacais las ganas para andar cambiando de distro así como así, a mí particularmente se me hace pesado andar instalando y configurando de nuevo una distro :shock: .

Para mí lo más importante es que ahora sí puede entrar en preferencias del sistema->apariencia del espacio de trabajo de kde. Siguiendo la prueba de hall9000 como siempre uso aptitude para actualizar pues probé que apt-get y bingo, el repo multimedia se me ha actualizado sin problemas y aparte el sistema estaba a medio actualizar de ahí los errores que me arrojaba kde, veré cuando apague el pc si no me de el error de kwin pero me huelo a que está ahora todo ok. Ahora tengo lío entre el funcionamiento de apt-get y aptitude pensé que era lo mismo actualizar con uno que con otro pero veo que no, ejemplos:

Primero ejecuto un aptitude upgrade:

Código: Seleccionar todo

aptitude upgrade                                                                                                                                                                
Resolviendo las dependencias...                                                                                                                                                                            
Se instalarán los siguiente paquetes NUEVOS:                                                                                                                                                               
  digikam{a} mplayer2{a} mplayerthumbs{a}                                                                                                                                                                  
Se actualizarán los siguientes paquetes:                                                                                                                                                                   
  deadbeef deadbeef-plugins-dev ffmpeg kipi-plugins kipi-plugins-common libavcodec54 libavdevice54 libavfilter2 libavformat54 libavutil51 libpostproc52 libswresample0 libswscale2 libvlc5 libvlccore5     
  libxvidcore4 udisks vlc vlc-data vlc-nox vlc-plugin-notify vlc-plugin-pulse xfonts-mathml                                                                                                                
Se RECOMIENDAN los siguientes paquetes, pero NO se instalarán:                                                                                                                                             
  cryptsetup-bin fonts-stix                                                           
Después el error de hash difiere y no se actualiza nada. Ahora pruebo con un apt-get upgrade:

Código: Seleccionar todo

apt-get upgrade
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Los siguientes paquetes se han retenido:
  amarok amarok-common amarok-utils apt kde-window-manager kde-workspace kde-workspace-bin kde-workspace-data kde-workspace-dev kde-workspace-kgreet-plugins kdm kinfocenter kipi-plugins
  kipi-plugins-common ksysguard ksysguardd libkdecorations4 libkephal4abi1 libkscreensaver5 libksgrd4 libksignalplotter4 liblsofui4 libplasma-geolocation-interface4 libplasmagenericshell4
  libprocesscore4abi1 libprocessui4a libqt4-dbus libqt4-declarative libqt4-designer libqt4-dev libqt4-dev-bin libqt4-help libqt4-network libqt4-opengl libqt4-opengl-dev libqt4-qt3support libqt4-script
  libqt4-scripttools libqt4-sql libqt4-sql-mysql libqt4-sql-sqlite libqt4-svg libqt4-test libqt4-xml libqt4-xmlpatterns libqtcore4 libqtgui4 libsolidcontrol4abi2 libsolidcontrolifaces4abi2
  libweather-ion6 mysql-common plasma-dataengines-addons plasma-dataengines-workspace plasma-desktop plasma-widget-lancelot plasma-widgets-addons plasma-widgets-workspace poppler-data qdbus
  qt4-linguist-tools qt4-qmake udisks xbmc xbmc-bin xbmc-data xbmc-skin-confluence xfonts-mathml
0 actualizados, 0 se instalarán, 0 para eliminar y 67 no actualizados.
Como ven, no actualiza nada pero me dice que se han retenido una gran cantidad de paquetes, cosa que aptitude no me indicaba de ahí los errores que me daba kde ya que estaba a medio actualizar. ¿Alguién puede explicarme porque se han retenido todos esos paquetes y la diferencia que hay entre apt-get upgrade y aptitude upgrade? porque ya ven la diferencia entre uno y otro.

Para poder actualizar completamente el kde he tenido que usar apt-get dist-upgrade.

Por último vuelvo a ejecutar un aptitude upgrade y apt-get upgrade y vean la diferencia:

Código: Seleccionar todo

root@debian:/home/jonatan# aptitude upgrade
Resolviendo las dependencias...                   
Se instalarán los siguiente paquetes NUEVOS:
  libmysqlclient18{a} 
Se ELIMINARÁN los siguientes paquetes:
  amarok-common{u} amarok-utils{u} kdemultimedia-kio-plugins{u} libaio1{u} libkworkspace4{u} liblastfm0{u} libloudmouth1-0{u} libqtscript4-core{u} libqtscript4-gui{u} libqtscript4-network{u} 
  libqtscript4-sql{u} libqtscript4-uitools{u} libqtscript4-xml{u} libtag-extras1{u} mysql-server-core-5.1{u} 
Se actualizarán los siguientes paquetes:
  mysql-common xbmc xbmc-bin xbmc-data xbmc-skin-confluence 
5 paquetes actualizados, 1 nuevos instalados, 15 para eliminar y 0 sin actualizar.
Necesito descargar 32,8 MB de ficheros. Después de desempaquetar se liberarán 47,9 MB.
¿Quiere continuar? [Y/n/?] n
Cancela.
root@debian:/home/jonatan# apt-get upgrade
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Los siguientes paquetes se han retenido:
  mysql-common xbmc xbmc-bin xbmc-data xbmc-skin-confluence
0 actualizados, 0 se instalarán, 0 para eliminar y 5 no actualizados.
root@debian:/home/jonatan# 
Aptitude me va a eliminar y actualizar paquetes y apt no actualiza nada y me dice que se han retenido paquetes. No entiendo, a ver si lo expertos en debian me aclaran y me indican como debo actualizar el sistema porque la diferencia de funcionamiento entre apt-get y aptitude son notables.

Saludos.

Avatar de Usuario
doc
Forista Ancestral
Forista Ancestral
Mensajes: 3472
Registrado: Mié Ago 11, 2010 10:32 am
Ubicación: Oviedo-es_ES
Contactar:

Re: error al refrescar al lista de paquetes en debian

Mensaje por doc »

pasan cosas raras: el 'aptitude update' recarga bastante mal, y además te informa de los paquetes obsoletos, que me parece que antes no lo hacía (o yo no me había dado cuenta, claro). Pero lo curioso en que, a pesar de las muchas líneas 'Ign' (que supongo que será 'ignoradas') luego haces un 'aptitude safe-upgrade' y te detecta los nuevos paquetes a actualizar.

Bueno, dejemos pasar unos días, a ver si se aclara el panorama.

Avatar de Usuario
CharlieBros
Forista Mayor
Forista Mayor
Mensajes: 691
Registrado: Lun Sep 26, 2011 2:01 am
Ubicación: Mexico, DF

Re: error al refrescar al lista de paquetes en debian

Mensaje por CharlieBros »

Yo soy un saltadistros de primera, he probado Fedora, Ubuntu, Debian, Archlinux, Chakra, Fuduntu, ZorinOS, OpenSUSE, Mageia, Crunchbang, Antix, Mandriva, ROSA, Tuquito, SolusOS, Bodhi, Jarro Negro, Mint, Mint Debian y la lista sigue.
Saludos,
Charlie

Avatar de Usuario
Yoyo
Administrador
Administrador
Mensajes: 3156
Registrado: Mar Jun 06, 2006 7:00 am
Ubicación: España
Contactar:

Re: error al refrescar al lista de paquetes en debian

Mensaje por Yoyo »

Los repositorios llevan unos días tontorrones, en mi testing se hace eterno el update por terminal cuando empieza a indexar traducciones, cosa que entes nunca me habia hecho..

Respecto al apt-get y aptitude hay que tener cuidado. El aptitude puede borrar cosas que no queramos que borre, el apt-get simplemente las retiene y el autoremove arrasa con todo.

Alguna vez por ir corriendo en la terminal y no mirar me ha pasado algún chasco de esos

Avatar de Usuario
hall9000
Forista Medio
Forista Medio
Mensajes: 186
Registrado: Jue Ene 07, 2010 1:06 am
Ubicación: en la orbita de jupiter
Contactar:

Re: error al refrescar al lista de paquetes en debian

Mensaje por hall9000 »

los paquetes que apt-get dice que tiene retenidos son los mismos que actualizaría/eliminaría según el caso, si hiciéramos apt-get dist-upgrade. igual que si hiciéramos aptitude full-upgrade.
lo que pasa es que aptitude no los muestra, al menos que hagamos full-upgrade

Código: Seleccionar todo

root@debian:/home/pablo# apt-get upgrade
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Los siguientes paquetes se han retenido:
  apt evolution evolution-common evolution-data-server
  evolution-data-server-common evolution-plugins gnome-panel gnome-panel-data
  gnome-shell gnome-shell-common libedataserverui-3.0-1 libevolution
  libgtkhtml-4.0-0 libgtkhtml-4.0-common libgtkhtml-editor-4.0-0 poppler-data
  python-tagpy
soy muy fan de aptitude, pero veo que últimamente apt-get se esta comportando mejor :?

como veis a continuación apt-get te resuelve sin problemas y aptitude se vuelve un poco loco ::lol::

Código: Seleccionar todo

root@debian:/home/pablo# apt-get dist-upgrade
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Calculando la actualización... Listo
Los siguientes paquetes se ELIMINARÁN:
  cmap-adobe-japan1 gs-cjk-resource libebook-1.2-12 libebook1.2-10
  libedata-book-1.2-11 libedataserverui1.2-11 libept1 libpanel-applet2-0
  python-gnomeapplet
Se instalarán los siguientes paquetes NUEVOS:
  libboost-python1.49.0 libchamplain-0.12-0 libchamplain-gtk-0.12-0
  libebackend-1.2-2 libecal-1.2-11 libedata-book-1.2-13 libedata-cal-1.2-15 libpst4
Se actualizarán los siguientes paquetes:
  apt evolution evolution-common evolution-data-server evolution-data-server-common
  evolution-plugins gnome-panel gnome-panel-data gnome-shell gnome-shell-common
  libedataserverui-3.0-1 libevolution libgtkhtml-4.0-0 libgtkhtml-4.0-common
  libgtkhtml-editor-4.0-0 poppler-data python-tagpy
17 actualizados, 8 se instalarán, 9 para eliminar y 0 no actualizados.
Necesito descargar 38,2 MB de archivos.
Se liberarán 2.899 kB después de esta operación.
¿Desea continuar [S/n]? n
Abortado.
root@debian:/home/pablo# aptitude full-upgrade
Se instalarán los siguiente paquetes NUEVOS:     
  libboost-python1.49.0{a} libchamplain-0.12-0{a} libchamplain-gtk-0.12-0{a} 
  libebackend-1.2-2{a} libecal-1.2-11{a} libedata-book-1.2-13{a} 
  libedata-cal-1.2-15{a} libpst4{a} 
Se actualizarán los siguientes paquetes:
  apt evolution evolution-common evolution-data-server{b} 
  evolution-data-server-common evolution-plugins gnome-panel{b} gnome-panel-data 
  gnome-shell gnome-shell-common libedataserverui-3.0-1 libevolution 
  libgtkhtml-4.0-0 libgtkhtml-4.0-common libgtkhtml-editor-4.0-0 poppler-data{b} 
  python-tagpy 
Se RECOMIENDAN los siguientes paquetes, pero NO se instalarán:
  gnome-contacts 
17 paquetes actualizados, 8 nuevos instalados, 0 para eliminar y 0 sin actualizar.
Necesito descargar 38,2 MB de ficheros. Después de desempaquetar se usarán 7.424 kB.
No se satisfacen las dependencias de los siguientes paquetes:
 poppler-data : Rompe: cmap-adobe-japan1 (<= 0+20090930-2) pero está instalado 0+20090930-2.
                Rompe: gs-cjk-resource (<= 1.20100103-3) pero está instalado 1.20100103-3.
 libept1 : Depende: libapt-pkg4.10 que es un paquete virtual.
 evolution-data-server : Rompe: libebook-1.2-12 (< 3.4) pero está instalado 3.2.2-3.
                         Rompe: libebook1.2-10 (< 3.2) pero está instalado 3.0.3-2.
 gnome-panel : Rompe: libpanel-applet2-0 pero está instalado 2.30.2-4+b1.
Las acciones siguientes resolverán estas dependencias

      Eliminar los paquetes siguientes:                
1)      cmap-adobe-japan1                              
2)      evolution                                      
3)      evolution-data-server                          
4)      evolution-plugins                              
5)      gnome-applets                                  
6)      gnome-panel                                    
7)      gnome-session-fallback                         
8)      gs-cjk-resource                                
9)      libept1                                        
10)     libfolks-eds25                                 

      Dejar las siguientes dependencias sin resolver:  
11)     alacarte recomienda gnome-panel                
12)     evolution-common recomienda evolution          
13)     libfolks25 recomienda libfolks-eds25           
14)     gnome-panel recomienda evolution-data-server   
15)     gnome-panel-data recomienda gnome-panel        
16)     gnome-session recomienda gnome-session-fallback
17)     gnome-shell recomienda gnome-session-fallback  


¿Acepta esta solución? [Y/n/q/?]
We were but stones, your light made us stars

Debian testing + Openbox --- Arch + Xfce4
http://linuxveredas.blogspot.com/ http://identi.ca/hall9000

Avatar de Usuario
jony127
Forista Mayor
Forista Mayor
Mensajes: 605
Registrado: Jue Ago 24, 2006 7:00 am

Re: error al refrescar al lista de paquetes en debian

Mensaje por jony127 »

vaya lío no? dos herramientas para actualizar y que se comporten de manera tan distinta, igual como dicen ustedes es mejor dejar pasar unos días a ver si se estabilizan los repos.

¿Cual creen que es la mejor forma de mantener el sistema al día, safe-upgrade full-upgrade con apt-get o aptitude? porque visto lo visto no me queda nada claro.

Parece que lo mejor es realizar una actualización completa con apt-get dist-upgrade o aptitude full-upgrade para evitar que se queden paquetes sin actualizar como me pasó a mí con el kde.

Avatar de Usuario
Yoyo
Administrador
Administrador
Mensajes: 3156
Registrado: Mar Jun 06, 2006 7:00 am
Ubicación: España
Contactar:

Re: error al refrescar al lista de paquetes en debian

Mensaje por Yoyo »

Yo desde hace un tiempo tanto cuando tenía Ubuntu como ahora en Debian y SolusOS tiro siempre de apt-get


apt-get update | apt-get upgrade | apt-get dist-upgrade

Luego pa limpiar le hago un apt-get clean y un apt-get autoclean y me va de perlas

Hace tiempo no uso el aptitude pues me ha causado algún que otro estrago, sin embargo, yo antes era de los que lo defendía frente al apt-get. Las cosas cambian según las experiencias

Un saludo

Avatar de Usuario
hmg79
Forista Legendario
Forista Legendario
Mensajes: 2211
Registrado: Lun Mar 31, 2008 8:00 am

Re: error al refrescar al lista de paquetes en debian

Mensaje por hmg79 »

Yo siempre use apt-get, de la siguiente forma:

apt-get update
apt-get upgrade varias veces seguidas cosas que se resuelvan los problemas que puedan haber, eso si siempre verificando que no desinstale nada importante.-
apt-get dist-upgrade para que actualice a los paquetes retenidos.-

Nunca me gusto aptitude.-

Avatar de Usuario
CharlieBros
Forista Mayor
Forista Mayor
Mensajes: 691
Registrado: Lun Sep 26, 2011 2:01 am
Ubicación: Mexico, DF

Re: error al refrescar al lista de paquetes en debian

Mensaje por CharlieBros »

Pues yo siempre uso aptitud y me va genial.
Saludos.
Charlie

Avatar de Usuario
neurus
Forista Legendario
Forista Legendario
Mensajes: 1815
Registrado: Dom Oct 10, 2004 7:00 am

Re: error al refrescar al lista de paquetes en debian

Mensaje por neurus »

Empecemos: yo uso apt-get. Realmente no sé qué países tienen en los repositorios, o qué repositorios tienen.
El usuario que abrió el hilo, por ejemplo, tenía su sources.list apuntando a los repositorios debian.mirror.evertje.net. Realmente no me importa que apt-spy haya determinado que es el más rápido. ¿A nadie le resulta extraño semajante servidor?. Va rápido, claro, porque no lo usa nadie. ¿Y si apt-spy determina que el servidor más rápido es http://debian.tuvecinitahot.timbuctu/debian, vas a usar ese?

Un repositorio Debian tiene el siguiente formato:

deb http://ftp.$PAIS.debian.org/debian $RAMA

En Argentina, en la UBA (Universidad de Buenos Aires), montaron un repositorio hace un tiempo. Iba rápido para quienes vivimos aquí, claro. Cuando iba. No sé si seguirá online. También tenía una dirección esotérica.

Sigamos:
hall9000 escribió:
como veis a continuación apt-get te resuelve sin problemas y aptitude se vuelve un poco loco :::lol:::
Acá hay un error de concepto: apt-get no te resuelve nada. Por eso no hay mensaje de error. Luego, puede instalar el paquete con las dependencias rotas, o no instalarlo, lanzando un error al intentar configurar el paquete. Allí es cuando el sistema te dice que debes ejecutar apt-get -f install. Para hacer lo mismo que hace aptitude. O puede que no te diga nada, si el problema es muy menor, y el sistema puede funcionar con esa dependencia rota. Pero que está rota, está rota.

Aptitude, por otra parte, chequea las dependencias de cada paquete. Por esa razón, en la lista de paquetes a actualizar (que es la misma para ambos), el paquete conflictivo es señalado como poppler-data{b}. {b} de Broken. Roto.

No es que se comportan "tan distinto". Uno hace chequeos y el otro no. Intentan actualizar lo mismo, el mismo número de paquetes y llegar al mismo resultado.

Y un poco más:
CharlieBros escribió:Pues yo siempre uso aptitud y me va genial.
Charlie
Pero un rato antes:
CharlieBros escribió: Pues hoy empece a tambien tener problemas con debmulti.
Asi que mejor me cambio de nuevo a Arch, que esa si es full rolling
¿En qué quedamos?


En cuanto a problemas por el sistema a medio actualizar, es lógico que falle:
jony127 escribió: Después el error de hash difiere y no se actualiza nada. Ahora pruebo con un apt-get upgrade:

Código: Seleccionar todo

apt-get upgrade
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Los siguientes paquetes se han retenido:
  amarok amarok-common amarok-utils apt kde-window-manager ETC.
0 actualizados, 0 se instalarán, 0 para eliminar y 67 no actualizados.
Resulta que en el sistema del usuario se comportan de manera diferente aptitude y apt. ¿Alguien más ve que uno de los paquetes a actualizar se llama apt? Un tip muy útil a la hora de efectuar una actualización mayor del sistema, consiste en colocar un cartel indicador arriba del monitor que está conectado a la máquina, con una flecha hacia abajo y la leyenda: AQUI. Digo, así uno no mira otro monitor por error.

Y apt, en este ejemplo, es uno de los paquetes retenidos, porque el usuario está haciendo un upgrade. Actualizar apt implicaría actualizar el sistema base (dist-upgrade). Como sólo le pides un upgrade, pues bueno, eso es lo que te da el sistema. Es otra mala costumbre de las computadoras: hacen lo que uno les ordena, no lo que uno quiere.


En resumen:
1) repositorios decentes. Pueden chequear el estado de los mirrors en el sitio de Debian. En el chequeo diario pueden no aparecer algunos mirrors (claro que la información es más confiable). Nada de repositorios emejerte o similares. http://ftp.PAIS.debian.org.

2) apt-get update && apt-get upgrade && apt-get dist-upgrade. O: aptitude update && aptitude safe-upgrade && aptitude full-upgrade. Si sólo quieren actualizar paquetes menores, no hagan el dist- o full- upgrade. Pero entonces, que nadie se sorprenda si se retienen paquetes. Esa es precisamente la idea de un manejador de dependencias.

3) Si la suma hash difiere, es porque están actualizando el mirror. Para un usuario corriente, la actualización masiva es de algo más de 1GB. Para un repositorio, es de decenas de GB. Lleva horas, porque son servidores con mucha velocidad de subida, no de bajada (y para actualizarse a sí mismos, deben usar la velocidad de bajada). Es esperable, además, que los servidores que están usando un kernel 2.6 hayan sufrido un kernel panic o fallo de aplicaciones como rsync al intentar actualizar las listas, debido al bug del leap second. Si no hay nadie atendiéndolos, seguirán caídos hasta que los arreglen. Si el repositorio que has elegido se llama ftp.debian.remojarte, es muy probable que no haya nadie atendiéndolo...

4) Esto pasa cada vez que se congela una Debian. Supongo que hay muchos usuarios nuevos.

5) Estudios realizados por la Universidad de Jarbard, dicen que tu vida no corre peligros extras por esperar una semana para actualizar la distro.

6) Borra la lista de paquetes del repositorio, a ver si después de tanto lío es que el fallo lo tienes en un archivo local: rm /var/lib/apt/ftp*



PD: No tuve un solo problema al actualizar. Estoy usando testing. Tuve que bajar 1,5GB de actualizaciones. Ningún error. Sólo reconfigurar el driver nvidia para el nuevo kernel. Uso repositorios de Brasil; además de los repositorios de webmin, koha, opera y chrome. Repito: ningún fallo.

Avatar de Usuario
Yoyo
Administrador
Administrador
Mensajes: 3156
Registrado: Mar Jun 06, 2006 7:00 am
Ubicación: España
Contactar:

Re: error al refrescar al lista de paquetes en debian

Mensaje por Yoyo »

Como siempre, neurus, poniendo claridad en el asunto

Otro hilo para guardar en marcadores

Avatar de Usuario
CharlieBros
Forista Mayor
Forista Mayor
Mensajes: 691
Registrado: Lun Sep 26, 2011 2:01 am
Ubicación: Mexico, DF

Re: error al refrescar al lista de paquetes en debian

Mensaje por CharlieBros »

¿Que hariamos sin neurus?

@neurus: ¿Que no puedo tener otra PC?, pues no, por que no tengo dinero xDD. A lo que me refiero que siempre que tengo Debian o derivadas yo utilizo aptitude.

Saludos.
Charlie

Avatar de Usuario
jony127
Forista Mayor
Forista Mayor
Mensajes: 605
Registrado: Jue Ago 24, 2006 7:00 am

Re: error al refrescar al lista de paquetes en debian

Mensaje por jony127 »

ok entendido, ya había cambiado los repo, unas preguntas más:

¿Porqué cuando actualizaba con aptitude me daba el error de hash difiere como comentaba otro usuario en este hilo con el repo multimedia y si actualizaba con apt-get no daba ese error?

¿Porqué aptitude elimina paquetes que yo no quiero borrar? también Yoyo comentó que había tenido este problema, a mí concretamente me eliminó el amarok sin yo pedirselo

¿Porqué usas apt-get para actualizar y no aptitude, si como tú comentas no maneja las dependencias?

Saludos.

Responder
  • Temas similares
    Respuestas
    Vistas
    Último mensaje