Reglamento general de los foros   •   FAQ   •   Buscar en el foro •  Registrarse | Iniciar sesión 



Portada » Foros Linux » Administración del sistema » Sistema


Nuevo tema Responder al tema
 [ 28 mensajes ]  Ir a página Anterior  1, 2
Patrocinadores

Autor
Buscar:
Mensaje

Desconectado
Forista Ancestral
Forista Ancestral
Avatar de Usuario

Registrado: Jue Abr 12, 2007 7:00 am
Mensajes: 9186
Ubicación: tras la pantalla (...)

Nota Publicado: Lun Mar 07, 2011 5:00 pm 
Arriba  
moxideo escribió:
Vale vamos por partes , tengo la lista de sudo dmesg . Pero tengo que buscar algo concreto ? ó directamente la pongo aqui .
Mi tarjeta es Ati , asi que no se como la reconoce , pero se me ocurre desabilitar drivers privativos de la tarjeta gráfica y probar .


pasanosla via pastie.org o similares. si hay algo relevante, lo veremos nosotros (encontrar algo ahi puede ser... complicado). eso si... mirala y confirma que salgan los tiempos, digo, que el formato sea algo de este estilo:

>>> dmesg |tail -n 5
[ 16.311214] hp4x: v1.00:HP4x (48/49) Generic Serial driver
[ 20.448017] eth2: no IPv6 routers present
[ 83.228736] lo: Disabled Privacy Extensions
[23517.524828] eth2: link down.
[84729.092792] eth2: link up.

[15:53:21] - [niky@ian:~]
>>>


es decir, que en la primera "columna", te aparezca, para todas las lineas, algun tipo de numeros. (esos numeros en realidad no son mas que un cronometro... pero los necesitamos para ver si hay algun tipo de parada).

tambien puedes cortarla un poco y pegar solo a partir del segundo 1 (aka, saltate las que empiezan por 0,...), porque antes hay mucha info y no me parece que para el caso sea relevante (de hecho, estuve por pasarte un comando que lo filtrara, pero... :? no se me ocurrio como hacerlo :D)

tema ati y drivers, olvidalo. a lo que se refiere doc, es a un cambio "mayor" de version. pero... si tras el cambio de kernel, sigues teniendo imagen, y no hace cosas raras, entonces no te afecta (seguramente, tus actualizaciones sean solo pequenias revisiones, mas con parches de seguridad que otra cosa. ) ademas, no creo que la grafica tenga mucho que ver en esto.

los principales culpables en estos casos, suelen ser, exim (o quiza tambien otros mailers), y discos duros. (al menos, eso me ha enseniado mi epxeriencia.)
:)

resumo (a veces me enrollo y luego la gente se pierde)
a) comprueba que en tu dmesg, las lineas vayan precedidas de numeros (el cronometro)
b) corta la parte anterior a un segundo (las que empiezan por 0. xxx)
c) vete a pastie.org (o cualqueir servicio similar), pegas alli el dmesg cortadito, y nos pasas el enlace.
d) esperas a que lo veamos.
e) uy, aqui ya no se lo que viene... :? :P
:)

_________________
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]

 Perfil WWW  

Desconectado
Forista Medio
Forista Medio
Avatar de Usuario

Registrado: Jue Sep 11, 2008 7:00 am
Mensajes: 107

Nota Publicado: Mar Mar 08, 2011 10:31 am 
Arriba  
Aqui os dejo el enlace de pastie.org : http://pastie.org/1645222
Entiendo que necesitais a partir de 1 segundo . También he probado a deshabilitar los drivers privativos . Y la cosa ha mejorado un poco , pero no mucho mejor ,rectifico por si alguien leyó lo anterior , me sigue haciendo lo mismo aún después de estar parado el pc.

 Perfil  

Desconectado
Forista Ancestral
Forista Ancestral
Avatar de Usuario

Registrado: Jue Abr 12, 2007 7:00 am
Mensajes: 9186
Ubicación: tras la pantalla (...)

Nota Publicado: Mar Mar 08, 2011 3:00 pm 
Arriba  
vamos mejorando. yo ahi veo dos paradas:

1.500864] ata7: SATA max UDMA/133 abar m8192@0xfeafe000 port 0xfeafe100 irq 16
[ 1.500867] ata8: SATA max UDMA/133 abar m8192@0xfeafe000 port 0xfeafe180 irq 16
[ 1.500959] scsi6 : SCSI emulation for USB Mass Storage devices
[ 1.501061] usbcore: registered new interface driver usb-storage
[ 1.501063] USB Mass Storage support registered.
[ 1.501121] usb-storage: device found at 2
[ 1.501123] usb-storage: waiting for device to settle before scanning
[ 1.612012] usb 8-1: new low speed USB device using uhci_hcd and address 2
[ 1.707529] EXT4-fs (sda1): mounted filesystem with ordered data mode
[ 1.789918] usb 8-1: configuration #1 chosen from 1 choice
[ 1.824024] ata7: SATA link down (SStatus 0 SControl 300)
[ 1.824053] ata8: SATA link down (SStatus 0 SControl 300)
[ 6.500679] usb-storage: device scan complete

[ 6.501177] scsi 6:0:0:0: Direct-Access Generic USB SD Reader 1.00 porque: 0 ANSI: 0
[ 6.501680] scsi 6:0:0:1: Direct-Access Generic USB CF Reader 1.01 porque: 0 ANSI: 0
[ 6.502180] scsi 6:0:0:2: Direct-Access Generic USB SM Reader 1.02 porque: 0 ANSI: 0
[ 6.502679] scsi 6:0:0:3: Direct-Access Generic USB MS Reader 1.03 porque: 0 ANSI: 0
[ 6.502958] sd 6:0:0:0: Attached scsi generic sg3 type 0
[ 6.503056] sd 6:0:0:1: Attached scsi generic sg4 type 0
[ 6.503150] sd 6:0:0:2: Attached scsi generic sg5 type 0
[ 6.503238] sd 6:0:0:3: Attached scsi generic sg6 type 0
[ 6.506160] sd 6:0:0:0: [sdc] Attached SCSI removable disk
[ 6.506785] sd 6:0:0:1: [sdd] Attached SCSI removable disk
[ 6.507535] sd 6:0:0:2: [sde] Attached SCSI removable disk
[ 6.508162] sd 6:0:0:3: [sdf] Attached SCSI removable disk
[ 17.786160] udev: starting version 151

[ 17.843089] udev: renamed network interface eth0 to eth1
[ 17.956217] Adding 9828344k swap on /dev/sda5. Priority:-1 extents:1 across:9828344k
[ 17.957104] type=1505 audit(1299401301.104:2): operation="profile_load" pid=612 name="/sbin/dhclient3"
[ 17.957583] type=1505 audit(1299401301.104:3): operation="profile_load" pid=612 name="/usr/lib/NetworkManager/nm-dhcp-client.action"
[ 17.957851] type=1505 audit(1299401301.104:4): operation="profile_load" pid=612 name="/usr/lib/connman/scripts/dhclient-script"
[ 17.959219] type=1505 audit(1299401301.104:5): operation="profile_replace" pid=661 name="/sbin/dhclient3"
[ 17.959699] type=1505 audit(1299401301.104:6): operation="profile_replace" pid=661 name="/usr/lib/NetworkManager/nm-dhcp-client.action"
[ 17.959964] type=1505 audit(1299401301.104:7): operation="profile_replace" pid=661 name="/usr/lib/connman/scripts/dhclient-script"
[ 18.119764] usbcore: registered new interface driver hiddev


la primera me parece que se trata de algun tipo de checkeo de discos (dmesg no lo muestra, pero es justo despues del mount, parece razonable pensar eso)

y la segunda... tienes un lector de tarjetas?? parece algo de ahi, de que intenta inicializar unos discos (aka, tarjetas o algo por el estilo)..

udev salta justo despues de la paradam por lo que dudo que sea el culpable, pero tambien podria ser.

tras esto... necesito mas datos. :D pasanos el /etc/fstab, y el lsusb O lspci (donde aparezca el lector de tarjetas o lo que sea eso). (son relativamente cortos, asi que puedes pegarlos aqui directamente si quieres. )

y si es posible, pasanso tambien esto (como root, instalalo si te dice not found), via pastie.org. :)

Código:
hwinfo --disk


a ver lo que aparece por ahi... :?

PD: puedes tambien, volver a pasarnos el dmesg?? (digo, para verificar los tiempos, y tal. lo mismo de antes. quiero tener los datos de dos arranques por si acaso)
:)

_________________
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]

 Perfil WWW  

Desconectado
Forista Medio
Forista Medio
Avatar de Usuario

Registrado: Jue Sep 11, 2008 7:00 am
Mensajes: 107

Nota Publicado: Mié Mar 09, 2011 3:04 am 
Arriba  
Vale mi PC es un sobremesa y el lector de tarjetas es externo , es decir que lo quito y lo pongo cuando lo necesito .

Vale te paso :

Desde /etc/fstab, :

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
# / was on /dev/sda1 during installation
UUID=253a3c64-7a8e-4ecf-90c3-7b7011d2bb16 / ext4 errors=remount-ro 0 1
# swap was on /dev/sda5 during installation
UUID=9a646181-2a66-428f-b395-a634df95e4cc none swap sw 0 0
#“none /proc/bus/usb usbfs devgid=46,devmode=666 0 0?
------------------------------------------------------------------------------------------------------------------------------------------------
Enlace : lsusb desde sudo nautilus :

http://pastie.org/1649608

---------------------------------------------------------------------------------------------------------
Y desde lspci :

00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller (rev 02)
00:01.0 PCI bridge: Intel Corporation 82G33/G31/P35/P31 Express PCI Express Root Port (rev 02)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 02)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 02)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 02)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 92)
00:1f.0 ISA bridge: Intel Corporation 82801IR (ICH9R) LPC Interface Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801IR/IO/IH (ICH9R/DO/DH) 4 port SATA IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 02)
00:1f.5 IDE interface: Intel Corporation 82801I (ICH9 Family) 2 port SATA IDE Controller (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc RV790 [Radeon HD 4800 Series]
01:00.1 Audio device: ATI Technologies Inc HD48x0 audio
02:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8056 PCI-E Gigabit Ethernet Controller (rev 12)
03:00.0 SATA controller: JMicron Technology Corp. JMB362/JMB363 Serial ATA Controller (rev 03)
03:00.1 IDE interface: JMicron Technology Corp. JMB362/JMB363 Serial ATA Controller (rev 03)
05:03.0 FireWire (IEEE 1394): Agere Systems FW322/323 (rev 70)
05:04.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8110SC/8169SC Gigabit Ethernet (rev 10)
------------------------------------------------------------------------------------------------------------------------------------------------------------------
Te paso enlace dsmesg :

http://pastie.org/1649589
--------------------------------------------------------------------------------------------------------------------------------------------------------------------
Enlace: hwinfo --disk : Tuve que instalarlo primero :

http://pastie.org/1649604

 Perfil  

Desconectado
Forista Ancestral
Forista Ancestral
Avatar de Usuario

Registrado: Jue Abr 12, 2007 7:00 am
Mensajes: 9186
Ubicación: tras la pantalla (...)

Nota Publicado: Mié Mar 09, 2011 2:27 pm 
Arriba  
:? :? tu maquina hace unas cosas muy raras.... :?

vale. la primera parada la tengo diagnosticada:

(dmesg1)
[ 1.824024] ata7: SATA link down (SStatus 0 SControl 300)
[ 1.824053] ata8: SATA link down (SStatus 0 SControl 300)
[ 6.500679] usb-storage: device scan complete
(dmesg2)
[ 1.808025] ata7: SATA link down (SStatus 0 SControl 300)
[ 1.808054] ata8: SATA link down (SStatus 0 SControl 300)
[ 3.831901] Adding 9828344k swap on /dev/sda5. Priority:-1 extents:1 across:9828344k
(fstab)
UUID=253a3c64-7a8e-4ecf-90c3-7b7011d2bb16 / ext4 errors=remount-ro 0 1


es un checkeo de discos. que unas veces tarde mas y otras menos, ni idea de si es normal, aunque asumo que si.

solucion?? deshabilitar el checkeo. aunque... igual casi mejor que lo dejes. son unos poquitos segundos, y te ahorra dolores de cabeza (aunque como el disco de arranque NO es el seagate, tampoco es imprescindible dejarlo).

la siguiente parada... para empezar no conicide, supongo que por el cambio de driver de la grafica. yo te digo, decide cual quieres usar, y deja ese. y lo solucionamos "bien". me refiero, si la solucion fuera usar vesa, habria que buscar otra solucion, no?? pues con esto, lo mismo.

en el nuevo dmesg, veo otra parada, pero no acierto a ver de que es:

Código:
[    8.580273] type=1505 audit(1299577455.736:10):  operation="profile_replace" pid=547 name="/usr/lib/NetworkManager/nm-dhcp-client.action"
[    8.580346] type=1505 audit(1299577455.736:11):  operation="profile_replace" pid=834 name="/usr/lib/NetworkManager/nm-dhcp-client.action"
[   11.326244] sky2 eth1: enabling interface
[   11.326372] ADDRCONF(NETDEV_UP): eth1: link is not ready


diria que dhclient, si no fuera porque en el "anterior arranque" es obvio que no para. el otro culpable pareceria ser la tarjeta de sonido (o lo que sea ese intel HDA, que juraria que es sonido), pero de nuevo, en el primer arranque no para.

y lo mismo con el encendido de eth1.

amos a ver. que yo me aclare. decide como lo quieres hacer (me refiero especificamente al driver de la grafica*), y vuelve a pasarnos el dmesg, si?? (como ves, yo pruebas hago miles. luego al final llego a alguna conclusion, y todo. :? )

*hablando de drivers: radeon tarda MUCHISMO mas en cargarse que fglrx, al menos, a juzgar por tus dmesg.

y una cosa mas. habia por ahi una herramienta, para medir el tiempo de arranque, que llegaba (a medir hasta ) el escritorio. si, lo encontre, es el bootchart. te voy a pedir que lo instales y nos muestres los datos. porque...

me temo que lo que realmente notas lento, no es tanto el init, como la carga del entorno grafico. mas que nada, porque mi debian, segun dmesg, esta en... 37s. hasta login. (login NO grafico). tu ubuntu, esta en 25. a mi me parece que el mio es rapido (vaaa... solia estar en la mitad, ahora mismo es un HD que se porta mal en el arranque... :? ). asi que lo tuyo no debe ser de init. asi que a ver lo que nos dice bootchart de gdm.

PD: optimizacion ultrapotente si la maquina la usas solo tu, o bien, los que la usan no tienen miedo de ver una consola. prescinde de gdm, y deja que sea startx quien levante gnome. eso si, automatizalo via /etc/profile (si te interesa, lo dices y te doy mas detalles, no voy a escribir una quia de las mias para que me digas que 'no se quien', si ve el login de texto sale corriendo. :P )

_________________
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]

 Perfil WWW  

Desconectado
Forista Medio
Forista Medio
Avatar de Usuario

Registrado: Jue Sep 11, 2008 7:00 am
Mensajes: 107

Nota Publicado: Jue Mar 10, 2011 12:13 am 
Arriba  
A ver poco a poco niky45 , chequear el disco duro es bueno , ok , yo tengo la manía de montar los diferentes sistemas operativos que tengo en el pc , en diferentes discos duros . Ahora mismo tengo solamente Ubuntu y wind7 que lo gestiona el grub2 .
Lo del sonido seguramente es el sonido de la conexión hdmi , que tiene las gráficas modernas . Ya que yo empleo el sonido de la tarjeta de la placa madre.
Y lo de gdm ó startx , mejor que no , ya que este pc lo empleo yo y mi hijo de 11 años . Como segundo usuario .
Es gracioso ya que en el colegio trajeron nuevos portatiles , con ubuntu , y mi hijo como pez en el agua , claro todo el mundo le pregunta en clase como se hace esto , esto otro .
Lo del driver gráfico como dije lo tengo desinstalado , empleo el genérico , ya que la gráfica la voy a cambiar por una nvidia . Creo que los drivers están mejor hechos. Entiendo que el tuyo tarda más . Aunque no se si influye lo lleno que esté el disco duro de archivos .

 Perfil  

Desconectado
Forista Ancestral
Forista Ancestral
Avatar de Usuario

Registrado: Jue Abr 12, 2007 7:00 am
Mensajes: 9186
Ubicación: tras la pantalla (...)

Nota Publicado: Jue Mar 10, 2011 10:04 pm 
Arriba  
Citar:
chequear el disco duro es bueno , ok , yo tengo la manía de montar los diferentes sistemas operativos que tengo en el pc , en diferentes discos duros


yo solo digo que una de las paradas es de ahi. y que siendo un WD, en principio te puedes saltar el checkeo de discos, o ponerlo a cada X arranques (si quieres info avisa y te la busco).

Citar:
Lo del sonido seguramente es el sonido de la conexión hdmi , que tiene las gráficas modernas . Ya que yo empleo el sonido de la tarjeta de la placa madre.


NOP. intelHDA es la integrada. la otra aparece como ati. a lo que me referia, es a que en un sitio veo una parada y en otro no. :?

tema drivers... como quieras. mientras uses siempre el mismo... :D

Citar:
Entiendo que el tuyo tarda más

de hecho yo tengo una nvidia integrada. el que tarda mas es tu radeon frente a tu fglrx. :
(arranque radeon)
[ 5.365836] [drm] Initialized drm 1.1.0 20060810
[ 5.473509] [drm] radeon defaulting to kernel modesetting.
(...)
[ 6.606683] vga16fb: mapped to 0xc00a0000
[ 6.606685] vga16fb: not registering due to another framebuffer present
(/fin arranque radeon. ~1.3 segundos)
(arranque fglrx)
18.513841] [fglrx] Maximum main memory to use for locked dma buffers: 3861 MBytes.
[ 18.514039] [fglrx] vendor: 1002 device: 9460 count: 1
[ 18.514398] [fglrx] ioport: bar 4, base 0xb000, size: 0x100
[ 18.514408] pci 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 18.514412] pci 0000:01:00.0: setting latency timer to 64
[ 18.514600] [fglrx] Kernel PAT support is enabled
[ 18.514615] [fglrx] module loaded - fglrx 8.72.11 [Apr 8 2010] with 1 minors
(/fin arranque fglrx ~ <0.01 segundo. )


son tus datos, no los mios. :P

Citar:
lo de gdm ó startx , mejor que no , ya que este pc lo empleo yo y mi hijo de 11 años . Como segundo usuario


te comprendo. pero podrias hacer la prueba. la UNICA diferencia para el usuario, es que tiene que meter los datos (user y pass) antes de que arranquen las X. luego todo salta automatico... y te ahorras el mas que pesado gdm.

lo explico un poco mejor. tu sabes el loguin de las tty virtuales, no?? bueno. pues el usuario se loguea ahi. luego, lo demas va automatico, saltan las X, y carga el escritorio, sin que el user haga nada extra. (te digo... yo lo tengo asi. y es mas que practico. mas aun que gdm, en serio).

en fin,. pasame de nuevo el dmesg con el driver que elijas, a ver lo que pasa. y de paso, los datos de bootchart. a ver que veo por ahi. :)

_________________
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]

 Perfil WWW  

Desconectado
Forista Medio
Forista Medio
Avatar de Usuario

Registrado: Jue Sep 11, 2008 7:00 am
Mensajes: 107

Nota Publicado: Sab Mar 12, 2011 9:06 am 
Arriba  
Aquí te dejo el enlace del nuevo dmseg con la nueva gráfica nvidia :

http://pastie.org/1662383

Pero el bootchart no se como ponerlo aquí , gracias . Me crea una imagen " .png " ó un comprimido " .gz "

 Perfil  

Desconectado
Forista Ancestral
Forista Ancestral
Avatar de Usuario

Registrado: Jue Abr 12, 2007 7:00 am
Mensajes: 9186
Ubicación: tras la pantalla (...)

Nota Publicado: Sab Mar 12, 2011 4:41 pm 
Arriba  
sube la imagen via el hosting de espaciolinux: en el editor completo, justo encima de las tags de bbcode, pone "aniadir una imagen al post", pues le das, y luego todo es muy sencillo.

vamos con lo que tenemos por ahora:

Código:
[    1.714211] EXT4-fs (sda1): mounted filesystem with ordered data mode
[    1.828532] ata7: SATA link down (SStatus 0 SControl 300)
[    1.828559] ata8: SATA link down (SStatus 0 SControl 300)
[    2.828621] ieee1394: Host added: ID:BUS[0-00:1023]  GUID[0011d8000171fe5f]
[   15.758908] udev: starting version 151


de nuevo, la parada del lector de tarjetas. tiene que haber alguna forma de que no lo levante inmediatamente en el arranque (pedirte que lo desenchufes para arrancar NO es logico. es un dispositivo que en teoria puede estar siempre conectado. asi que lo haremos que pueda. ) ya pensare en ello. :?

y luego otra mini-parada:
Código:
[   17.546262] ADDRCONF(NETDEV_UP): eth1: link is not ready
[   17.547552] r8169: eth0: link up
[   19.350479] vboxdrv: Found 2 processor cores.


viendo eso, pareceria el arranque de la red. y ademas, por ahi siempre acaba por hacer algun tipo de parada. de cualquier manera, son menos de dos segundos.

aunque... puede ser de aqui:

Código:
[   17.469575] type=1505 audit(1299912323.609:5):  operation="profile_replace" pid=874 name="/sbin/dhclient3"
[   17.470055] type=1505 audit(1299912323.609:6):  operation="profile_replace" pid=874 name="/usr/lib/NetworkManager/nm-dhcp-client.action"
[   17.470321] type=1505 audit(1299912323.609:7):  operation="profile_replace" pid=874 name="/usr/lib/connman/scripts/dhclient-script"
[   17.475614] type=1505 audit(1299912323.613:8):  operation="profile_load" pid=875 name="/usr/bin/evince"
[   17.477649] type=1505 audit(1299912323.617:9):  operation="profile_load" pid=873 name="/usr/share/gdm/guest-session/Xsession"
[   17.483187] type=1505 audit(1299912323.621:10):  operation="profile_load" pid=875 name="/usr/bin/evince-previewer"
[   17.486922] type=1505 audit(1299912323.625:11):  operation="profile_load" pid=877 name="/usr/lib/cups/backend/cups-pdf"


pareceria el arranque de... un monton de cosas. (no es unicamente dhclient :| ). pero si como me parece, es el arranque de las X... necesito ese bootchart.

queda ver lo que se puede hacer con ese lector de tarjetas. yo creo haber oido alguna vez que al kernel se le puede pasar un parametro para que levante algo tras un rato (se suele hacer porque, por ejemplo, a veces la maquina tarda en encender un dispositivo, y el kernel quiere levantarlo antes de que este encendido). te lo mirare a ver que veo, porque ahora mismo no ando muy alla de tiempo, y hay unos cuantos mensajes mas esperandome :P
:)

PD: un ultimo dmesg sin el lector?? a ver que pasa?? (segun yo, deberia darte unos ~15 segundos maximo desde dmesg. ojo porque el tiempo de dmesg es significativamente menor que el de arranque hasta login, pero si que es orientativo. ) :)

_________________
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]

 Perfil WWW  

Desconectado
Forista Medio
Forista Medio
Avatar de Usuario

Registrado: Jue Sep 11, 2008 7:00 am
Mensajes: 107

Nota Publicado: Jue Mar 17, 2011 12:55 am 
Arriba  
Bien lo del lector de tarjetas sólo lo enchufo cuando tengo que leer alguna tarjeta . Osea por regla general lo tengo desenchufado . ¿ Puede ser si cuando actualizé el kernel , lo tuviera enchufado y ahora siempre sale en el arranque .
Y lo de la red puede ser que mi placa madre tiene dos tarjetas de red .
Aqui te dejo el bootchart :


Imagen

 Perfil  

Desconectado
Forista Ancestral
Forista Ancestral
Avatar de Usuario

Registrado: Jue Abr 12, 2007 7:00 am
Mensajes: 9186
Ubicación: tras la pantalla (...)

Nota Publicado: Jue Mar 17, 2011 5:14 pm 
Arriba  
para empezar: el bootchart muestra una parada MUY clara. ureadahead. pero... esto es ureadahead.
http://ubuntuforums.org/showthread.php?t=1434502

se supone que sirve para acelerar el arranque. :?

yo veria a ver si sin ureadahead mejoraban esos tiempos... porque lo que es yo, no lo tengo, y tengo un arranque de ~ 15 segundos en el portatil (y son 900 Mhz!!)
Citar:
Bien lo del lector de tarjetas sólo lo enchufo cuando tengo que leer alguna tarjeta . Osea por regla general lo tengo desenchufado . ¿ Puede ser si cuando actualizé el kernel , lo tuviera enchufado y ahora siempre sale en el arranque .


podria ser. pero... aun asi. hay que ver como hacer que no lo levante desde el principio. (aqui las cosas se solucionan del todo. :P)

EDIT: datos de mi eeepc: 15 segundos hasta login, incluso segun bootchart. NO tiene en cuenta las X, pero te puedo garantizar que son inmediatas (menos de 1 segundo). eso si, supongo que el hecho de no cargar gestor de sesiones ayuda...
Imagen

definitivamente, ese ureadahead te esta frenando el arranque. (no es logico que en un dual core tarde 15 segundos en leer datos. :shock: )

_________________
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]

 Perfil WWW  

Desconectado
Forista Medio
Forista Medio
Avatar de Usuario

Registrado: Jue Sep 11, 2008 7:00 am
Mensajes: 107

Nota Publicado: Vie Mar 18, 2011 12:37 am 
Arriba  
Como ya te he puesto anteriormente el problema para mi es desde el grub hasta el login , y no , desde el login hasta el escritorio .
He sacado del enlace que me has dejado este trozo que creo que es el que pone como desinstalar el ureadahead :

*****************************************************************************************************
ureadahead slows down my boot!

I want to hear from you! It really shouldn't; to give you an example of the savings, my trusty laptop boots in about 1m30s without ureadahead - and only 30s with it.

Make sure you have the bootchart package installed. the ureadahead pack files, and move the /etc/init/ureadahead.conf file to something like ureadahead.dissabled. Reboot, login, etc. and wait for the bootchart to appear ("watch status bootchart" until stop/waiting).

Now put the ureadahead conf file back, reboot and login again and wait for bootchart to appear.

Finally reboot and login once more, and wait for bootchart to appear.

You'll now have three bootcharts. One is without ureadahead, one is when ureadahead is profiling, and the final one is with ureadahead behaving normally.

File a bug report on ureadahead (ubuntu-bug ureadahead) and attach these three files along with the output of "sudo ureadahead --dump" (this is quite a bit, so capture it in a file).

I'll take a look, and we'll see if we can fix that bug for you!
**************************************************************************
El trozo en azul creo que es donde pone como desinstalar ureadahead . Entiendo que hay que quitar el paquete de archivos de ureadahead desde la ruta : /etc/init/ureadahead.conf file y guardarlo como : ureadahead.desahbilitado . Reiniciar y probar .
Me he ido a la ruat y tengo 2 ureadahead: uno es el ureadahead.conf y el otro es ureadahead-other.conf , supongo que será sólo el primero y espero no cargarme nada importante del inicio .

 Perfil  

Desconectado
Forista Ancestral
Forista Ancestral
Avatar de Usuario

Registrado: Jue Abr 12, 2007 7:00 am
Mensajes: 9186
Ubicación: tras la pantalla (...)

Nota Publicado: Vie Mar 18, 2011 8:05 pm 
Arriba  
lo que pone en azul no es exactamente como desinstalarlo, sino como deshabilitarlo para ver que pasa si no se carga en el arranque.

efectivamente, el que tienes que mover es el que te indica (ureadahead.conf)

eso solo es mover el fichero de configuracion, para que ureadahead no sepa lo que hacer y no haga nada. aka, el sistema carga igual que si no estuviera ureadahead instalado. no estas eliminando nada. solo evitando que se cargue.

:)
Citar:
Como ya te he puesto anteriormente el problema para mi es desde el grub hasta el login , y no , desde el login hasta el escritorio .


no, no me has entendido. mi login NO es grafico. es.... (a ver como leches capturo yo esa pantalla... ) esto es una "captura":

Código:
ian login: niky
Password:
Last login: Fri Mar 18 18:58:37 CET 2011 on tty2
Linux ian 2.6.37-2-686 #1 SMP Sun Feb 27 10:51:32 UTC 2011 i686

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
niky@ian:~$


una vez que me logueo, ya arrancan las X (pero NO antes!!). de ahi que te este dando datos extras del arranque del entorno: tu maquina TIENE que cargarar las X y gdm antes del login . la mia no.

sip. me logueo en la tty1, y luego ya saltan las X automaticamente. me ahorro el gestor de sesiones. esa era otra de las opciones que te proponia por ahi. gdm es pesado, y viendo ese bootchart, te podrias ahorar unos cuantos segundos si prescindes de el. y una vez logueado, no hay ninguna diferencia entre usar este sistema o un gestor grafico (gdm) , bueno, salvo para logins multiples (dos sesiones de X corriendo a la vez. con mi sistema, la segunda hay que lanzarla a mano. y tampoco es que tenga muy claro como :? )

_________________
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]

 Perfil WWW  
Mostrar mensajes previos:  Ordenar por  
 [ 28 mensajes ]  Ir a página Anterior  1, 2
Nuevo tema Responder al tema

Saltar a:  


 Temas relacionados   Autor   Respuestas   Vistas   Último mensaje 
Dónde postear un dato sobre kernels

en Sistema

lSaKenl

2

612

Mié Ene 06, 2010 12:54 am

shakka Ver último mensaje

¿Cómo borrar kernels antiguos en OpenSuse?

en Software

Achileepoo

3

1034

Mar Mar 13, 2012 3:46 am

hmg79 Ver último mensaje

No puedo usar mas kernels compilados (SOLUCIONADO)

en Programación

ran8489

2

696

Vie Jul 09, 2010 7:09 am

ran8489 Ver último mensaje

Apple presenta sus nuevos productos

en Vídeos

hipersayan_x

4

2825

Dom Oct 16, 2011 12:09 am

seadx6 Ver último mensaje

Un wallpaper que no nos deberia de faltar a los nuevos!

en Screenshots

xiumeteo

1

706

Mié Sep 08, 2010 4:53 am

Fanton Ver último mensaje



¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 2 invitados

No puede abrir nuevos temas en este Foro
No puede responder a temas en este Foro
No puede editar sus mensajes en este Foro
No puede borrar sus mensajes en este Foro
No puede enviar adjuntos en este Foro

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group :: Style based on FI Subice by phpBBservice.nl :: Todos los horarios son UTC + 1 hora [ DST ]
Traducción al español por Huan Manwë
phpBB SEO