Reglamento general de los foros   •   FAQ   •   Buscar en el foro •  Registrarse | Iniciar sesión 



Portada » Foros Linux » Administración del sistema » Sistema


Nuevo tema Responder al tema
 [ 11 mensajes ] 
Patrocinadores

Autor
Buscar:
Mensaje

Desconectado
Forista Menor
Forista Menor
Avatar de Usuario

Registrado: Mié Dic 23, 2009 10:56 am
Mensajes: 99
Ubicación: Alcalá de Henares

Nota Publicado: Mar Oct 19, 2010 11:22 am 
Arriba  
Qué tal?

Tengo la versión 10.04 LTS (Lucid Lynx), previamente he actualizado los paquetes con los comandos
Código:
sudo apt-get update
y
Código:
sudo apt-get ugrade
y después he usado el comando
Código:
sudo apt-get dist-upgrade
para actualizar a la versión 10.10 pero no me ha actualizado el sistema. Alguien sabe por qué ha podido pasar?

Un saludoç!

_________________
Linux user number 503022
Ubuntu user number 30034


Última edición por antopv el Mar Oct 19, 2010 6:21 pm, editado 1 vez en total
 Perfil  

Desconectado
Forista Legendario
Forista Legendario
Avatar de Usuario

Registrado: Dom Oct 10, 2004 7:00 am
Mensajes: 1797

Nota Publicado: Mar Oct 19, 2010 11:48 am 
Arriba  
¿y qué versión está apuntada en los repositorios (/etc/apt/sources.list) ?

 Perfil  

Desconectado
Forista Menor
Forista Menor
Avatar de Usuario

Registrado: Mié Dic 23, 2009 10:56 am
Mensajes: 99
Ubicación: Alcalá de Henares

Nota Publicado: Mar Oct 19, 2010 11:53 am 
Arriba  
El encabezamiento del archivo que me dices es este:

Código:
# deb cdrom:[Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5)]/ karmic main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

_________________
Linux user number 503022
Ubuntu user number 30034

 Perfil  

Desconectado
Forista Legendario
Forista Legendario
Avatar de Usuario

Registrado: Dom Oct 10, 2004 7:00 am
Mensajes: 1797

Nota Publicado: Mar Oct 19, 2010 1:16 pm 
Arriba  
Esas líneas están comentadas (#), por lo que no sirve de nada que las copies aquí. No pregunté por el encabezamiento, y menos todavía un encabezamiento comentado.

¿Qué dicen las líneas no comentadas?

 Perfil  

Desconectado
Forista Menor
Forista Menor
Avatar de Usuario

Registrado: Mié Dic 23, 2009 10:56 am
Mensajes: 99
Ubicación: Alcalá de Henares

Nota Publicado: Mar Oct 19, 2010 1:19 pm 
Arriba  
Pues las primeras líneas no comentadas dicen lo siguiente:

Código:
deb http://es.archive.ubuntu.com/ubuntu/ lucid main restricted
deb-src http://es.archive.ubuntu.com/ubuntu/ lucid main restricted
deb http://es.archive.ubuntu.com/ubuntu/ lucid universe
deb-src http://es.archive.ubuntu.com/ubuntu/ lucid universe
deb http://es.archive.ubuntu.com/ubuntu/ lucid-updates universe
deb-src http://es.archive.ubuntu.com/ubuntu/ lucid-updates universe

_________________
Linux user number 503022
Ubuntu user number 30034

 Perfil  

Desconectado
Forista Legendario
Forista Legendario
Avatar de Usuario

Registrado: Dom Oct 10, 2004 7:00 am
Mensajes: 1797

Nota Publicado: Mar Oct 19, 2010 2:07 pm 
Arriba  
Como puedes leer tu mismo, las líneas apuntan a los paquetes de lucid. Por lo que el sistema está haciendo lo que le pides: actualizar a la versión lucid (para actualizar a la versión que quieres, aptitude debería leerte el pensamiento).

Si quieres otra versión, debes especificarlo en ese archivo. Ni idea de cómo se llama la versión a la que quieres llegar (supongo que algo con M). Reemplaza el nombre allí, o busca un sources.list de la versión 10.10 y cópialo.

Luego, sí, apt-get update && apt-get dist-upgrade.

 Perfil  

Desconectado
Forista Menor
Forista Menor
Avatar de Usuario

Registrado: Mié Dic 23, 2009 10:56 am
Mensajes: 99
Ubicación: Alcalá de Henares

Nota Publicado: Mar Oct 19, 2010 2:10 pm 
Arriba  
Entonces, si la versión 10.10 se llama Maverick Meerkat, tan sólo tengo que cambiar esto:

Código:
deb http://es.archive.ubuntu.com/ubuntu/ lucid main restricted
deb-src http://es.archive.ubuntu.com/ubuntu/ lucid main restricted
deb http://es.archive.ubuntu.com/ubuntu/ lucid universe
deb-src http://es.archive.ubuntu.com/ubuntu/ lucid universe
deb http://es.archive.ubuntu.com/ubuntu/ lucid-updates universe
deb-src http://es.archive.ubuntu.com/ubuntu/ lucid-updates universe
...


por esto otro:

Código:
deb http://es.archive.ubuntu.com/ubuntu/ maverick main restricted
deb-src http://es.archive.ubuntu.com/ubuntu/ maverick main restricted
deb http://es.archive.ubuntu.com/ubuntu/ maverick universe
deb-src http://es.archive.ubuntu.com/ubuntu/ maverick universe
deb http://es.archive.ubuntu.com/ubuntu/ maverick-updates universe
deb-src http://es.archive.ubuntu.com/ubuntu/ maverick-updates universe
...


y luego actualizar la distribución como siempre, no?

Un saludo y gracias!

_________________
Linux user number 503022
Ubuntu user number 30034

 Perfil  

Desconectado
Forista Legendario
Forista Legendario
Avatar de Usuario

Registrado: Dom Oct 10, 2004 7:00 am
Mensajes: 1797

Nota Publicado: Mar Oct 19, 2010 2:14 pm 
Arriba  
Sí, en principio. No sé si irá maverick o meerkat. Pero si lo que escribes está mal, no te preocupes, el sistema no se romperá. Sólo dará un mensaje de error y no descargará nada. Así que puedes probar con tranquilidad.

 Perfil  

Desconectado
Forista Ancestral
Forista Ancestral
Avatar de Usuario

Registrado: Jue Abr 12, 2007 7:00 am
Mensajes: 9186
Ubicación: tras la pantalla (...)

Nota Publicado: Mar Oct 19, 2010 3:25 pm 
Arriba  
si, eso en principio deberia funcionar. :)

por cierto, los nombres clave para los repos, es siempre solo la primera palabra del nombre de la release.

_________________
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]

 Perfil WWW  

Desconectado
Forista Menor
Forista Menor
Avatar de Usuario

Registrado: Mié Dic 23, 2009 10:56 am
Mensajes: 99
Ubicación: Alcalá de Henares

Nota Publicado: Mar Oct 19, 2010 6:22 pm 
Arriba  
Ya tengo el Ubuntu 10.10 en mi máquina.
Muchas gracias. Saludos!

_________________
Linux user number 503022
Ubuntu user number 30034

 Perfil  

Desconectado
Forista Medio
Forista Medio
Avatar de Usuario

Registrado: Jue Jun 17, 2010 5:23 am
Mensajes: 402
Ubicación: Venezuela

Nota Publicado: Dom Oct 24, 2010 5:01 am 
Arriba  
Estoy actualizando de esta manera a ver que tal. Llevo ya varios días porque la descarga estaba muy lenta pero hoy mejoró y parece que es sólo cuestión de minutos para tener lista la actualización. Como el Ubuntu arranca desde el grub2 de Debian posiblemente voy a tener que hacer cambios allí para que arranque.

Saludos

Nota: Ubuntu 10.10 funcionando. Primera vez que hago una actualización desde la versión anterior que transcurre sin problemas.

_________________
[Reglamento del foro] [Blog]

 Perfil  
Mostrar mensajes previos:  Ordenar por  
 [ 11 mensajes ] 
Nuevo tema Responder al tema

Saltar a:  


 Temas relacionados   Autor   Respuestas   Vistas   Último mensaje 
no puedo actualizar pidgin de 2.4.3 a 2.6.4[solucionado]

en Software

Ahuizolt

5

994

Jue Dic 24, 2009 2:03 am

Deckon Ver último mensaje

No puedo Actualizar Sistema - Debian (Solucionado)

[ Ir a página: 1, 2 ]

en Sistema

eldelantero

20

6969

Jue Abr 17, 2014 7:22 pm

itacense Ver último mensaje

No puedo actualizar ubuntu 12.04 de ninguna forma.Solucionado

[ Ir a página: 1, 2 ]

en Sistema

neogarde

26

4077

Lun Dic 02, 2013 11:42 pm

mcun Ver último mensaje

No puedo actualizar sistema

[ Ir a página: 1, 2, 3 ]

en Sistema

clamide

33

4830

Jue Oct 20, 2011 3:55 pm

clamide Ver último mensaje

no puedo actualizar en ubuntu 10.04

en Sistema

viko

4

903

Vie Jun 18, 2010 4:54 am

ps-ax Ver último mensaje



¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 0 invitados

No puede abrir nuevos temas en este Foro
No puede responder a temas en este Foro
No puede editar sus mensajes en este Foro
No puede borrar sus mensajes en este Foro
No puede enviar adjuntos en este Foro

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group :: Style based on FI Subice by phpBBservice.nl :: Todos los horarios son UTC + 1 hora [ DST ]
Traducción al español por Huan Manwë
phpBB SEO