[phpBB Debug] PHP Warning: in file [ROOT]/includes/acm/acm_memory.php on line 146: Cannot use a scalar value as an array
[phpBB Debug] PHP Warning: in file [ROOT]/includes/acm/acm_memory.php on line 146: Cannot use a scalar value as an array
[phpBB Debug] PHP Warning: in file [ROOT]/includes/acm/acm_memory.php on line 146: Cannot use a scalar value as an array
Como configurar xorg.conf para arreglar resolución de pantalla? : X Window
 Reglamento general de los foros   •   FAQ   •   Buscar en el foro •  Registrarse | Iniciar sesión 



Portada » Foros Linux » Entorno gráfico » X Window


Nuevo tema Responder al tema
 [ 8 mensajes ] 
Patrocinadores

Autor
Buscar:
Mensaje

Desconectado
Forista Nuevo
Forista Nuevo

Registrado: Vie Ene 15, 2010 2:53 pm
Mensajes: 7

Nota Publicado: Jue Ene 28, 2010 9:10 pm 
Arriba  
Hola gente, tengo problemas con la resolución de pantalla.
Leí que podía tirarme error por relación alguna con drivers de nvidia... leyendo el foro para saber la tarjeta gráfica recomendaban usar el hardinfo o sysinfo que me funcionaron muy bien.
Y ahí mi duda, al parecer no tengo nvidia (?), les dejo un pantallazo:

Imagen

Antes de esto había intentado cambiar la resolución en Sistemas->Preferencias->Pantalla pero sólo tiene dos opciones 800x600 y 640x480.
Leyendo encontré que podía cambiar la resolución editando el xorg:
sudo gedit /etc/X11/xorg.conf

Lo hago y me salta lo siguiente:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder63) Fri Aug 14 17:54:58 PDT 2009

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection

Creo que se cambia en la parte screen, cómo quedaría en todo caso?
Gracias a quien me ayude.

 Perfil  

Desconectado
Forista Distinguido
Forista Distinguido
Avatar de Usuario

Registrado: Sab Dic 08, 2007 8:00 am
Mensajes: 1337

Nota Publicado: Jue Ene 28, 2010 10:43 pm 
Arriba  
Hola como estas, parece que tiene una tarjeta grafica sis, pero lo que no entiendo porque en tu xorg aparece configurado para trabajar con el driver de nvidia, revisa bien que tarjeta grafica realmente tienes, por lo pronto intenta usando el driver generico vesa:
Citar:
Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection


cambialo asi

Section "Device"
Identifier "Device0"
Driver "vesa"
VendorName "NVIDIA Corporation"
EndSection

saludos

 Perfil  

Desconectado
Forista Nuevo
Forista Nuevo

Registrado: Vie Ene 15, 2010 2:53 pm
Mensajes: 7

Nota Publicado: Vie Ene 29, 2010 1:51 am 
Arriba  
Lo hice y lamentablemente no funcionó 8(
No sé que más tocar =_= igual gracias!

 Perfil  

Desconectado
Moderador
Moderador
Avatar de Usuario

Registrado: Dom Abr 01, 2007 8:00 am
Mensajes: 3273
Ubicación: México, Estado de México

Nota Publicado: Vie Ene 29, 2010 2:17 am 
Arriba  
si tienes una grafica nvidia instala el modulo(controlador) privativo. salu2

_________________
Reglamento del Foro | Temas mas Preguntados | WikiEL | GitHub
Linux User #:406092
Manjaro | Asus P8z77-v | i5-2310 | Nvidia GeForce Gt 610 | Hp Ultrabook Folio 13

 Perfil  

Desconectado
Forista Distinguido
Forista Distinguido
Avatar de Usuario

Registrado: Sab Dic 08, 2007 8:00 am
Mensajes: 1337

Nota Publicado: Vie Ene 29, 2010 4:55 pm 
Arriba  
Estoy de acuerdo con Deckon, si realmente tienes una grafica nvidia, asegurate de tener instalado los drivers privativos de nvidia, las graficas nvidia estan muy bien soportadas en gnu linux.



saludos

Si el cambio que te recomende no funciono, el xorg.conf vuelvelo a poner como estaba antes y asegurate de tener el driver privativo de nvidia, buscalos en los repositorios de tu distro.

 Perfil  

Desconectado
Forista Nuevo
Forista Nuevo

Registrado: Vie Ene 15, 2010 2:53 pm
Mensajes: 7

Nota Publicado: Sab Ene 30, 2010 7:51 pm 
Arriba  
Ya lo puse como estaba antes, cuando intento instalar los drivers de nvidia me saltan errores, no sé si es porque los controladores no son los apropiados, ya que no tengo la remota idea de cuál es para el mio http://www.nvidia.com/object/unix.html xD!
Fui a consola y tipié
sudo nvidia-settings

Como resultado tengo esto
Imagen

Voy a seguir intentando, saludos :(

 Perfil  

Desconectado
Moderador
Moderador
Avatar de Usuario

Registrado: Dom Abr 01, 2007 8:00 am
Mensajes: 3273
Ubicación: México, Estado de México

Nota Publicado: Sab Ene 30, 2010 7:58 pm 
Arriba  
y ya intentaste hacer lo que te dice el mensaje de nvidia?? ...por en tu terminal como root
Código:
nvidia-xconfig

_________________
Reglamento del Foro | Temas mas Preguntados | WikiEL | GitHub
Linux User #:406092
Manjaro | Asus P8z77-v | i5-2310 | Nvidia GeForce Gt 610 | Hp Ultrabook Folio 13

 Perfil  

Desconectado
Forista Nuevo
Forista Nuevo

Registrado: Vie Ene 15, 2010 2:53 pm
Mensajes: 7

Nota Publicado: Sab Ene 30, 2010 9:52 pm 
Arriba  
Lo hice me saltó esto en la terminal:
El programa «nvidia-xconfig» puede encontrarse en los siguientes paquetes:
* nvidia-glx-173
* nvidia-glx-185
* nvidia-glx-96

Instalé el 185, y luego volví a tipear
nvidia-xconfig

Me dice esto:
Using X configuration file: "/etc/X11/xorg.conf".
Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
New X configuration file written to '/etc/X11/xorg.conf'

No sé si voy bien... :|

 Perfil  
Mostrar mensajes previos:  Ordenar por  
 [ 8 mensajes ] 
Nuevo tema Responder al tema

Saltar a:  


 Temas relacionados   Autor   Respuestas   Vistas   Último mensaje 
Resolucion en xorg.conf

en X Window

luisrodg

6

1804

Mar Jul 02, 2013 3:36 am

enriquehh Ver último mensaje

y mi xorg.conf?? (solucionado)

en X Window

niky45

12

8533

Jue Jul 30, 2009 10:44 am

tepes89 Ver último mensaje

Mi xorg.conf ya no sirve mas en Squeeze (SOLUCIONADO)

en X Window

ran8489

3

6302

Sab Oct 31, 2009 8:09 pm

niky45 Ver último mensaje

Cómo arrancar xorg.conf desde setup?

en Software

electric_dragon

2

677

Dom Ene 23, 2011 10:52 pm

niky45 Ver último mensaje

problema resolucion DNS por culpa del resolv.conf

en Redes y Servidores

spa_hyperion

11

4404

Sab May 14, 2011 1:48 pm

niky45 Ver último mensaje



¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 0 invitados

No puede abrir nuevos temas en este Foro
No puede responder a temas en este Foro
No puede editar sus mensajes en este Foro
No puede borrar sus mensajes en este Foro
No puede enviar adjuntos en este Foro

cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group :: Style based on FI Subice by phpBBservice.nl :: Todos los horarios son UTC + 1 hora [ DST ]
Traducción al español por Huan Manwë
phpBB SEO