Raton en linux

Dudas y comentarios relacionadas con paquetes o programas específicos (obtención, uso, actualizaciones, versiones, problemas de instalación, etc.)

Moderadores: doc, Deckon

Responder
Avatar de Usuario
Meng60
Forista Nuevo
Forista Nuevo
Mensajes: 15
Registrado: Jue Oct 01, 2009 7:00 am

Raton en linux

Mensaje por Meng60 » Jue Oct 01, 2009 5:34 pm

Buenas tardes

Soy nuevo usuario de linux y al instalar wine y empezar a jugar al wow he encontrado un inconveniente. Mi raton tiene 8 botones, izquierdo, derecho, ruleta hacia adentro, dos laterales, dos en una esquina y uno debajo de la ruleta. El problema es que el wow no me reconoce estos botones y no se como solucionar el problema. Son botones en los que tengo asignadas acciones del juego y en windows los utilizaba mucho y me gustaria saber como puedo conseguir que linux me los reconozca.

El raton es un trust MI 7700R y utilizo ubuntu.

Muchisimas gracias.
Avatar de Usuario
niky45
Forista Ancestral
Forista Ancestral
Mensajes: 9186
Registrado: Jue Abr 12, 2007 7:00 am
Ubicación: tras la pantalla (...)
Contactar:

Re: Raton en linux

Mensaje por niky45 » Jue Oct 01, 2009 8:30 pm

busca info sobre como configurar las teclas multimedia. el proceso es el mismo, solo que en vez de "detectar" las teclas, tienes que "detectar" los bootnes del raton.

aunque en tu caso, una vez que los hayas detectado, configuralos como teclas virtuales (F13, F14...), y l/uego le asignas las acciones a estans teclas virtuales.

:D
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]
Avatar de Usuario
Meng60
Forista Nuevo
Forista Nuevo
Mensajes: 15
Registrado: Jue Oct 01, 2009 7:00 am

Re: Raton en linux

Mensaje por Meng60 » Jue Oct 01, 2009 11:13 pm

mmm, esa solucion no me vale. Cuando lanzo xev y preto los botones del mouse el SO no me los reconoce. Es como si no existieran, el SO pasa de ellos. He leido algo que cambiando el xorg.conf se puede arreglar algo y he conseguido que los botones del lateral me funcione pero los dos superiores siguen sin funcionar...
Avatar de Usuario
niky45
Forista Ancestral
Forista Ancestral
Mensajes: 9186
Registrado: Jue Abr 12, 2007 7:00 am
Ubicación: tras la pantalla (...)
Contactar:

Re: Raton en linux

Mensaje por niky45 » Sab Oct 03, 2009 3:56 pm

osea, que xev no los ve..... y me dices que con el xorg has consegido que te vea algunos.... pues.... que tal si nos pones lo que has metido para que te los vea?? y asi a ver si vemos lo que hay que hacer pala que vea el resto. :D
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]
Avatar de Usuario
Meng60
Forista Nuevo
Forista Nuevo
Mensajes: 15
Registrado: Jue Oct 01, 2009 7:00 am

Re: Raton en linux

Mensaje por Meng60 » Dom Oct 04, 2009 11:17 pm

Lo que tengo escrito en el xorg es lo siguiente

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ImputFashion" "Mouse"
Option "Buttons" "8"
Option "ZAxisMapping" "4 5"
EndSection

Cuando cargo el wow (es la forma en que compruebo que me coge el boton) y pruebo en la configuracion del juego a cambiar los controles los botones laterales si que me los detecta y son el 4 y el 5 pero los dos botones de arriba no me los coge. Es decir, me coge los dos de clics, la ruleta, los dos laterales pero no los dos de arriba.

Por otra parte, cuando reinicio linux, me dejan de funcionar los dos botones laterales y no se porque, si vuelvo a cargar el xorg.conf desde la consola "sudo gedit /etc/X11/xorg.conf" y cierro ya si que me funcionan...
Avatar de Usuario
Meng60
Forista Nuevo
Forista Nuevo
Mensajes: 15
Registrado: Jue Oct 01, 2009 7:00 am

Re: Raton en linux

Mensaje por Meng60 » Sab Oct 10, 2009 2:21 pm

ninguna soluicion?
Avatar de Usuario
enriquehh
Forista Distinguido
Forista Distinguido
Mensajes: 1337
Registrado: Sab Dic 08, 2007 8:00 am

Re: Raton en linux

Mensaje por enriquehh » Sab Oct 10, 2009 4:24 pm

Hola como estas, parece que te manejas bien con la terminal, y con la edición de archivos de texto.

En cuanto a tu problema mira encontre este enlace

http://humanreadable.nfshost.com/sdeg/s ... -mouse.htm

Por lo que he leido, hay un ejemplo de siete botones, y alli indican que cuando es de siete botones, la siguiente linea debe ser:

Option "ZAxisMapping" "4 5 6 7"

por lo que deduzco que al ser tu raton de 8 botones deberia ser:

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ImputFashion" "Mouse"
Option "Buttons" "8"
Option "ZAxisMapping" "4 5 6 7 8"
EndSection

saludos.

Nota: es recomendable hacer respaldos de tu xorg.conf

saludos
krovikan
Forista Nuevo
Forista Nuevo
Mensajes: 1
Registrado: Jue Ene 29, 2015 2:01 pm

Re: Raton en linux

Mensaje por krovikan » Jue Ene 29, 2015 2:42 pm

Hola:

Ante todo perdón por esta nigromancia pero el tema sobre botones y WoW me interesa (tras horas de búsqueda en la web).

Mi problema lo tengo con un Logitech MX1000 (con rueda y 3 botones laterales) a la hora de querer usar los 10 botones que detecta Xev.

Según Xev:

Click izquierdo: botón 1
Clck central: botón 2
Click derecho: botón 3
Rueda arriba: botón 4
Rueda abajo: botón 5
Rueda izquierda: botón 6
Rueda derecha: botón 7
Botón lateral abajo: botón 8
Botón lateral arriba: botón 9
Botón lateral central: botón 10

En teoría hay 2 botones más pero no estoy seguro:

Botón encima de rueda arriba: botón 4
Botón debajo de rueda abajo: botón 5

Pero en el WoW:

Click izquierdo: botón 1
Clck central: botón 2
Click derecho: botón 3
Rueda arriba: Rueda ratón arriba
Rueda abajo: Rueda ratón abajo
Rueda izquierda: botón 4
Rueda derecha: botón 5
Botón lateral abajo: botón 4
Botón lateral arriba: botón 5
Botón lateral central: este no lo detecta

Botón encima de rueda arriba: Rueda ratón arriba
Botón debajo de rueda abajo: Rueda ratón abajo

He rebuscado mucho por internet (castellano, inglés, desde 2005 hacia adelante) y no consigo dar con la solución, si la hay. Me interesa en especial que funcionen también los laterales de la rueda ya que el WoW detecta con el mismo número los laterales de la rueda y 2 de los botones del lateral del ratón.


Mi X.org actual es:

Código: Seleccionar todo

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Logitech MX1000" "CorePointer"
    Option         "Xinerama" "0"
    Option         "BlankTime" "0"
    Option         "StandbyTime" "0"
    Option         "SuspendTime" "0"
    Option         "OffTime" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    Identifier     "Logitech MX1000"
    Driver         "evdev"
    Option         "Name" "Logitech Logitech BT Mini-Receiver"
    Option	   "Device" "/dev/input/event2"
    Option         "CorePointer"
EndSection
Si necesitais más info, sólo pedidla.
Aunque creo que no hace falta uso Opensuse 13.1 y KDE 4.11.


Saludos y muchas gracias si alguien puede guiarme en este gran atolladero en el que me encuentro.
Responder
  • Similar Topics
    Respuestas
    Vistas
    Último mensaje