[Solucionado] La instalación de linux se congela

Todo lo relacionado con la elección e instalación de las diferentes distribuciones y los problemas que se presentan durante el proceso.

Moderadores: doc, mcun

Responder
charquicán
Forista Nuevo
Forista Nuevo
Mensajes: 4
Registrado: Vie Nov 20, 2020 9:44 pm

[Solucionado] La instalación de linux se congela

Mensaje por charquicán »

Saludos.

Quiero comenzar en linux, y he tenido dramas con la instalación.
Mi problema es el siguiente: acabo de comprar un notebook acer aspire 3, y estoy intentando de instalar Linux en él, pero se queda congelado después de hacer el check de los archivos, he probado con Ubuntu, Debian y Mint, y ocurre lo mismo en todas.

He tratado de cambiar el modo UEFI a Legacy, pero la bios no me lo permite, he hecho el set de la contraseña y se desbloquean todas las opciones menos el boot mode, también encontré algo sobre cambiar los parámetros de Ubuntu antes de iniciar la instalación pero no me aparecen los mismos parámetros.

Dije lo que había hecho ya que soy un ignorante en cuanto a linux.
Este seria mi segundo día intentando instalar, y me recomendaron este foro para preguntar.

(Actualización 1)
Me sale el siguiente error "AMD-Vi: Unable to write to IOMMU perf counter"
He agregado flags pero pasa lo mismo

(Actualización 2)
En las flags agregue el nomodeset
se queda congelado en "A start job is running for Monitoring of LVM2 Mirrors"

(Actualización 3)
Pude hacer funcionar la vaina, entre al live mode, pero aun me queda instalarlo.
Lo logre agregando lo siguiente a los parámetros de instalación:

Código: Seleccionar todo

nvme_core.default_ps_max_latency_us=14000


(Actualización 4)
Al final pude instalar Linux, el problema es que tengo que agregar la lineal anterior a los parámetros de booteo de manera permanente, sino tendré que editarlos cada vez que inicie.

(Actualización 5, Historia final de mi proceso)
Estoy en linux posteando esto, al final lo hice funcionar, paso lo siguiente, al momento de instalar y añadir la linea que está en la "Actualización 3", se instalo normalmente, luego debí reiniciar esta vez sacando el usb, después de eso no inició, lo debí apagar y presionar la letra E varias veces para entrar a los setparams de boteo, agregue nuevamente la linea a los parámetros, luego de eso inicio normalmente.

En mi ignorancia creí que estaba todo listo, pero para mi sorpresa luego de actualizar dependencias y todos los paquetes tocó reiniciar, se estropeo de nuevo, entraba a linux pero se congelaba a penas entraba al login screen, tuve que reinstalar linux ya que para mi sorpresa una vez instalado y luego del primer inicio no pude volver a entrar a los setparams con la letra E, una vez reinstalado hice el proceso nuevamente pero al primer inicio, debí modificar el grub para conservar para siempre el cambio de los parámetros de inicio, aplique lo siguiente:

Código: Seleccionar todo

sudo nano /etc/default/grub 
Modifique lo siguiente:

Código: Seleccionar todo

Antes:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Despues:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nvme_core.default_ps_max_latency_us=14000"


Una vez modificado el grub conserve y aplique los cambios con lo siguiente:

Código: Seleccionar todo

sudo update-grub
Se supone que cambiar el 14000 a 0 debería de desactivar ese modo por lo que leí, supongo que funcionaría a full y sin limitaciones, pero es cosa de probar, esta opcion es algo sobre el modo ahorro de energia
Fuente: https://wiki.archlinux.org/index.php/Ta ... drive/NVMe

Gracias de antemano! <3
Última edición por charquicán el Dom Nov 22, 2020 1:18 am, editado 10 veces en total.

Avatar de Usuario
doc
Forista Ancestral
Forista Ancestral
Mensajes: 3522
Registrado: Mié Ago 11, 2010 10:32 am
Ubicación: Oviedo-es_ES
Contactar:

Re: La instalación se congela

Mensaje por doc »

pues lo que parece más probable es que hay algo que haces mal... pero el problema es que no está claro qué. Mira, yo creo que lo mejor es que identifiques aquí...
https://forums.linuxmint.com/viewtopic. ... cionInicio
cual es exactamente tu caso (qué tienes y qué quieres hacer), y que sigas exactamente las instrucciones del tutorial correspondiente, que está muy probado... y a ver si tienes suerte (si no, habría que pensar que tienes algo raro en tu PC... pero la verdad es que yo hace años tuve un Acer Aspire, ahora tengo un sobremesa Acer... y nunca he tenido problemas).

peter_48
Forista Nuevo
Forista Nuevo
Mensajes: 41
Registrado: Lun Ago 15, 2016 7:19 pm

Re: La instalación se congela

Mensaje por peter_48 »

Como tienes la virtualizacion en el bios? esta activada?
Y "secure boot" ? esta desactivado?

charquicán
Forista Nuevo
Forista Nuevo
Mensajes: 4
Registrado: Vie Nov 20, 2020 9:44 pm

Re: La instalación se congela

Mensaje por charquicán »

doc escribió:
Sab Nov 21, 2020 12:21 pm
pues lo que parece más probable es que hay algo que haces mal... pero el problema es que no está claro qué. Mira, yo creo que lo mejor es que identifiques aquí...
https://forums.linuxmint.com/viewtopic. ... cionInicio
cual es exactamente tu caso (qué tienes y qué quieres hacer), y que sigas exactamente las instrucciones del tutorial correspondiente, que está muy probado... y a ver si tienes suerte (si no, habría que pensar que tienes algo raro en tu PC... pero la verdad es que yo hace años tuve un Acer Aspire, ahora tengo un sobremesa Acer... y nunca he tenido problemas).
No encontre algo en especifico, hice el tuttorial de instalación pero me pasa lo mismo

charquicán
Forista Nuevo
Forista Nuevo
Mensajes: 4
Registrado: Vie Nov 20, 2020 9:44 pm

Re: La instalación se congela

Mensaje por charquicán »

peter_48 escribió:
Sab Nov 21, 2020 4:26 pm
Como tienes la virtualizacion en el bios? esta activada?
Y "secure boot" ? esta desactivado?
Secure boot desactivado
AMD-SVM Activada
AMD-OIMMU Activada

Avatar de Usuario
doc
Forista Ancestral
Forista Ancestral
Mensajes: 3522
Registrado: Mié Ago 11, 2010 10:32 am
Ubicación: Oviedo-es_ES
Contactar:

Re: [Solucionado] La instalación de linux se congela

Mensaje por doc »

si pones lo de 'solucionado', los demás usuarios te agradeceríamos que pusieses 'cómo'

(edito: veo que lo has puesto en tu primer post. Estupendo, gracias.)

Responder
  • Temas similares
    Respuestas
    Vistas
    Último mensaje