Instalando/actualizando opensuse 13.2, repositorios. [solucionado]

Todo lo relacionado con la elección e instalación de las diferentes distribuciones y los problemas que se presentan durante el proceso.

Moderadores: doc, mcun

Avatar de Usuario
Kenton
Forista Mayor
Forista Mayor
Mensajes: 548
Registrado: Sab Jun 21, 2014 1:54 pm

Instalando/actualizando opensuse 13.2, repositorios. [solucionado]

Mensaje por Kenton »

Hola,

Recien puedo instalar opensuse/gnome, la actualizacion del sistema la comienzo asi: primero los repositorios, zypper ref y despues hago una actualizacion de la distribucion, zypper dup pero no se si estos son todos los repositorios que debe tener el sistema, salio esto:

"Advertencia. Estás a punto de realizar una actualización de la distribución completa con todos los repositorios habilitados. Verifica que estos repositorios sean compatibles antes de continuar."

Saludos.

Editado -- Sab Ene 03, 2015 10:18 pm --

Parece que termino de actualizar ...

Primero pongo para ver los repositorios:


linux:/home/keos # zypper lr
# | Alias | Nombre | Habilitado | Actualizar
--+---------------------+------------------------------+------------+-----------
1 | repo-non-oss | openSUSE-13.2-Non-Oss | Si | Si
2 | repo-oss | openSUSE-13.2-Oss | Si | Si
3 | repo-update | openSUSE-13.2-Update | Si | Si
4 | repo-update-non-oss | openSUSE-13.2-Update-Non-Oss | Si | Si
linux:/home/keos #

y despues lo que pide aqui:

Hay algunos programas en ejecución que utilizan archivos eliminados por una reciente actualización. Debería considerar verificar y reiniciar algunos. Ejecute 'zypper ps' para listarlos.

[es muy larga la lista, solo lo que me parece significativo]

linux:/home/keos # zypper ps
Los siguientes procesos en ejecución utilizan archivos eliminados:

PID | PPID | UID | Inicio de sesión | Comando | Servicio | Archivos
-----+------+------+------------------+-------------------------------------+--------------+----------------------------------------------------------
356 | 1 | 0 | root | systemd-journald;54a894f8 (deleted) | | /usr/lib/systemd/systemd-journald;54a894f8 (deleted)
377 | 1 | 0 | root | lvmetad | | /usr/lib64/libudev.so.1.4.0;54a894ef
378 | 1 | 0 | root | dmeventd | | /usr/lib64/libudev.so.1.4.0;54a894ef
682 | 1 | 491 | avahi | avahi-daemon | avahi-daemon | /lib64/libdbus-1.so.3.8.7
687 | 1 | 0 | root | wpa_supplicant | | /lib64/libssl.so.1.0.0;54a894c8
| | | | | | /lib64/libcrypto.so.1.0.0;54a894c8
| | | | | | /lib64/libdbus-1.so.3.8.7
689 | 1 | 0 | root | gdbus | | /usr/lib64/libgudev-1.0.so.0.2.0;54a89529
| | | | | | /usr/lib64/libudev.so.1.4.0;54a894ef
| | | | | | /usr/lib64/libsystemd.so.0.0.1;54a894f8
694 | 1 | 499 | messagebus | dbus-daemon | | /usr/lib64/libsystemd.so.0.0.1;54a894f8
| | | | | | /bin/dbus-daemon;54a894f7 (deleted)
697 | 1 | 0 | root | gdbus | | /usr/lib64/libplds4.so;54a894cf
| | | | | | /usr/lib64/libplc4.so;54a894cf

1191 | 1 | 1000 | keos | pulseaudio;54a89716 (deleted) | | /usr/lib64/libpulse.so.0.17.3;54a89529
| | | | | | /usr/lib64/libFLAC.so.8.3.0;54a894e7
| | | | | | /lib64/libcrypto.so.1.0.0;54a894c8

Editado -- Dom Ene 04, 2015 12:08 am --

Hago un apagado prolongado. Creo que ya esta actualizado:

keos@linux:~> su
Contraseña:
linux:/home/keos # zypper up
Obteniendo los datos del repositorio...
Leyendo los paquetes instalados...

No hay nada que hacer.
linux:/home/keos #

Hay dos problemas:

No viene la pagina del gestor de inicio en donde debo poner la clave para que se abra, sino que aparece ya listo para comenzar.

Por mas que cambie el teclado a ingles en el icono superior derecho, cuando se reinicia cambia siempre al espanol.

Saludos
Última edición por Kenton el Dom Ene 04, 2015 4:07 pm, editado 1 vez en total.
"Me lo contaron y lo olvidé. Lo vi y lo entendí. Lo hice y lo aprendí." -- Confucio.

Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

Sistemas Operativos: PCLinux

Avatar de Usuario
enriquehh
Forista Distinguido
Forista Distinguido
Mensajes: 1337
Registrado: Sab Dic 08, 2007 8:00 am

Re: Instalando/actualizando opensuse 13.2, repositorios.

Mensaje por enriquehh »

Hola, los problemas que mencionas se solucionan mediante la opción de configuración del sistema.

Imagen


Para los de inicio de sesion

Ve a configuracion de sistema --> usuarios --> desbloquear --> Mueve la barra despalzable de inicio automatico a apagado (ponlo en off)

Para lo del teclado

Configuración de sistema --> Teclado --> fuente de entrada --> Selecciona el teclado que no necesitas y eliminalo

Saludos

Avatar de Usuario
Kenton
Forista Mayor
Forista Mayor
Mensajes: 548
Registrado: Sab Jun 21, 2014 1:54 pm

Re: Instalando/actualizando opensuse 13.2, repositorios.

Mensaje por Kenton »

Hola enriquehh, el primer asunto ha sido resuelto, gracias.

En cuanto al teclado, sigue viniendo en espanol, lo hago tal como dices:

Imagen

elimine en donde dice fuente de entrada el espanol, dejandolo en ingles (?)

Saludos

Editado -- Dom Ene 04, 2015 10:36 am --

No se como, pero se abrio otra ventana mas al final, hice otros cambios y se arreglo, la verdad, no se bien ... (?)

saludos
"Me lo contaron y lo olvidé. Lo vi y lo entendí. Lo hice y lo aprendí." -- Confucio.

Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

Sistemas Operativos: PCLinux

Avatar de Usuario
enriquehh
Forista Distinguido
Forista Distinguido
Mensajes: 1337
Registrado: Sab Dic 08, 2007 8:00 am

Re: Instalando/actualizando opensuse 13.2, repositorios. [solucionado]

Mensaje por enriquehh »

Hola, para que tengas mas software disponible en Opensuse puedes agregar los repositorios packman, para ello ve a Yast --> añadir --> repositorios de la comunidad --> repositorios packman.

Saludos.

Avatar de Usuario
Kenton
Forista Mayor
Forista Mayor
Mensajes: 548
Registrado: Sab Jun 21, 2014 1:54 pm

Re: Instalando/actualizando opensuse 13.2, repositorios. [solucionado]

Mensaje por Kenton »

Hecho, pero sigo sin encontrar lo que busco:

keos@linux:~> zypper if stockfish
Obteniendo los datos del repositorio...
Leyendo los paquetes instalados...


No se ha encontrado paquete 'stockfish'.
keos@linux:~> zypper if clamtk
Obteniendo los datos del repositorio...
Leyendo los paquetes instalados...


No se ha encontrado paquete 'clamtk'.
keos@linux:~> zypper if localepurge
Obteniendo los datos del repositorio...
Leyendo los paquetes instalados...


No se ha encontrado paquete 'localepurge'.

En cambio si esta el que no deberia ...

keos@linux:~> zypper if systemd
Obteniendo los datos del repositorio...
Leyendo los paquetes instalados...


Información para paquete systemd:
----------------------------------
Repositorio: openSUSE-13.2-Update
Nombre: systemd
Versión: 210-25.8.1
Arquitectura: x86_64
Proveedor: openSUSE
Instalado: Si
Estado: actualizado
Tamaño instalado: 12,2 MiB
Resumen: A System and Session Manager
Descripción:
Systemd is a system and service manager, compatible with SysV and LSB
init scripts for Linux. systemd provides aggressive parallelization
capabilities, uses socket and D-Bus activation for starting services,
offers on-demand starting of daemons, keeps track of processes using
Linux cgroups, supports snapshotting and restoring of the system state,
maintains mount and automount points and implements an elaborate
transactional dependency-based service control logic. It can work as a
drop-in replacement for sysvinit.
keos@linux:~>
"Me lo contaron y lo olvidé. Lo vi y lo entendí. Lo hice y lo aprendí." -- Confucio.

Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

Sistemas Operativos: PCLinux

Avatar de Usuario
enriquehh
Forista Distinguido
Forista Distinguido
Mensajes: 1337
Registrado: Sab Dic 08, 2007 8:00 am

Re: Instalando/actualizando opensuse 13.2, repositorios. [solucionado]

Mensaje por enriquehh »

Hola, El equipo de desarrollo de Opensuse decidio implementar systemd hace muchos meses atras (desde la version 12.1), asi que es completamente normal encontrar a systemd en opensuse, en cuanto a stockfish y scid deberias encontrarlos al agregar el repositorio packman.

En cuanto a clamtk, puedes instalarlo desde este enlace.

http://software.opensuse.org/package/clamtk

En cuanto a localepurge me parece que no hay este paquete para opensuse, en su lugar puedes instalar bleachbit

Saludos

Nota: Stockfish aparece en los repositorios con el nombre de stockfish20

Avatar de Usuario
Kenton
Forista Mayor
Forista Mayor
Mensajes: 548
Registrado: Sab Jun 21, 2014 1:54 pm

Re: Instalando/actualizando opensuse 13.2, repositorios. [solucionado]

Mensaje por Kenton »

No hay como descargarlo:

Imagen
"Me lo contaron y lo olvidé. Lo vi y lo entendí. Lo hice y lo aprendí." -- Confucio.

Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

Sistemas Operativos: PCLinux

Avatar de Usuario
enriquehh
Forista Distinguido
Forista Distinguido
Mensajes: 1337
Registrado: Sab Dic 08, 2007 8:00 am

Re: Instalando/actualizando opensuse 13.2, repositorios. [solucionado]

Mensaje por enriquehh »

Haz click en opensuse 13.2, y luego presiona en el enlace que dice "show unstable package", se abrirá una ventana y le das a continuar, finalmente seleccionas 1 click install de la sección security, el resto es seguir los pasos que te aparecerán en las instrucciones.

Saludos

Avatar de Usuario
Kenton
Forista Mayor
Forista Mayor
Mensajes: 548
Registrado: Sab Jun 21, 2014 1:54 pm

Re: Instalando/actualizando opensuse 13.2, repositorios. [solucionado]

Mensaje por Kenton »

Lo descargue pero hay problemas, en descargas, le di click derecho, se abrieron las opciones, no vi extraer, pero si comprimir, arriba decía click para abrir con yast-click install, algo asi, fui ahí, seguí las indicaciones hasta que aparece esto:

Imagen
"Me lo contaron y lo olvidé. Lo vi y lo entendí. Lo hice y lo aprendí." -- Confucio.

Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

Sistemas Operativos: PCLinux

Avatar de Usuario
enriquehh
Forista Distinguido
Forista Distinguido
Mensajes: 1337
Registrado: Sab Dic 08, 2007 8:00 am

Re: Instalando/actualizando opensuse 13.2, repositorios. [solucionado]

Mensaje por enriquehh »

Hola, lo correcto es instalarlo con YAST, para proseguir solo dale a siguiente, si el software clamtk no funciona adecuadamente lo puedes des instalar sin problemas posteriormente, usando yast o zypper.

Saludos

Avatar de Usuario
Kenton
Forista Mayor
Forista Mayor
Mensajes: 548
Registrado: Sab Jun 21, 2014 1:54 pm

Re: Instalando/actualizando opensuse 13.2, repositorios. [solucionado]

Mensaje por Kenton »

No comprendo, cerre la pagina por lo que dice que hay problemas, abri YAST y no esta ahi:

Imagen

Como puedo hacerlo pasar de descargas a YAST sin ese problema que aparece diciendo que se danara ...?

Editado -- Dom Ene 04, 2015 3:20 pm --

Lo siento estoy cansado, no me di cuenta, dice añadir no *danar* ... volvere mas tarde, gracias.
"Me lo contaron y lo olvidé. Lo vi y lo entendí. Lo hice y lo aprendí." -- Confucio.

Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

Sistemas Operativos: PCLinux

Avatar de Usuario
enriquehh
Forista Distinguido
Forista Distinguido
Mensajes: 1337
Registrado: Sab Dic 08, 2007 8:00 am

Re: Instalando/actualizando opensuse 13.2, repositorios. [solucionado]

Mensaje por enriquehh »

Hola, perdón quise decir Yast click install.

Saludos

Avatar de Usuario
Kenton
Forista Mayor
Forista Mayor
Mensajes: 548
Registrado: Sab Jun 21, 2014 1:54 pm

Re: Instalando/actualizando opensuse 13.2, repositorios. [solucionado]

Mensaje por Kenton »

O'k prosigo, esto fue lo que debi poner para que se vea mas claro el problema:

Imagen

O sea cuando le das a 'siguiente' aqui: http://postimg.org/image/5bor5kalx/ aparece el cuadro o ventanita de arriba advirtiendo de posibles danos ...
"Me lo contaron y lo olvidé. Lo vi y lo entendí. Lo hice y lo aprendí." -- Confucio.

Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

Sistemas Operativos: PCLinux

Avatar de Usuario
enriquehh
Forista Distinguido
Forista Distinguido
Mensajes: 1337
Registrado: Sab Dic 08, 2007 8:00 am

Re: Instalando/actualizando opensuse 13.2, repositorios. [solucionado]

Mensaje por enriquehh »

Hola responde que "si" a la pregunta que te esta realizando el sistema, acabo de instalar clamtk de esa forma en opensuse y parece que todo anda bien.

Saludos

Nota: Básicamente el sistema esta agregando algunos repositorios para poder instalar clamtk en opensuse 13.2, y la pregunta que te esta realizando el sistema es si estas conciente de cuales son los repositorios que se agregarán. Luego te preguntara si confias en las llaves de los repositorios que agregaste y alli deberias decir también que "si", ya luego se instalará clamtk automaticamente.

Avatar de Usuario
Kenton
Forista Mayor
Forista Mayor
Mensajes: 548
Registrado: Sab Jun 21, 2014 1:54 pm

Re: Instalando/actualizando opensuse 13.2, repositorios. [solucionado]

Mensaje por Kenton »

Hecho.

Muchas gracias por la ayuda!!.

Saludos.

Editado -- Dom Ene 04, 2015 6:33 pm --

Olvido:

keos@linux:~> su
Contraseña:
linux:/home/keos # zypper if stockfish
Obteniendo los datos del repositorio...
Leyendo los paquetes instalados...

No se ha encontrado paquete 'stockfish'.
linux:/home/keos #

-- Lo hice por YAST pero ...

linux:/home/keos # zypper if packman
Obteniendo los datos del repositorio...
Leyendo los paquetes instalados...


No se ha encontrado paquete 'packman'.

Editado -- Dom Ene 04, 2015 6:40 pm --

Y YAST dice que esta:

Imagen

Editado -- Dom Ene 04, 2015 6:47 pm --

Equivoque el comando, pero de cualquier manera stockfish no se encuentra:

linux:/home/keos # zypper se packman
Obteniendo los datos del repositorio...
Leyendo los paquetes instalados...

E | Nombre | Resumen | Tipo
--+----------------+-----------------------------+------------
| rpmkey-packman | The packman rpm public keys | paquete
| rpmkey-packman | The packman rpm public keys | paquete src
linux:/home/keos #

Editado -- Dom Ene 04, 2015 6:51 pm --

Ahora aparece y sin embargo no lo da, ya no se que hacer (?)

linux:/home/keos # zypper se stockfish
Obteniendo los datos del repositorio...
Leyendo los paquetes instalados...

E | Nombre | Resumen | Tipo
--+-------------------------+--------------------------------------+------------
| stockfish14 | A very strong, UCI compatible Ches-> | paquete
| stockfish14 | A very strong, UCI compatible Ches-> | paquete src
| stockfish14-debuginfo | Debug information for package stoc-> | paquete
| stockfish16 | A very strong, UCI compatible Ches-> | paquete
| stockfish16 | A very strong, UCI compatible Ches-> | paquete src
| stockfish16-debuginfo | Debug information for package stoc-> | paquete
| stockfish16-debugsource | Debug sources for package stockfis-> | paquete
| stockfish17 | A very strong, UCI compatible Ches-> | paquete
| stockfish17 | A very strong, UCI compatible Ches-> | paquete src
| stockfish17-debuginfo | Debug information for package stoc-> | paquete
| stockfish17-debugsource | Debug sources for package stockfis-> | paquete
| stockfish18 | A very strong, UCI compatible Ches-> | paquete
| stockfish18 | A very strong, UCI compatible Ches-> | paquete src
| stockfish18-debuginfo | Debug information for package stoc-> | paquete
| stockfish18-debugsource | Debug sources for package stockfis-> | paquete
| stockfish19 | A very strong, UCI compatible Ches-> | paquete
| stockfish19 | A very strong, UCI compatible Ches-> | paquete src
| stockfish19-debuginfo | Debug information for package stoc-> | paquete
| stockfish19-debugsource | Debug sources for package stockfis-> | paquete
| stockfish20 | A very strong, UCI compatible Ches-> | paquete
| stockfish20 | A very strong, UCI compatible Ches-> | paquete src
| stockfish20-debuginfo | Debug information for package stoc-> | paquete
| stockfish20-debugsource | Debug sources for package stockfis-> | paquete
linux:/home/keos # zypper in stockfish
Obteniendo los datos del repositorio...
Leyendo los paquetes instalados...
stockfish no se encontró como nombre de paquete, probando en prestaciones.
No se han encontrado proveedores de 'stockfish'.
Resolviendo dependencias...

No hay nada que hacer.
linux:/home/keos #
"Me lo contaron y lo olvidé. Lo vi y lo entendí. Lo hice y lo aprendí." -- Confucio.

Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

Sistemas Operativos: PCLinux

Responder
  • Temas similares
    Respuestas
    Vistas
    Último mensaje