conflicto con ratón y teclado, en Debian Testing [SOLUCIONADO]

Todo lo relacionado con la elección e instalación de las diferentes distribuciones y los problemas que se presentan durante el proceso.

Moderadores: doc, mcun

Responder
Avatar de Usuario
doc
Forista Ancestral
Forista Ancestral
Mensajes: 3477
Registrado: Mié Ago 11, 2010 10:32 am
Ubicación: Oviedo-es_ES
Contactar:

conflicto con ratón y teclado, en Debian Testing [SOLUCIONADO]

Mensaje por doc »

me está pasando algo que no entiendo: a ver, uso Testing (Wheezy) en mi ordenador (me actualicé desde Debian estable (Squeezy), y me funciona todo perfectamente. Y estoy con el kernel 2.6.38-2

Pero tengo una partición "para pruebas" donde acabo de instalar un Debian Testing actualizado a 2 de mayo (CD-1, bajado de aquí: http://cdimage.debian.org/cdimage/weekly-builds/amd64/ ) que veo que ya carga el linux-image 2.6.38-2, y el LibreOffice

El caso es que se me instala perfectamente, pero no me reconoce ni el ratón ni el teclado y claro, no puedo ni entrar. Por cierto, ambos están conectados por puerto PS/2, y digo esto porque si conecto un ratón por USB, funciona (no tengo a mano un teclñado por USB, pero me imagino que podría funcionar también)

¿por qué me parece raro todo esto...? pues porque en en mismo ordenador, en mi Debian "oficial", con su root en /dev/sda1, con el mismo kernel... ratón y teclado PS/2 me van perfectamente. Luego no es un problema del PC.

Lo he instalado tres veces, siempre me da el mismo problema... y ya estoy pensando si será algún fallo de este 'daily-builds' que me he bajado.

Y ahora mi pregunta: ¿puedo hacer algo? (se me ocurre que si entro en modo recovery (usuario único), como root (ahí si me funciona el teclado) a lo mejor puedo arreglar algo. Pero... ¿qué? (o ¿qué comandos meter?) Es que no tengo ni idea.

(nota: aunque 'nouveau' no lo necesite, también creé un xorg.conf, con X -configure, y lo comparé con el que tengo en mi "debian oficial"), donde uso los privativos de nvidia. Curiosamente tienen idénticas especificaciones para el mouse y el keyboard (incluso probé copiarlas de un xorg.conf al otro) pero en el Testing recién instalado (root en /dev/sda8), como digo, no van.

¿alguna ayudita...? (no se si he explicado bien el problema, o está muy confuso. Incluso no se si algo parecido lo había posteado antes, no se si aquí o en otro foro). El caso es que estoy empezando a tener la cabeza a pájaros.
Última edición por doc el Lun May 09, 2011 12:23 pm, editado 1 vez en total.

Avatar de Usuario
enriquehh
Forista Distinguido
Forista Distinguido
Mensajes: 1337
Registrado: Sab Dic 08, 2007 8:00 am

Re: conflicto con ratón y teclado, en Debian Testing

Mensaje por enriquehh »

Hola como estas, bueno yo apuestao a que es el cd de instalacion, ya me ha pasado algunas veces cuando tenia que descargar el instalador de debian testing, en cuanto a tu problema, prueba esto:

entra en modo texto, e inicia gdm o gdm3 de la siguiente manera:

/etc/init.d/gdm3 start

o

/etc/init.d/gdm start

si todo arranca bien, lo mas probable es que tengas un problema con udev, ese problema lo he tenido yo cuando actualice, el responsable era udev y algunos paquetes relacionados a este.

saludos

Avatar de Usuario
niky45
Forista Ancestral
Forista Ancestral
Mensajes: 9186
Registrado: Jue Abr 12, 2007 7:00 am
Ubicación: tras la pantalla (...)
Contactar:

Re: conflicto con ratón y teclado, en Debian Testing

Mensaje por niky45 »

si sales de las X funcionan?? (donde "no te funcionan", dale a ctrl+alt+f1 a ver)

algo me dice que no se han instalado los drivers...

Código: Seleccionar todo

aptitude install xserver-xorg-input-mouse xserver-xorg-input-kbd 
juraria que eran esos los paquetes. :?

:)

PD: ciertamente, las daily-builds hacen cosas raras a veces, pero... a mi eso me suena mas a que faltan paquetes. :)
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]

Avatar de Usuario
doc
Forista Ancestral
Forista Ancestral
Mensajes: 3477
Registrado: Mié Ago 11, 2010 10:32 am
Ubicación: Oviedo-es_ES
Contactar:

Re: conflicto con ratón y teclado, en Debian Testing

Mensaje por doc »

por lo que he podido leer (en el Foro esDebian) hay varios casos de 'denuncia' de este problema instalando Testing, y efectivamente parece ser problema de 'udev' pero como no se qué diablos es eso y sobre todo cómo se le mete mano... pues me he instalado el Debian_Pruebas desde Squeeze, y desde ahí he actualizado a Testing, y todo perfecto (bueno, solo que no ha instalado el 2.6.38 'de entrada', ni el LibreOffice pero bueno, en estos momentos lo que quería ver es cómo iba avanzando el 'nouveau', su aceleración, y tal (en mi Debian 'oficial' uso los privativos de nVidia, por aquello de las chorradillas del cubo Compiz, que me hacen gracia, pero en el fondo me gustaría usar el 'nouveau', para cosas como HDMI va mejor (al menos en mi equipo).

Lo que voy a hacer, dentro de 2 o 3 semanas, (antes tengo que meter en mi partición de pruebas el Ubuntu, para ver cómo va eso del gnome3) es bajarme y quemar (es curioso, tampoco consigo poder instalarlo desde USB, con MultiSystem) otra 'daily build' de Testing, a ver si mejora algo, que ya estoy harto de tirar CDs (y si no va probaré lo que dices, Nicky, de los drivers... aunque yo diría que están en el Xorg.conf que me monté).

Edito: bueno, pensándolo bien, como me pica la curiosidad, lo voy a probar esta noche. Mañana informaré.

Avatar de Usuario
niky45
Forista Ancestral
Forista Ancestral
Mensajes: 9186
Registrado: Jue Abr 12, 2007 7:00 am
Ubicación: tras la pantalla (...)
Contactar:

Re: conflicto con ratón y teclado, en Debian Testing

Mensaje por niky45 »

doc escribió:(y si no va probaré lo que dices, Nicky, de los drivers... aunque yo diría que están en el Xorg.conf que me monté).
puedes poner el driver paquito en el xorg.conf, que si no esta instalado.... :?

has hecho una netinstall (minimal), o una full??

ciertamente, en una full, o si simplemente has instalado el xorg entero (xserver-xorg con todas las dependencias), seria MUY raro que no hubiera instalado los paquetes, pero... vete tu a saber. :?

:)
doc escribió:(es curioso, tampoco consigo poder instalarlo desde USB, con MultiSystem)
las iso-hibrid son una solcuion muy rapida. imagenes oficiales solo hay lives de squeeze (estable), pero creo recordar que habia un paquete en los repos para convertir cualquier iso en iso-hybrid (con lo que se puede volvar a usb con un simple dd, o incluso cat? )

si quieres info, avisa. :)
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]

Avatar de Usuario
doc
Forista Ancestral
Forista Ancestral
Mensajes: 3477
Registrado: Mié Ago 11, 2010 10:32 am
Ubicación: Oviedo-es_ES
Contactar:

Re: conflicto con ratón y teclado, en Debian Testing

Mensaje por doc »

nada, lo he intentado otra vez, e imposible. He intentado lo del 'aptitude install xserver-xorg-input-mouse... (etc)' arrancando desde consola, con el modo 'recovery' (donde funciona perfectamente el teclado, abrir una tty desde otra situación imposible, porque no puedo teclear) pero no conecta con deb http://ftp.es.debian.org/debian/ testing main.

Veo dos cuestiones: una, que en el arranque me sale el mensaje "startpar: service(s) returned failure: udev failed", pero no se qué hacer. También he visto otra cosa curiosa, que es que parece ser que nombra las particiones como /dev/sdc... (cuando lo normal, y lo que pasa en mi 'Debian_oficial' es que sean /dev/sda...) así que a lo mejor van por ahí los tiros.

En el foro esDebian que antes mencionaba un forero mencionaba el mismo problema, y se autocontestó con este mensaje
Solucionado. Renombré el directorio /run y me funciono todo el ratón y teclado.
naturalmente le pedí que detallase más su solución pero como lo marcó como [Solucionado] no ha vuelto por el foro y ni idea de qué es lo que, exactamente, había renombrado (y qué nombre había puesto) ¿teneis alguna nidea...?

Avatar de Usuario
biker3
Forista Nuevo
Forista Nuevo
Mensajes: 2
Registrado: Jue Oct 30, 2008 8:00 am

Re: conflicto con ratón y teclado, en Debian Testing

Mensaje por biker3 »

doc escribió:[...]
En el foro esDebian que antes mencionaba un forero mencionaba el mismo problema, y se autocontestó con este mensaje
Solucionado. Renombré el directorio /run y me funciono todo el ratón y teclado.
naturalmente le pedí que detallase más su solución pero como lo marcó como [Solucionado] no ha vuelto por el foro y ni idea de qué es lo que, exactamente, había renombrado (y qué nombre había puesto) ¿teneis alguna nidea...?
Con lo de renombrar se refiere a darle otro nombre al directorio por si las moscas, que en caso de que la cosa empeore pueda volver a darle su nombre anterior.
Por ejemplo ejecutando, como root, algo como:

Código: Seleccionar todo

mv /run /run.old
En mi caso me ha funcionado. Además, es posible que si sigues probando con el teclado por USB antes de hacer lo de ese directorio te des cuenta de que la tarjeta de red no te la detecta, tampoco la tarjeta de sonido,.. A mi me lo hacía. Al principio elegí en el instalador el initrd que no es el genérico y pensaba que sería por eso, por lo que volví a instalar pero eligiendo genérico.
Espero que hayas dado con el remedio a tiempo. :)

Avatar de Usuario
doc
Forista Ancestral
Forista Ancestral
Mensajes: 3477
Registrado: Mié Ago 11, 2010 10:32 am
Ubicación: Oviedo-es_ES
Contactar:

Re: conflicto con ratón y teclado, en Debian Testing

Mensaje por doc »

caramba, pues es verdad, me bastó cambiar el nombre del directorio, de /run a '/run_old' para que, tras reiniciar, se solucionasen los problemas del ratón y del teclado.

Esto es, claramente, un ejemplo de 'la navaja de Ockham'.

Gracias. Y pongo el aviso de [solucionado]

Responder
  • Temas similares
    Respuestas
    Vistas
    Último mensaje