Webcam Trust (Packard Bell) no funciona

Las partes físicas de tu maquina funcionando bajo linux (Tarjeta de video, de sonido, modem, tarjeta de red, monitor, etc.)

Moderador: doc

Avatar de Usuario
hipersayan_x
Forista Legendario
Forista Legendario
Mensajes: 1905
Registrado: Vie Abr 27, 2007 7:00 am
Contactar:

Re: Webcam Trust (Packard Bell) no funciona

Mensaje por hipersayan_x » Sab Dic 18, 2010 9:15 pm

Aqui he encontrado personas con problemas similares:

http://forums.gentoo.org/viewtopic-t-80 ... 8a151dd53d
https://bbs.archlinux.org/viewtopic.php?id=56774
http://cateee.net/lkddb/web-lkddb/USB_GSPCA_SONIXJ.html

Aparentemente, así debería funcionar:

Código: Seleccionar todo

sudo modprobe gspca_main
LD_PRELOAD=/usr/lib64/libv4l/v4l1compat.so mplayer -tv driver=v4l2:width=640:height=480:device=/dev/video1 tv://


o

Código: Seleccionar todo

sudo modprobe gspca_main
LD_PRELOAD=/usr/lib64/libv4l/v4l2convert.so mplayer -tv driver=v4l2:width=640:height=480:device=/dev/video1 tv://


También hablan de instalar algún paquete llamado gspca sonix o algo así.
Desarrollo en Qt: Qt Developer Network
Mis proyectos: github | SourceForge.net
Avatar de Usuario
clamide
Forista Medio
Forista Medio
Mensajes: 298
Registrado: Dom Mar 25, 2007 8:00 am

Re: Webcam Trust (Packard Bell) no funciona

Mensaje por clamide » Sab Dic 18, 2010 11:44 pm

Acabo de mirar esas webs y algunas otras pero el problema persiste...
Avatar de Usuario
hipersayan_x
Forista Legendario
Forista Legendario
Mensajes: 1905
Registrado: Vie Abr 27, 2007 7:00 am
Contactar:

Re: Webcam Trust (Packard Bell) no funciona

Mensaje por hipersayan_x » Dom Dic 19, 2010 12:28 am

Probaste los comandos que te di antes?
También podes probar con esto:

https://help.ubuntu.com/community/Ov51x
Desarrollo en Qt: Qt Developer Network
Mis proyectos: github | SourceForge.net
Avatar de Usuario
clamide
Forista Medio
Forista Medio
Mensajes: 298
Registrado: Dom Mar 25, 2007 8:00 am

Re: Webcam Trust (Packard Bell) no funciona

Mensaje por clamide » Dom Dic 19, 2010 2:12 pm

Sí, lo hice y el resultado es este:

Código: Seleccionar todo

LD_PRELOAD=/usr/lib64/libv4l/v4l1compat.so mplayer -tv driver=v4l2:width=640:height=480:device=/dev/video1 tv://

MPlayer 1.0rc4-4.4.5 (C) 2000-2010 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing tv://.
TV file format detected.
Selected driver: v4l2
 name: Video 4 Linux 2 input
 author: Martin Olschewski <olschewski@zpr.uni-koeln.de>
 comment: first try, more to come ;-)
v4l2: unable to open '/dev/video1': No such file or directory
v4l2: ioctl set mute failed: Bad file descriptor
v4l2: 0 frames successfully processed, 0 frames dropped.


Exiting... (End of file)


Código: Seleccionar todo

LD_PRELOAD=/usr/lib64/libv4l/v4l2convert.so mplayer -tv driver=v4l2:width=640:height=480:device=/dev/video1 tv://
MPlayer 1.0rc4-4.4.5 (C) 2000-2010 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing tv://.
TV file format detected.
Selected driver: v4l2
 name: Video 4 Linux 2 input
 author: Martin Olschewski <olschewski@zpr.uni-koeln.de>
 comment: first try, more to come ;-)
v4l2: unable to open '/dev/video1': No such file or directory
v4l2: ioctl set mute failed: Bad file descriptor
v4l2: 0 frames successfully processed, 0 frames dropped.


Exiting... (End of file)


He probado con el link que me das (tenía ciertas esperanzas) pero me da error.
No comprendo que puede pasar porque la cámara me la detecta perfectamente y con el karmic no tuve ningún problema para usar cheese . ¡Ajjjjj :evil: !!!
Avatar de Usuario
hipersayan_x
Forista Legendario
Forista Legendario
Mensajes: 1905
Registrado: Vie Abr 27, 2007 7:00 am
Contactar:

Re: Webcam Trust (Packard Bell) no funciona

Mensaje por hipersayan_x » Dom Dic 19, 2010 6:21 pm

Código: Seleccionar todo

v4l2: unable to open '/dev/video1': No such file or directory
v4l2: ioctl set mute failed: Bad file descriptor
v4l2: 0 frames successfully processed, 0 frames dropped.


Te esta diciendo que no encuentra el dispositivo donde esta conectada la webcam, fijate que este conectada o que no haya cambiado de numero, conecta la camara, volvé a ver que dispositivo le corresponde(v4l2-ctl --list-devices), reemplaza donde dice device=... y volvé a correr el comando anterior

clamide escribió:He probado con el link que me das (tenía ciertas esperanzas) pero me da error.
No comprendo que puede pasar porque la cámara me la detecta perfectamente y con el karmic no tuve ningún problema para usar cheese . ¡Ajjjjj :evil: !!!


Según parece, el controlador que se usaba con estas camaras ya no funciona con versiones mas nuevas del kernel y hay que hacer un poco de magia negra :( .
Por eso lo mejor es comprarse una webcam que sea plug&play y te olvidas de los problemas, como por ejemplo esta:

http://www.geniusnet.com/wSite/ct?xItem ... =1304&mp=3

Y hay camaras todavía mas simples y baratas que esa que también funcionan en linux, pero siempre te tenes que fijar que digan que son plug&play o UVC.
Desarrollo en Qt: Qt Developer Network
Mis proyectos: github | SourceForge.net
Avatar de Usuario
clamide
Forista Medio
Forista Medio
Mensajes: 298
Registrado: Dom Mar 25, 2007 8:00 am

Re: Webcam Trust (Packard Bell) no funciona

Mensaje por clamide » Dom Dic 19, 2010 8:22 pm

Iba a hacer lo del comando anterior cuando me sale esto:


Código: Seleccionar todo

$ sudo modprobe gspca_main
[sudo] password for :
WARNING: All config files need .conf: /etc/modprobe.d/ov51x, it will be ignored in a future release.

Y ahí no sé como seguir.
En cuanto a lo que dices de una nueva cámara pues ya lo estoy pensando, ya, aunque la Genius de la que hablas es pelín onerosa...
Avatar de Usuario
hipersayan_x
Forista Legendario
Forista Legendario
Mensajes: 1905
Registrado: Vie Abr 27, 2007 7:00 am
Contactar:

Re: Webcam Trust (Packard Bell) no funciona

Mensaje por hipersayan_x » Dom Dic 19, 2010 8:44 pm

clamide escribió:Iba a hacer lo del comando anterior cuando me sale esto:

Código: Seleccionar todo

$ sudo modprobe gspca_main
[sudo] password for :
WARNING: All config files need .conf: /etc/modprobe.d/ov51x, it will be ignored in a future release.


Y ahí no sé como seguir.


No te preocupes, no es un error así que podes continuar con el siguiente paso, pero como ves, algún error de incompatibilidad con el controlador te esta marcando.

clamide escribió:En cuanto a lo que dices de una nueva cámara pues ya lo estoy pensando, ya, aunque la Genius de la que hablas es pelín onerosa...


:D , no es necesario que compres esa, era solo un ejemplo, hay camaras mucho mas baratas, por ejemplo yo tengo esta:

http://www.geniusnet.com/wSite/ct?xItem ... =1303&mp=3

y funciona perfecta, también hay unas noganet mas económicas.

http://www.noganet.com/productos/noganet/webcams

Vos simplemente fijate que digan que son plug&play y que funcionar para linux y/o mac.
Desarrollo en Qt: Qt Developer Network
Mis proyectos: github | SourceForge.net
Avatar de Usuario
clamide
Forista Medio
Forista Medio
Mensajes: 298
Registrado: Dom Mar 25, 2007 8:00 am

Re: Webcam Trust (Packard Bell) no funciona

Mensaje por clamide » Dom Dic 19, 2010 9:11 pm

Código: Seleccionar todo

$ v4l2-ctl --list-devices
BT878 video (Pinnacle PCTV Stud (PCI:0000:06:01.0):
   /dev/video0
   /dev/vbi0

USB Camera (usb-0000:00:1a.0-2):
   /dev/video1

:~$ sudo modprobe gspca_main
[sudo] password for 
WARNING: All config files need .conf: /etc/modprobe.d/ov51x, it will be ignored in a future release.
alida@labestia:~$ LD_PRELOAD=/usr/lib64/libv4l/v4l2convert.so mplayer -tv driver=v4l2:width=640:height=480:device=/dev/video1 tv://
MPlayer 1.0rc4-4.4.5 (C) 2000-2010 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing tv://.
TV file format detected.
Selected driver: v4l2
 name: Video 4 Linux 2 input
 author: Martin Olschewski <olschewski@zpr.uni-koeln.de>
 comment: first try, more to come ;-)
v4l2: your device driver does not support VIDIOC_G_STD ioctl, VIDIOC_G_PARM was used instead.
Selected device: USB Camera
 Capabilites:  video capture  read/write  streaming
 supported norms:
 inputs: 0 = ov519;
 Current input: 0
 Current format: RGB24
tv.c: norm_from_string(pal): Bogus norm parameter, setting default.
v4l2: ioctl enum norm failed: Invalid argument
Error: Cannot set norm!
Selected input hasn't got a tuner!
v4l2: Cannot get fps
v4l2: ioctl request buffers failed: Device or resource busy
v4l2: ioctl set mute failed: Invalid argument
v4l2: 0 frames successfully processed, 0 frames dropped.


Exiting... (End of file)


Parece que vuelve a suceder lo mismo.
¿Por cierto, dónde compraste tú la Genius que tienes ahora y que te va de perlas? 8O
Avatar de Usuario
hipersayan_x
Forista Legendario
Forista Legendario
Mensajes: 1905
Registrado: Vie Abr 27, 2007 7:00 am
Contactar:

Re: Webcam Trust (Packard Bell) no funciona

Mensaje por hipersayan_x » Dom Dic 19, 2010 11:43 pm

No, definitivamente ya no se me ocurre nada, todo pareciera estar normal, pero aun así falla :?

clamide escribió:Parece que vuelve a suceder lo mismo.
¿Por cierto, dónde compraste tú la Genius que tienes ahora y que te va de perlas? 8O


En Argentina, pero se puede conseguir en cualquier país y casa de computación, es bastante común. Eso si tiene una resolución máxima de 640x480, no me daba para mas :P , pero funciona perfecto.
Desarrollo en Qt: Qt Developer Network
Mis proyectos: github | SourceForge.net
Avatar de Usuario
clamide
Forista Medio
Forista Medio
Mensajes: 298
Registrado: Dom Mar 25, 2007 8:00 am

Re: Webcam Trust (Packard Bell) no funciona

Mensaje por clamide » Lun Dic 20, 2010 12:31 pm

Bueno pues no me queda más que agradecerte todo el tiempo y la atención que has prestado a este problemilla mío :) Por lo visto no me va a quedar más remedio que cambiar de cámara.

Saludos grandotes y agradecidos =D>
Avatar de Usuario
Yoyo
Administrador
Administrador
Mensajes: 3094
Registrado: Mar Jun 06, 2006 7:00 am
Ubicación: Andalucía/España
Contactar:

Re: Webcam Trust (Packard Bell) no funciona

Mensaje por Yoyo » Lun Dic 20, 2010 2:16 pm

¿ y no podría ir es web cam con los drivers stk11xx ?

Ya se que no son los suyos pero como último intento desesperado. Mira a ver el manual que dejé por aquí.

hardware/hacer-funcionar-una-syntek-web-cam-packard-bell-bu45-easynote-mx66-208w-linux-t47510.html
Reglamento del Foro

Informáticamente hablando...
Avatar de Usuario
clamide
Forista Medio
Forista Medio
Mensajes: 298
Registrado: Dom Mar 25, 2007 8:00 am

Re: Webcam Trust (Packard Bell) no funciona

Mensaje por clamide » Sab Ene 08, 2011 9:39 pm

Perdona la tardanza...
No funcionó lo que me dijiste. Gracias de todas formas.
Responder
  • Similar Topics
    Respuestas
    Vistas
    Último mensaje